[Guide] How to flash a modded AMI UEFI BIOS

Hello again,
had a look at the chip which you marked and it’s a MXIC 25li2872f. Also found a soic8 chip abit above to the right of ram slot and it’s a MXIC 25v5126f.

Don’t know which of them is for BIOS :slight_smile:

Wanted to make sure that I would be able to flashback using ch341 if software fails. Seems Asprogrammer has support for 25LI2873F which should work with 25LI2872F

I’m running an ASRock Z790 Nova and I’m trying to flash a modified bios to it. I’ve tried following the instructions for using Flashrom but I get an error of “no eeprom/flash detected” whenever I run it. Am I doing something wrong?

Maybe Flashrom cant identify (due to Outdated DB) such new mb and her SPI IC…
Have you at least identified it yourself?

EDIT: Dont know, maybe an CH341 SPI programmer or the SPI_TPM header, your mb is too new but you don’t seem to have enough knowledge of these things… do you?

What do you mean by identify? Is there anything else I can do here to flash this bios? I don’t have flashback (thanks for removing that, ASRock), scewin doesn’t work because of protected variables and instant flash doesn’t work for it.

I’m starting out in this space, just doing this for the sake of modifying bios to optimize my install for gaming and accessing hidden settings. SCEWIN had failed me because ASRock write protects runtime variables, I’m unable to just use instant flash, there’s no bios flashback, and I had the detection issue with flashrom running from a flash drive.

What were you saying regarding the SPI_TPM header? Is there some kind of method using that? I’m not at my house ATM but I’ll look for the bios chip and that when I get back

What did you expected??? Modern motherboards containing revised AMI Aptio V bios files and AMI Core bios security, prevents almost all bios mods (modified…) from being flashed by regular know/specific MB methods… welcome to mod world my friend…
Take a walk and read on the forum other users posts and you’ll find out that you’re not alone on this…

SPI_TPM header?
If even possible on this MB model…search…read, read a lot.

Could something like afuefi work
It shouldn’t, as its an AMI official flash tool, so…

Another method to try if you have any experience with the Intel ME tools package…and dont ask how, i dont have time for such background teaching:
[GUIDE] [UPDATE] Usage of AMI’s AptioV UEFI Editor + FPT Flash Method - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

This will only/can work if the access to bios regions is unlocked for writing:
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

Thats it, nothing more to add, good luck.

1 Like

Could something like afuefi work, or is that out of the question?

Edit: There is such a header, does it have any relevance to bios modding?

Ok, by this question… your a bit out of your league and don’t engage on this… we don’t want to see users with a death MB.

1 Like

That’s valid, I’ll probably steer clear of it and just see if there’s anything I can change via scewin and avoid modding and risking any kind of damage lol

Just for reference sake, chip is a Winbond 25Q256JVEQ

Datasheet W25Q256JV

I might actually try building the latest version of flashrom (1.3) on linux for DOS and trying to read again, since the newer version has some updates to it

1 Like

Has anyone else compiled a version of flashrom 1.3 for DOS? I’ve been trying to compile this thing for over an hour but I’m quickly reaching the limits of my linux knowledge lol


Since I don’t want to do anything stupid regarding the procedure for flashing the modified bios, I’m posting here for help.

I have an MSI Big Bang X-Power 2 motherboard.

I followed Fernando’s guide regarding adding the nvme module in bios.

So I have my bios modified with the same extension in .280 compared to the original.

To flash the modified bios if I understood correctly, I need to have a usb key formatted in fat32, which I copy and paste my modified bios onto the usb key (on the usb key there will only be the modified bios file) , I restart the PC, I enter the cm bios, I click on M-Flash, I click on “Select a file to update the BIOS”, I select my USB key, I select the modified bios which is on my USB key and finally I press enter.

Is the procedure good?

Thanking you in advance for your help.

Yes, the procedure is, general rule the proper method, as per the guide…
Now if trying to get some assurance that nothing will go wrong and the flash mod will have a 0% of failing… that my friend NO one can assure you… understood?
This is MOD world… Whoever takes this path must be prepared by any kind of results, success and failures and this is a user choice ONLY, not a forum or a user responsibility of further actions.

In your case, the MB model in question has dual bios, an advantage over other MBs/Users, this will give you a way to recover.

First of all, thank you for your answer to my question.

I asked if the flash procedure that I plan to use is functional with the modified bios (or rather if that’s how you flash with the modified bios), because as there are 3 different methods of flash with msi including the main thing is to run the .exe of the program which will flash the original bios, I was wondering if I should add the exe + the folders and files extracted from this .exe (without the original bios file ) with that of the bios modified to execute a bios flash.

Hence my request for my first message.
No, I’m not asking for assurance that everything will go well, in any way.
I was wondering if this is how you flash the modified bios with msi’s m-flash.
I’m talking about flashing procedure, not pass or fail.
Maybe I expressed myself incorrectly in my first message.
I agree with you that responsibility for the flash rests solely with me and not with other users.

For the double bios I was already aware thank you.

I don’t understand why almost every time I post a message with questions that I ask myself which are simple questions whose I don’t have the answer, I get almost rebuffed.
Maybe you don’t like me, I don’t know, in any case I remain polite every time.
Or maybe it’s me who takes your message the wrong way.

There’s nothing wrong with your posts… and you should not get personal with every kind of answer you may get from different users on the forum, we are all still “living” people with their own personality.

But i do believe that due to the kind of operations and risks to users personal assets, the true, bare and naked, should be told to users, especially those not familiar with the risks associated with mods, avoiding many common situations like “…my system is dead, how to recover” etc etc.

Straight answer to your question, yes M-Flash is the current method for flashing the mod.
Good luck.

I’ve compiled flashrom 1.3 for DOS after a Herculean amount of effort…it didn’t end up working for my board.

I gave up and used FPT, thankfully that’s worked

1 Like

Hi, I went into the bios of my motherboard (ms-7737) M-flash section to flash the modified bios, I clicked on “Select one file to update bios” then it shows me a window linked to my usb key formatted in fat32 with 2 choices FS0: PMAP and FS1: PMAP

If I select FS0 it shows me this
Same thing with FS1.

My USB key has I’ll say 2 partitions, a public one where I can put whatever I want on it and the other where it’s a secure mode, if I want to activate a password or not.
By default this is not enabled.

I guess that’s why there are 2 FS?

Another thing, there is a “BIOS Boot Function” which is disabled by default.

This is what the explanation of this function tells me when I click on “help”

Do I need to activate this bios boot function so that it detects the bios file on my usb key?

I leave it to you to know how to proceed so that it detects the modified bios file on my usb key so that I can flash it.

Maybe try formatting it in FAT and no FAT32 with my USB key? i don’t know

Thanking you in advance for your help.

The easiest way is to update in legacy mode, disable UEFI bios save reboot enter bios setup again, then M-Flash to select the bios mod and update.
The USB (FAT32) doesn’t need to be bootable.

hi @MeatWar

I only have 2 modes

The first time I tried to flash but the modified bios file did not appear, I was already in Legacy + UEFI.

I have no way to put only Legacy mode directly in bios.

Another idea how to proceed?


Legacy+UEFI is the priority, so if bios finds any boot entry in Legacy mode thats what she’ll take and ignore secondary EFI entries.
Does exist an entry in bios regarding OS Win8 WHQL, if so disable, that’s part of Legacy/EFI mode setup.
Well, bios files or mod files apart if you an issue with usb ports or disks, that’s not a mod flash issue.
The board doesn’t like the usb disk model or the usb file system is not ok…
You report that the bios cant see any files on partition(s) of your usb…
It’s a human error or hardware error… simple.
The best way to test this is according to the manual on page 1-38 and making a backup as USB destination.

Hi, I managed to flash my modified bios.

The error came from me, I had named the modified bios by adding _mod as shown in the example of the photo in Fernando’s how to insert module nvme guide.

I apologize for the inconvenience caused.

I just have to test over several days if my SSD goes from ntfs to raw.
If everything is good after this test, I will be able to clone my hdd (windows) to my ssd and be able to enjoy it

Thanks to Fernando for his guide and everyone who helped.
Thanks to MeatWar for your help and explanations.

I wish you a pleasant year 2024.

1 Like