[Guide] How to flash a modded AMI UEFI BIOS

I followed that guide you mention, and the BIOS did flash, but the modules I updated in UBU were not updated at all. It’s as if I flashed the stock BIOS.

Here’s what I did:

1) Downloaded 0511 (xxx.CAP) BIOS from ASUS’ website
2) Opened said BIOS in UEFITool and extracted the body. Saved it as xxx.ROM
3) Updated the modules using UBU (as I normally do with my own motherboard’s BIOS)
4) Saved the BIOS as mod_xxx.ROM
5) DOS mode, afudos.exe mod_xxx.ROM /GAN and the BIOS flashing takes place.

Weirdly enough … it never asks me to reboot, turn off, nothing. So I naturally just exit the program via CTRL + ALT + SUPR and once I go back into the bios, I make a backup in AFU and then I reopen said backup in UBU to check modules’ version, still the old ones.

Any insights? Thank you, Fernando.

@Punkster_Sanders :
Since I cannot help you myself, I recommend to ask a real BIOS Guru like CodeRush for a solution.

I sent a PM to CodeRush but he never replied back. I think I just gave up. There’s no way of flashing the modded .CAP BIOS file in this motherboard. I tried ~10 different approaches and not a single one worked. The .ROM file in AFUDOS with /GAN command flashes “correctly” but the modules never update.

Luckily this isn’t my motherboard and now I learnt to stay away from ASUS.

Thank you for your support, Fernando!

I followed this guide, without success :frowning: , here are the steps I followed, maybe somebody can tell me where the error is?

I have an ASUS Z97 PRO GAMER MotherBoard with an i7-4790K

1.- Download the official BIOS from ASUS’s website: Z97-PRO-GAMER-ASUS-2203.CAP
2.- Open Z97-PRO-GAMER-ASUS-2203.CAP with UEFITool.exe, extract the body

3.- Save it as a new file BIOS.ROM
4.- Open BIOS.ROM with UBU, the BIOS.ROM looks ok to me:

5.- Use option 7 to update the CPU microcode, save modified BIOS.ROM
6.- I try to flash this BIOS.ROM with official ASUS’s EZFlash2, don’t work since this tool require *.CAP files
7.- Boot in MSDOS, then try to flash usin AFUDOS BIOS.ROM /P /B /K, got this error:

8.- Try again using AFUDOS BIOS.ROM /GAN, error: option /GAN don’t exists

So here I am, I have a moded BIOS.ROM but I can’t flash it into my ASUS Z97 PRO GAMER motherboard. There are some ASUS’s MB that have a dedicated USB port + back-button to flash BIOS, this USB port don’t exist on my MB.

Can somebody help me flashing the BIOS with the updated CPU microcode? I am generating the modified-bios file correctly? I will summon @Fernando and @CodeRush

@AikonCWD :
Welcome to the Win-RAID Forum!

Unfortunately I cannot help you.
What about asking the ASUS Support for a BIOS with an updated CPU Microcode?

Dieter (alias Fernando)

@Fernando nvm… I finally solved!!

My problem was that I had a retarded AFUDOS version without the /GAN option. I did another Google-search, downloaded a different AFUDOS.EXE and tried again. Here are the results:

CPU microcode updated to 23 :smiley:

@AikonCWD :
Thanks for your feedback! It is fine, that you finally succeeded.

I follow the article 【How to flash a modded ASUS/ASRock/Gigabyte AMI UEFI BIOS】to do that,but failed。The bios file was modded by mmtool to insert 3 NVME *.ffs files and updated modules by UBU ,but AFUDOS and AFUWIN didn’t let me falsh the bios whose size doesn’t match the existing one.

Is there another method to do that ?

@kyobox :
Welcome to the Win-RAID Forum!

Without knowing the exact ASUS mainboard model, which you are using, we cannot help you.
I have moved your post into this alread existing thread about exactly your topic.
Please read accurately the start post of this thread and >this< post as well.
By the way: Why did you insert 3 NVMe modules into the BIOS of your mainboard, although only 1 will be needed and used? Why didn’t you follow >this< guide?

Dieter (alias Fernando)

thanks for your reply…

My mainboard model is P8H77-V,the 3 NVMe modules is Nvme.ffs,NVMEINT13.ffs and NvmeSmm.ffs,which are extract from the bios of Asus Z97 model by mmtool v5.0.0.7.

In fact ,I downloaded your uncompressed NvmExpressDxE_3 module GUID 9A4713C2 to creat another bios file ,whose size is the same to the 3-modules.Surely be rejected by Afu.

When I used AFUDos to flash bios,I also tried command “/GAN”,but it didn’t work. the utility just listed other option and command…

Since your mainboard BIOS is an AMI Aptio IV UEFI one, the correct MMTool version would have been

No correctly done modification will change the BIOS file size, no matter how many modules the user will insert. The native size difference will be compensated by a different compression amount of the modules.

Maybe you have used a wrong AFUDOS version, which doesn’t support the " /GAN" suffix. I already gave you the advice to have a look into >this< post.

Hi there

I just flashed my z97 pro gamer with even older afudos, from 2011 and for some reason it worked with /k /b /p commands :slight_smile:
As u can see, mC is 17 now, was 13

/GAN on other versions give me erasing/programming info but no change in mcode. If anyone is interested in that afu dos, here’s link :

@Gregix :
Welcome to the Win-RAID Forum and thanks for your contribution, which may help other users, who have problems to flash their modded BIOS.
Dieter (alias Fernando)

Thanks for your help!
Finally I use URFITool instead of mmTool v5 to insert ffs files,and the size is confirmed by AFU.But It reject the fashing,because of the secure rules.Luckily,I find a way to solve this problem.I use the AiSuit’s flash update function.Step one:choose the ASUS original P8H77-V bios file,and click “Next” to let AiSuit verify but don’t click “Update”,Step 2:delete it and put the modified bios file to replace.Rename the modified file the same to the original ,Step 3:click “Update” and AiSuit will execute the flashing.

Hi Fernando , the link to the X99 Post by sinders in the 1st post is taking me back to the Forum Start Page currently

took a screen grab but can’t seem to find how to post an image anymore ?

@Kbird :
Thanks for your info.

The link was broken, because we had to remove sinder’s original post upon request of the Company American Megatrends Inc (AMI). We are not allowed to offer or link to AMI tools (MMTool etc.), which are sold by AMI to the mainboard manufacturers for a lot of money and have never been designed for the public.
I just have removed the related sentence within the start post, which contained the broken link. So there is no misleading link anymore.

>Here< is the related guide.

Okay I thought I had read sinter’s post about a year ago but am only now getting to a point where I will try modding a Bios for myself…

I didn’t get the Attach file button because I used the Quick reply window and not the Full reply window , which you only get if you click on the reply button to get it …not sure if that information is in the "add a pic " tutorial? or I missed it ?

Thanks Fernando

People who have used the /GAN switch have often said, that while the flash seemed to have gone smoothly, there was no actual change to the new bios.
Maybe it works with bios that is modded with new microcode updates, but not with Nvme module insertions?

hi guys. is it possible to flash a modified bios on Asus motherboard that has not the biosflashback features?
for example z370g gaming

@xelanaiznac :
Since your question has nothing to do with the UBU tool, I have moved your post into this thread. You will find the answer within the start post resp. within the linked threads.