[Guide] How to flash a modded AMI UEFI BIOS

2 questions, was that for IV or V? and if its for IV, can you let me know what version it was?

@All: reason being is I have an A88X-Pro, uses the .CAP file, no method works to flash, Flashback blinks a few times then goes solid, updater says not a cap file (duh and even rename wont work of course, secure file), and the version’s of AFUDOS i can find are from 2014, dont have /GAN and report:
1e - Error: Secure Flash function is not supported on this file (both trying to flash back the backup.rom like the instructions and the modified.rom/bin/cap)

Wish there was a version repo for AMI’s tools… if not the files, then just the version list :X

Thanks for any help anyone can give!

EDIT: I had tried 3, the 4th was the charm… HOWEVER… same issues as others, did a backup, used UBU to examine the backup, none of the updated modules show… rechecked the modified file, modules are updated both with UBU and MMTool manually… im lost here, thoughts anyone?

If your mainboard supports the “USB Flashback” feature, the flashing should work.
Change the USB stick (should be a small sized FAT32 formatted USB 2.0 one) and rename the BIOS file according to the ASUS rules. Then follow exactly the Flashback guide.

sadly not, I have quite the collection, 128MB, 512MB, 1GB, 2GB, 4GB, same thing happens with flashback, I did edit above about using older AFUDOS, nothing updated desite it going through :confused:
https://puu.sh/zqFBk/d8cfb0cf46.png (backup.rom AFTER flash of modified rom using /GAN)
https://puu.sh/zqFEI/17e4c08ff4.png (updated rom that was flashed using /GAN)

Side note, is that meant to say: AMD OROM and EFI “Nodules”, or should Nodules be Modules!

@Net7 :
There are many ASUS mainboard users, who reported, that the USB Flashback method didn’t work for them, but later on they surprisingly succeeded (after having changed the USB stick or corrected another mistake).

That is just a typo. Please consider, that SoniX is a Russian and has severe problems with his eyes.

@Fernando :
as mentioned tried with multiple drives, no workie…
and yes, hence why I went about it jokingly, SoniX is FANTASTIC

EDIT by Fernando: Unneeded fully quoted post replaced by directly addressing (to save space)

EDIT: ANNNDDD after digging through my desk, 4 more USB’s, and ONE MAGIC ONE!.. literally have 8 that WILL NOT WORK, and 1 that did… (all USB2.0, all 4GB or below, mbr/fat32)… Flashback is EXTREMELY picky!
Now to see if it worked!

EDIT2: worked… phew, might want to change the notes, its EXTREMELY picky about USB drives, try 9 DIFFERENT ones :smiley:

Somewhere in this forum I did read a solution for ASUS mainboards without USB BIOS Flashback:

- download AI-Suite (when not for Win10 available use Version for 8.1)
- Start Easy Update for BIOS Update in Windows, select ORIGINAL file (then some timeconsuming checking seems to happen)
- before start flashing delete selected original file and replace with modded one (same name, same location).
- proceed with bios flash

I did this with some P8Z77-V LK, P8Z77-M, some ITX Z87 and ITX Z97 boards (all without USB-Flashback).
And previously did it while testing with a P8Z77-M Pro, a P8Z77-V Deluxe and a Z87I-Pro having USB-Flashback (in case of bricking while trying)

So no AFU /GAN or FTK or NVram-mod was needed.

Other one, maybe wrong thread… because of Supermirco.

Having some X9, X10, X11 Supermicro Server boards.

BIOS of them is a bit tricky:
some don’t habe EFI Graphic modules for Intel (because most Xeon don’t habe IGPUs, but some e.g. C226 have support for that CPUs),
but they have Graphic GOPs for IGPUs
nearly all Boards have additional microcodes for CPUs which do not fit into sockets = silly Supermicro

Did add iGPU efs module as last DXE files with UEFItools, also added NVMe-ffs. Then updated microcode, LAN, GOPs and RSTe with UBU.
Flashed with AMIflash and after successfull flash ended in recoverymode of bios (bios showing “entering recovery” then restarting in a loop).
Renamed modded BIOS to SUPER.ROM and put it onto root of stick (FAT32),
Mainboard restartet many times, each time again going into recovery (maybe each time a bit further).
After around four restarts BIOS-Menu for Recovery appeared, selectet flash recovery bios and so flashed modded bios again.
After flashing modded bios in recovery mode, modded bios was accepted and mainboard now has a running system.

First tried it with a X10 mainboard with defect LAN (no problem if brickage), then flashed all other X10, then X11 and then X9 without problems.
Now all boards running well under ESXi 6.5

@Wishbringer :
Thank you very much for your recent reports about how you were able to successfully flash modded BIOSes into the related BIOS chip of ASUS and Supermicro mainboards.
Your contributions are very helpful for users of an ASUS mainboard without the “USB Flashback” feature and for users of a Supermicro mainboards as well.
Thanks again!

Due to Wishbringer’s reports I have updated the start post of this thread and customized the thread title (to include the Supermicro BIOSes).

@Fernando :
for AI-Suite Solution: I didn’t found it out! I only read about it and tried it out and it worked.
But I don’t know the original post anymore and member who wrote it.

Exactly this is, what I have written within the start post.

I just found >this< post, where our Forum member mazebaer has written, that he flashed the modded BIOS by using the ASUS AI Suite, but the related post does not contain any detail regarding the procedure.

@lgrootnoob :
If you use an external programmer, when saving, choose to save the second, save as image.bin if you use the first it adds .cap capsule add on! Size grows…

??? Where did you go?

Confirmed working installation: P8Z77-V LK. This is an Aptio 4 Bios without flashback feature.

I read multiple SUB Forums here and harvested information from everybody’s experiences. Page 1 is always being updated by the mods in each subforum, refer to it often.
For THIS motherboard only the SPI program method worked for me, it doesn’t have a flashback port (which is basically a self-contained SPI programmer built into the motherboard)
Afudos will not work
EZflash will not work

Removed BIOS chip. (precautions with static here, grounding myself all times)
Installed on CH341A Mini Programmer (Black Edition), ran program to “read” the BIOS.
Saved BIOS info to bios.bin (this retains my information for system UUID, serial #, and MAC address)
Confirmed bios.bin has the above personalized information via FD44Editor 0.9.2
I used bios.bin as my starting point.

Ran UBU_v1_69_13 (using mmtool installed everything but microcode updates (will do later)
Ran UEFITool 0.22.1 to insert NvmExpressDxe_3 after the last DXE
bios.bin file is ready for Programming into the CH341A

CH341A program: load, program, verify - all went well.
Put chip back into the motherboard, note orientation.
Turned computer on - changed some BIOS settings as recommended: Turned off secure boot; chose “other OS”, and CSM off
Used a 8Gb USB for my installation OS - UEFI type GPT (lots of people in the forums got stuck here - they used MBR)
Installed OS - took 7minutes from beginning of installation to end.

Thank you to the major players on this website, very well run, very dedicated people with lots of knowledge.


Thats pretty cool you got it working… Wonder though was it necessary to use the flash programmer to backup the bios or would software tools have done the job as well?


yes I believe ‘AFUDOS /o bios.bin’ will give you a backup of your original ROM (without the CAP of course), and it preserves the UUID, MAC, Serial #.
Its the exact same as using the flash programmer for backing it up.

Hi there. I would like to update my laptop with the last microcode update by intel. I have an asus update. I can successfully update the ivy bridge microcode with ubu but now i don’t know how to safely flash this mod file. The easy flash utility inside the bios didn’t see the file in any way.

I just wanted to add something I found out about Asus flashback being picky about the USB-stick used.

Of course I wanted to update my bios with the new microcodes, prepared one with UBU like I did before, putted it on a random 4GB/FAT32 USB-stick and tried to use the flashback method, it worked before, but this time it just flashed 3-4x and nothing more.

I tried to find out why it wouldn’t work and came to the conclusion the partition type on the USB-stick had to be MBR. After changing GPT to MBR it worked like a charm with the same USB-stick that failed before!

I tried Wishbringer’s method on my ASUS ROG STRIX X370-F GAMING. After rebooting it automatically went into the built-in EZ Flash 3 and flashed successfully, but it just seems to have flashed the original unmodified image.

I am not sure if I should be asking this here, but does anyone know how to force bios recovery on a gigabyte motherboard with dual bios? I am thinking to flash a UBU modified bios (with microcodes and roms updated) and I worry in case it does not work correctly after flashing.

@kyriacos :
Hi there. I also have a gigabyte dual bios board. AFAICT (at least on my one), the recovery system on these boards is entirely automatic. The board has some mechanism(s) to detect a previously failed boot and will likely perform such BIOS switching in a hands off fashion. Going back to last known working configuration. Actually the way this mechanism works is still not clear to me either. And requires some further hardware probing / investigation. By reading each of the 2 BIOS chips between boots and deliberately flashing a corrupt BIOS. Yet I have not heard of anyone actually doing these tests properly and posting a clear explanation of what is actually going on under such failure conditions. So please help me finding that answer too. And that would be great. Very much appreciated.

Or perhaps there is a software tool that lets us read / flash the 2 chips independantly? Not sure.

@dreamcat4 :
I was able to find some information about the backup bios in the following link:

I have not yet confirmed any of this information myself.