[Guide] How to flash a modded AMI UEFI BIOS

Thanks for your feedback and the report, that the " /GAN" command suffix doesn’t work with the currently latest AFUDOS version v3.07.01. The version 3.05.04.ones seem to be the latest AFUDOS and AFUWIN tools, which do support the " /GAN" option. As a consequence I will customize the related guides.
It is fine, that you finally succeeded and now can boot off the NVMe SSD with your old ASUS mainboard.
Enjoy it!


of nothing is a duty, I also come from years of forums and guides made by me, I understand and know well the commitment that must be dedicated and rightly so, anyway thank you again it was 2 days that I could not understand why this nvme it didn’t work you don’t know how much it helped me

Hi All! I try to write modified bios with Flashrom tool to ASRock H310M-STX from freedos.
But receive some errors. Can somebody help? Is any other way to flash it?
Dump log Write log

Whats your doubts here, cant you read the log?
Only bios_region can be written.
The Intel FPT tool can write this region, the correct tool for your ME FW version

Full backup: fpt -d spi_full.bin
Bios region dump: fpt -bios -bios -d bios_reg_bak.bin
Bios region write: fpt -bios -f bios_reg_mod.bin


[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15) - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

1 Like


I am a bit new to modding scene - trying from fresh. Wanted to mod my Lenovo ThinkCentre M700 SFF (H110) to support Kaby-Lake-S Xeons.

I tried to follow Guide by Unleashed Overclocking of how to use UBU Tool.
I took the .bin files / microcodes for the Xeon i am trying to mod from here - exactly that one

Socket 1151 (LGA)
506E3 Skylake-S, Skylake Xeon E3 v5

(Got 1250v5 and 1250v7 which i wanted to use)

Furthermore, I had no big issue of modding bios file itself - the issue is happening when i tried to flash that modded bios via FreeDoS of the pendrive (tho same issue happens when i try to do it through windows with official Lenovo tools but after replacing “official” file with modded one)

I am getting stopped after “Reading Flash” with an error that i guess many of you already saw many times, exactly “18 - Error: Secure Flash Rom Verify fail.”

Do i need to do some kind of… hex edits or what exactly?
If yes - about Hex Edits.
Would you be so kind to give me some help of how to do here?

I can provide original bios file and the modded one if anyone want to check it.

Cheers for all the help!

What did you expect from flashing mods? Of course it fails as most of bios security doesnt allow flashing mod files.
Work on a bios region dump with Intel FPT tool from the correct ME11 tools package.
Search on forum for similar user experiencies on flash/unlock Lenovo machines.

EDIT: Stop doing new posts. You can edit it.

Welcome to the Win-RAID Forum!
Since a thread about the topic “How to flash a modded BIOS” already exists, I have moved your help request into it (and the reply given by @MeatWar).
Good luck!
Dieter (alias Fernando)

1 Like

I was looking for a way to add Xeon v5 support to the Lenovo ThinkCentre M700 SFF motherboard (H110, LGA1151)

I tried to search it first myself, sadly no other topic related to that motherboard. Likewise, I also tried to make modded bios myself for that, but I failed massively… (Error 18).

Here is the latest official bios from Lenovo site
m05jt93usa.zip (5.0 MB)
( You can also download it from official Lenovo website here )

If there is anything else needed from me, please inform me and I will try to get those things as fast as I can :slight_smile:

And just wanted to ask - is it also possible to add ECC memory support to motherboard like that, or not really?

edit - sorry @Fernando for the mess, still catching whole that forum

Your problem has is not about how to modify the BIOS of your Lenovo mainboard, but how to get the modded BIOS properly flashed into the mainboard’s BIOS chip.

1 Like

Ok, I see what I was doing wrong.

Will have to try that AMIAFU tools after weekend when I will have that motherboard back in my hands - is it better to use DOS or WIN version? Or really no difference there?

Thanks for the tips @Fernando of where to go

Wondering if someone could help, I’m trying to update the bios on my asus rampage iv extreme so I can boot from a nvme drive.

I’ve tried multiple 4901 bios mods with the nvme module added in including one I made myself but having no luck

Every bios I try when flashing it via the rear(white) usb port and holding the rog button it just flashes for a couple seconds then stops, if I try it though the bios I get “failed security verification” or some some other error depending on which bios mod I try.

Does anyone have any suggestions on why I can’t flash my bios to a modded version or have a download link on another one I can try but have tried ones that have been verified to work but still no luck

We see the 1rst post, you dont need to post everywhere, understood?

The mod file must be renamed as the original, R4E.CAP (CORRECTED)
Some usb drives are picky, same as some Asus boards… so keep trying all the smallest USB you got.

Mod files in ASUS with USB BFB function is the solution, of course that every mod will fail in EZ Bios, it detects a tampered file and security will not let this files to be flashed, more than obvious and long time know in the mod world.

deleted the other post sorry,

Yeah I was aware it wouldn’t work via the ez bios but after it wasn’t working I tried it that way just to try all options, even tried afuwin but failed through that as well. just thought I’d say all the the options I tried.

I’ve named them “R4E.CAP” is that what you mean?

Forgot to add, two of the bios’ I’ve tried flashed through the rear white port after holding the rog button for 3 seconds, took about 3 minutes to complete but the computer won’t post just displays “00” on the motherboard so have boot in bios 2 and copy that over to 1 for bios 1 to work again

I’ll try agin now with a different usb

Thank you

@Meese @MeatWar
I have moved your last posts into this better matching thread.

Hello im quite actually new to bios “modding” reason why i quote that is since all i am trying to do is to change the serial number of my ROG Strix B660-G Gaming Wifi motherboard
All ive done is just run

AFUWINx64.exe bios.rom /O (as admin this just dumps the bios)
edit the serial number with HxD
AFUWINx64.exe bios.rom /GAN (this is where i get the error code “10 - Error: Unable to load driver.” not really sure how to fix this i got AFUWIN from a onedrive link from this website that i cant paste here and yes the AFUWIN is 64 bit so it should technically work)

Welcome to the Win-RAID Forum!
Which AFUWIN version did you use? Only old ones up to v3.05.04 do support the " /GAN" command suffix.
Please look into the ASUS mainboard section of the start post. That is the reason why I have moved your help request into this already existing thread.
Good luck!
Dieter (alias Fernando)

I get an error
10 - Error: Unable to load driver.
anyone know a fix? i am running Win11 22H2 afuwinx64 did work for some time but now it just doesnt for some reason

Yes i did use v3.05.04 and i got it from this post tried it from the internet archive one too

Damm sir…you have a recent motherboard not an old museum mb, AMI V Core bios, not AMI IV.
The following linked tool is an oficial file.
/GAN cmd as Fernando already told you will not work in modern AFU versions.

Your motherboard model has USB BFB feature, this is the method to use on mod files, as instructed in this guide/thread…to read and not to rush it.


AMI Support & Additional Sources

I read that and I’m trying to change my motherboards serial number and I’m pretty sure atleast 99% the bios cap/rom file does not pre-include a serial number and just checks something to get my motherboards serial number so my main worry of that way it just is not possible to change the serial number

But im pretty new to this stuff and dont know if its possible as i’ve only seen it be done through AFUWINx64.exe

I wont help no one, to that related action that you want to perform.
Every Asus bios update file doesnt contain specific mb data, only a dump/backup of the bios on a system have it.

EDIT: You’re welcome.