[Help] AsRock X299E-ITX + JEDEC DDR4 3200 = No Boot. Can it be supported by BIOS mod?

CPU: i9-9820X, i7-7800X
Samsung M471A4G43AB1-CWE (Native DDR4 3200 SO-DIMM 32GB module) x4
Micron D9XPF chip SODIMMs (Native DDR4 3200 SO-DIMM 32GB module) x2
Samsung M471A4G43MB1-CTD (Native DDR4 2666 SO-DIMM 32GB module) x2
Native DDR4 3200 x1-4 only — No Boot
Native DDR4 3200 x1-3 + DDR4 2666 — Boot & all capacities recognized properly
DDR4 2666 only — Boot & all capacities recognized properly

I sent an e-mail to AsRock.
They firstly don’t manage to support it because they said these DDR4 3200 RAMs are not inside the QVL list.

So I ask here that if there is a method to support these DDR4 3200 RAMs by BIOS modding?

Are you mixing all these memories? Sorry, that is not explained very clearly above.
Am I correct in assuming you want to boot Samsung M471A4G43AB1-CWE (Native DDR4 3200 SO-DIMM 32GB module) x4 and this is the 1-4 that wont boot by itself? If yes, why mention/use Micron D9XPF chip SODIMMs (Native DDR4 3200 SO-DIMM 32GB module) x2?
Did you swap around the Samsung M471A4G43AB1-CWE (Native DDR4 3200 SO-DIMM 32GB module) x4, maybe only one stick in some certain slot is causing the issue. Also, check each stick one by one and make sure their SPD/XMP profiles all match, if one is different or missing this could cause issue too.
You may need to purchase Taiphoon burner and edit Samsung M471A4G43AB1-CWE (Native DDR4) and give it a stock 2666 profile, then change speed post boot.

When you do this >> Native DDR4 3200 x1-3 + DDR4 2666 — Boot & all capacities recognized properly << What speed does it boot at? And, does it boot no matter where you put the 2666 module?

I tried several patterns by mixing and no mixing.

Micron ones don’t boot either when not mixing them with 2666 ones.

I did swapped them all.
It’s not the module itself’s issue. Neither the slot’s.

Oh I forgot the method of making a custom SPD!
This may work.
Thanks I’ll try it later.

They’re all running in 2666.
They run properly no matter which slot the 2666 one is in.

Mixed memory often causes it’s own issues, that’s why I asked.
Yes, you may need to make a custom SPD, Taiphoon burner is only tool I know of for DDR4, and paid version is $26 I think

You can run 3200 speed when mixed with that one 2666 module, correct? Also, you didn’t answer my last question in the last quote you posted

Yes, the mixture of 3x3200 + 1x2666 run properly no matter which slot the 2666 module is in.

$26 is far cheaper than selling & re-purchasing RAMs. It can also resolve the Micron memory’s problem.

Make sure you do the test to confirm you can write to SPD on that board, you may not be able to due to chipset. - http://www.softnology.biz/tips_wptest.html
I also assume you will first need BIOS mod to enable SPD Write option too. I can do this for you and you need to do this before you do the above test.
Do you already know if you can flash mod BIOS on this Asrock model without issue? If not, then we’ll have to go FPT route to flash in mod BIOS to enable SPD write. Link me to the BIOS you are using so I can confirm it’s there (and actually, I can show you how to change without BIOS mod too, using DOS/RU method)

Oh my god. Those three 3200 RAMs are protected.
The BIOS I’m using is - https://download.asrock.com/BIOS/2066/X2…ac(2.20)ROM.zip
I don’t know the detail about AsRock BIOS flashing. If OK please teach me. Thanks very much.

BTW I tested my Micron ones on Lenovo M75q-1.

micron 32GB.png

They’re unprotected (maybe it is because of these Micron 32GB ones are remarked RAM modules?).

I just tried manually setting the RAM parameters to DDR4-2666 & specific CL tRCD tRP tRAS tRFC CR.
Then JEDEC DDR4 3200 x4 can be booted properly.
But I still want to modify the SPD since if I have to clear CMOS then it will become unbootable again.


on older spd chip it was pin 7 that needed to be grounded to write the spd. connecting it to vcc or open line will prevent from writing.

@MelonGx - You need to change this setting to 00 >>
SPD Write Disable, VarStoreInfo (VarOffset/VarName): 0xF24
This can be done via grub/setup_var method, or RU method

Here is grub/setup_var guide, you can start at step #6, I’ve done 1-5 for you and info will be below
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Rename .efi file too >> Shell.efi
SPD Write Disable variable to change >> 0xF24

So at grub prompt, you will type the following and then reboot and it will be disabled (case sensitive)
setup_var 0xF24 0x00

RU method to is here, ignore what they are changing, you change what I posted above
Go to section 2.2 and make bootable USB with RU program, then read 2.3-2.5

OR, I can make you mod BIOS to flash in, all up to you? If you’d rather do that, let me know.
You will need paid version of the Taiphoon burner tool, and still may be unable to write to SPD due to chipset (not sure about X299)

Sorry for my 12 hours late replying.
Many thanks for the tutorial.
Since I saw the UUID things I’ll try to modify it myself first.
Does it require dumping my current BIOS instead of using official site’s download?

BTW, how about using Lenovo M75q-1 (seems to be AMD B300?) as a SPD modifying platform?

Sorry for bumping this post again.
I find a Japanese brand called Century Micro sells DDR4 SPD programmer.
It doesn’t have SO-DIMM access but I can use a physical adapter for it.
I think I can use it instead of Thaiphoon Burner.
Am I right?