[HELP] Asus ROG Strix G531GT notebook


I am trying to mod my bios and it seems impossible to flash the modded bios, it gives the (18 - Error: Unable to start a Secure Flash session) error
My notebook is unable to boot msdos and i cannot run afudos238 which can bypass the signature.
Is there any other way to flash the modded bios from windows 10 or from linux? I already tried afulnx which output the same error 18

Many thanks,


@serdeliuk - You can’t flash mod BIOS like that. Please do below, and tell me what error you get at step #2
DO NOT FLASH anything stock modified with FPT!! Only dump with FPT, modify, then reflash - Basically, this is huge warning, AND saying to delete your current mod BIOS as you cannot use this for anything.

Once we get past error #2, then you will make new file at step #1 with new name, then modify this, and then reflash it back via step #2
Once you tell me error you get at #2 I will show you how to disable the cause of the error

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

Hi @Lost_N_BIOS many thanks for your time, this is the error received


Intel (R) Flash Programming Tool Version:
Copyright (C) 2005 - 2019, Intel Corporation. All rights reserved.

Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
MX25L12875F ID:0xC22018 Size: 16384KB (131072Kb)

Error 167: Protected Range Registers are currently set by BIOS, preventing flash access.
Please contact the target system BIOS vendor for an option to disable
Protected Range Registers.

FPT Operation Failed.

Hi @Lost_N_BIOS actually i am trying to see if i can disable the nvidia card (power off) through a bios mod and use only intel one.

Then if this is possible, i want to create a efi driver to disable the nvidia card without modding the bios and use this in conjunction with clover bootloader for G531GT hackintosh users.

What do you think? Is this achievable? I can disable nvidia card and use only intel one? It the default card on my notebook is the nvidia and this way the hdmi port does not work on hackintosh, if i disable the nvidia card and put intel one default i wonder if i can enable the hdmi port.

Disabling the nvidia card will reduce the power consumption and hopefully will switch the hdmi output to intel video card.

Hi, I used IRF extractor and found following variables

0x3FA58 Setting: Flash Protection Range Registers (FPRR), Variable: 0x1205 {05 91 D5 10 D6 10 ED 06 01 00 05 12 10 10 00 01 00}
0x3FA69 Option: Disabled, Value: 0x0 {09 07 04 00 30 00 00}
0x3FA70 Option: Enabled, Value: 0x1 {09 07 03 00 00 00 01}
0x3FA77 End of Options {29 02}

Then used shell.efi with ( setup_var 0x1205 0x0 ) which ended with an error “GUID does not match the GUID” and offset out of range.
Is there anything i can do or i need to purchase a flash programmer?

The error is this one http://s000.tinyupload.com/?file_id=99136978665746076933

Reading more about the issue i saw that there is a bios lock too :slight_smile: i disabled the bios lock and i was able to flash the bios as instructed, then moded saved bios and flash again.

Those are modified addresses through shell.efi

0x4BEE8 Setting: BIOS Lock, Variable: 0xB4B {05 91 94 0A 95 0A D8 0B 01 00 4B 0B 10 10 00 01 00}
0x4BEF9 Default: 8 Bit, Value: 0x1 {5B 06 00 00 00 01}
0x4BEFF Option: Disabled, Value: 0x0 (default MFG) {09 07 04 00 20 00 00}
0x4BF06 Option: Enabled, Value: 0x1 {09 07 03 00 00 00 01}
0x4BF0D End of Options {29 02}

0x3FA58 Setting: Flash Protection Range Registers (FPRR), Variable: 0x1205 {05 91 D5 10 D6 10 ED 06 01 00 05 12 10 10 00 01 00}
0x3FA69 Option: Disabled, Value: 0x0 {09 07 04 00 30 00 00}
0x3FA70 Option: Enabled, Value: 0x1 {09 07 03 00 00 00 01}
0x3FA77 End of Options {29 02}

Many thanks @Lost_N_BIOS for your great tutorials.

@serdeliuk - This is my warning given to users when giving them an unlocked BIOS, and what you mention is what this directly warns against “Here there be Monsters” - Unless you have a flash programmer in hand, and backup made in advance

*** WARNING - To ANYONE with laptop and unlocked BIOS!!! ***
DO NOT try to enable this graphics card or disable that card, switch cards etc. Otherwise you will end up with no display output (ie black screen) and no way to recover except by blind flash or with flash programmer.
You can change graphics related settings, like changing memory sizes, or core speeds etc, just don’t try to disable one card or change which is main etc.

Additionally, be very careful when trying to undervolt CPU, you can leave BIOS unbootable due to CPU voltage too low (Sometimes even 0.05 is too much)

If you don’t want Nvidia card working, open system and remove it. This is safe way you can test if it works or not.
HDMI out will probably not work if you remove the Nvidia card and system still works, usually out-ports are directly connected to the add-on card, everything internally may go through both but comes out to display from the Integrated GPU

Great you were able to find and work your way through unlocking the BIOS lock and FPRR etc
If you still want unlocked BIOS, or help with that, I can do for you, but warning is above and I suggest not messing with what you want to unless you have flash programmer and get ready for recovery in advance.

Hi @Lost_N_BIOS thanks, i understand all warnings and i am trying to not brick the notebook, if happen i have a pickit2 which seems to be able to program my flash memory, unfortunately the flash chip is not on the right side of the mainboard and the whole notebook should be disassembled to reach the flash chip.

Please tell me how i can permanently set those variables to 0x0 to not go to shell.efi each time i need to write a new mod version, it is possible?

For those ones who have a pickit2 and need to use it as a programmer this is the wiring diagram
Connections for 25LC devices
PICkit 2 Pin <–> 25LC Device Pin (DIP)
(1) VPP <–> 1 nCS
(2) Vdd <–> 8 Vcc
(3) GND <–> 4 Vss
(4) PGD <–> 2 SO
(5) PGC <–> 6 SCK
(6) AUX <–> 5 SI

More details in readme at http://ww1.microchip.com/downloads/en/De…0%20%28a%29.txt

I found both, “BIOS Lock” and “Flash Protection Range Registers” with amibcp, but only bios lock was enabled by default, under chipset > pch-io configuration > security configuration

@serdeliuk - to make changes permanent, until you flash in stock or unmodified BIOS, you simply need to change them in grub or with RU, then dump current unlocked BIOS region and use that as your base to modify moving forward
The changes you want to make however, if you mean BIOS lock, to a stock BIOS before you flash it in, several things need edited (setup which AMIBCP does not adjust, and then AMIBCP changes aka AMITSE/SetupData AND NVRAM edits need applied if doing manually)

Are you sure your device can read AND properly program the exact BIOS chip you have? If you are not sure, that needs to be tested and confirmed before you try any of the graphics changes.
And if it fails to write properly, then you will need CH341A + SOIC8 test clip with cable to fix later. So really, best bet is to get this in advance, make a dump and have someone check to confirm it’s OK, and give your BIOS chip ID so we can tell you what software/version will work best to write back to chip (otherwise write may fail)

Thanks @Lost_N_BIOS indeed, the pickit2 i not tested but a CH341A is not expensive so if i brick the notebook i will purchase one, till then i am poking around for infos.
Exists there any ways to modify a stock bios and be able to flash via ez-flash?

@serdeliuk - Best to purchase it in advance and have backup made, checked and confirmed OK, then you know you can recover easily. Otherwise you wont have a full BIOS to program back in when you need to recover.
You can however dump FD, GbE, and ME (if allowed) regions via FPT, then along with BIOS region dump from FPT you can later rebuild a proper known working BIOS to be used for recovery.
Some old desktops allow mod BIOS flash via EZ-Flash, but it’s rare, I’ve never seen any reports of it allowed on laptops.
Mod BIOS can be flashed here with FPT, you may need to disable a few locks before it’s allowed, but we can get there if you want - see post #2

Many thanks for your time @Lost_N_BIOS i was able to save and flash bios region as in post #2 and i put the backup/bin in a more than one "safe" places, this file is not enough to flash with a CH341A in case of disaster?

I found that the biosreg is not enough if you need to reflash your bios with CH341A, if you do not have a full backup with all flash regions (not only bios region) you should have one.

If you have only bios region and you need a full flash you may need to find your bios file on biosarchive telegram channel.

Be sure is intel image not aptio capsule (firmware update) , use UEFITool to open the bin file, please see the image


Then you can replace the biosreg in the image with yours, same tool UEFITool, right click on "BIOS region" select replace as is, you will be required to select your biosreg.bin, after you open your biosreg


Press ctrl+s to save the your new flash, please be sure you chose a new name for your reconstructed file :slight_smile:
Good luck.

Dear Sir, Good day!, Please kindly help with problem. I have Asus GX502LWS. Laptop was bricked and not switch on at all. Finaly at service they repaired and laptop can switch on and working only with integrated UHD Intel graphics. As for diskrette graphics RTX2070 Superb the multicontroller are burned and some anther chip, so at the service they decide to remove this chip’s and after that laptop start working. So at the final i make a very mistakes to push the icon at the Armory Crate as for swith on “GSync” and the laptop was restart and start working normally but no any display at all even from HDMI cable. So at the present time and didnt know what to do. If you can help me to modify my bios to start laptop only with Intel UHD graphics. Cause now no any display, i didnt see nothing. Sorry for gramatics, i am frokm Ukraine. At the present moment service not working for repairing my laptop.