[HELP] ASUS ROG STRIX X99 GAMING Bifurcation x16 in x4x4x4x4 mode

Immediately I will forgive you, I do not know how to communicate in English and everything that I wrote in my native Russian was programmed through Google by a translator.

Initial data:
ASUS ROG STRIX X99 GAMING bios Version 2101 2019/07/17
Xeon 2697v3
Adapter JEYI iHyper m.2 X16 on 4X NVME PCIE3.0 GEN3 X16 on 4 * NVME RAID - 1 pieces
Asgard AN3 RED SERIES M.2 - 2 pieces

A task:
transfer pcie x16 to x4x4x4x4 mode of operation to install 2 pieces of nvme at once and 2 more pieces at a distance with integration into RAID 0 by windows
(screenshot 1)

I myself modified the stock bios for my motherboard. did it via UBU + AMIBCP + UEFITool.
First, I disassembled the BIOS in the UBU program (I put the BIOS in the UBU folder, the download went and the program did everything by itself), I received the body of the BIOS separated from the signature and the signature itself, then with the help of AMIBCP I made the necessary edits to the body of the BIOS, then deleted the microcodes all in to the same UBU program and collected the BIOS. As a result, I have a modified BIOS with a signature. After that, in the already modified BIOS, I edited the efi driver from ser8989 to unlock the turbo boost through the UEFITool program

that as a result, as a result, the turbo boost works, but the slots do not :frowning:
I tried to put the adapter in different slots in different ways, but the result is the same, the system sees only one disk that is in slot 1 and that’s it. I tried to set the values ​​in different ways in the BIOS settings, namely in IIO 0, IIO 1, IIO 2, IIO 3, the result is identical.

I saw posts on the forum where they did almost the same, but they took out the efi driver from the BIOS and made edits in it through a hex editor, how many did not look and did not understand how to do it -> the problem may be this, but this is not accurate.

Who did this, tell me, please, what is the error and what is wrong, I still do not understand :frowning:

Yesterday I left it in the system like this
(screenshot 2)

It turns out that the GPU works in x8 mode and shares it with the lowest PCIE8_3 slot (according to the asus manual) -> my thoughts on the scheme are very similar to the truth.

below I attached screenshots of a block diagram, which I made myself from my own experience, vision and attached an example from where I took the data to test my thoughts.
(screenshot 3)

Link to my modified BIOS, I can not attach it since it is more than 6MB (drive.google.com/file/d/18e_Rad-3bEdhrJVadzduGTdjgklOmsyO/view?usp=drivesdk)
(screenshot 123)


UP1: (screenshot 4)

123.png

3.png

2.png

photo_2021-03-17_11-38-20.jpg

1.png

4.png

there is a movement, unloaded the image section with IIO PCIe Port 2 from the BIOS PE32 (screenshot 2-1), brought it into readable form using Universal IFR Extractor-0.7, in the resulting file IIO PCIe Port 2 IFR.txt I found the IIO PCIe section through the search Port 2 and now I do not understand where to make the edit (screenshot 2-2). somewhere here (screenshot 2-3) or (screenshot 2-4)?

2-1.png

2-2.png

2-3.png

2-4.png

looked at the information somewhere, you need to change the VarStore value from 0x1 to 0x4 for x4x4x4x4 to work. but I do not understand which parameter needs to be changed in the hex line. Does anyone have information?

3-1.png

3-2.png

Hello~TECHNOKEK
The features you need is under a external menu “IntelRCSetup” ,don’t you find that you can adjust you need options in amibcp??refer to below picture.



Although it didn’t show in bios interface ,but at least you can tune them. Now you need to do is that use intel fpt to dump bios then edit this dump via amibcp ,then re-flash it again then you can test your device. If you have an hardware programmer ,everything would be easier because it still use a dip8 bios chip on this mainboard.


Hello. I did edits in IIO 0,1,2,3, = did not help, did it through AMIBCP (screenshot 123 - edit in IIO 0, I repeated this with everyone) = did not help (through the UBU program I parsed the BIOS into the body and the signature, edited body and then again through UBU collected = modified body and signature -> working BIOS, which is stitched through a flashback). I suppose that the problem is in the EFI driver, it is probably loaded into Windows and it is he who interferes with the division of the slot, but I can’t fix it myself in the hex editor -> I can’t check :frowning:

why I think the problem is in EFI, I compared the hex sum of my modified BIOS, which I had previously edited through AMIBCP and the stock BIOS from the ASUS website = hex sum is equal -> the point is in it -> little experience, I can not check and confirm

there is no programmer, I did everything in the mode: I took out the battery and closed the cmos reset contacts with a screwdriver and started after flashing the BIOS through a flashback

123.png

I only can give you a small advice ,next you need to do several tests for yourself.Good luck!


can you unlock resizable bar on X99 platforms?

UP. HEEEEELP

UP2. HEEEEELP

Have you solved the problem?
I have the same problem

I did this a few years ago. Posted a thread here how I did it. Memory has faded unfortunately on exact specifics but on X99 bifurcated x8 into x4x4 using Supermicro bifurcated adapter card. Here is a link to my guide explaining how I did it:

[Guide] - How to Bifurcate a PCI-E slot