[HELP] ASUS s510ua-db71 WINBOND W25Q64JVSIQ BIOS read and write

I’m very green to this level of BIOS interaction. I have this laptop I inherited from a parent, was shut off while BIOS was being flashed. Following it powers up, but no display, no audio indicators, no post, just power light and hd spins up and CPU fan spins. Been trying like hell to go through everything I can find to try and write a clean image /fix the BIOS. I’m using ASProgrammer 1.41, CH341 Programmer 1.29, 1.30, 1.34 to attempt to write BIOS bin from ASUS to chip to no avail. Both programmers don’t seem to have the W25Q64JV chip, I have tried the FV, BV, CV, but when I open the BIOS file from ASUS support and write it fails withhave Main memory and buffer don’t match. I could be way off and may have destroyed any chance of fixing this. I will have access to the exact same model laptop which is fully functional in a couple of days, which I will attempt to read and save a good dump from. The problem is I don;t know which model to select such that this will be successful. Please advise. (My apologies if I formatted or submitted this incorrectly, I’m grasping at straws!!!)

- cobra

[EDIT] I’m interfacing with the BIOS chip via Gikfun USB Programmer CH341A Series Burner Chip 24 EEPROM BIOS Writer 25 SPI Flash AE1185 and SOIC8 SOP8 Flash Chip IC Test Clips Socket Adpter BIOS/24/25/93 Programmer and a windows 7 laptop running the software. I Installed the drivers and the software(s) recognize the USB and reads data from the chip.

Normally, BIOS from Asus is a partial upgrade file, not a complete BIOS and it’s often in a capsule which you can’t write to chip. Stop now!

Did you backup the BIOS contents before you did anything? If yes, please upload that file for me. Then, please link me to the BIOS download page and tell me what BIOS you want to use.

I would try 1.30 or 1.34 and W25Q64BV This is just updated version of W25Q64FV / W25Q64BV, and with FV I have to choose BV to get a proper dump and or write.
Hopefully you made some dumps before you did anything, if so please zip them up and upload to a free file host like tinyupload

Battery and 24pin or main power needs to be connected and plugged in (Don’t turn on, just have system fully powered)

You may also need to try Flashrom software, it’s here in forum, look for newest person posting a build of it via search, unsure how updated the ones would be in github or via google searches

UGH. I did not make a back up… I guess I assumed (poorly) it was borked and just didn’t… And I totally took the contents of 1… maybe 2 of those files from ASUS and wrote them to the CHIP. I can get you the current contents of the chip if that helps, though I think it just be the same as those BIOS files I grabbed from ASUS or did I make the ultimate NoNo here… :frowning:

I’m going to get a current dump will post the link to it back here shortly. Also I will be able to get a good dump from a functional identical model of this laptop, is there any hope in that regard?

- cobra

Here is dump from CH341 v1.30 with BV selected http://s000.tinyupload.com/index.php?fil…117342872926255

Alright… I was able to get a good dump from an exact model of the laptop. I used the W25Q64BV model and ch341 programmer v1.30 to get the dump. I ended up getting it to write successfully by disconnecting the battery and power from the mobo, using ASProgrammer. CH341 v1.29 kept throwing an error on the verify. The machine boots and I’m actually responding to this post from the repaired laptop! So stoked I got it to work. Thank you for all of your help and insight @Lost_N_BIOS. Here is a link to the good dump if it helps anyone in the future: http://s000.tinyupload.com/index.php?fil…512360409387550

Hi. I have an ASUS S510UA-BR298T with the same problem as @cobrachaos. It was turned off while updating the bios.
The BIOS chip is GD 25B64CSIG.

Could that dump file work for my notebook?

Thank you!

Hey @j0nA , that dump is for the chip on my mobo which is a W25Q64JVSIQ which I don’t know enough about the differences between BIOS chips to tell you if that dump will work for yours or not. Hopefully someone can chime in and tell you if it will. Sorry I couldn’t be of more help!

- cobra

@cobrachaos - current contents of chip will not help. Did you ever backup the BIOS previously, even years ago with software would be fine.

Current dump from someone elses system will be helpful to put back your board specific information into the correct locations, if that person will provide/confirm their details as I find them to be correct values.
Then you will need to gather yours from stickers on the board/inner casing. Often in this case, actual serial # will be lost and we can only put in the board serial # instead (board serial and system serial are not same) UUID will be lost as well, but can be partially recreated
Give me images of the bottom of your casing, outside. And then inside the bottom if there is any stickers, and then images of all the stickers on the board too, be sure to look on, around and underneath the memory (remove the sticks and check), often sticker hides there on the slot and or under the memory.

As I mentioned before, for that chip ID you need to use 1.30 or 1.34 to do the write, wit BV selected. 1.29 will always fail, not sure why you listed and dumped with 1.30, then tried to write again with 1.29??
Good you are running, but that was not my concern to help you, that could always be done easily, even with the stock BIOS once a full BIOS was created with it properly. My goal was to help you fix the system properly.
Is your Ethernet LAN working still now? If yes, LAN MAC ID is not stored in BIOS, so that’s a plus. Currently you would have the other persons dump serial and UUID, if it was an actual dump and not a dump from one of the BIOS “Repair/Dump” sites.
Those are often simply stock BIOS repackaged properly to make a system run and not an actual dump from a running system, despite what they say, this can be confirmed by the NVRAM contents and or your current Serial/UUID being all FF or 00’s etc and not real values (ie if FF or 00’s, then not a real dump, and missing 1x NVRAM volume and 95% of the other NVRAM volume)

@j0nA - yes, that dump or stock BIOS built into a full BIOS would make your system run again, but that should not be your goal. You want it to be running and have a proper BIOS.
Please dump your current BIOS and send to me, I will send you a fixed BIOS to program back in.

@Lost_N_BIOS I understand. So though my machine is working now the BIOS probably has the UUID and system serial of the other machine that I pulled the dump from. Here is what I get from the cli in windows on that machine:

PS C:\WINDOWS\system32> wmic bios get name,serialnumber,version
Name SerialNumber Version
X510UA.310 H8N0CX11J323330 ASUS - 1072009

But if I understand you correctly this is from the other machine, which I don’t have access to any longer so I can’t confirm. Here is the UUID info as well:

PS C:\WINDOWS\system32> wmic csproduct get name,identifyingnumber,uuid
IdentifyingNumber Name UUID
H8N0CX11J323330 X510UA 304E3848-5843-3131-4A33-323333333041

Images from the stickers and info on the mobo and under mobo:


Some of the pictures aren’t perfect and probably useless, but I just ut everything in there. Let me know if you need anything else. I really appreciate all your help and insight.

@cobrachaos - It all depends on the source BIOS dump, and if it was an actual dump, or just stock BIOS someone put together and called it a dump. If it’s the latter, generally those would be blank in these areas (so FF’s)

Please clarify what is the above detail outputs. I’m confused, you say you don’t have access but then give SMIC output, so unsure if top/bottom is current BIOS contents, which are what etc.
Or, is all that info, serial, UUID etc is dumped from current system, that you programmed in some random dump? If yes, then that looks like it was an actual dump and not stock BIOS recompiled and shared as a dump (fake), since all values are actual #'s and not FF or 0123456789 etc.
Please add to this info (Just the LAN MAC ID, no need for wireless or other info), then I will copy it later, current LAN MAC ID, in case it’s not valid and we need to fix >> IPConfig /All

Please also link me to the stock BIOS download page you use for this system.

You didn’t answer about the LAN, is your Ethernet LAN working still, or not? If not, check your router logs and see if you can find and ID your original MAC ID from this system, in case it’s not on any stickers.

This dump, you linked above (bdump_20190831.bin), is invalid, dump it again so you know you have a valid backup (unless you don’t care, could use the other dump any time you wanted)

None of the images helped, well maybe, your system serial is on back of system casing. Most of what you showed is all part # stickers.
You left out on, around, and underneath the memory, is there any stickers there?


This is where I had downloaded the BIOS files from ASUS: https://dlcdnets.asus.com/pub/ASUS/nb/X510UA/X510UAAS310.zip

I was not looking at any sites for stock BIOS. I didn’t use stock BIOS to restore…

Just for clarification:

Let’s call the “broken” laptop BROKE and the fully functional, exact model laptop I read the BIOS dump from WORKING.

WORKING is the exact model laptop that BROKE is, they are the exact model version of each other, they have the exact same model BIOS. That is what I pulled/read the BIOS dump from(WORKING) and wrote to my BIOS(BROKE). The command line output above is from BROKE following writing the Dump from WORKING to BROKE.

The pictures are from BROKE

There are no stickers under or around the memory. There may be some stickers on the memory, though those appear to only be to do with the memory. I will get you the mac address for the Wireless adapter, but there is no physical adapter on this model.


Not sure if this helps… Here is the iponfig /all output:
Snipped for user privacy

I removed your IPConfig info for your privacy, that was all wireless info anyway, no ethernet.
Please disable all wireless controllers in network device manager, and connect a ethernet cable, then do that again, and see if you can get online or not.
I assume not, or it would have been visible in the info you originally posted.

Stock BIOS is what you linked above, and then you said you don’t use stock BIOS to restore, very confusing, please explain. Why did you link to Asus stock BIOS, and what did you use to restore the system with?
If you used that link, that is not a dump at all, this is asus stock BIOS upgrade file (partial BIOS, stock, no dump at all)

Thanks for clarification about the Broke/Working systems, I assumed that much, except wasn’t sure if you dumped from that system yourself or obtained from some online site.
My original statement stands, I don’t know how this applies to what’s going on, but I need new dump if you want me to fix it or if you want a valid backup >> This dump, you linked above (bdump_20190831.bin), is invalid, dump it again so you know you have a valid backup (unless you don’t care, could use the other dump any time you wanted)

Yes, stickers on the memory are not what I meant, those would be for the memory only. I meant on the memory slot plastic mech itself, or under the memory. If there is SSD or M.2 etc, look under it too.
If we cannot find, then all we can do is put on serial from back of system, generate new UUID (once MAC is found) and then fix MAC. On the Working system, what is it’s MAC ID for the ethernet (not wireless)?

@Lost_N_BIOS there is no physical adapter on this device, so I cannot generate a MAC id from an adapter that doesn’t exist. It physically doesn’t have an Ethernet adapter is what I’m trying to convey.
The stock BIOS I linked is what I originally wrote to the BIOS from the file I linked, from ASUS. That, the bdump_20190831.bin is what I had pulled from my BIOS that I linked and that is definitely no good, it sounds like because it’s a partial BIOS. The other link in that post, W25Q64JVSIQ_1.30_dump_20190901.zip, is what I pulled from WORKING and is what I’m currently running right now.

As far as pictures go I pulled the motherboard out and the pictures I sent are all that is there. There are no stickers or printing under the memory or around the memory. The M2 slot also has no information under or around it. Unfortunately, everything I sent is all that is there. All I really have for you it seems is that SN. Here is the link again of what I’m currently running on this machine: http://s000.tinyupload.com/index.php?fil…512360409387550

If there is no Ethernet, then there is no LAN MAC ID, only wireless ID’s, and those are stored in the cards themselves.
You shouldn’t use Asus stock BIOS to recover a system, this is partial BIOS upgrade usually, if it is a complete BIOS then you still loose all your system specifics and NVRAM.

That bdump_20190831.bin is bad due to bad dump correct? I assumed you dumped that when I asked you to, from the working system, correct? If yes, as I mentioned, dump it again, with the stuff I said above (1.30 or 1.3 and BV not FV as the ID)
The other dump is good because you used the correct software version, but may not be 100% match to BIOS contents due to using FV instead of BV in the ID

For your safety, I suggest you dump current BIOS again with 1.30 or 1.34 and W25Q64BV - this way you know you have a 100% for sure good file.
Then, in that, if you want, I can put in corrected serial # since that is all we have. Current UUID etc can all be left as it is in there. And really, serial is only needed if you ever planned to, or even could, RMA for repair/replacement, or if windows deactivated which it would do pretty quick if that was going to happen.
So up to you if we edit BIOS or not, but for you to know you have a good valid backup of your current BIOS in case something ever goes wrong in the future I would dump BIOS again using info I mentioned above.

Hi. I could read the chip using the ch341a programmer, v1.30. I selected the GD25Q64 chip.

This is the file: http://s000.tinyupload.com/?file_id=92471376354450968114

Can the dump file be repaired?


@j0nA dump looks good, I can get your valid info from that and put in new fixed BIOS for you. Do you want back on the old 302 BIOS from 2017, or do you want on latest 310 version from 2019 (I suggest this, so you don’t run into same again)

Yes, I would like to have the latest 310 version.


@j0nA - Here is fixed 310 BIOS for you - http://s000.tinyupload.com/index.php?fil…203803296658473

It works perfectly!! Thank you!!


@j0nA - thanks for quick report back Good to hear all is well!
Next time it auto updates don’t interrupt it If this was due to Win10 Auto-update of the BIOS, you have to yell at Asus and Microsoft for allowing such crap, I’ve had to help MANY people recover from this “Auto-BIOS-Update” mess

Hi @Lost_N_BIOS
I’ve read your replies on this read. I am also on same situation my laptop bricked after windows BIOS update (Bios update pushed by windows). My Model is Asus X510UF,
Can you help me to fix this issue, W will take backups before proceed, ill do this probably tomorrow.

Thanks and Regards,

@Nuwantha - Yes, I can help. Please link me to your BIOS download page, not the BIOS download itself, just the page to choose and download BIOS
What is your BIOS chip ID? Look in person, do not rely on what some software possibly told you previously.

DO NOT use Auto, Erase, or Write with programmer, until I’ve told you that you’ve made a good backup and we can proceed. Then I will fix BIOS for you to program back in.
Here is a guide with lots of images if you are unfamiliar with using - [GUIDE] Flash BIOS with CH341A programmer
And here is software package - http://s000.tinyupload.com/index.php?fil…213094641136166

Once you tell me chip ID, then I can tell you what software/version may be best to use to dump and write