[Help] Bios for z97 extreme6 can run QDE4 es cpu

I have a cpu es code name is QDE4 a.k.a 4770k 2.8/3.2Ghz can run normally in Asrock B85m-pro4 . I want to upgrade to m.2 nvme ssd so I bought Asrock Z97-extreme6 but it can’t run with my es cpu . The debug code in motherboard is 2b (26) . So, please help me for the modded bios can run es cpu QDE4 stepping b0 .
Thank you !
Bios download link :https://www.asrock.com/mb/Intel/Z97%20Ex…/index.asp#BIOS
Lastest bios is 2.80

Please link the exact BIOS version from Asrock B85M-Pro4 that you used with this CPU, thanks!

All bios form B85M-pro4 can run with QDE4 CPU . Lastest bios is 2.60 . Lastest Bios can set CPU raito in B85M-Pro4 is 2.30 but I can’t OC my CPU with B85M-Pro4 and don’t have Non-Z OC feature in 1st version 1.50. You can find the B85M-Pro4 form here :https://www.asrock.com/mb/Intel/B85M%20Pro4/#BIOS
Thank you for supporting me . Regards

P/S: Z87 motherboad can run this CPU but All of Z97 this CPU is Locked . Maybe it is the request form Intel !

My CPU info here :

So which version do you want me to look at for putting stuff into Z97 Extreme? 2.30 or 1.50?
Non-Z OC is controlled by BIOS settings, Microcode version and ME version, so I need to know which exact one you’d rather have (Set CPU ratio only, or also bclk and older BIOS)?

2.30 . So can I OC this cpu on Z97 extreme6 after mod bios? My CPU can run normally in Z87 extreme6 so please mod Z87 extreme6 bios version 2.90 . Thank you . My Z97 extreme6 current ME firmware is 9.1.x.x . I can’t downgrade to 9.0.x.x beacause SKU mismatch error

I don’t know if you can OC after mod, I will make BIOS same as your other board in regards to that compatibility though. you are confusing me with your BIOS versions mentioned, please be specific as this is important for how you want things.

Please state in this way or similar.
Use this B85M-pro4 BIOS ME/Microcode >> put into this Z97 Extreme6 BIOS.

Sorry for this going on, but your last reply on this really lost me due to all the different BIOS versions here, and now a third motherboard mentioned too, when you said 2.90 which hadn’t been mentioned at all until that reply.

You can downgrade ME, just not through normal methods. I think it can be done with FPT (After mod BIOS applied and flashed), and certainly with a flash programmer if you have one of those
And you can use pinmod method “E1” from here to unlock your FD and then you can put any ME you want using FPT if first method I mentioned fails.
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing

If the BIOS changes you want, require ME downgrade, you will need to do one of those things or you wont get ME backflashed and functionality you want wont work until you do.
Order CH341A flash programmer now and it will arrive in 3-5 weeks (Cost $2.50-3.00), or price can be $8-12 if you want it fast from a computer place that sells motherboards and ships closer to you, like Amazon or Newegg type places.
Or, get that E1 method acccoplished and flash an unlocked FD region to your BIOS, then it will be all unlocked moving forward as long as you edit FD to unlocked in any BIOS you flash in the future.

Sorry for talking about third motherboard . I don’t know anything about how to modded bios so I can make you feel uncomfortable , angry, headache .

After posted this theard . I go to my friend’s home to test cpu on Z87 extreme6 and it work normally . My B85m-pro4 current bios is working normally with ES CPU and in bios changelog Z87 Extreme6 2.90 and B85m Pro4 2.60 is release same day and same description about update Microcode for spectre variant affect CPU performance . Best performace is z87 extreme6 bios version 2.80c and B85m-Pro4 2.5.0 . If can please mod Bios base on 2.80C bios version .

After you posted about the feature is controlled by bios , Micro code and ME version I tried downgrade the ME version form 9.1.x.x to 9.0.x.x with a little hope my CPU can run normally with Z97 Extreme6 and I realise ME firmware can upgrade easily but vert hard to downgrade .

Again, sorry about my knowledge make you feel uncomfortale . Thank you for wasted time for me .

Bios link for Z87 extreme6 is here :http://www.asrock.com/mb/intel/Z87%20Extreme6/#BIOS

No, not angry or headache, just got confused and since you initially mentioned two types of possibly overclocks on the other system, wanting to choose one to move to this new system, I needed to know specifics exactly.

No waste of time either, I am here to help!! So to clarify, your CPU works now on Z87 Extreme6 2.90 and B85m Pro4 2.60, correct? If yes, then whatever ME is in those, and microcodes for your CPU, will be what I can use to put into Z97 Extreme6.

Do you have flash programmer? If not, can you enable FD unlock and re-write the FD to all regions unlocked via the link I provided above (Section E1 - Pinmod)?
One of those “May” be required, if I can’t help you get ME backflashed via a simple BIOS edit I will do during the rest of the mod changes. If you’re reading this now, give me some time and tonight hopefully I will have time to do these mods for you

I can unlock via OEM/ODM Hidden BIOS-UEFI Options Me FW Image Re-Flash . Bios lock default is disable , bios interface lock is enable do I need to disable bios interface lock??

Microcode in B85m-pro4 is 306C2/FFFF0006 (can’t read?) , Microcode in Z87 extreme6 2.90 is 306C3/24 , 2.80C is 306C3/19 , Z97 extreme6 2.80 is 306C3/24 , 2.70F is 306C3/19 . Microcode 24 is for spectre . I don’t want loss performance so just mod microcode 19 .

ME in B85m-Pro4 is 5MB , Z97 extreme6 is 1.5MB , IDK ME in z87 extreme6 because I don’t stay on my friend’s home anymore . He don’t know how use MEinfo so I can’t know .

Here is CPU-Z TXT report

No, you can leave BIOS interface lock as it is. ME reflash will not help backflash always, so that may not work. OK, so we need to know Z87 Extrem6 ME version then, since I can’t use 5MB ME in Z97 Extreme6. Ask him what BIOS he is using, I can get ME version that way from his board.

So is it bricked or not? I see you said bricked over at mod-BIOS. If it’s bricked then you need programmer as mentioned (CH341A), it’s only $2.50 on ebay, you do not need SOIC8 cable/clip shown in the images since both your BIOS are removable.
Or you can switch BIOS chip and recover, but you know already correct?

I can switch bios and restore for another bios if it brick . My friend use lastest bios 2.40 on Z87 extreme6 . I use the mod from mod-bios forum and It is bricked . Motherboard can’t boot , No light , just show 00 debug code

One BIOS is brick, other is not, you can switch them in sockets, or probably your motherboard has a switch to use one or the other. If it has a switch, switch to the other BIOS, enter BIOS and get to the update BIOS page, then switch back to bricked BIOS and update it.

Thanks for BIOS info on other board, now I can make BIOS. Recover your board though, and if you physically switch the chips around, be very careful popping them out, wiggle from one side then the other back n forth gently. The closer you get to them coming out the more dangerous it is, be gentle, the legs bend VERY EASY!!
Use a plastic tool to wedge one side little at a time, end of ink pen without barrel of ink in it, something small hard plastic.

My motherboard bios have duplicate form A-B or form B-A so it is easier for restore bios

So you recover/switch BIOS already and it’s now OK? If yes, flash the other BIOS how I mentioned now, that way both chips have working BIOS in them again

Already restored when it bricked and All of 2 bios work normaly

@thanh25896 Great you’re all recovered!

So, I checked ME of Z87 Extreme6 and Z97 Extreme6, and both have ME 9.1.xx with same VCN (Version control number), so you can backflash to this ME version in Z87 manually without issue using ME FW Update tool, so will be no issue if flashing it in without programmer does not work or you can’t unlock FD etc.
I will help you do that once you flash BIOS, and check if ME reflashed or not, I will include the clean/backdated/settings transferred ME extracted from BIOS too, you’ll use that with ME FW Update tool from following.
Intel System Tools Package V9.1, please download now if you don’t have, don’t use FTK package - https://mega.nz/#!uQV12IxD!KGAUutQZrdL7T…SugQhzGkt5K5EWU

Microcodes almost same too, except 306C3 19 instead of 24 in new one, ES microcodes are already same in both BIOS. So, either this microcode 19 is the key, or the slightly older ME version
Here is BIOS with both the older ME and the ver 19 microcode. Your BIOS is difficult to modify in a way, so please be ready to recover from failed BIOS possibly, sorry. That maybe why BIOS from BIOS-mods failed too (Hopefully I made mod other way instead
If this fails I can mod other way instead, but this way looked better maybe, who knows though maybe other way is better? Change log included in file.

Put in non ES CPU for now, until we are done with this process.



Please flash twice (Flash, reboot to BIOS, flash again), unless asked if you want full or partial BIOS update, if asked you want full.
Once done with second reflash, please shut down, remove power supply plug from wall, short CMOS pins with jumper and leave there or remove battery, press and hold the power on button for 10-15 seconds
This is to ensure ME state is reset. Once done, remove jumper or put CMOS battery back, plug in power supply and boot to BIOS, load optimal defaults and the set SATA settings how you need, boot to windows and check ME version (unless you can see in BIOS, if so check there).
If ME version is great, we are done, you can test other ES CPU now. If ME version is not yet, then do as noted below.

Go to Intel System Tools Package >> FWUpdate folder >> Local-Win << select that folder, then hold shift and right click, select open command prompt here.
Put ME file I included into the Local-Win folder, and then run the following command from the command prompt we opened at that folders location
FWUpdLcl.exe -f ME_Region.bin

If this method is used, you do not have to do any of the power drain stuff I mentioned, but you can if you want. Hit BIOS once done, load optimized, set SATA, load to windows, shut down and put in the ES CPU (Of course, once you’ve confirmed the ME updated to

Hi all! I’m glad to be here because i see people who know what they do.

Don’t know if i can write my post here, but ill try.

My rig is Gigabyte B85 D3H rev 1.0/1.1 and i also have QDE4 B0

My bios is F15.

What can i do to CPU will work on my motherboard?

Can anyone add microcodes? How to downgrade bios if it is needed? How to enable K o/c mode? My motherboard can overclock 4670K, 4770K only with multiplier but here i can’t.

You need ME and microcodes as discussed in this thread. To downgrade ME you need to either do pinmod to unlock your FD and then reflash with unlocked FD. If not pinmod, then you need flash programmer (Such as CH341A or EZP2010 or EZP2013), and a SOIC8 test clip cable.
Then you can flash any ME/BIOS combo you want with FPT.

On your K overclock issue, please explain more, is this for the B85-D3H you can’t overclock, or what board? Confused because you said you can, but then can’t? This also depends on ME/microcode versions too.

My mobo have option to o/c but this option don’t work with QDE4 B0 because board don’t see this CPU as “K”.

This is my options when K is inserted. This options don’t work with QDE4 and even don’t show in menu like “K OC”.


I don’t have any knowledge over this flash programmers. I only can update from software.

Is QDE4 K-CPU? If not, then it may never matter if you can set K-OC or not anyway. But, I can force that “K OC” to always be visible for you if you want.
But first, please research and decide what ME and microcode you want in the BIOS, I will do it all at once for you. I assume, it may be same as we discussed here already.

ME you may need to purchase a flash programmer, I’m not sure, can’t remember how Gigabyte flash tools react to ME back flashing. I will dig out my board like this tomorrow and see if you can wait, I’m sure I have one of these somewhere
I do not have K CPU though, only Pentium/Celeron for Z97