Help microcode update for Quanta

Help microcode update for Quanta S210-T2W, need support E5 v2
used the instruction
the board does not start, apparently where the error is with the microcode.
use donor bios intel S2600CP (E5 v2 work )
I ask for help. THANK YOU!

s210.rar (2.86 MB)

is there anyone? )

Need to know what CPUID you need updated/added, not general series (E5 v2 etc), please give specific CPU model or which specific SPUID. All microcodes in the BIOS you attached are 2010/2011, is this one you already worked on, or stock BIOS?
That Intel BIOS has newer Intel ME too, may need this updated as well?

e5-2680v2 (306E4)
e5-2609v2 (306E4)

I tried to add 306E4
add attach test3-s210.rom

test3-s210.rar (2.88 MB)

Thanks! So is that stock BIOS in first post? What happened with your insert test? You think it’s bad mod?

CPU microcode FIT table is wrong on BIOS in post #1 and post above BIOS too (Incorrect microcode count and locations etc)
LAN MAC ID address is also invalid in both = 88:88:88:88:87:88

It is the STOCK rom in post #1. It works great with 2670v1 and 2609v1 but lacks support for 2680v2/2609v2 (specifically CPUID 306E4).
Can you please describe what is wrong with the FIT table in stock BIOS? (because it works)
And how to fix the LAN MAC address?

Can you please help me to properly integrate microcodes for 306E4 in that stock bios from post #1 ?

FIT Table as mentioned has incorrect CPU microcode count, thus incorrect locations (missing locations, due to count off).
So microcode count needs corrected, as well as then location entries for all will likely need fix, at least the newly added ones (old missing ones and new inserted one) for sure. I will fix this and insert 306E4 for you.
For the stock BIOS - 206D3, 206D5, 206D6, 206D7 OK - The following are missing from FIT table but included in BIOS microcodes 206D0, 206D1, 206D2, 206D3 (Thus any of these CPU’s may not load properly, or may not load with proper firmware)

LAN Mac address is stored in GbE region of the BIOS, but may also be stored in another location (Search via hex for that incorrect string, and your correct LAN String too)
If you need me to fix that as well I can, please find the correct LAN ID, often this is printed on the board on a sticker near the LAN, may be on top or side of LAN metal block.
It may also be on any other sticker on the board, be sure to check side of 24pin, top and bottom sides of PCI/PCIE slots too. Post images of all the stickers here if you are unsure.

I know about the incorrect microcode count, but it was so in stock firmware (maybe it’s wrong, but it works).
Regarding LAN MAC, here’s the photo of this board - 2 NICs with LAN MAC addresses on the stickers.
It would be great if you help me to fix it properly. My main goal is to make the 2680v2/2609v2 work in this board.


Yeah, it’s lazy coding by the manufacturer, it works for your CPU currently because it’s not one of the messed up CPUID’s, if you try one of those other CPU’s they may or may not work or may or may not work properly/fully
I will make BIOS with fixed FIT table, and all updated microcodes + 306E4, and LAN MAC ID fixed. You may need Intel ME changed too, but for now I left as it is in case it’s OK.

For now, can you tell me, if you connect to either LAN do they work? What is output of ipconfig /all when connected to each one?
I ask because they may be OK, and what I saw as invalid LAN MAC may be default they left, as more incorrect BIOS coding, I only see your actual LAN ID’s in NVRAM boot history entries (Both, in two separate boot logs each)
So that may be where they intended to store LAN MAC ID in this BIOS, and left the invalid one at normal position and it goes unused.

Is that a “Stock” BIOS as in download, or stock BIOS flashed, then dumped/backed up with programmer? It’s normal sometimes to see that invalid ID in a stock download BIOS, but I thought it was dump/backup from programmer which caught my eye.

Both LAN works OK, both MAC addresses inside OS are as shown on the stickers.
You’re right - the stock BIOS I’ve attached in the 1st post was dumped with programmer.

OK, then we can ignore the invalid one I see in normal area (GbE location). Since it’s a dump, and LAN working, then we know it’s normal for this BIOS coding job

Here is BIOS with all updated microcodes except I left the 206D2 PRE-Production code there in case you ever need for older/ES/Xeon/Other CPU = 306E4 latest added, then FIT table corrected
Also, since you are using programmer now, I went ahead and unlocked the FD as well.


Right click download button, save as or open in new tab - lots of ads/pop-ups here, no need to enter credit card or join anything.

I flashed your bios and it doesn’t boot (sad)

Doesn’t boot at all, as is no reaction, or does it reboot, stay running but black screen, please describe. If you have debug card please put that in and check what code it stops on.

Can you recover to other BIOS, if yes I can do again without FIT table correction. The issue may be it’s working fine, but just not with the E5 V2 CPU. Remember I said maybe certain ME version might be needed too.
Before recovery attempt, can you please test with BIOS still there, but older known compatible CPU to see if BIOS OK, but it’s CPU compatibility issue still.

When I turn it on with 2609v2 cpu installed - the coolers are spinning, but motherboard shows no signs of life (monitor is off, keyboard not responding). I have a chineese debug card which shows only E1 code (or F1, it’s hard to understand). That’s all.

What happens with other compatible CPU installed? This needs to be tested before I make BIOS without FIT correction, as it may not be needed anyway, may just be CPU incompatibility issue. Which next to test would be Intel ME change

Everything’s perfect with <E5-2609> CPU

OK, thanks for testing. I will make new BIOS for you tonight without FIT correction, see if that matters or not (I doubt it, it should be correct no matter what). But then, you need to research others doing mod for this CPUs, and see what Intel ME is required, usually some older version

*Edit, got your PM. Sorry I didn’t make BIOS mentioned above yet, but sounds like you found compatible BIOS. Please post it here and I’ll take a look. Or, do you even need anything done now, since you already found compatible BIOS, more updates on it too? if yes, OK, just asking to be sure what you wanted now that you have compatible one (I didn’t read back)

In this version, v2 works.
USB does not work
does not work external card gtx 10 **

quanta-v2.rar (3.64 MB)

Thanks. Please explain more, no USB Works at all, some USB works, did you change USB BIOS settings, have you loaded optimized defaults and try again.
What BIOS is this, for your system or some other? External GFX, maybe BIOS setting, or could be vBIOS issue, hard to say.

I’ve dumped a BIOS from another board (Quanta v2), flashed it to my board (Quanta s210), and Xeon 26** v2 started to work on my board. But no USB ports working with this BIOS.