[Help needed] ASUS laptop bricked after a bad/wrong BIOS flashing

Hi all.

First of all, this is about recovering a bad flash, not modding, but I don’t know where to put it.

I bricked an asus laptop flashing its bios. Flashing ended ok, shut down and now it doesn’t boot, does nothing.
Stick says Asus model is A53S with MB K53SC. After dissassembling, I can see MB is K53SV, maybe it is why it got bricked.
I´ve bought a ch341 programmer to reflash it and have downloaded the latest bios from asus. I’ve done a backup of the actual bios too.
If I open the actual bios in fd44editor this is what it shows:


If I open the bios file downloaded from asus website:


I know I have to fill S/N. UUID and mac from stickers, but ¿what about me? Bios file from asus hasn’t got ME.
Bios is MX25L3206E chip wich is 4 MB long. Bios downloaded from Asus is only 2,5 MB, suppose the 1,5 left is for ME.

How can I flash a correct bios?


EDIT by Fernando: Thread title specified to get help from any of the BIOS Gurus.

Hi, I’ve downloaded both K53SC and K53SV bios image from the Asus site and they have not the ME region inside them,
so I suppose they are simply bios with updated area and they can’t be flashed as they are using the eeprom programmer,
due to the lack of the ME region.
The best thing you can do is to use Flash Image Tool (Intel) under Command Promt to see if your laptop motherboard
have descriptors unlocked, then use the same FIT for Windows, exporting the ME region from the backupped bios file
and inserting into the new one, mapping also the relative settings, compile it and flash the whole eeprom with your
programmer and see if it works.

It’s a boring procedure, but I have no other ideas in my mind.

@Sylar76 :
Thank you for your help.
I’m going to try to do it. ¿Is there any guide for inserting the ME region and mapping and compiling?


EDIT by Fernando: Unneeded fully quoted post replaced by direct addressed top line (to save space)

@PsyduckAP :
Welcome at Win-RAID Forum!

Since I cannot help you myself, I am glad, that you got already support by Sylar76.

Good luck!
Dieter (alias Fernando)


You can try to read this user guide.


But download links for the stuff you need are currently disabled on this site.

Thanks @Sylar76 , I have fitc for V7.

How can I do it? Only have fitc. Do I need another program?

Is it the ME Region.bin file under Decomp?

Do you mean open the bios file downloaded from Asus with fitc and pointing the ME Region.bin file?

Sorry about so many questions, but this is new for me.


ASUS includes only the BIOS and sometimes EC images at their mobile CAP BIOS updates. In your case, the problem should be at the BIOS/EC and not ME. In theory, if you reflash the BIOS region you should be able to work even with the ME region from the current dump via the programmer. I suggest you take that dump and replace only the BIOS/EC region with a configured one (FD44) from ASUS website. First you need to know what ASUS’s CAP file includes, only BIOS or EC+BIOS. Does the SPI image you dumped have the same layout or is the EC stored elsewhere in it? It’s best if you attach both the dumped SPI image and latest BIOS from ASUS for your exact system.

Thank you @plutomaniac

I don’t know how to check if the bios file has only bios or bios + ec. I’ve opened it with UEFITool but don’t know what to look for.
When opening the bios dump and the bios file with UEFITool, I’ve seen there is something left in BIOS region of chip dump (highlighted in images), last padding in dump instead third section in bios update.

The dump from bios


The bios 320

Bios 320.png

The rest looks the same (with the data from 221)

Do you mean opening the dump with fitc, pointing the bios region to the bios downloaded from asus and building?

Here are the bios files:
chip is the dump from programmer.
K53SVAS 320 is the latest bios from asus
K53SVAS 315 just in case, in the changelog it says EC firmware update, so I suppose it has EC.
K53SCAS 221 just in case, is the file I used to flash bios and bricked the laptop


chip.zip (1.65 MB)

K53SCAS 221.zip (1.15 MB)

K53SVAS 315.zip (1.14 MB)

K53SVAS 320.zip (1.15 MB)

I’ll try to assemble a stable bios for flashing it.

I only need few hours and I’ll keep you updated later. Now I’m working for something else, sorry.

Edit : Bios Assembled.



Take the bios linked above. I’ve checked that your programmer dump is corrupted. ME region size is not correct.

Try to program eeprom with mine and tell me if it works. I’ve used the K53SVAS.320 bios file.

I’m going to flash it and will tell you if it works.

Thank you very much

You could experience some LAN issues due to the MAC Address missing.

I’ve put mac address, UUID and S/N with FD44editor.
Unfortunately I’ve broken the clip I use for programming. Tomorrow will fix it and will flash the bios.


Oh, I’m sorry about that, but I’m sure you’ll fix it soon. :slight_smile:

Well, busy weekend with the programmer.

Fixed the clip and flashed your bios and it works!!! Thank you @Sylar76 !!

(My english isn’t good so maybe next explanation is not very clear)
Laptop booted but there were some problems in device manager. Couldn’t initialize both graphics cards and the network card.
It was my fault. When bricked the laptop, I thought it was because I used a wrong bios.
My laptop is a K53SC but motherboard is K53SV. I flashed it with a bios for K53SC and bricked the laptop. When I saw the motherboard, I thought I should have used the bios for the K53SV. But the problem was the bios from K53SC was not written correctly.
I asked for help and I said the correct one was the K53SV and you helped me fixing the bios.
Now I realized the correct one is the K53SC and I’ve tried to flash the bios downloaded from asus with ASUS Easy Flash (no way, model name doesn’t match) and with FTK (some differents problems depending on the version)
I didn’t want to bother you asking for another bios fix, so I have tried to do it.

I’ve opened your bios file with fitc and replaced BIOS Region.bin with the bios file downloaded from asus for the K53SC and built it.
Later changed mac address, S/N and UUID with FD44Editor and programmed the chip. Now both graphic cards are ok, but network card can’t initiate. Maybe it’s because I put a mac address like AA:11:22:33…

Is this process correct or will have a lot of problems?


Hi mate.

I’m very happy to hear my previous bios worked. In your case you have to insert a valid mac address. You can do It using the bt.exe tool from Asus package (find It on the net) or inserting with FD44.

Hi @Sylar76

Thanks again, I’ve inserted a valid mac with bt.exe and now network card is working.


Glad to hear that. Have a nice day mate.

Sorry to bump an old thread, but thought I’d come here as my laptop is driving me crazy.

Psyduck - I’ve got the same problem as you previously. An Asus N53JQ but with an N53JF main board.

I’ve got a backup of the corrupted bios.
I’ve got the official N53JQ bios from Asus.
I have an CH341A SPI programmer

But I am stuck on how to rebuild a new working bios.

Could you provide some basic steps? I’ve tried inserting the new bios (2MB) into the old corrupted bios but that does not work. The onboard flash is 4MB so it looks like the offical bios is missing the Intel ME info and also the EC?

Any help is appreciated.

A bit of the blind leading the blind since I’m a newb, but I have noted that many people use FD44Editor to inject unique info into a fresh MFG ROM before burning. Have you attempted this yet? I can dig up a relevant mydigitallife link if you need more assistance. When you say you want to rebuild a new working BIOS, are you trying to get a fresh image with your DMI info put onto the board, or are you trying to modify the factory image to another end?