Help Needed for RAID - Dell Optiplex 3070 - H370 Chipset

Hiya, Great forum, seems like loads of helpful people here.

I have a Dell Optiplex 3070 which I bought from Dell last year.
It came configured with one Solid State M2 drive and one DVDRom Drive.
I opened up the case and fitted 2x SATA Drives (Traditional Hard Drive Type).
The new drives are recognised by Windows and the Drives section of the BIOS.

My intention is to setup RAID 1 array using the 2 x extra SATA drives (300GB each).
The instructions for how to do this, saying it’s supported for my machine.
dell[.]com/support/kbdoc/en-uk/000132392/how-to-configure-raid-on-a-dell-pc (remove [ ] around .)

I have installed the Intel® Rapid Storage Technology Driver and Application from Dell’s download drivers site. I was hoping to set up a RAID 1 array with the 2 newly installed SATA drives. I want this to be a redundant data disk separate from the boot disk which I want to remain on the SSD.
Production Version: 18.0.1017.0
Driver Version:

Unfortunately I can’t seem to create the raid volume.
I have tried in Windows but although there is an option to create a raid volume, the next button is greyed out.
I have tried pre boot by pressing F12 then choosing device configuration but again the option to create a raid volume is not present at the top.
I have spent hours looking at tutorials and trying loads of different things but nothing seems to help.
Intel have said I need to ask Dell and Dell want $50.00 because I only got the basic warranty. Reluctant to pay Dell because I could get a separate controller card for that money.

Pics attached with the various screens on my device.

Please help, totally lost.


IntelScan1.txt (28.1 KB)





Latest bios?
EDIT: Storage controller set to RAID…?
F12 on startup


Is this screen available?


Note: this options r for initial system setup…not migrations as Dell recommends the Intel Rapid Storage Console

EDIT: Try to set up the raid volume on bios/orom without the NVMe installed on the system, just to see if the options visible changes.

Hiya, thanks for the reply.
Yes it’s on the latest bios available from Dell support page.
Dell Inc. 1.7.0 , 10/20/2020

I can get to the 2nd Screen the Intel one. On mine it doesn’t have the create RAID Volume. I have attached what mine looks like on the above pictures. It’s like it hasn’t been programmed or something. I thought it would be easy going for a Dell because I did IT support and they were good. Kinda regretting my choice now.

"EDIT: Try to set up the raid volume on bios/orom without the NVMe installed on the system, just to see if the options visible changes."

Can I deselect it in the Drives available on the Bios or would i have to physically remove it?

The system/bios options can react differently on one option or other, u got nothing to loose trying both.

I tried disabling simply by unticking the NVME Drive in the Bios and it made no difference.
I also removed it completely from the motherboard and again exactly the same result.
See picture.

Anyone got any ideas? Could it be an issue with the way DELL have written the BIOS?
I’m sure the chipset itself supports RAID, and I have enough SATA slots.
I realise this is a complicated area. It would be good to speak to other Optiplex 3070 owners to see if theirs is setup the same.
Thanks in Advance


@PhilPhil7000 :
Please enter the "Advanced" section of the BIOS and search for the SATA mode settings of the on-board Intel SATA Controller. The Controller seems to run in "AHCI" mode, but you need the "RAID" mode to be able to create an Intel RAID array.

Thanks for the reply.
I usually enter the bios by pressing f12 then choosing bios. It is the most modern kind of dell bios. Is there a way to get into advanced mode or are you referring to the sata operation feature?

Mine is like attached pic from another pc but I have it set to RAID already.


Did you check if Optane is configured? What does the Optane section in the Windows utility show?

Why didn’t you attach a picture, which shows your Intel “SATA Operation” setting?

Sorry my bad. Please see attached my picture of my machine.

Re optane. It was an option when I bought the machine but I didn’t go for it so the software says not available.


What kind of 3070 is this? Only the tower has 2 sata 3.0 lines, ‘Small form factor’ is described with 1 sata 3 and 1 sata 2 which makes me think that the sata2 port maybe isn’t connected directly to the chipset (and therefor not available for RAID conf.)?

Hiya. That’s interesting. Its the tower version. The biggest of the options.

After inspect the motherboard There is one slot for the nvme drive.
Then there is sata 0, sata 2 and sata 3.
I disconnected the optical drive for testing. Do you think it matters which of the sata sockets on the motherboard you connect the 2x sata drive to?


How would I identify which port is sata 3 and which is sata 2? It would make sense to have the optical Drive in the sata 2 slot and then the 2x sata hdd in the sata 3 slots wouldn’t it?

Tower…nual7_en-us.pdf board on page 69, 3 sata connectors blue, black, white
SFF…nual2_en-us.pdf board on page 62, 2 sata connectors blue, white

I’d assume the white one shoud be the sata2, but it doesn’t make too much sense to me…

The ports are as follows but I can’t see anything that says what speed they are at.
Sata0 = blue
Sata2 = white
Sata3 = black

I will try to check some software for the speed. Still baffled about the raid.

The SATA0 port is usually the fastest and should be used for the bootable system drive containing the OS and the boot sector.

I have tried the drives in all possible combinations and it doesn’t make a difference. Sata0+Sata2. Sata0+Sata3. Sata2+Sata3.
I am beginning to think that the way dell have implemented the Rapid Storage Technology, it only supports the NVME drive and not a RAID Array (1 or 0) of SATA drives, even though the system itself allows the NVME Drive, 2x 2.5 SATA Drives and an Optical Drive.
I feel really disappointed. I may buy this card and use the raid facility on that,
I hope that it works in the PCIe x16 slot as it says it is PCI Express 2.0 but it goes in a slot rated higher than that aswell.
I think you have to switch to legacy boot to get to the onboard card. CTRL + M.

Quoting a user upon his contact with Dell:
"…So Dell told me in the end I cannot do a normal RAID array, and that all the RAID-On and Intel Storage manager are for is to use the Optane drive acceleration. But thanks to everyone for their help."

The same user tried legacy bios interface to see option rom display with CTRL+i/m, always the same results and screens as u have…guess u run out of luck, u can always contact Dell to inquire and verify this situation is indeed accurate.

Read these threads, too, and I’m quite sure that RAID is factory disabled here, you’re possibly supposed to buy a more expensive machine…

The more interesting part is how they disabled it and if it could be fixed:




@PhilPhil7000 Would you mind telling us which driver is loaded for your SATA controller and what the device ID for you SATA- controller is (Prefered screenshots from device manager)? It could make it easier to answer these questions in the future if we knew that they did break it via messing with the device ID…

There’s also been the question in other threads if a change between RST and RSTe could be made- seems that’s one bit down. Bit 7 decides if RAID is accessible and bit 6 if its RST or RSTe.