[Help Request] Problems after an ASUS ROG GL502VT BIOS downgrade


I have recently attempted to update my BIOS to the latest version available, which has caused my notebook not to boot anymore.
This was due to the incompatibility of this new BIOS version with the Samsung SSD I have installed.

So I had to downgrade my BIOS, and ASUS forbidding to do so, I ended up flashing the previous version with AFUDOS /GAN.

Long story short, I erased all the unique information from my BIOS.

I made a lot of google research, and since I don’t have a backup, I think I need a dump from the same notebook than mine.

I found a dump from a GL502VM, which was customized by LOST_N_BIOS, we can see where these information are stored :

Unfortunately, my model does not use the same GUUID.

Thanks for any help !

EDIT by Fernando: Thread title shortened (can be customized by the author)

Yes, as you’ve found, using /GAN and stock BIOS you’ve erased your NVRAM, and serial, UUID, and LAN MAC ID probably too.
If you had a backup you could fix with AFU /GAN again, but this never ideal method to flash, only as last resort and NEVER on Intel CPU system since there is other much better/safer ways to flash
Same GUID’s probably used, but since you don’t have a full backup there’s no way to check and see, stock BIOS does not contain these kind of NVRAM entries.

You don’t have ANY backup, from any software, even from years ago?? If not, maybe I can find a dump from this same system, if not we may not be able to fix your backlight.
NVRAM is only sparsely included in a stock BIOS (one entire volume missing and other only 5% is in stock), all this kind of stuff is never in there.
Serial, UUID and LAC MAC ID we can fix, from stickers on your board probably, but UUID/Serial really only needed for RMA, but LAN MAC ID You need to fix for Ethernet.
Sometimes windows activation may be tied to serial, or you may have erased the stock key from BIOS too. Only time will tell on that, you can check windows updates, reboot and see if it stays activated.

I found three dumps at one site, ideally I may need to download them all, since often people program stock BIOS, dump it and call that a dump which it’s not, so may need to get all three to hopefully find a proper actual dump.
I can only download one file per day from this site, so may take a few days. I will also look at other places for a proper dump too. Got two today so far, one from the site w/ 3, and one from another site, none actual proper dumps
So, over next two days I will get other two files from the one site, while I also look for other sources too.

For your serial, UUID, MAC etc. Remove the back casing and send me images of all stickers on front and back of the bottom casing, and then images of all stickers you can see on the board with the back removed.
Be sure to look on/around the memory slots too, and remove the memory, sometimes sticker is hidden on the memory slot itself and or under the memory sticks. I don’t need images of the memory or it’s stickers

Hello, and thanks a lot to take time for my issue :slight_smile:

Unfortunately I do not have a backup because I never tried to mod bioses, I just made an official update I thought would be harmless, and I was not informed enough when I proceeded with a rollback.
The only backup I have now is from after erasing my NVRAM. Stock bios flashed with AFUDOS, booted and then backed up.
Not very usefull but I have attached it.

I don’t think this is the same GUUID because I searched for the GUUID used in the capture above inside my BIOS and there is absolutely no reference.
The ethernet card is somehow is still OK, with the same MAC as before.

Windows had to be reactivated, as some other softwares.

Here are the files, I did not manage to attach them here : https://www.dropbox.com/s/mrjyii83u2ne5i…p_infos.7z?dl=0


You’re welcome. Sorry to hear you didn’t make any backup ever. You did not make “official update” since you used a non-standard method with an engineer tool (non-public and not for your BIOS type), but yes, even stock BIOS update using standard method can mess up, or even brick a BIOS.
Yes, no need for any backup now, pointless to fix any of these issues. As explained, the GUID shown there is not in your current BIOS, you erased the entire NVRAM volume, so many things are missing (100’s of GUID’s and entries in NVRAM)
Also, yes, sometimes it’s not same GUID # anyway, but always same text name of NVRAM entry (MFG0 or CNFG)

Good to hear your Ethernet MAC ID is still working at least!

I don’t need any backup from after this happened. Neither of those images have UUID, one possibly has MAC ID, but since your MAC is working that’s not needed. You can check it to confirm though if you wanted, the 708BCD #, is that your MAC ID? You can check by CMD line >> IPConfig /All
The G7N may be serial, but since you’ve already re-activated windows again, best we not change that now, or you would have to redo again and they may deny due to same hardware and third activation with different serial (Might thing something funny going on)
No stickers on, around, or under memory if you remove the memory stick?

So, I think for now, only thing you should fix is backlight, but I’ll first need to get proper full dump first so we can redo your NVRAM volume/volumes.

Yes I did use an engineering tool to rollback to previous version, since ASUS tools forbid me to do so.

I think this is not the right uuid because in the bios from which the screeshot is taken, we can find plenty of reference to the CNFG uuid everywhere in the bios, even outside of NVRAM. This makes sense because to be read this information must be referenced somewhere.
In my bios it is not the case.

My mac address is 70-8B-CD-15-21-59 yes :slight_smile:

Edit: I missed your question regarding other numbers.
There are plenty inside the notebook but I don’t think they are relevant.
Pictures here: https://www.dropbox.com/sh/5i7vta1y93jzw…XvPhvMKBVa?dl=0

I know, that’s why I countered your comment, that you “made an official update”

I don’t know what you are saying "this is not the right uuid " I’ve not given you any UUID, that’s not possible since you have no backup. UUID would have to be regenerated, this is usually random data+MAC or DTS Key+MAC etc.
As for the screenshot, that is not your model for one, and two, that image if from a complete full proper BIOS dump, thus has a complete NVRAM volume, which you do not have until I can find a proper dump from this exact model. Since you have no backup made.
You mean GUID, in reference to CNFG, and as I mentioned, any modules GUID may not always be the same. But, no matter what, CNFG entry itself (no matter what GUID is used in your BIOS), is not in your current stock BIOS, this is never in any stock BIOS, this is only in on-board BIOS, or a backup of an on-board BIOS - which you don’t have

Thanks for the other images, what you think is relevant or not may not apply to what is actually relevant. I work on BIOS all day every day, so I know plenty about all of this.
Can you please put all those images into a single 7zip archive, thanks! I can’t view them as it, they are too huge and I’m not going to download them all one at a time.
Also, please add another, unless there is nothing there, I don’t see any image of what’s under the Kingston memory stick. Is there a sticker there? If not, OK, but if you didn’t check, please check and add if there is.

Still no luck finding proper full actual dump from this model I’ve found four dumps now, all stock flashed incorrectly, then dumped, so no complete NVRAM volumes yet.
Need to find somewhere that someone posted there dump and asked for a mod or something, all the usual “BIOS repair/recovery” type sites only have this non-actual dump rubbish, I’m still looking.
I checked here, and you’re the only one who’s posted anything with this model, otherwise I’d PM users and ask for a FPT dump. Do you know anyone on any forums with the same exact model? I have full dump from GL502VS, close but no cigar
You may need to purchase a dead board on ebay and then flash programming tools to dump it’s BIOS, that may be cheapest way to fix your backlight.


Thanks again for your time.
I am still searching on my side for a proper bios. I am also searching for dump of similar models.

Glad to hear all these numbers can be usefull. I have checked under the RAM module, there is nothing. The sticker was under NVME SSD, it is the first I one I posted.
There is a download link on the top right corner allowing to download all pictures in one zip, does that work for you ? If not I will repack the images and send it to you.

I don’t have experience with bios modding but I have been working in software development for 12 years.
I may be wrong, but I think the guid is an address, used to access the data.
My hypothesis is that this address should be in the stock bios, in the parts of the code that read this data.
If not, then it’s the name “CNFG” that should be there (I found it), and then the guid used would not matter.
But the existence of programs like FD44 editor make me think that it is indeed the guid that matters.

From what I have red online, I guess that the CNFG block has always the same structure, so if I manage to retrieve the right guid, I would like to try to insert the CNFG block from the GL502VM dump I have.

But of course finding a proper bios would be the better way :slight_smile:

Edit: Sorry, I see I wrote uuid but I meant guid !

You’re welcome. No need for “Similar” model dumps, I have those, nothing you can use from that anyway, need actual dump from exact system (And not some improper dump where someone incorrectly flashes/programs in stock BIOS then dumps - this is what many BIOS dump/repair sites post)
Thanks for checking under memory. No, I didn’t realize I could download those all in dropbox provided zip, thanks. Damn! 40MB for some images, crazy MB’s for something I could easily see in less than a single MB or two.

You do not need to hypothesize about GUID, you are thinking correctly about what it means, but your hypothesis of “it should be in stock BIOS” is the only problem there. It is not, and I’ve explained this many times, please re-read this <<
CNFG or any GUID that contains the CNFG entry is not in stock BIOS, same for 100’s of other GUID’s. Stock BIOS is simply put a partial BIOS upgrade, not even half the BIOS is there.
FD44 editor has nothing to do with any of this, or any related GUID’s That software is only used for exchanging serial, UUID, DTS keys, LAN MAC ID in some BIOS.

CNFG entry cannot simply be placed back into NVRAM. We need a proper dump, with complete NVRAM volumes.
Here is a general example, with similar model (502VS), stock BIOS NVRAM vs actual properly dumped BIOS with complete NVRAM volume, so you can see what I mean.
If you’ve found a proper actual dump of the 502VM, then you’ll see similar vs stock for that model, if you see same NVRAM only in the “dump” vs stock, then it’s not a proper actual dumped BIOS.



I know a proper bios dump would be the best solution, but unfortunately I can’t get my hands on one :frowning:

After a lot of research, online, using uefitools and other tools such as hex editors and universal IFR extractor, I think I have found out which guid in NVRAM should contain the CNFG block.

I am pretty sure it is 984EB4E9-5A95-41DE-AAD0-53668CA513C0.

So I would now like to try to add this CNFG block in my NVRAM, it should at least bring back the keyboard backlight, which I know is configured this way.
Can you help me try that ?

CNFG block and my bios are attached.

I am not sure how to read your last post, if you meant adding back CNFG block would not do or if we simply cannot add entries in NVRAM.
UEFITool don’t allow me to, so I am looking for another solution.

Thanks and regards,

Edit: I did find the way to put this CNFG var with this GUID in my NVRAM.
Not yet working as I wish it would but I will figure it out.

_My_Bios.zip (2.52 MB)

@madkat - no, it’s not the best solution, it’s the only solution. You cannot rebuild or simply add a GUID into NVRAM like you are thinking, well you can but it (insertion to NVRAM) doesn’t work that way.
So yes, that is how my post was written, you understood it exactly. This is not me trying to be difficult, this is just how these things work and this why you always backup BIOS before you flash any BIOS or erase a chip etc.

The only way forward here that will fix your backlight is a proper actual dump from a running system, that is not a generic dump where someone erased a chip then programmed in stock BIOS only and then dumped.
This is what you get 99% of the time when you purchase BIOS from “BIOS/Dump sales/recovery sites” too, so don’t waste your time or money.

You either need to find some thread in a forum where someone dumped this systems BIOS and said “here is my BIOS dump” (For whatever reason, to fix, or to mod etc)
Or find someone you know, or can randomly run into on some forum, or directly request in a thread for this reason, that will dump their BIOS region for you via AFU and FPT (in case AFU Doesn’t dump the NVRAM)

You could try making a thread here “Calling All/Any Asus GL502VT Owners - BIOS Dump Request” I’d also make same exact thread over at notebookreview forum, I bet there you’d get a dump within a day or three.
Be sure you make it clear you want an actual directly dumped BIOS from live machine with proper and full NVRAM volumes and not stock programmed/flashed/dumped that does not include full populated NVRAM volumes
I say that last part because at notebootreview 100 people will instantly find and pass along to you the 4-5 incorrect dumps I’ve already gathered, so you have to make it clear dumps like those aren’t going to work (From sites such as Vinafix (Paid), Dinistor, GeekDias etc)

I can help get you programmed over into a 502VS BIOS that will work, but then you will be stuck with that model/BIOS moving forward.
They use different video cards, so I would have to modify that BIOS for this too first, but that’s easy and this all can be done if that is what you want instead of waiting until you can find a proper dump.

Great news

While googling for CNFG / MFG0 which are the name of the Asus config variables, i found out this russian page : https://novoselovvlad.ru/2019/03/07/asus…-transmit-tool/
There I found the BT2 Asus tool.

I managed to add back the serial number of my notebook and the mac address, so they show up in the bios.
For future reference, should work for any Asus notebook :
Read the mac

BT2.exe -C CNFG -N 6 /R D7

Write it
BT2.exe -C CNFG -N 6 /W D7

Then type the mac

To set the serial number:
BT2.exe -S -N 15 /W 00

Then type it.

I also managed to get keyboard backlight working during POST :)
BT2.exe -C CNFG -N 1 /W DD 7E

This tool is quite powerful, it seems it can also handle uuids.

I will not close the request for bios dump as it could still be usefull, but I am happy I can get back my backlight :)

To set a uuid derived from the mac address:
bt2 /uuid B8 -c cnfg

You are then prompted to type the mac address.

@madkat - Yes, I know all about BT tool and have it for a long time, it’s not required and shouldn’t have been able to help in this instance or I would have already sent it to you.

So, it worked for you, even though you do not have populated NVRAM already? This doesn’t seem possible. Maybe it just made the CNFG entry and added the 7E at DD only and rest is blank?
Dump your BIOS region with FPT and send to me so we can check. MAC/serial can easily be fixed with FPT, rarely would you need it for this too, but it could be used too.

Yes, it can do quite a lot, here is my notes on it from past experiences and usage in other situations etc

1. The machine pre-installed vista basic (which I can not be determined, because my N80 preloaded with VISTA, the insurance point, this article also listed on the inside)
2. SLIC2.1 refresh with the BIOS, a specific model and version of the corresponding Web site you can find bios.net.cn.
3. Modify the machine readable Part Number (ie BT tool), method:
First, download the tools BT, such as stored in the D drive into DOS, type
bt spaces / w space 27 space 47 (Note that the center has a space)
The code is as follows: 41 is the Home Basic version of 43 is the Home Premium 45 is a commercial version of 47 is the flagship edition
When prompted return = 0 says that the success of changes
4. Into the Recovery Disk can be resumed at the corresponding version of the win7

BT / r 27
BT /w 27 5A BT / w 27 5A

HomeBasic (x64) => 52 HomeBasic (x64) => 52
HomePremium (x64) => 54 HomePremium (x64) => 54
Professional (x64) => 56 Professional (x64) => 56
Ultimate (x64) => 5A Ultimate (x64) => 5A

-S : String format
-FN : filename
-L: within <begin> <end> Limits
-C <block>: Select block, CNFG,MFG0 are available now, default is MFG0
/W <offset> <data>: Write data to the offset in BIOS flash ROM
/W1 <offset> : Write barcode to BIOS flash ROM from offset
/R <offset> <data>: Read the offset data & check it
/RBit <offset> <Data>: read bit(data bit6~4) data and check with bit0
/WBit <offset> <Data>: Set(bit0=1) or Clear(bit0=0) Bit(data bit6~4)
/PD: System soft off
/CB: Clear reserved block in BIOS ROM
/WF <fn1> <fn2> … <fnN>: Write data in file into BIOS ROM
/RF: Read data in BIOS ROM and restore to file

Return Code: OK(0), ERROR(-1)

BT.exe -s /r 9 9ABCD → Read the 9th offset data & check it is ‘9ABCD’
BT.exe /rbit 2 21 → Read 2nd offset data and check if bit2 is 1
BT.exe -l /w1 60 69-> Write barcode to the 60h~69h offset
BT.exe -l /r 60 69 > TEMP.DAT-> Read 60h~69h data & output TEMP.DAT
BT.exe -fn fl.txt /wf → Write data in file described in fl.txt to BIOS ROM
BT.exe /wf d1.dat d2.dat → Write data in d1.dat & d2.dat file to BIOS ROM

Correct command to fix the keyboard lights
bt -c cnfg /w dd 7c (Sometimes 7E, or other values as well)

This is another trick for writing a MAC Address on ASUS Laptop computers (under pure dos environment). << From a user here, can’t remember who)

1) Uncompress zip file and copy bt.exe on the root device (I assume to use an USB stick formatted and dos bootable).

2) Let’s suppose to use a MAC Address like this : 14-DA-E9-5B-1B-04

3) You’ll have to use the following syntax :

bt.exe -C CNFG / W C2 14
bt.exe -C CNFG / W C3 DA
bt.exe -C CNFG / W C4 E9
bt.exe -C CNFG / W C5 5B
bt.exe -C CNFG / W C6 1B
bt.exe -C CNFG / W C7 04

bt.exe -C CNFG / W D7 14
bt.exe -C CNFG / W D8 DA
bt.exe -C CNFG / W D9 E9
bt.exe -C CNFG / W DA 5B
bt.exe -C CNFG / W DB 1B
bt.exe -C CNFG / W DC 04

I also found out about bt maybe the first day of my bios issues.
BT is not working on recent computers, BT2 is needed for these, and BT2 is much much harder to find.

BT2 has not written anything in NVRAM, actually it has written its settings in the second padding block.
This location seems to be different than the settings location of the bios of the GL502VSK I have.

Since paddings are overwritten on BIOS update (you confirm ?), my guess is that CNFG, MFG0, … vars in NVRAM are used during the update process to put these settings back in place.

Anyway I could restore some of the settings, if I can get my hands on a correct bios dump I might manage to put everything back :slight_smile:

I have tried FPT before on my notebook, it does not work.

I have attached my results so far so you can check it out.

Edit: I have added more stuff back in my bios since I made this dump but I don’t have time to re dump it this morning.
I will update if I make more progress.

redone.zip (2.54 MB)

I have three different versions if you want copies? I’m not sure if that is same as BT2.exe you mention (it’s all just “Asus Block Transmit Tool” I assume) - anyone can rename exe file


Revision 2.00 (9/26/2003) - 93kb
Revision 2.06 (2/14/2007) - 182kb
Revision 1.10 (2/11/2011) - 62kb

"Padding" files may not be padding files, depends on what tool you are looking at them with. And in this situation, where BT writes may be “padding now” due to it’s exact location (ie your image showing second padding), but that area could be second NVRAM volume in a properly dumped BIOS source “sometimes”.
Or, it may be simply written to the wrong location, since no CNFG exists in current NVRAM (most likely this) In general, yes, if you write with FPT a stock BIOS which has a blank padding file where data is stored in current BIOS, then blank will be written.
If using AFU, it depends on the BIOS, what’s in this area, what options are chosen in AFU command etc.

Normally, that second padding would either be NVRAM or a padding as it is now that would contain serial, UUID, Mac etc, but none of these GUID’s nor any info/data that go into NVRAM areas.
So if you’ve written NVRAM GUID info into this padding area with BT tool and it works, good, but that is not proper nor how it should be done nor how it’s done in proper BIOS dump before stuff like this happens.
I’m really surprised this turned the KB backlight back on, especially considering how much hassle this single byte gives so many people I see complaining online.
The enable variable for this function and this particular model, 7E is now written to 1DD, in a non-standard location (not at DD as it should be, not in CNFG or MNFG GUID entry, and not in NVRAM at all, so you’re lucky)

NVRAM and padding files/modules are not related at all, nor do they contain same kind of things.

FPT works, you just have to know how to use, use the correct version (V11 if your ME FW is 11), and use it carefully and properly.
I already know it works on this system as it’s same as the other similar models, which I’ve unlocked entire BIOS for many users previously, who gave me their FPT dumps

Thanks for your dump to check, see my thoughts above, this answers your thoughts/comment about VSK BIOS when you compare (because it’s properly correct valid dump, so what you see is proper)

@madkat :
Since your chosen thread title was very long, I have shortened it and hope, that this is ok for you.
You can customize the title according to your wishes at any time by editing the start post.

Hello @Lost_N_BIOS

BT2 is a different tool than BT, the command line interface has been changed and it will work with post 2011 computers when BT will not.
But it seems you have it :

Yes I would like it please, mine is a little older :

FPT does not work on my system, that is the error message I got when I tried it.
Since afudos works perfectly fine on my system, I use it.

During the past weeks I have used a ton of tools on windows, usb bootable linux, dos, efishell, I am getting tired of it

About the padding in the bioses, you are right, while seen as padding by uefitools it is probably not just padding.

When I tried to find a proper bios dump for my model, I have downloaded a lot of dumped asus bioses.
I Thought most of them where corrupted / had NVRAM cleared the same way I cleared mine.

After having repaired my bios with BT2, I have looked again at these bioses and they ALL have data in the “padding” volume.
All but one have their serial number written at offset 0 of this padding, the one beeing the GL502VSK.

Here are these bioses : http://s000.tinyupload.com/?file_id=00024500166902594096
I used these to determine at which offset I should write wich data.

Now I am not sure anymore there are always CNFG / MFG0 / OEM1 / … variables in NVRAM.

I have succedeed getting back :
- keyboard backlight,
- LAN Mac address (shown in bios and seen in windows),
- Laptop Serial (shown in bios and seen in windows),
- Laptop uuid (generated a new one with BT2)

I did not succeed in setting back the motherboard serial, I have inserted it but windows do not see it.

For now I will stop trying to add info inside my bios until I can get a bios dump from the same model I have.

Anyway thanks a lot for your time and for this forum
I hope my findings can be useful to someone in the future :slight_smile:

@Fernando no problem, that’s fine by me :slight_smile:

Looks like you have the same tool already? You said “mines older” and then showed same date

FPT does work on your system (For sure), and you didn’t show the error you get so I can’t comment further? AFUDOS does not work perfectly fine, hence this thread.

Yes, many BIOS out there provided by BIOS fix/recovery sites often have BIOS incorrectly flashed and then dumped so it ends up just like yours did here.
This is a workable way to dump BIOS to not have to spend extra five seconds to FF out system specific details from what you are dumping from, or easy way to create a complete BIOS that’s ill boot from the stock BIOS, but is never actually dumped from any running system.
Pure lazy and incompetent is what this is called when a BIOS recovery or BIOS repair site hands out a file like this and specifically says it’s a dump or calls it a dump etc (Direct lie, and they know it’s not a dump)

Yes, as mentioned, many BIOS do use this specific padding area for information (often a copy of UUID, DTS key, serial etc is stored there). Never is CNFG/MNFG info stored here in padding areas, those go into NVRAM only, when used and yes they are not always used.

Once we have dump from this exact model I can put back in all your information in the correct format and proper locations.

Same version number but slightly different date, maybe one is build date and the other is release date.

Ok I have downloaded another version of ftp and this one worked.
I attached my latest dump. You may notice that while I was at it, I have upgraded intel microcodes, spectre and meltdown and such was the reason I wanted a bios update in the first place.

Actually most of the bioses of the collection I uploaded come from here or other bios modding forums, and are dumps that come from bios modding request / bios curruption fix request.

We shall see when/if we can get a working dump for my laptop, but I do think that CNFG/MFG0 are stored in the padding area in Asus bioses.

I will be offline a few days, but I will get back :slight_smile:
Cheers !

biosreg.zip (2.53 MB)

Hi, I have GL502VT with 970m. I can send you my BIOS dump.

BUT the motherboard has been replaced and I do not have keyboard backlite. Can anyone help with that?

I have tried old solutions with ATK and old Gary Key fix (fixmykb) but it does not work - returns error “Can’t wrote data.”

Hi Bipper,

I had the same symptoms as you, and I could get my keyboard backlight to work again with the solution I described in this post :
[Help Request] Problems after an ASUS ROG GL502VT BIOS downgrade

You must use BT2, older versions of BT don’t work with our laptop model.
I have linked the page where I found BT2 in my previous post.