[HELP]The acuteangle HTPC Bios Modding

I have an acute angle HTPC. It has an Aptio V bios.
But that bios doesn’t see the “Advanced” tab.
I opened this “BIOS” with “AMIBCP” and I can see that the “Advanced” tab has not been removed.
When I use “AMIBCP” to make it visible and flash it, the “Advanced” tab is still hidden.
I tried to extract “IFR” but could not find the corresponding “GUID”.
And after I modified the “bios” and flash it, it automatically enters the “recovery” tab when the power is turned on.
Can someone teach me to solve this problem?

afuwin.rar (4.12 MB)

What… So it’s not obtuse then I take it? What did you create the above file with?

Please link me to the stock BIOS download page, not the BIOS itself, I want to get the full exact model name too so I can keep this BIOS in a properly named folder.
Plus, I want to download the stock BIOS package too and see the stock flashing tools, process etc.

Please download ME System Tools v3 from section C2 on this page
Intel Trusted Execution Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Win64 folder. Select that Win64 folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTW64.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error given >>
FPTW64.exe -bios -f biosreg.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help

Your mod BIOS flash may be due to bad BIOS mod, or Intel Boot Guard maybe stopping you.
Please also find in the above System Tools package,TXEInfo folder, and run >> TXEInfoWin64 -verbose and show me the end of this report

Thank you for your reply.
I got this file as you said.
No error when I write back the BIOS Region dump.

biosreg.rar (3.98 MB)

Thanks, I will check it out, please wait. I edited your post above, no need to quote me, it’s just us talking

Please link me to the stock BIOS download page for this system

Sorry, I am not sure how to reply to the forum.
The official hadn’t BIOS download page for this system.
My previous BIOS attachment was got by “afuwin64” backup,it can load and edit by “AIMBCP”

@Unknown - what do you mean you don’t know how to reply on this forum?? You’ve replied a few times above?

Do you mean there is no stock BIOS download page for this system? Where is the driver download page, maybe I can find it
I wanted the stock BIOS, it’s not required for what I need to do, but I did want it if we can find a copy. Your AFU dump will not be used here, nor will AFU

* Edit - @Unknown - I also still need to see the end of this report, or you can check and let me know, do you see “Measured” or “Verified” boot enabled on left/FPF side?
TXEInfoWin64.exe -verbose

Hi @Lost_N_BIOS ,

I have also received an Acute Angle PC, and I found this thread on Google, when searching to how to mod/change the BIOS default values, because I am trying to see if it is possible to enable a feature to “Power ON after AC loss”.

I opened the AFUWIN extract from @Unknown in AMIBCP and I see that under the Chipset > South Cluster Configuration > Miscellaneous Configuration, there is a “State after G3”, that supposedly by default is set to “S0 state”. But if power is loss the PC does not automatically turn on :frowning:

AMIBCP option

From your experience, is there any hope that this feature can be activated on the BIOS?

PS: I have also contacted the manufacturer, but my hopes are not high (https://www.acuteangle.com/product.html)

Thanks in advance

@maps - Please see post #2 - and download that package and from the TXEInfo folder, run this command >> TXEInfoWin64.exe -verbose
Show me the end of the report

I need more time to look into this tonight, but I’m sure we can probably change that value for you, maybe without even having to modify BIOS. What do you want it set to, “last State”?

Thank you @Lost_N_BIOS .

Here is the output of the TXEInfoWin64.exe -verbose command

Intel(R) TXEInfo Version:
Copyright(C) 2005 - 2018, Intel Corporation. All rights reserved.
Windows OS Version : 10.0
FW Status Register1: 0x80000255
FW Status Register2: 0x09F40400
FW Status Register3: 0x30B50608
FW Status Register4: 0x00080000
FW Status Register5: 0x00000000
FW Status Register6: 0x00000000
CurrentState: Normal
ManufacturingMode: Enabled
FlashPartition: Valid
OperationalState: CM0 with UMA
InitComplete: Complete
BUPLoadState: Success
ErrorCode: No Error
ModeOfOperation: Normal
SPI Flash Log: Not Present
Phase: ROM/Preboot
TXE File System Corrupted: No
FPF and TXE Config Status: Not committed

Error 83: Communication error between application and Intel(R) TXE module (HCI client)
Error 81: Internal error (Could not determine FW features information)

There isn’t any “Measured” or “Verified” on the FPF.
Also, are the two last errors a possible issue?

I am evaluating using the PC as a “Home Server”, and in reality I would like it to turn on automatically after power loss (S0 state I think).
In theory you are right that it could be “Last State”, but I am not seeing any battery cell on the PC Board, and the BIOS configurations seem to be lost if the AC is disconnected. Maybe this can also be an issue … losing the configurations, even if we are able to set it with the right defaults.
(I will probably try do disassembly a plastic cover that is covering the PC board components, to check if indeed there is a battery or not)

Appreciate your assistance.

That looks like you don’t have Intel TXE Drivers installed, I’m not sure, I don’t deal with this kind of ME FW often.

You are correct, Setting of S0 State for State After G3 should turn it back on whenever power is applied. Last state would work, if it was running when power was lost, but only if that is also not affected by the bug currently stopping S0 State from being applied
I checked all areas that possibly hold this settings saved value (State After G3), and all areas are set to S0 State by default, so the only reason this is failing must be a BIOS Bug itself (nothing to do with settings or how/where they are retained etc)
The only way to fix this is to try a newer or older BIOS, and hope you find one that works. The BIOS version Unknown sent me was AB40014 (00.14) - Dated 04/26/2018 - What BIOS version are you using?

No CMOS battery is not ideal, but even at Fail Safe which would be applied until you load optimal, the setting is the same. Hopefully you can find and replace the battery, then we can test change this to Last State and see if that helps.


I am not seeing a date, but it looks like it is the same BIOS version that you refer (AB4 0.14 x64): BIOS Info
At the manufacturer site there aren’t any other BIOS versions or anything to download. I have sent them an e-mail yesterday, but I am not sure if this is a company that might be AWOL. Let’s see if they answer.

Tonight I will try and check if indeed there is a CMOS battery or not.
I will keep you posted.

Thank you

Yes, looks the same, but can’t be 100% sure without checking your BIOS region dump.

It’s too bad there is no other versions on their site! I’ll see if I can find any out there, but even then, they may be all bugged… I noticed a lot of user complaints about BIOS bugs related to that when I looked earlier
Even without a CMOS batter, the fail safe setting is S0 too, so no matter what (BIOS Bug aside) that would be the default and it should boot back up. However, without a CMOS battery, I’m not sure how it should be acting in such a case

Wow, they have a LOT of “Contact Us” links to social at the bottom, hopefully they are alive and replying! I see on Facebook, they updated cover photo on Aug 2019, but last reply 45w ago

This seems to be a common issue, I found this review/blog post, maybe it’s yours? He says clock reset each time (so probably no CMOS, unless this is you)

Clock complaints about time/BIOS here as well, in the comments area (I think same users review)

Seems odd that would be forgotten on a motherboard?? I looked, but could not find a BIOS other than what’s posted here (This is AA-B4 model)

Yep, they did it.
There isn’t any battery connected to the motherboard! Also no obvious solder points to where I could think about soldering two wires and connecting a battery.

On the first link, I am not the author.
On your second link, you were referring to this: Review ?
There are references to shorting for a few seconds the power button, or configuring Wake on LAN to wake on PHY activity.

The thing is that WOL is disabled by default on the BIOS. So probably I can manually enable it, but with no battery, it will be disabled after power is lost and restored, and the PC wont turn on.

If you think it will help, I can get you a BIOS region dump.
Else, if you think its feasible, do you think you can give me some pointers on how could I change the default BIOS values myself?

Once again thank you for your time.

Wow, such a nice unique system, and they didn’t think “hey, this needs a CMOS battery so the clock and BIOS settings will be retained”??? WTH, really no wonder they don’t answer email, probably don’t know how that works either?

Second link, yes, probably, that URL looks familiar (sorry, I pasted wrong one) WOL if disabled by default in BIOS can be changed easily, in various ways. But yes, as you mentioned, unless changed to always default enabled, then would be lost at power-loss
But, maybe setting that to default enabled always, like State after G3 is already S0, maybe this one will work properly even after power is removed. So yes, if you want a hard set enabled on WOL send me a dump, I will set default at all (many) locations for it to always be enabled no matter what.

You’re welcome! For this, no, it’s not really ideal for me to show you how to do all the edits, due to I will change at NVRAM (possibly in 5-20+ places) as well as setup + AMITSE/SetupData. NVRAM is the tricky edit, other two are more simple to do.
Additionally, this BIOS can’t be easily worked on due to how it’s compiled, UEFITool does not expand in the area that contains all the modules that need edited, MMTool V5 or Phoenix Tool 2.73 must be used instead

But if you want, here is info where I’ve discussed all these kinds of edits in the past -
AMITSE/SetupData edit (Setup edit info there too) - [Request]Maximus XI Hero - Unlock AMIBCP >> Edit for both “QuestionID’s” below (remember, little endian)
NVRAM edit explained - Determine configurable aperture size from BIOS file >> Edit all areas for both VarOffset/VarName’s below
Setup and NVRAM editing here [Help] Unlock advanced menu on 2019 Acer Predator Helios 300 PH315-52 (5)

Sorry, in all instances I discuss setup edits here on the forums they are starting with UEFITool as I prefer that, but it’s similar with MMTool, extract uncompressed and you may need to fix the checksum at bytes 10h and 11h before you can reinsert the edited module

Setup Edit - x2
One Of: Wake On Lan, VarStoreInfo (VarOffset/VarName): 0x148, VarStore: 0x1, QuestionId: 0x183, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 E2 04 E3 04 83 01 01 00 48 01 10 10 00 01 00}
0x1C7DC One Of Option: Disable, Value (8 bit): 0x0 (default) {09 07 A2 02 30 00 00} << Move this 30 to below in same position, in this 30’s place, put 00
0x1C7E3 One Of Option: Enable, Value (8 bit): 0x1 {09 07 A1 02 00 00 01} << Put 30 here, move 00 to above (30 is the “Default” marker)

Wake On Lan, VarStoreInfo (VarOffset/VarName): 0x148, VarStore: 0x1, QuestionId: 0x2DB, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 E2 04 E3 04 DB 02 01 00 48 01 10 10 00 01 00}
0x1FD00 One Of Option: Disable, Value (8 bit): 0x0 (default) {09 07 A2 02 30 00 00} << Same as above
0x1FD07 One Of Option: Enable, Value (8 bit): 0x1 {09 07 A1 02 00 00 01} << “” “”

Hi @Lost_N_BIOS ,

Apologies for the delay to reply.

Indeed it is a pity that such a PC does not have a battery, and even worse that the BIOS seems to have bugs, at least with the State after G3 configuration.

In attachment you can find the region dump that I took with FPTW64.exe .
Also, the write back of the dump worked ok.

If I could request your help one more time, do you think you can enable the WOL on the dump, and share it with me?
On my side, I will also follow your guidelines, and try to enable it. But using your file as a reference, I can do a binary comparison to see if I have done it right on my side :slight_smile:

Thank you.

biosreg.zip (3.92 MB)

@maps - do you have flash programmer? If yes, I think I can enable Advanced menu for you, but maybe only worth test risk if you have flash programmer (I already did edit, and checked, looks OK, but I can’t confirm it wont brick)

Can you already see “Fast Boot” option on Boot Page? In that review, I don’t see it on boot page, but in AMITSE/SetupData of your BIOS, looks like it may be enabled (via Access Level = Default 09/Yes)
But that may need to be USER= 0D/Yes or Supervisor = 0F/Yes instead. Normally if I edit for this, I change to 0F first if Access Level isn’t shown to user on Main BIOS page, then if that fails User will work instead

So, to edit, I had to put your BIOS region into full AFU dump from post #1 (if using MMTool to edit), then extract BIOS region again once done (just heads up in case you do edit yourself)
NVRAM volumes can be extracted with UEFITool (from BIOS region as-is, or in ^^ compiled edit I mentioned), but they must be put back into BIOS via hex editor.
Or you may be able to extract and edit with MMTool (they are volume 03 + 04 GUID - CEF5B9A3-476D-497F-9FDC-E98143E0422C) - I just did via hex insert, since I’m used to this anyway
Included is my noted on the WOL edit + All files I edited before and after (After all have “M” Appended to name)

I did not include the Advanced menu edit, but if you want it I can send after you test this BIOS and let me know if it’s OK (Should be, but you know how that goes )
If it is OK, then I will edit the Advanced menu reveal into this BIOS + Probably other menu items revealed in the currently visible section, once you answer my question above about fast boot

Here is WOL Enabled by default in all possible areas BIOS - http://s000.tinyupload.com/index.php?fil…216345295998196

Wow! Thanks, for the detailed explanation and the BIOS edit files!

Unfortunately, I don’t have a flash programmer :frowning:
Also I don’t see the “Fast Boot” option on the Boot page. What I see/have is exactly like the review screens.

I see that to replicate your steps with success on my own, I will have some long “nights” ahead. You really know what you are doing! :slight_smile:

To test your BIOS, and sorry from being so noob, I will write your modded region dump with: FPTW64.exe -bios -f ModWOL1.bin (this is the correct file to write, ModWOL1.bin)?

If this BIOS mod is successful, maybe we can see were we can go from there, with your next steps :slight_smile:

Thank you very much!

@maps - You’re welcome! Bummer about no programmer, maybe you can order and we’ll test once it arrives? Programmer and test clip is only less than $7 shipped slow way, if you want to do it let me know and I’ll link you to what you need.

I thought maybe those review images were correct, but then looking at the BIOS I wondered if maybe you had a newer edit of same BIOS where they enabled it. Then, the 09 I see, must need to be 0F instead and you’ll see it
Yes, this BIOS is a bit tricky due to how they compiled it, very unusual and non-standard. So that’s true, without being really familiar with BIOS editing you may run into some hassles trying to do this one yourself, it’s not so simple (any part of it really)

Yes, you are correct on FPT command line above, although I do suggest you use the regular FPTw instead, but that’s up to you Sometimes x64 one can give errors or cause issues when it shouldn’t, so I just always suggest to not use it.

Yes, if all is OK, I can make some hidden from you settings visible now, but for the advanced menu add it’s probably best for you to have programmer in hand before we try
But making stuff visible in menus you can already see is not very hard or risky at all, other than dealing with this funky BIOS in general

Adding the advanced menu edit is probably fine, I do this all the time for all kinds of BIOS (add several hidden menu sections, re-arrange BIOS, move stuff from here to there etc)
Just this odd BIOS structure worries me, and this is a cool looking system, so I’d hate to have it brick on you without programmer in hand, they’re so cheap anyway, best to wait it out until you have one just in case


So I have tested it and wrote the ModWOL1 with FPTW64 (I used this one because I couldn’t find any WIN32, on the ME System Tools v3 mentioned on post #2).
The dump ended with success, but when booting, the PC went into the BIOS recovery menu with “ROM Image is not loaded. ROM Image Update denied”.
I was able to “ignore” it, boot and wrote back the original biosreg.bin, and the BIOS returned to normal.

No worries, I know what I am getting into, and this BIOS might be more trouble that it is worth :slight_smile:

As my main objective is to automatically power on the PC after a power failure, and the default State After G3 does not work, I am thinking about taking a “hardware” route by:
- Hacking the power button with something similar to this or
- Investigate if somehow a battery can be soldered, so that the BIOS settings are preserved, hoping that WOL or State After G3 works after this

If you need me to do any more tests, I will gladly do them, and it is as you say for the “advanced” tests it will be better to have a programmer :smiley:

Thanks for everything! I am learning a lot about BIOS during this process!

@maps - I see what you meant it the FPTwx64, it’s OK Ahh, sounds like some security in place (Yes, I see TCO Lock enabled)!
You may need flash programmer to put in modified BIOS, if you have the extra funds order one now and it will arrive by the time you forget you ordered Let me know if you need linked examples
I can make you one more of the same type of edit, but less areas touched, but I assume outcome will be same, there is some check going on at boot so programmer may be only way.

You don’t have secure boot mode enabled do you? If yes, disable this, reboot, and try the FPT flash again like before, see if you get the same error

On the board, do you see any locations for a CMOS battery attachment, or where CMOS pin/header or leads would get soldered in place?

We can change BIOS default settings other ways, that do not require BIOS flash, but that would be similar to making change in BIOS too, it would be lost on power-loss due to no CMOS

Ohh!! Almost forgot, we can try this method as well, this will allow us to change defaults without a BIOS flash either, and it should not violate the security check
And I think maybe it should remain post CMOS loss (but I’m not 100% certain, and this not always compatible with all BIOS)
Download this package, and run the command on text file, directly from each versions folder in place. Once done, zip back up and send to me so I can see if any gave valid output we can edit and program back

If one of those will work, we can disable TCO lock too If not, there is one other way we can disable TCO lock by making similar “BIOS setting change” using grub and setup_var (like booting to DOS or Shell).
This changes live/current setting only, and would be lost on reflash, but if we can do that it would then also allow the FPT flash to proceed after reboot.

You’re welcome, sorry it’s not so easy with this BIOS