Help to change SATA module in HP xw6600 workstation

I try to add a 4 Tbyte Western Digital Red HD to a HP xw6600 workstation, but during bot it shows it only as 1.8 Tbyte HD and in fact Windows let me format it only up to 1.8 Tb.

However Partition Manager correctely identify it as a 4 Tbyte HD and let me format it up to the real 3.6 Tb.

After rebooting Windows identify it as 3.6 tbyte drive, but while copying file on it when I reached 1.8 tbyte the files begun to get corrupted and after the reboot and scandisk the disk was not readable anymore.

I was wondering if updating the SATA module with a new one IntelAHCI ROM 1.20E will let me identify correctely the HD.

From the HP site I was able to download the program to update the bios and identify the bin file, but I was not able to open it.

TIA

@ Devilman:
Welcome at Win-RAID Forum!

I don’t think, that an update of the Intel AHCI ROM will solve your problem.
With which SATA mode (IDE/AHCI/RAID) are your SATA ports running?

Regards
Fernando

RAID + AHCI

Which SATA mode is valid for your 4TB drive?

SATA 6 Gb/s

I meant the SATA mode (AHCI or RAID) and not the speed of the data transfer.
Furthermore I would like to know the OS you are running.

Sorry, I didn’t understand.

I think is AHCI in the bios I can only choose these options: AHCI + RAID or Separate IDE controller or Combined IDE Controller, but with this last option the system freeze during boot.

I have an old 160 Gbyte SATA HD for the OS (Windows 7) and this new 4 Tbyte Western Digital Red to archive

I don’t know any Intel SATA Controller, which supports AHCI and RAID at the same time.
Which Intel SATA Controllers does your Device Manager show within the sections “IDE ATA/ATAPI Controllers” and “Storage Controllers”?

If you want to use the full capacity of your new 4TB HDD, you have to use the modern GUID Partition Table (GPT) instead of the old Master Boot Record (MBR).
>2TB sized RAID volumes additionaly need an Intel RAID ROM v10.5.x.xxxx or higher within the BIOS.

Using Partition manager I already choose GPT for the HD.
Right now I don’t have the PC so I cannot answer your question precisely, but a little search on Internet shows Intel ESB2 SATA RAID Controller

As I already have written: If the 4TB HDD is running in RAID mode, you will have to update the Intel RAID ROM module of your mainboard BIOS.
I just have tried to open the BIOS file named 7F4_0146.bin, but neither CBROM32_198 nor the MMTool v3.26 worked.
So I am sorry, but not able to help you.

HP Bioses cannot be modded. The only custom-made tools over at MyDigitalLife deal with card blacklists and SLIC injection. You should also ask at bios-mods.com.

Fernando says that if you have oROM v10.5.x or later then >2TB drivers should be supported. What version do you have? To check your RAID oROM version make sure you have selected RAID at the BIOS, reboot and press Ctrl+I to invoke it’s configuration menu. Example of how it looks like:

The Intel Matrix Storage Manager option ROM installed on this workstation is the 5.6.2.1002 ESB2

The random photo I found in Google and shown above is just an example. It happens to show the exact same version. Is that a coincidence or did you check the picture and report that version at your reply above? Sorry, I have to ask.

When I booted up the PC I entered the RAID Module and I copy the information, if you want I can upload a picture of the monitor.

No, that’s ok. It was a coincidence. However, as I understand you are not looking into building a RAID array. You just want a single 4TB disk (implies AHCI). In that case, the RAID firmware version does not matter. Have I understood properly?

Exactly, I just want to add a single 4 Tbyte HD as an archive for my media while the OS is on the 160 Gbyte HD that came with the workstation.

At Device Manager > IDE ATA/ATAPI Controllers, what’s the device name listed. Also, what driver is installed?

According to what I found out it should say: Intel(R) ESB2 SATA AHCI Controller

Under IDE ATA/ATAPI it shows only ATA Channel or controller Standard PCI IDE, while under archive controller in says Intel(R) ESB2 SATA RAID Controller

You only need AHCI enabled, not IDE nor RAID. This should be set via the BIOS. At SATA Mode what options are there? On most motherboards it’s three options: IDE, AHCI, RAID. What does your BIOS show exactly?

Here are the option:

SATA Emulation—Sets the SATA emulation mode with the following options:

RAID + AHCI–Both the RAID and AHCI OPROMs execute. This emulation mode is the default and offers the best performance and most functionality.

Separate IDE Controller–Offers standard SATA supports (four ports only).

Combined IDE Controller–Makes the SATA controller look like an IDE controller and offers best IDE compatibility (two ports only).

If I choose Combined Ide the system doesn’t load the OS.

On SATA port 1 is connected the first HD, on SATA port 2 the BR-ROM on SATA port 3 the 4 Tbyte HD