[HELP] TongFang GM7MQ8P bricked after undervolting

I have unbranded TongFang which is equivalent to popular Eluktronics MAX 17 with i7-10875H and RTX 2080S max q. I undervolted my CPU to -130mV with Intel XTU and rebooted. Laptop went bricked and wouldn’t boot, screen is black but leds and fans are working. Tried removing CMOS battery connector for 5 minutes but it didn’t help. I didn’t know it is possible that Intel XTU modifies BIOS in a way that could brick my laptop. So now I’d like to get laptop working back.

For startes, I was looking for BIOS files I should install, but I couldn’t find any. For example, Eluktronics is hiding their BIOS files and only updating it for people via TeamViewer. Other manufacturers I checked didn’t update their BIOS on website, only XMG did, but they don’t have my exact TongFang chassis in their offer yet. Is it possible to find suitable BIOS somewhere? And what should I do after that?

I can’t really ship it back to the seller, because it’s overseas and I need my laptop for work as soon as possible. Please help me with that!

The thing I described happened on friday and I kept trying to boot but it didn’t work (and I tried many, many times). But today it worked and it boot once. First thing I done was enter BIOS and reset it to default settings. I left voltage at -0mV. I tried to reset everything Intel XTU set and I switched to ThrottleStop. Now it seems like it works. I’d like to make a BIOS backup in case of bricking my laptop again. How can I do this?

@gahaalt - Awesome to hear you got back in there, I was coming to tell you that you probably need CH341A + SOIC8 test clip, but you got it.
Maybe order those now, it’s very cheap, then next time you have issue with any BIOS you can fix easier and quicker. Let me know if you need linked examples

Do step #1 only of below, to backup BIOS region, this is most important. Then below step #1, I’ve added additional single region dumps (in case entire dump can’t dump all due to restrictions) + entire dump
Then, if you want me to check what is there, or missing, upload all for me in a zip, and I’ll tell you if you have all BIOS to be able to fully recover easily (with programmer, if bricked, will be required)

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

Backup FD >> FPTw.exe -desc -d FD.bin
Backup ME >> FPTw.exe -me -d ME.bin
Backup GbE (if does not exist, then error expected) >> FPTw.exe -gbe -d GBE.bin
Attempt to backup entire BIOS (not always possible, may error, or may skip sections) >> FPTw.exe -d SPI.bin

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

Thanks a lot!
I did all of this and it seems like entire dump (FPTw.exe -d SPI.bin) worked. So I am sending you two files.
Will this link work for you? https://drive.google.com/file/d/1ZThT0iN…iew?usp=sharing

I’d buy those tools in case I need it in the future. Would this work?

@gahaalt - I need to see ALL files created from the commands I gave you, to be able to tell you if SPI dump is complete.

Yes, the tools are so cheap, and can be a lifesaver, especially when you have in hand already vs having to order when you need and wait.
Yes, that set is what you need Be sure to pick the third Set/Image option, before adding to cart, that way you get the complete set. I see coupon for $2 off, if you can apply that then super cheap!

That google link works for me, but I did not download, please redo and include all files from all commands above.
Then I can let you know if you have good complete backup, or at least enough for someone to rebuild complete backup for you

Sorry! I’ve included now 4 files, because GbE threw an error (Region does not exist).
There it is: https://drive.google.com/file/d/1iVryq40…iew?usp=sharing

Now if I keep those files on my drive, will I be able to recover BIOS in case something goes wrong?

Sorry for this bump, but I think I’ve been forgotten! Can I ask you to verify my files?

@gahaalt - Thanks for the bump!! Sorry, you were not forgotten, just got buried and lost, it’s hard to keep up here

Can you link me to stock BIOS download package for this model, that includes BIOS and EC FW as well as all the flash tools etc?
Sorry, I can’t download above Google link at post #5, it says “File is in owners trash” so I can’t check. Please re-upload

Yeah… So now I restored it from trash and link should work. https://drive.google.com/file/d/1iVryq40…9qRpWQwxbo/view
So my problem was that there are many TongFang resellers but none was willing to share stock BIOS with me, including my own reseller. Isn’t my “copy” as good as stock one?

@gahaalt - No, your copy is used/dirty etc and has your system specific info inside it, and may not be complete (as you’re wanting me to check). I assumed your reseller would give you BIOS package, that’s lame, everyone else’s does!
Usually you can find in google too, via the Tonfang model name, so it’s OK, I only wanted it to have for future reference and keep your BIOS in it’s folder

I checked, yes, you have complete SPI Dump there, and you have unlocked FD, so you can flash any/all regions with FPT if needed in the future too (such as you need to fix ME FW or something like that, you wont have hassles)