Help with BIOS mod for Dell XPS 9360 Kaby Lake

Hi All

I’ve previously successfully modded XPS bioses to enable all hidden options, update/patch CPU microcode and update VRAMs etc. All successfully done with a combination of Phoenix, UBU and my trusty HxD.

However when trying to patch the new Dell XPS 9360 (Kaby Lake) I keep finding structural problems to repack the modded BIOS. I can extract the HDR and ROMs from the EXE file found here:…?driverId=CKNJX

And I’ve successfully located and patched the BIOS setup module, which I’ve attached.

Problem is I can’t find a way to successfully repack the file into the original EXE or HDR. I suspect it’s due to the two-level compression that Dell has recently used. I’ve tried using Z.version.bat, which manages to unpack the files, however I can’t find a way to repack. Any suggestions? (214 KB)

First check to see if the system is protected via BootGuard. From the ME thread, run MEInfo and check the bottom of the report. If BG is active, you cannot do any modifications. If not, your best bet is either a direct chip dump/mod/reflash via a programmer or PhoenixTool. For the latter, I suggest you contact the dev at MDL and ask him/her to help you (I remember doing such in the past myself too).

Thanks. Yes that’s actually a good idea - I spoke with Andy in the past regarding a few changes to the Dell Tiano support. I’ll reach out and see it’s possible to extend support for the latest generation of Dell BIOSes.

One other question - I’m getting Error 86 on MEInfo, and all the drivers are installed (and ME is definitely present). FPTW -greset doesn’t work either. What could be the issue here?

What does the MEInfo error report exactly? Are you using ME System Tools v11.7 as your system requires?

Yes all up to date.

This is what I get:

Intel(R) MEInfo Version:
Copyright(C) 2005 - 2017, Intel Corporation. All rights reserved.


Error 86: Communication error between application and Intel(R) ME module (FWU client)
Error 81: Internal error (Could not determine FW features information)

Is there an “Intel(R) Management Engine Interface” device at Device Manager > System devices? If yes, what driver does it show? Have you tried either the DOS or EFI MEInfo to see if you get the same error? Try to shutdown the laptop and remove all power (AC + battery) for 1 minute, does that solve the communication error?

Intel (R) Management Engine Interface device is present and working correctly. Driver version is the latest posted (, dated 20/7/2017).

Pure DOS boot does work though. Here is the MEInfo output. Bootguard is enabled:

Intel(R) MEInfo Version:
Copyright(C) 2005 - 2017, Intel Corporation. All rights reserved.

Intel(R) ME code versions:

BIOS Version 2.1.0
MEBx Version
GbE Version 1.3
Vendor ID 8086
PCH Version 21
FW Version LP

FW Capabilities 0x31111240

Intel(R) Capability Licensing Service - PRESENT/ENABLED
Protect Audio Video Path - PRESENT/ENABLED
Intel(R) Dynamic Application Loader - PRESENT/ENABLED
Intel(R) Platform Trust Technology - PRESENT/DISABLED

Intel(R) AMT State Disabled
TLS Disabled
Last ME reset reason Global system reset
Local FWUpdate Enabled
BIOS Config Lock Enabled
GbE Config Lock Enabled
Host Read Access to ME Disabled
Host Write Access to ME Disabled
Host Read Access to EC Disabled
Host Write Access to EC Disabled
SPI Flash ID 1 EF4019
SPI Flash ID 2 Unknown
BIOS boot State Post Boot
OEM ID 68853622-eed3-4e83-8a86-6cde315f6b78
Capability Licensing Service Enabled
OEM Tag 0x00000000
Slot 1 Board Manufacturer 0x00001028
Slot 2 System Assembler 0x00000000
Slot 3 Reserved 0x00000000
M3 Autotest Enabled
C-link Status Enabled
Independent Firmware Recovery Disabled
EPID Group ID 0xFC0
LSPCON Ports None
5K Ports None
OEM Public Key Hash FPF 234EB9DE1AC240CC1376378CA22D245372D665B40F93D148141A66E9B76293EF
OEM Public Key Hash ME 234EB9DE1AC240CC1376378CA22D245372D665B40F93D148141A66E9B76293EF
GuC Encryption Key FPF 0000000000000000000000000000000000000000000000000000000000000000
GuC Encryption Key ME 0000000000000000000000000000000000000000000000000000000000000000

— –
Force Boot Guard ACM Enabled Enabled
Protect BIOS Environment Enabled Enabled
CPU Debugging Enabled Enabled
BSP Initialization Enabled Enabled
Measured Boot Enabled Enabled
Verified Boot Enabled Enabled
Key Manifest ID 0xF 0xF
Enforcement Policy 0x3 0x3
PTT Enabled Enabled
PTT Lockout Override Counter 0x3
EK Revoke State Not Revoked
PTT RTC Clear Detection FPF 0x0

The fact that the driver is shown and that DOS works means that there is some sort of OS interference that does not allow the Windows tools to work properly. Some background utility or motioning program (aida64, hwinfo etc) could cause that. Other than that, as you said, BG is fully enabled on your system so you cannot modify it, to my knowledge.

Thanks for the help. Do you think there’s any chance I can modify the ME regions by shorting a couple of pins or editing using FITC (I’ve done this on previous XPS machines)