How to boost the AHCI/NVMe performance of Intel Chipset systems

It’s DEV_7AE2:

Intel SATA AHCI Controller.png

Edit by Fernando: Inserted picture re-sized and directly attached by using the Forum software (can be enlarged by clicking onto it)

Attached is the 32bit Intel RST AHCI+RAID driver v11.2.0.1006, which has been modified and signed by me today to additionally support the DEV_7AE2 Intel SATA AHCI Controller.
Please test it and give me a feedback regarding your result (success/failure).
Important: You have to point to the file named iaAHCI.inf. The only suitable Controller is named "Intel(R) SATA AHCI Controller DEV_7AE2 added by Fernando".
Good luck!

Universal 32bit Intel RST AHCI+RAID driver v11.2.0.1006 mod+signed by Fernando.rar (254 KB)

Thank, I’ll test it after work

Hello everyone and @Fernando ,
I have been following this forum for a long time where I have always found excellent solutions for my projects with new PCs by installing old operating systems. God bless you for the contribution you all make with different problems solving.
Now I have decided to subscribe to this forum, because I need your help.

It is not the first time that I have used Nlite software (for Windows 7 version), and I have used it in the past to build the Windows 7 iso with the drivers to be installed on a new generation of laptop.
Now I have fixed an old computer with an Asus X79 P9X79 WS / IPMI motherboard, a motherboard that I discovered later (also read here in the Forum) very strange because it is not a normal motherboard that is on the market.
Having said that, my problem is that I am / and I need to install Windows XP under AHCI mode. I have found all the drivers compatible with XP, but I cannot install Windows XP with the SATA AHCI Drivers from the beginning. I was able to install Windows XP only in IDE Mode.
I also tried to prepare the iso with the Nlite software (XP version) with extracted Original Drivers from the “.exe” file and inject into the ISO the SATA-AHCI drivers of the motherboard, but I can’t go over with CD at the installation phase because after loading the drivers I get a BSOD (only in AHCI Mode).

Where I mistake? Or , I need to do some other steps?
Below, I attached the original drivers that I extracted from the .exe file and also containing the included drivers for XP to be examined.

So summarizing below the OS, ID and drivers:
OS: Windows XP
Motherboard: Asus X79 P9X79 WS / IPMI
Controller: Intel C600 Series Chipset
SATA-AHCI Hardware ID: PCI \ VEN_8086 & DEV_1D02 & CC_0106

Thanks in advance to whom will help me… (2.8 MB)

Tested yesterday but i still have 7B error.

and also i can’t load it with F6 key at install startup, he didn’t find any drivers

Welcome to the Win-RAID Forum!
Since I have written a specific and detailed guide about how to get an Intel AHCI driver properly integrated into a Windows XP Image, I have moved your request into the related thread. Please read the content of the start post and follow its advices.
Notes to your post:
1. The tool named nLite can only be used with very old Windows Operating Systems (XP/W2k3), but not with modern Windows Operating Systems from Win7 up.
2. Your attached driverpack contains only Intel “Chipset Device INF Files”, but no Intel AHCI driver.
Dieter (alias Fernando)

Thank you for having tested the freshly modded Intel RST driver v11.2.0.1006.
It is a pity, that the XP Setup didn’t accept it, although the driver’s INF file named iaAHCI.inf definitively contains the matching HardwareIDs. This indicates, that the driver itself (the file named iaStor.sys) doesn’t support the Intel SATA AHCI Controller of Z690 chipset systems. By the way - Intel has never released an AHCI driver, which supports the DeviceID DEV_7AE2 (not even for Win10/11). Since such Intel AHCI driver doesn’t exist, Win7/8/10/11 users with an Intel Z690 chipset have to use the generic in-box MS AHCI drive instead.
My conclusion:
To be able to get XP installed onto an Intel Z690 chipset in AHCI mode, the user has to integrate/load an AHCI driver, whose hex code has been modified. Since I generally don’t touch any *.SYS file, I cannot help.

Hello @Fernando ,
I don’t know why these past days the forum it doesn’t allowed me to reply and gave me always the error…anyway.

Thank you to reply me and sorry if I posted my new topic as new thread, and thanks again to move it in the right place.
Your guides are fantastic, and usually I can find so easily from your posts the right drivers, but this time I don’t know why I saw many of your posts drivers with the right chipset but always written in parentheses “except for X79”, so seems all the drivers are correct but except for the X79 motherboard.

Now, before I saw your reply here, I decided to keep with testing in meantime that some one can help me with my case; and i decided to watch more detailed in your driver topics, and voilà, I found your correct drivers (signed by you) that allows me to install under AHCI Mode Windows Xp. Now everything are working perfectly!!!
I took the drivers from here:
The first on the list: Intel AHCI/RAID drivers from the “classical” Intel RST Series - the Universal 32bit Intel

Anyway, I thought that into the folder that I attached was all the necessaries files drivers to install the controller AHCI… thank you, now I can understand why cannot be recornized the controller during the installation process.
Glad to have a conversation with you and infinitely thanks for your support

Edit by Fernando: Unneeded fully quoted post removed (to save space within this voluminous thread)

Hello, is it possible to get Windows XP x64 edition working on my computer, devmgmt.msc reports my AHCI controller as Intel(R) 100 Series/C230 Chipset Family SATA AHCI Controller. My motherboard is H110M-S2PV DDR3-CF, and my CPU is Intel Core i5-6400.

@Daniel7689 Welcome to the Win-RAID Forum!

Yes, but it will not be easy due to a lot of other driver problems (ACPI, USB3, Graphics etc.).
Regarding the Intel SATA AHCI Controller I recommend to integrate the “Universal 64bit Intel RST textmode driver v11.2.0.1006 mod+signed by me”, but don’t forget to check the DeviceID of your on-board Intel SATA AHCI Controller before you start.
Good luck!
Dieter (alias Fernando)

Was reading over this and wondering about my systems performance. Currently it’s running fine & trouble free but is it optimized for best performance??? Currently I have no RST driver/s installed only what Windows 10 installed with exception to the PCIe USB 3.2 card I have (Inateck KU5211). System is currently running in AHCI mode.

Motherboard: GA-Z68XP-UD3 (rev. 1.0) Specification | Motherboard - GIGABYTE Global

Within device manager under: IDE ATA/ATAPI controllers shows:

Standard SATA AHCI Controller - Microsoft 6/21/2006 10.0.19041.1889
Standard SATA AHCI Controller - Microsoft 6/21/2006 10.0.19041.1889

Storage Controllers:

Asmedia 116x SATA Controller
Microsoft Storage Space Controllers
USB Attached SCSI (UAS) Mass Storage Device

Any suggestion/s?

Full systems specs:

Windows 10 Pro 22H2 19045.2364
Core i7 3770K
GA-Z68XP-UD3 rev 1.0 (BIOS F-10)
32GB G-Skill Trident X DDR3 F3-1600C7-8GTX
Asus RTX 2070 OC 8GB
Crucial 1TB MX-500 SSD
(x3) 1TB Mushkin RAW SSDs
LG Blue Ray Burner DL
Corsair RM-750w PSU
Rosewill Mid Tower Challenger Black
TrackIR 5 Pro
Inateck KU5211 USB 3.2 adapter
Oculus Quest 2
LG 34in Ultra Wide Screen
T Mobile 5G Home internet (KDV21)
Alura-tek Powered USB Hub 2.0 AUH1207F

An attempt to install RST and I’m greeted with…

The setup program ended prematurely because of the following error:

This platform is not supported.

Intel RST/RSTe Drivers (latest: v17.11.3.1007 WHQL/v8.0.0.4028 WHQL) - Important Drivers / Specific: Intel AHCI/RAID Drivers - Win-Raid Forum (

Intel RST(e) drivers v12.9.4.1000

Welcome to the in-RAID Forum!
How did you try to get the Intel RST(e) driver v13.2.8.1002 installed?
Note: Only Intel SATA Controllers are supported by Intel’s RST/RSTe drivers.
Please post the HardwareIDs of both Standard SATA AHCI Controllers and of the ASMedia 116x SATA Controller. You will get them from within the Device Manager by doing a right-click onto the listed Controllers and choosing the options “Properties” > “Details” > “Property” > “HardwareIDs”.
Merry Christmas!
Dieter (alias Fernando)

Tried via the .exe

Standard SATA AHCI Controllers :



116x SATA Controller:


Thanks for the quick reply.
Only the second “Standard SATA AHCI Controller” is an Intel one, whose driver can be replaced by a matching Intel RST driver. The latest original Intel RST driver, which natively supports your on-board “Intel(R) Desktop/Workstation/Server Express Chipset SATA AHCI Controller” (DeviceID: DEV_1C02), is the v12.9.4.1000 one (as MeatWar already has mentioned).
If you want to get the Intel RST driver v13.2.8.1002 installed, you have
a) to download and use the mod+signed variant (don’t forget to import the Win-RAID CA Certificate) and
b) to install the “pure” driver manually from within the Device Manager.

Nice…thanks a lot. Any benefit (missing out on something) from the 13 vs 12 version?

I downloaded the recommended and unzipped it to a folder. Which of the files do I install via the device manager?

Look >here<.

Point to the file named iaAHCIC.inf to get the correct driver files installed.

1 Like

Is the other AHCI perhaps something to do with Marvell 88SE9172 chip?


1 Like