How to flash bios ME

My notebook started to suddenly power off (not shutdown but hard power off like when the battery is removed) . Investigating the issue led me to following:
1. Notebook worked fine for 30 mins to the sec and then powered off [same thing happens in Bios & UEFI modes].
2. Noticed the corrupt ME issue as MEI device was not there in the device manager.
3. Tried to install the drivers for MEI, dishes out a message that hardware is not supported on running the setup.
4. Ran the FTK meinfo, "Communication error between application and Intel(R) Mgmt. interface".
5. Ran the FTK mestate, msg - "Status: Disabled and waiting to timeout (guessing this is the 30 mins prompting power off), IC not programmed, etc etc…".
6. Unable to re-flash Me region, as there seems to be a lock on it. msg - "CPU does not have access to flash area".

I only have two questions, how can the ME region get corrupted in the first place and/or how can I go back to previous version of bios. Please provide some insight/assistance on how to deal with this situation/issue.

Please find the attached images, that might provide some more insight into the issue.



ME writes to inner MFS partition and theoretically can destroy itself / flash chip exceeded write cycles / unexcepted power off / some else

reflash a full BIOS image if vendor’s tool can deal with full reflashing

Did you make any hardware/firmware changes before the problem occurred? No matter what, firmware corruption can happen due to various reasons which are not transparent the user. Do not the old/outdated FTK but run the required tools directly as can be found at the ME thread. To repair the firmware corruption, you need to follow the Engine CleanUp Guide at your SPI chip dump. Since you have no read/write access to the Engine region of the SPI chip for servicing purposes, you can either use a hardware programmer (preferable if you have one) or try the “pinmod” as recently discussed here.

Thank you @Mov AX, 0xDEAD.

@plutomaniac Thank you for your response. No I did not make any hardware changes, only thing I did was upgrade to widows 10 & it failed & all of this started. I will try to follow the steps you have mentioned & will report back. My only concern is finding the right tool at Intel Management Engine: Drivers, Firmware & System Tools.

From the pictures above I can see that you were using ME 10 tools. But you haven’t mentioned what notebook you have.