How to Force Flash ME?

Somehow, the Management Engine on my motherboard became corrupted, and now certain overclock options (XMP, DDR speeds above 1333, CPU clock ratios above 37, etc.) in UEFI are gone. How can I force flash the ME on my ASRock Extreme3 Gen3 (currently on BIOS/UEFI version 2.31A) motherboard?

You can’t, because the Descriptor regions of Asrock bios are locked. The only way is to remove the bios chip and use an external SPI Programmer.

Maybe you could try with AFUDOS /GAN syntax command to flash the whole stock bios 2.31a but I don’t know if it works.

Asrock boards have ME restoration capability triggered by Descriptor Security Override, aka pinmod. It’s hard to perform because pins are small nowadays, but your board will restore ME automatically if you will be able to start it in this mode, and will not need any manual flashing.

I have to do that pinmod? There’s no way to flash an older version of the ME with Intel’s Management Engine software and then use the ASRock official BIOS to overwrite it or something? I’m desperate, and don’t want to buy something to fix it… If not, can you explain the pinmod in layman’s terms for this particular motherboard, if possible?

Which is the ME firmware version you currently have ?

I’m not sure. How can I check?
Here’s the BIOS, if that’s helpful:…(L2.31A)

Use MeINFO. Or use UBU mea file with the following syntax : MEA.exe -info under command prompt and see what it shows.

I got this from MEInfoWin.exe from…/ > FTK8 folder:

Intel(R) MEInfo Version:
Copyright(C) 2005 - 2014, Intel Corporation. All rights reserved.

GBE Region does not exist.
Intel(R) ME code versions:

BIOS Version: P2.30
MEBx Version:
Gbe Version: Unknown
VendorID: 8086
PCH Version: 5
FW Version:
UNS Version: Not Available
LMS Version: Not Available
MEI Driver Version:
Wireless Hardware Version: Not Available
Wireless Driver Version: Not Available

FW Capabilities: 0x01101C40

Intel(R) Capability Licensing Service - PRESENT/ENABLED
Protect Audio Video Path - PRESENT/ENABLED
Intel(R) Dynamic Application Loader - PRESENT/ENABLED

CPU Upgrade State: Upgrade Capable
Cryptography Support: Disabled
Last ME reset reason: Power up
Local FWUpdate: Enabled
BIOS Config Lock: Enabled
Host Read Access to ME: Disabled
Host Write Access to ME: Disabled
SPI Flash ID #1: EF4017
SPI Flash ID VSCC #1: 20052005
SPI Flash BIOS VSCC: 20052005
BIOS boot State: Post Boot
OEM Id: 00000000-0000-0000-0000-000000000000
Capability Licensing Service: Enabled
Capability Licensing Service Status: Permit info not available
OEM Tag: 0x00000000
Localized Language: Unknown
Independent Firmware Recovery: Disabled

It says BIOS 2.30 and not 2.31A because I had tried flashing the previous version, by the way.

EDIT by Fernando: Put the MEInfo details into a “spoiler” (to save space)

The is the latest one for the 8.1.0.xxxx versions.

There is a newer version, dated 2012 July, but I do not know if it can be suitable for Z68.

I could provide you a valid bios file with MEI updated but I cannot guarantee it will fix your issues.

So tell me what you would like to do.

Can you tell me how to create the valid BIOS with updated ME? I’d prefer to do it from scratch myself.

Saw a post by CodeRush in another thread/site where he seemed to indicate (I think anyway; been looking at a lot info about this) that wouldn’t work for a corrupted ME. I guess my only options are pinmod, which I would try if I could get a simple explanation of how to do it, or buy a new BIOS chip.

You have to extract the ME FW from Bios file, then take the new one from the repository firmware package, use Flash Image Tool (FIT) for your chipset (8 Series)
and manually edit the new bin file to match settings of the old one.

If you’re able to do all of this, you can try. The choice is yours, of course.

How did it get corrupted? Did you try flashing something or did it happen on it’s own? Try these first:

1) Flash the latest BIOS (L2.31A) from within the UEFI menu using Instant Flash or however ASRock is calling it. Try to see if the ME is ok. If not, move to 2.
2) Use FWUpdate tool to flash the latest ME8 firmware for your system which is 1.5MB as seen at my ME thread. Rarely, such an update can kick-start the ME again. If not, move to 3.
3) Run Flash Programming Tool with command fptw -greset and after the reset, check to see is the ME is ok.

If none of the above work, you have two options. As CodeRush said, your “BIOS” (SPI image) has a recovery ME Region embedded at GUID B3160739-[…] as shown by MEA. For that to be triggered you need to enable write access to the ME region by bypassing the locked down flash descriptor temporarily using the “pinmod”. You have a Realtek chip so performing that might be very difficult with the extremely small pins that these chips tend to have nowadays. Still, if you want, try the method as explained at the link that CR provided.

If the above doesn’t work as well, you need to buy a programmer and manually flash the entire chip to fix the ME region. Your board has a socketed SPI chip so you can easily reflash it using a cheap programmer without any soldering or similar tricks.

I just assumed the ME had been corrupted because I read elsewhere that causes this kind of behavior (i.e. missing UEFI/BIOS options). I had been tinkering with timings and voltage on new memory when they disappeared. My guess is that it was caused by adjusting the VCCSA voltage (something I had never done before), which some say never change and others say it helps with overclocking memory.

1) I had already tried this.
2) Flashed successfully, but no change on reboot.
3) Automatically rebooted PC on completion, but no change.
(I used the 64 variants of the programs you listed, by the way, since I’m on Windows x64.)

Guess I’ll have to buy a new BIOS chip. Is that plug and play on this motherboard or would it require additional tools?

Thanks to everyone who tried to help me fix it, though.

I went ahead and bought this:…3-/380443053155
I hope it’s all I need (is it?) and easy to install.

If you have already tried a cmos (since you mentioned that it happened after changing BIOS settings) then you will have to get a programmer or a pre-flashed chip if you wish. Personally I would go for a programmer but it’s your choice.

So after replacing my BIOS chip and having my system running fine for a week or two, I’m back to where this thread started…

The only differences were:

-Started with BIOS version 2.30 as the chip was pre-programmed with that
-Never changed the memory when this new chip was used (had the same ASRock supported list memory in it that I’ve used for years)

I did update the BIOS to version L2.31A, but the system ran fine with it for said week or two.

Update: I was able to do the pinmod. The system is running fine again, but as CodeRush said, it triggers automatic ME restoration without the opportunity for user-input (i.e., flashes and then restarts system). Since I have no reason to believe the problem I originally had won’t manifest again, I’m wondering if there’s a way to do the pinmod and then flash ME to a specific version.