How to unlock a Numa BIOS built by DEPO Computers?

Good day everyone! The problem is that the motherboard and BIOS are created by a commercial organization which has its own license. The information on its products is provided only as part of the warranty service. Now I have AMD320 chipset motherboard (AMD 218-0891004), I know this chipset supports many processors. But, my board can only work with Ryzen processors, only 3rd generation and having graphics core. When installing a graphics card to the motherboard, always load the integrated graphics core first, and the graphics card is defined as the second device (the image from the graphics card is only displayed on the monitor when the desktop appears). In the BIOS settings there is no settings related to the option of switching graphics, very few settings. On the manufacturer’s website you can choose to buy a computer with or without a graphics card installed, so this card can work with a graphics card, just in my case, this option is blocked by the developer. I can’t figure out what type of BIOS I have and how it can be fixed. Please help me, I need to access the settings for switching the embedded graphics core and video card (Advanctd AMD PSB \ Primary Video Adaptor) and unlock the processors supported by the chipset. Is it realistic? I have DUMP BIOS which I copied from the programmer and some pictures, but I can’t attach them. I can’t upload all the files here… no access. If I made a wrong request, sorry.

Translated with DeepL Translate: The world's most accurate translator (free version)

Edit by Fernando: Thread moved into the “BIOS Modding Problems” section and thread title shortened

@Aleksandr85
Welcome to the Win-RAID Forum!
As you may have already realized I have moved your thread into the “BIOS Modding Problems” section and shortened the thread title.
Good luck!
Dieter (alias Fernando)

1 Like

Guys I would dump bios, but I do not have that option, the site does not give, if you have options how to do it, please help. I can’t figure out my problem myself… Or tell me where to start, advise a program to work with my image, I am stumped.
I really need some advice on what to do next.

Damm sir, you now how to come to a forum… asking for mods, but you dont know how to share a file on a free sharing/cloud service???
With such user knowledge, probably mods are not also for you…
AMD bioses are hard to mod due to the AGESA, the tool AMIBCP may open your bios file/dump and show you some settings and probably can change some.

EDIT: Even worst…the bios is InsydeH2O, cant help you and ignore the tool tip as it wont work with it, the only possible tools maybe the IFRextract tool/RU and HEX edit possible variables/strings and the of H2O tools, search on forum for user experiencies about InsydeH2O unlocks etc…sry good luck.

1 Like

I know, I just thought it was necessary to attach files to the post here…
Yeah, I’m not great with BIOS files, but I do have experience. My friends can’t help me, and your resource has helped me many times, especially when working with MEregion after replacing the chipset and editing VideoBIOS. This is the first time I created this thread on this forum. I know, there are the best experts here, sorry if I started the topic incorrectly, but everyone has the right to make a mistake.
Here’s the BIOS image read by a SPI-flash programmer: 6.54 MB file on MEGA
Here is a picture of the board:
6.21 MB file on MEGA

Thanks for the tip about AMIBCP, I will try to work with it

Got it. Thank you very much for your help, I opened the dump with HEX program, then I was able to open it with IDA Pro, now I’ll figure it out. I’m sure I’ll have more questions, I’ll write the results of my work…

Friends, I need some advice. If this is InsydeH2O BIOS, then I can open it with InsydeH2OUVE, but the program will not detect it. Can you please tell me why I can’t read it with InsydeH2OUVE? I want to use this program because it is easier than HEX.

Guys, I give up, the simple methods that I found on the Internet I can not find the settings I need, working with HEX, I can not identify the values I need and even more to change the code … I’m stupid in this matter))) need help, I can not do it myself. If anyone can help, please let me know, I just need to change the settings in the BIOS, so that when you start the video is displayed from the PCIexpress video card, not from the built-in graphics core. I’m willing to pay.

This BIOS is possible to unlock. I need to know more information. You took a screenshot that you shared here on the forum. It only shows one bios page, but I found a lot more.
The question is: do you have access to any other menus in this bios by default?

Good afternoon! Thank you so much for your help! Now I’m at work and don’t have access to BIOS. Here is what I have saved on my phone. As soon as I get home, I will make a detailed report.




Are you online? You posted a few pics, but that’s not enough. This BIOS is special. It does have a non-standard IFR. Like the one-page Insyde BIOS from Acer, where both common and not so common opcodes are combined.
With Numa’s Arche, things are getting worse in this regard.

Next, I’m having trouble translating. This BIOS is multilingual. Everything in the pictures is in Russian, and the IFR extractor gives output in English (Im still having difficulties, even if I filter out some string packages to eliminate lang <-> form set matching errors).

I’m trying to say that I need to see all available pages, or I would have to act on guesswork which element corresponds to what is already available.

Yes!!! Just on the eve of the new year work more. Now I’ll take a picture of everything in detail. I apologize for not answering for a long time…

So, I photographed all the pages one by one and filmed a video, I hope this helps you. Now I will be constantly in touch and will not disappear, I will wait for news

Thank you.
I’m pretty sure the main body of the setup utility already has all the options available, so I worked on the CBS/PBS menus.
BIOS MOD

I think that for this request we need to learn how to replace AMD AGESA software. I’ll let you know when I come up with something.

Hello friend! Thanks so much for your help, it means a lot to me! I downloaded the mod and wrote it into the memory chip. The motherboard starts, the logo appears, and then the error “Internal error 0x0047” appears. After that, if you continue to enter the BIOS, everything hangs and doesn’t work like this. Photo attached.

At this inscription everything hangs and does not react to anything, only turn off the power…

If you have any idea why this is the case, I look forward to hearing from you. It’s the holidays, so I’m not rushing you. Happy New Year!!!

I completely forgot to tell you… When entering the BIOS, it always requires a password, the factory password was “Qwe123$” I threw it on an empty field. Now it just hangs at the moment of entering the bios where the password must appear.

I don’t know, but will try to find out with your help.

I did not make any major changes to the BIOS that could cause an error. But I checked my edits anyway. All edits seem OK.

Looks like an artificial error because I touched external setup modules only. These should not be loaded until called from the main menu.

I found the lines “Internal error” and tried to clear its text in order to confirm whether I found the right place to work on or not.
Here you go: test.bin.

Good day friend! Problems again… turns on - logo appears - error pops up as in the photo, if you restart Alt+Ctrl+Del… again this error pops up…
Please don’t leave me alone, can you help me figure it out? I’m really hoping for your help.