[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

Because this thread is designed for users, who want to do the BIOS modification themselves by following the related guide.
Users, who want to offer their modded BIOS for the public or are searching for an already modded BIOS, should use/look into >this< Sub-Forum.

I tried cloning via windows 10 image and it was successful

Hi everyone. Thank you for this guide! I have (hopefully) modified my bios. I would like to ask if anyone would be willing to look it over before I flash it. If so how should I link to the files? I am over the 6meg file limit even if zipped. I could post a link to a filehosting site but I can’t do that until I hit 3 posts.

It is a Dell T3610 btw.

Thank you.

@P@rocks: Welcome to the Win-RAID Forum!
You can put 1 or 2 spaces into the linked url address. Then we will be able to get the files.
Dieter (alias Fernando)

Hello again! Here is a link (with space) to my modified and original bios files. I think I have followed the guide but I didn’t understand the padding issue so couldn’t check that part. If you could give my file a look over it would be greatly appreciated. It is a Dell T3610.


Here you can see the "Padding issue" (left Pic: original BIOS, right Pic: your modded BIOS):

original BIOS.png

modded BIOS.png

My advice: Don’t try to flash your modded BIOS.
This evening I will check the best way to get the NVMe module inserted without touching the rest of the BIOS.
Question: Which tool did you use?

I used MMtool. I can try UEFITool later.

Very happy I didn’t try flashing! Thanks for checking.


@P@rocks: With the UEFITool v0.28.0 you can even insert the full sized NvmExpressDxe_4.ffs file without creating any natively not present Pad-file.
Here is the proof:


Great. I will give it a go and let you know how I get on.

Thank you for your assistance and time.

Okay, I tried out today and it booted flawlessly from the NVMe SSD. Unfortunately, it is only PCI-E x1, so the speeds are clearly limited by this bottleneck:


I’ll upload the modified BIOS into the database now.
Thank you for your support!

sorry if the post is too full of general questioning i really tried to find the missing informations.

I want to suggest to open two new threads?
“padding-files - How to reliably detect problems and avoid or handle them”
"when i have to use compressed files/modules and when it is not neccesary"

back again with the dell optiplex machines

- remove the password jumper
- setting the service_mode jumper
- using the BACKUP-Tool from @Thewero
(post: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS (441)
from where I got the correct FPT-Versions-Information - thank you very much !)

Finally i had to boot in DOS mode and only there i got all my three different BIOSes extracted and unmodified reflashed for test again.

Now i tried to modified all of them using the different Tools “MM-Tool” and “UEFI-Tool v0.28”.
But now i am very confused about some facts i want learn to understand clearly.

The MM-Tool give me a warning for all three BIOS when i try to insert the uncompressed big NVME_4 File (size not enough…)
…the UEFI-Tool never give me this warning even with the big file. this tool let me insert small and big, but i not can find the option to insert "as compressed"

why this different behavior using the same files on the same BIOS?
which tool give me the correct information?

…OK …so i guessed in general i better insert the “_small” file and “compressed” for being on the safe side and i added the “_small” file first with the MM-Tool and compressed

Then tried to take care about the padding-files added or removed as i understand this can be the little difference of success or bricking the BIOS
But i not 100% understand how to reliably find and handle those paddings. In my modification-tries i found out that both tools can add or delete this paddings in the modded BIOS.

In the end now i am comletely confused.
Relying on the “size not enough…” info? And try use a tool which can insert compressed.?
But what to do when exactly this tool causes padding-problems?
Here is a link to all my different tries for the three mainboards. (it is the server of the company where i work)
inside the zip are three zip. one for each machine.
Inside there the original bios (_original.bin) , the MM-Tool-Modding (_mod_mm.bin) and the UEFI-Tool-Modding (_mod_UEFI.bin) and additional comparing screenshots when i think there is a padding-problem.
In my opinion only the 9020 BIOS modded with the MM-Tool and the file _small compressed seems to have no problems.

I hope somebody have the patience to answer my questions or even check my files to give me additional hints.
Thanks Michael

@mmh3 : Before I start checking all your modded BIOSes (you can expect my result tomorrow), here are my answers to your other questions:

The user should compare the structure of the original and the modded BIOS regarding the presence and location of Pad-files. If the modded BIOS contains at a certain location a natively not present Pad-file or a natively present Pad-file is missing, I don’t recommend to flash it.
Nobody can evaluate, whether a flashed modded BIOS with an added or removed Pad-file would work or cause a bricked mainboard.

I don’t offer (pre-)compressed FFS files, but the MMTool offers for the insertion of FFS files the options "As is" and "Compressed". If there is enough space within the "DXE Driver Volume", it doesn’t matter which option you choose, but sometimes it is necessary to choose the "Insert compressed" option to avoid the message "Not enough space".
By the way: All DXE Drivers will be compressed after the insertion, because the complete "DXE Driver Volume" is compressed (to be able to compensate the addition of a new module without changing the Volume’s size). The compression rate and the ability to add a natively not present DXE Driver depends on the uncompressed size of all DXE Drivers, which are within that Volume.

You should better ask the developers of the tools.

Only very few BIOSes have your reported problems. In such case it is time consuming even for a BIOS modding expert to find the perfect solution.

@mmh3 : Meanwhile I have checked the structure of all your modded BIOSes and compared it with the related original BIOS.
As I already have written, all available BIOS modding tools have problems to get the NVME module inserted into these speific BIOSes without removing a natively present or creating a natively not present Pad-file. The reason is the specific structure of the DELL BIOSes (they have 2 different DXE Driver Volumes, whereas "normal" BIOSes contain just 1 DXE Driver Volume).

According to what I have seen these modded BIOSes seem to be fine (no added/removed Pad-files): 7010_i3sp1_modUEFI.BIN, 7020_i5sp1_modmm.BIN and 9020_i3sp1_modmm.BIN
You may flash them at own risk - good luck!

Hi guys,
Could you help me out with my ASUS P8Z77-V DELUXE (Rev. 1.xx) (I have the flashback button).

I have tried patching and flashing the large NVME file and the small NVME file and done probably 20x++ windows installs.
I am able to see PATA in the bios, and also force it to boot. (but does not get into windows, I actually get a blackscreen with artifacts on lower 5cm of screen when it boots from the PATA (I know it is not possible to boot from PATA but I had to try).
But I NEVER get the Windows boot manager PATA etc. No mather what I do.
So starting to get a little frustrated after trying my best on and off for almost two weeks. #lifeasanoob

I have done the MOD via MMTool and it seems successfull when i save and everything. I also can see the NVME file in my modded BIOS when i open it with Uefitool and search for NVME.
And again I have gotten so far that I can see PATA in BIOS, but never have i gotten the Windows boot manager.
This leads me to believe that there is a fault in my MOD file, like the PAD file or something.
But now I am in over my head.

Could someone please help me?

Pictures: "Z77VD with NvmExpressDxe_4 picture from uefitool after MOD" (left) and "Z77VD with NvmExpressDxe_Small Picture from Uefitool after MOD" (right)

Z77VD with NvmExpressDxe_4 picture from uefitool after MOD.PNG

Z77VD with NvmExpressDxe_Small Picture from Uefitool after MOD.PNG

EDIT by Fernando: To save space I have merged the 2 source posts and put the 2 pictures into the same line

Z77VD with NvmExpressDxe_4.rar (4.18 MB)

Attached to this post is 3x BIOS files.
The one i made with the small NVME file injected called Z77VD with NvmExpressDxe_Small.rar
And the the original that i called "P8Z77-V-DELUXE-ASUS-2104.rar" is the original BIOS / unmodded which is the starting point for these two.
I added the third bios file here as well to make it easier to see and understand: Z77VD with NvmExpressDxe_4.rar

In short: My problem is I never get the "Windows boot manager" in my bios menu for my Samsung 980 (not pro modell) I am able to install to it and everything. But I never see the "Windows boot manager" in BIOS, only PATA.

Z77VD with NvmExpressDxe_Small.rar (4.18 MB)

P8Z77-V-DELUXE-ASUS-2104.rar (4.17 MB)

Z77VD with NvmExpressDxe_4.rar (4.18 MB)

@ck90 : Welcome to the Win-RAID Forum!
1. Your 2 modded BIOSes are fine and should properly work.
2. The fact, that you can see within the BIOS a device named "PATA" verifies, that the BIOS flashing was successful as well.
3. You cannot boot off the device named "PATA" and will never get the BIOS entry "Windows Boot Manager PATA".
4. If you follow my guide, you will be able to get Win10 installed in UEFI mode onto the NVMe SSD. Thereafter you can see the entry "Windows Boot Manager" within the BIOS.
Good luck!
Dieter (alias Fernando)

P.S.: 1 post would have been enough for your information (your 3 source posts took too much space within this voluminous thread).

Hi Dieter!
Thanks for your reply. I have followed every step. But i have a ASUS MOBO with the .cap files. I suspect the problem lies there. As you say i get the PATA in BIOS view. And I am able to install windows on it. But everytime it is finished installing windows and I enter the bios to choose the new drive to boot from, it never appears as "windows boot manager". no mather what I do, I have tried everything.
If you are able to mod the original bios file for me so I am able to boot my Samsung 980 successfully, I will send you a 20eur donation:)

Which Windows version and how did you do it? Did you unplug all other HDDs/SSDs before starting the OS installation?

Your modded BIOS is fine. You can use the money for other matters.

Thanks Dieter!
I am trying to install windows 10 pro (downloaded today from windows) as an ISO which I am transferring to usb flash drive via RUFUS (GPT etc).
I suspect that it might be something with windows considering you "cleared" my BIOS file.
Because one thing I found is that the drive became invisible in bios after innstall if i (in CSM settings) choose from uefi first then legacy in "boot device control" to UEFI only on the setting "boot device control" then the disk disappears. So trying to make another usb install stick via RUFUS. To check if it is something there.

@ck90 : The device named "PATA" will not be shown anymore within the "BOOT" section of the BIOS, when CSM has been set to "Disabled" or the BIOS settings allow only the loading of UEFI Option ROMs, but this is nothing to worry about - the BIOS still detects your NVMe SSD and is able to boot off it (in UEFI mode).