[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS


Firstly, I’d like to extend my thanks to you, Fernando, for your amazing work and forum. I’ve been a long-time reader, particularly of the Intel RST drivers discussions.

My Problem:

I own an Asus GL552VW-DM149 I5-6300HQ, which has a SATA port and an M.2 port, but theoretically, it supports only SATA and not NVMe. Currently, I have a Samsung SSD SATA connected to it.

In the past, I tried connecting an NVMe to this port, but it didn’t show up in BIOS, tried a win11 clean install just to test but the installer couldn’t locate a drive to proceed.

  1. Initially, I sought to enable “above 4G decoding” and realized the only way was to unlock the BIOS.
  2. After unlocking the BIOS successfully, the guide I followed led me to this thread to enable NVMe.
  3. I’ve followed the guide, but using my stock unlocked BIOS. There wasn’t any CSMCORE, so I used DXECORE as a reference instead.
  4. I wasn’t able to flash the modded BIOS using the onboard Asus easy flash utility. Despite renaming the modded BIOS the same as stock BIOS and changing file extensions, for some reason, the flash page could only detect the OEM BIOS file, none of the modded ones. Maybe there are some additional check options?
  5. Decided to flash using FPTW64 tool and, theoretically, it worked.
  6. Swapped the SSD SATA disk for the NVMe disk, enabled CSM on BIOS, saved, rebooted, and there wasn’t any PATA or even a disk available to select to boot.
  7. With a USB, I attempted a clean Win 11 install, but the installer couldn’t find any NVMe disk.
  8. Swapped the disk again, and made a new dump just to confirm that the NVMe injected BIOS was correctly flashed. Apparently, it was.

I’m at a loss as to what’s gone wrong.

For further details, I’m attaching four different BIOS:

Stock dump BIOS

The stock unlocked BIOS

The stock unlocked and NVMe modded BIOS

The latest PC BIOS dump, to verify if the BIOS was properly injected/flashed.
The Nvme that I’m trying to use is a Toshiba that came in a dell xps laptop

Looks like as new user I can’t upload files, so I’ve uploaded the bios to onedrive

Bios pack

Thank you in advance for any insights or assistance!

This is a know issue on some Skylake models from Asus and other vendors, the bios contains the AMI NVMe driver and no mods are needed.

The main culprit here on this subject is the OEM system board hw design/slot electrical connection circuit that doesnt support PCIe NVMe drives, only PCIe AHCI SATA disks.
This is no subject for a mod as fix and im not aware of anything related with success.

Hi. I realize this is an old thread. But if you still have the bios files. Could you please post a link to these bios files?

Thank you

@nonyabizzness Welcome to the Win-Raid Forum!
Your post is absolutely off-topic. This thread is designed just for users, who want to modify their mainboard BIOS themselves.
If you have a personal question to a specific Forum member, you should better post it via PM. Alternatively you can start a BIOS Modding Request thread within the related Forum Category.
Good luck!
Dieter (alias Fernando)

Ok. Thank you. My mistake. Apologies

very thanks for this guide.
It possibile insert this nvme module into old Aption III Bios, with MMTool 3.26?
I search CMSCORE, but ther’isnt.

I have external programmer , not problem to try.

Thanks advance for all help.

There is no AMI Aptio III… its AMIBIOS8 generation, and no, the guide referes to a DXE driver for AMI Aptio V UEFI bios generation.

Theres this option for it, you may try it: [Experimental] NVMe Option ROM - BIOS/UEFI Modding / BIOS modules (PCI ROM, EFI and others) - Win-Raid Forum (level1techs.com)

Experimental Modded VMware-NVME Option ROM for AMIBIOS8 Core ( Legacy ) - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

very Thanks for all info!

The issue for the ‘ASUS M5A97 R2.0 AM3+’
Followed **Only for ASUS BIOSes with the suffix .CAP:
To avoid problems while trying to flash later on the modded *.CAP file via the ASUS USB Flashback method, it is recommended to extract the “Body” of the original *.CAP BIOS. This can easily be done with the UEFITool by opening the *.CAP file, doing a right-click onto the “AMI Aptio Capsule”, choosing the “Extract body…” option and saving it as *.ROM file.’

Extracted rom done, insert Nvme, save as the new *.rom file done.
However how to replace .rom back the .cap file?
Asus EZ flash, only accept the cap file, however how to replace back the Nvme inserted rom file back to the cap file? thank you

You dont need such mess… anyway for AMD bios, this mb CAPSULE size is 800h (2048), the extracted UEFI image can be later pasted/merged with an HEX editor.

The M5A97 R20 has USB BFB feature, so you can mod the .CAP file for NVMe according the guide and flash it, this is the correct method for flash the mod, not EZ.
The procedure will preserve the mb original data.

EZ feature method only for mbs without USB BFB and no security issues with mod files, usually older mbs.
Theres also in the forum ready to flash mod files for this model shared by users.

Thank you for your reply.
I have read the ‘[Guide] How to flash a modded AMI UEFI BIOS

Usage of the ASUS “USB Flashback” feature

However, my question is how to prepare the moded .cap file?

I have the original A.cap file.
extract body to A.rom file
MMtool, open rom file, insert Nvme to A.rom file, save as, get the ready flast B.rom file.

What is the next step please?
How to convert B.rom back to B.cap?
Or just flash B.rom file by ASUS “USB Flashback” feature?

many thanks

No, you dont need to extract any ROM, edit/mod the .CAP directly, thats why USB BFB is the best option on flashing mods on board with this feature, there’s no concern of security issues.
Use the MMtool method for NVMe mod, put the mod file (M5A97R20.CAP) in an USB on root, thats it.

hello mr. fernando
i want mod nvme GA H61M-S1 (v2. 2) bios
please :pray:t2: help me.
I was trying to modify bios with nvme modules on uefi tool , mmtool but every time it shows some error.
please make mod nvme for my bios of mobo. GA H61M-S1 (rev 2.2)

Read STEP 2, B, expand Open guide and read notes.

thanks to all
i have successfully completed the process.
Now i can boot my pc from ssd .
thank you so much :pray:t2:
in future if anyone facing problem can contact me at [email protected]

1 Like

A post was merged into an existing topic: [Experimental] NVMe Option ROM

I modified and flashed my Asus UEFI ROM using the specific procedure described below, and all seemed to go well with an MSI NVME SSD in a PCIe adapter. But for some reason my PC kept shutting itself down, whether I was running Windows, Ubuntu, and even in the UEFI Shell. I finally flashed my original 0910 ROM back to my motherboard using BIOS Flashback, removed the NVME SSD from the PCIe slot, and reconnected the original SATA SSD instead. Now I’m waiting to see if the system will continue to shut down.

This is what I did - I opened P8Z77-V-LE-PLUS-ASUS-0910.CAP in UEFITool 0.28.0. I found the Volume containing the File with the Text description “CSMCore”. I scrolled down and highlighted the last file in that same Volume, right-clicked and then clicked “Insert After” and inserted there the file “NvmExpressDxe_5.ffs”. Then I clicked File > Save Image As, and saved it as CAP file with a different name. I flashed this modified CAP file to my Asus P8Z77-V-LE-PLUS using AI Suite II.

I installed my NVME SSD in a 4x PCIe slot. My PC booted fine. I had earlier used Clonezilla to clone my SATA SSD to the NVMe SSD, and since it booted to Windows just fine, I didn’t reinstall Windows on the NVMe SSD. I doubt that not reinstalling Windows caused the shutdowns, because the shutdowns also happened in a fresh installation of Ubuntu and also in the UEFI Shell.

I want to emphasize that these were “orderly” and not spontaneous shutdowns - both in Windows and Ubuntu, a message would pop up saying that Windows or Ubuntu was going to shut down, and then the PC did so. I thought maybe it was just hardware failure and not the BIOS, but I had another shutdown when I replaced the NVME SSD with my original SATA SSD. That’s when I decided to flash back the original unmodified BIOS.

So I’m wondering what was triggering the shutdowns. Was it something happening in the firmware? Could it be overheating or something, but if so, would it have been an “orderly” shutdown?

Also I’m wondering if it would have made any difference if I had extracted the body of the CAP file to a ROM file and worked with the ROM file instead of the CAP.

If anybody has any thoughts or suggestion on this I would be very glad to hear them! I did a search of the forum looking for any similar “orderly shutdown” problems with a modified bios, and didn’t find anything.

@jimspoon Welcome to the Win-Raid Forum!

Flashing of a modded, but still capsuled BIOS file without using the ASUS own USB Flashback feature may have been the reason for your shutdown issues.
That is why I recommend
a) to reflash the original BIOS,
b) to remove the BIOS capsule,
c) to modify the .ROM file and
d) to flash it according to >this< Guide.
If you want security, that the insertion of the Nvme module has been done correctly by the UEFITool, please attach or give us a link to your modded BIOS and the original BIOS.
Good luck!
Dieter (alias Fernando)

4 posts were merged into an existing topic: [Guide] How to flash a modded AMI UEFI BIOS

thanks for you very kind guide! i am trying to do the mod for my supermicro x10slh-f but bother methods sadly generates that extra pad file and i did not go ahead to flash as im worried for bricking my board.

wonder if you can help me to take a look or advice what can i do?