[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

I plan to use MMTool and use the flash utility directly in the BIOS.
Where do I check the ME FW version?

Although this question has nothing to do with the topic of this thread, MeatWar gave you the answer >here<.

Hello friend, how can I insert the nvme model in a B85M D3V A please help me


The procedure how to insert the NVMe module is layed down very detailed within the Guide (= first post of this thread).

If you want help, you should describe your problem. Where is the original and your modded BIOS attached? A screenshot (showing your problem) may be helpful.

Ok. Done:

Intel ME Version: v9.0, Build 1482, Hotfix 30

Full Report of HWInfo file:

Now grab the resulted “x64_bios-region” file, extracted from the RAR, apply the mod according the guide, use method 1 or 2 and share it again for verification before flashing, if you want it.
Recommended method, AMI MMtool and small DXE variant.
The “verification” is also described in the guide using UEFItool for missing/added PAD file on selected bios volume.

For flashing, get the ME9.1 tools package from C2. (CS)ME System Tools and use the Intel FPT tool as CMD line ADMIN, preferably on the root of a disk:
Ex.: fptw64 -bios -f x64_bios-region_mod

The forum and provided information is NOT responsible for any user actions based on the gathered information.
Its a user choice ONLY regarding the risks of flashing mod files.
Good luck.

EDIT: Use the MMTool_x86_5.00.0007

1 Like

Thank you for your reply,

I’m getting this error while inserting module:

What’s happening?

I don’t know. Maybe the path to the NVMe module was too long. It is never a good idea to use a personal user folder for such actions.
Advice: Put the folder named NvmExpressDxe_Small into the root of drive C: or drive D: and redo the insertion.
If this doesn’t help, use another BIOS Modding tool.
Good luck!

1 Like

Changing path does’t worked but I used UEFITools for inserting module and worked.

Now, opening new file in MMTool:

As you said, I would appreciate it if you could verify the file for me before I flash it:

As I write this post I saw your EDIT about the MMTool version 5.00.0007. I will try too.

EDIT: With MMTool 5.00.0007 that worked, this is result file:

About the version of ME 9.1Tools, it’s 9.1 and not 9.0, ok?

File verified, original PAD file still present in the end of the worked bios volume.
The ME FW image on the system is 9.0 but the tools available work for both.
Report back, good luck.

1 Like

Done. I’ll restart and test for verify the result and back for post if worked.

Impressive!!! Worked!!! Perfect.

Thank you very much! @Fernando @MeatWar

You are amazing.

1 Like

hello there, I’m successfully doing a bios mod and installing windows on dell T5610, i was wondering can i doing a raid 10 for the boot drive? i found a plx 4x nvme card on Aliexpress and intrigue to try it.

and also. while i’m doing the bios mod, i’m using the nvme small version in compressed mode and i just saw on this forum there’s a resizeable bar mod. can i use both or better with nvme boot using clover and resizeable bar mod? (if clover can do raid 10 please let me know)

thank you

As long as RAID arrays and RAID boot are supported form that card, it could be possible.
Careful with the seller/product description… regarding the card full features/supported, do not link the card for my opinion… i cant vouch for anything on AliExpress.
The DXE’s NVMe branchs are equal in their function, small or std.
Both mods, NVMe along with ReBar should also be possible, but better submit all the system info on the correct thread, related to ReBar

hey man, thanks for the fast reply, i think it’s the same plx chip as Sonnet x4 nvme raid card. i’m a bit confused to bios setup since it boot from Achi not raid one, should i configure raid in bios or in windows to raid the boot drive?
sorry i’m a beginner to do raid setup

nicee, will try the rebar setup with nvme and give the update

PLX is a PCIe lane switch (PCie lane endpoint manager), it does not have any more features than this or RAID related.
The card needs additional resources for additional features support, like RAID and boot, so thats what you need to look for.

That could be in the future …who knows… the next GEN of self-aware bios interface that would detect additional cards and their controllers providing/uncovering additional menu settings to control her functions…

But we’re not there yet… so answering your question, the bios can control the embedded controllers of her chipset, The Intel C600 AHCI/RAID and additional ones present in the mainboard, only.
The bios detects additional hw interfaces but cannot set/config her functions, this is usually done on the card when she possesses an Option Rom FW (OpROM) during the platform initialization.

So when looking for a card with RAID support, usually it comes with a OpRom of the controller used, ex.: Marvell, ASmedia, HighPoint, etc…

Why is it recommended to turn off Secure Boot? Won’t it work at all with these NVMe drivers?
I have an Asrock Z77 Extreme4. There is an official BIOS from 2017 with NVMe support, but also a newer one from 2018 without NVMe but with some microcode updates and possibly other fixes. I want to add the latest microcode and other modules with UBU anyway, but should I rather use the official, older NVMe BIOS as base file or the newer one and add the NVMe drivers provided in this thread?
For reference, the official BIOS files I mentioned:

Because otherwise you may not be able to get the OS properly installed onto the NVMe SSD.
Once the OS installation has been completed you can try to set “Secure Boot” to “Enabled”. This way you can verify yourself whether disabling this BIOS setting is permanently required or not.
Your other questions are off-topic. It is up to you to find out which BIOS version is the better source for your specific system.

Thanks; if there’s no specific problem with Secure Boot I’ll just use the latest BIOS version. I guess the DXE drivers from the forum have no disadvantages compared to those provided by Asrock?
I updated the microcode etc. with UBU and then tried to add the NVMe driver with MMtool but it reported ‘not enough space’, even with the small compressed driver, but UEFItool inserted even the large driver without error message, however I then went with the small one. I read an opinion on the forum that the small one might even be faster. What are the advantages of the large one?
The BIOS that I produced works so far, but I haven’t installed the NVMe drive yet.
Also the link in the first post appears to be broken, about how to compare the BIOS files in UEFItool to check for problems with the padding files. How do you do that? I can’t find the posting that this is referring to:


The broken link has been fixed by me. >Here< is the correct link showing the comparison pictures.