[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

A post was merged into an existing topic: [Guide] How to flash a modded AMI UEFI BIOS


I was browsing some of the modded bioses posted on the forum, and I notice some of them also contain the SAMSUNG_M2_DXE.ffs

Should both SAMSUNG_M2_DXE.ffs and NvmExpressDxe_5.ffs be included in the bios? Or is just the Nvm Dxe enough? Is there any harm/benefit having them both.

BTW, I will be using one of these:
SSD Samsung 970 EVO PLUS, M.2 - 1TB
or Samsung SSD 980 PRO, M.2 - 1TB

The SAMSUNG_M2_DXE module is only needed for being able to boot of an M2 SSD, which uses the AHCI data transfer protocol.
Since all your listed M2 SSDs use the NVMe protocol, only the insertion of the NVMe module makes sense.

1 Like

Ah, I see… So that’s support for the older Samsung m2 SSDs which are basically variant of older SATA hardware.
Thank you.

Reporting success. :slight_smile:
Thank you @Fernando for the help and the guide.

For ASUS users with CAP bios: You can mod your CAP with MMOtool and than simply flash the modded CAP with USB BFB (bios flashback function, if your motherboard supports that). More specifically, no need for ROM extraction steps (and re-capsuling in CAP) in this use case scenario.

Cheers :slight_smile:

I’ve tried to follow the guide for a Supermicro X10SAE Motherboard. Upon inserting the NVMe modue, I am noticing that a pre-existing Pad-File is removed. This appears to be the case when inserting the module with both MMTool and UEFITool. Below is a screenshot displaying the original on the left and the mod on the right.

Additional notes:

  • MMTool is only able to insert NvmExpressDxe_Small
  • UEFITool is able to insert both NvmExpressDxe_5 and NvmExpressDxe_Small

Are there any recommended steps I can pursue? Thanks in advance for any guidance.

@hethspd Welcome to the Win-Raid Forum!
Please attach the original BIOS or offer the link to it.

@Fernando Thank you for the quick reply. Below is the link to the BIOS that is currently flashed onto the motherboard.

Since I am not a registered Supermicro user and don’t want to become one, please attach the pure BIOS file as 7-zip or WinRAR archive.

Please see attached. This is the exact same file hosted on the manufacturer’s website, which not only includes the BIOS image but the readme and utilities.

X10SAE8_525.zip (6.2 MB)

The proper insertion of the NVMe module into your specific mainboard BIOS is more difficult than I thought. Unfortunately I don’t have currently the required time to solve your problem.

Can you help? Thanks in advance!

As the MMTool 5.x reports successful insertion of the Small variant, regarding volume space (besides the pad error) i would be using the UEFI_tool0.28 to insert the same variant.


Or if you wish to use the standard variants, you may try the method of removing unnecessary drivers, related to UEFI DXE network boot drivers.

Im not providing any files here, because it seems you’re a capable user and fully understands the processes, give it a try and ensure you have backups and recovery methods, good luck.

EDIT: I made another test with older MMTool 4.x and the insertion of the small variant is also OK with original Pad still present, so plenty to choose.

@Fernando - No worries. Thank you for taking the time to take a look.

@MeatWar - No need to apologize. Thank you for offering to help.

@MeatWar - Thank you for taking a look and providing advice. I’m still struggling to make sure that the Pad-files are retained from the pure image. I’ve tried to insert the NVMe module using MMTool4.x instead of MMTool5.x as you suggested. Below is specific version information.


As you have mentioned, the Pad-File after the DXE Volume appears to be intact with both MMTool and UEFITool as illustrated below.

However I now seem to be losing the Pad-Files before the DXE Volume as illustrated below. MMTool further seems to remove records with GUID 05CA01FC-0FC1-11DC-9011-00173153EBA8.

I’m all ears for any other advice you may have.

Humm… didnt checked those ones, usually we check end volume.
Indeed all options i elaborated will remove them and they got data… even getting more space and using other variants…
Tried to extract/insert/replaced, neither worked also, the volume is always modified…


The ROM holes change offset when their gone…

  • Even after UBU their gone…
  • An Hex edit data maybe… a bit painful here

We can try another method, make an FPT dump of the bios_region only, not AMI AFU backups.
Then try again all the methods we already know here… but do not get many hopes, this one is tricky.
Its a risk but it still could work if flashed… but dont do it if you cant recover it.

EDIT: Tomorrow il check other Supermicro X10 confirmed success reports here on forum and will analyse their structure ori/mod, this was never noticed and it works or this one is a damm pain…

1 Like

@MeatWar - Thank you so much for spending all this time to investigate. I am going to hold off from flashing anything until I have a higher degree of confidence that this will work. I will eagerly await any updates from you, regardless of whether you have good or bad news.

I have now successful results to share… but i would like to test the FPT dump as i stated/requested in my previous post, before final report.
Do you have knowledge to perform the dump operation/ME FW tools, you can share a private link/file to me, in the message system, if you dont want it public.

Read: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15) - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

Your system uses ME9, perform dumps/backups with the Intel FPTtool (CMD Admin from a temp root folder) from the correct package:

You need to enable JPM2 jumper for the operation, jumper back to initial position for normal operation, after system shutdown.

fptw64 -d spi.bin
fptw64 -bios -d bios_reg.bin

@MeatWar - I unfortunately don’t have the tools to perform the dump. If there are any instructions that outline the steps/tools, I might be able to figure it out.

Thank you for providing the guide. I did a quick read through - looks like I need to create a portable Win10 installation that I can boot into, install the tools/drivers, and get the dump. I’ll take a stab at this tonight when I have time and access to the server.

I was able to grab the FPT dumps you requested. I just tried send them to you via PM, but received an error indicating that you aren’t accepting messages at the moment.

I had no success working in latest bios .525 or dump from it, look at the highlighted Padding file, the only one always non-existent in the mod.
Tried several, manual edits related to MicroCodes… no luck.


I believe that its OK in the bios version 223, at least regarding the previous issues reported, download it and you should give yourself a good look into it, as im not responsible for any damage done by this files to the system board, if you really decide it to try them… i personally would only risk it, if it was not my primary system and having an SPI programmer with full backups aside.


Maybe… another user can spare some time to further look into this, good luck, all the best.

@MeatWar - Thank you so much for spending time to work on this. I’ll take a look at the 223 Mod that you have shared and determine if I want to try flashing. This system is one of my daily drivers for now, so I am not sure if I want to risk bricking it.