HP Elitebook 8560p BIOS chip replacement problem: ME is in recovery state

I have read most of the posts of this thread and I must say, thanks people for a lot of good work, amazing.
However, I’m very confused now, maybe I read and tried to much. (for days now) And still I can’t find a solution for my HP Elitebook 8560p.
Therefor I’m asking for help.
The bios chip has been replaced with a new one and it works, but at startup, error massage comes up for a brief moment "ME is in recovery state"
Whatever I do, I can’t solve it. I tried to reflash and recover the bios in various ways, no luck.
Tried to update the ME FW, but I get mainly error 8193: Intel (R) ME interface: cannot locate ME device driver.
So if I try MEinfo I get error 1002: Failed to retrieve ME FW version,also Error 9458: Communication error between app and ME FW and error 9459: Internal error (could not determine FW features info)
MEManuf comes with similar error codes.
To me, that would indicate there is no ME in the bios, but if I look in Device Manager I see the Intel Management Interface. I read, that the Mei is not in the bios like ME so that looks like the ME is not in the bios. The AMT and TPM are in the bios.
Intel 6 series and QM67 chipset.
Can anyone point me in the right direction how to get the ME (updated) in the bios?

I will have time to check your reply tomorrow probably. Make sure you have proper MEI drivers installed first (download and install "Intel MEI Drivers & Software v11.0.0.1162 for Corporate systems complete package" from section A2 of the first post).


Installed MEI V11.0.0.1162. The device manager says Intel Management Engine Interface driver
I’ll wait, thx

Edit: I added the HWInfo64 ME data on 2 pictures for info.

@ bicalov:

Now that you installed a proper MEI driver, can you run MEInfo and MEManuf tools and report back with the results? I’d like to see what these report first. Remember that you need the tools for 7.x firmware.

This is what I get.
In my previous post I added also HWinfo info.


First, do a clear CMOS and then restore default BIOS settings. If the problem persists, run Flash Programming Tool with command fptw -d SPI.bin . Does it report Error 26 or does it dump a file called SPI.bin? If the dump succeeds, please compress and attach it here.

Why did you change the chip? Did HP send it to you? Did you have this problem before changing the chip? Did the problem occur after updating the BIOS or changing anything else at the system?

Do the DOS versions of MEInfo and MEManuf report the same errors upon running them? Use MEManuf -verbose this time. Also, while at Windows, it’s better to use the x86 versions of the tools since the ME7 x64 ones were not always reliable.

When I bought this system, it was defective and the password was missing. I contacted HP and they helped me with a SMC file to clear all. Regretfully this was not working.
Than I bought a pre-programmed chip on Ebay and put this on the board. It was not functioning poper, missing system data and I had to use wndmifit to put in correct data. that went ok.

The problem occured after updating bios.

I use the dos versions because in windows the dos window closes to quick. The result is the same.
If I use x86 version, I get a error that he can’t function on 64 bit version.

result spi.bin is error 26[[File:flashresult.JPG|none|auto]]

@ bicalov:

The bad news are a) Your Flash Descriptor is locked and thus we do not have write access to full ME Region and b) HP does not include the system-customized ME Region at their BIOS updates. However, we might be able to fix this by making sure you have the latest BIOS and ME firmware up to date. Especially the latter might be the cause of the problem.

1) Make sure you have the latest BIOS from HP installed. After updating to it, restore settings to default.
2) Update to the latest ME7 5MB firmware which is Intel ME 7 Corporate 5MB Firmware v7.1.86.1221. Use FWUpdate for that.
3) Reboot and check if everything is ok.

I found THIS while searching for your issue. I’m thinking that updating the ME firmware might fix it.


Will be busy with this one a little bit, will come back asap.

Regretfully it did not work[[File:fwupd.JPG|none|auto]]

What also happened is, the system has bios version F60 and the latest is now F61. When I do the update, it is executed correctly, but afterwards it still have version F60. So it is not writing, although it seems to go good.

The link isn’t working.

At Device Manager > System Devices, do you see Intel(R) Management Engine Interface? If you do, what driver version does it report?

This is certainly a system specific issue. Something is wrong with the SPI chip or the image within. Maybe a ME Region reflash would fix it in case of corruption but HP does not provide the ME Region inside the BIOS they release so we cannot reflash it even with a programmer.

The fact that you cannot update to the latest BIOS proves that something is wrong with the spi image inside the chip. Maybe these tools that you used to restore settings or the source from ebay.

Have you tried flashing the latest ME firmware from DOS using FWUpdate? DOS doesn’t use the MEI driver either way.

Driver version of MEI is

It looks entirely possible that the spi get corrupted by something else,
so many things I tried before.

I tried under windows/dos window, I can try with dos/usb .

Thanks anyway for your efforts.

@ bicalov:

The command prompt is not a dos window. You need to boot into a dos operating system and then run the DOS versions of the tools. The DOS tools cannot be run under Windows.

In Dos mode Me is installed correct, but the "ME is in recovery" message stays.
In the pictures you can see the FW update went correct and HWinfo shows the new version also.


Can you show the result of MEInfo and MEManuf -verbose while running them at DOS? The Windows tools are not working because the MEI driver does not respond while in Recovery Mode.

You said you changed the chip only, not the whole motherboard. Right? So when you changed the chip, it was fine. There was no "ME in recovery state error"? The error started appearing exactly after you updated to a latter BIOS release? This notebook has two families of BIOS: 68SCF (ME 5MB) and 68SCE (ME 1.5MB). What BIOS family did you have before changing the chip? Is it possible that you flashed the wrong BIOS? Is it possible you got a chip which has the other type of BIOS inside?

I changed the chip only.2 times. The supplier send the first chip with old bios F08 and I try to re flash it but ended with a black screen. The supplier send me a new one with latest version F60.
It had a message that the “manufacturing program mode set” was open and I closed it ? There was no system ID , therefor I received the program winmifit as metioned
On the picture with the system data you can see 68SCF family. This picture was direct after the chip replacement.
Further the pictures from `Dos MEinfo and MEmanuf. sorry for the quality.


I don’t know which one I had because I could not get into the bios because of the startup password. I did not know of the 2 versions and only looked for 8560p

The ME itself seems to be fine and this is shown by MEManuf. MEInfo reports errors though, maybe it has to do with it being in Recovery Mode. Currently we can’t really see anything at MEInfo, only the last part is shown. Generally, while at DOS it’s best to save the output of the tools at a text file and then upload that or show it under Windows. For example MEInfo -verbose > result.txt will create a file called result.txt with the command line window output.

It is my belief that the problem lies with the rest of the system and not ME. I can think of three possible scenarios:

1) There is a jumper on the motherboard that puts the ME at a Recovery State. Have you changed any jumpers or anything else on the motherboard itself? What’s the model?
2) There is an option at the BIOS menu that puts the ME at a Recovery State. Have you searched all the menus for anything related? It could be called HMRFPO, ME Enable, ME [something] etc, Recovery etc.
3) If the above do not help, the problem is with the HP BIOS. In such case, you need to contact them and ask for help.

Herewith the result.txt file

You might be right about the problem.
1) The previous owners molested the board and ripped of some parts, like coil and capacitors. I replaced as good as I could, because for this motherboard is no schematic available at the net. Mobo number is: cure-dis-hr-hpb-mv-mb-v1, HP p/n: 684323-001.
I don’t think the missing parts belong to the bios chip because they are from a different area.
2) I can’t find anything related to ME in the bios settings.
3) Contacting HP is where I started with, but after the help with the SMC file their help stopped and I only can contact them to exchange the board. (To expensive, that’s why I try myself)

I managed to update the bios with F61 with the Dos update, but the “ME in recovery state” still remains.

@ bicalov:

Ok, I did some research and there are some weird things going on here.

1) At the MEInfo log I can see that there is no MEBx version supported ( which should only be the case for 1.5MB systems and not 5MB like yours. 5MB systems need MEBx to work properly. It should be there and accessible by pressing CTRL+P after POST (before the loading of Windows).

2) I searched to see if I can find other people’s SPI chip dumps from this laptop. I did find two full SPI/BIOS chip dumps (8MB, normal size). These images do have MEBx inside (as yours should have had) but here is the weird part: They both have a very old ME 5MB firmware which I didn’t have at my database and it’s Pre-Production, not Production.

According to a Revision History, that was some Alpha/Engineering firmware for testing and not public release. It makes no sense for HP to ship a consumer system with Pre-Production firmware. And the fact that I found it at two different SPI dumps proves that it wasn’t a one time thing from HP.

If I remember properly, you get error 26 when running fptw -d spi.bin command, right? It’s a shame we can’t dump the whole SPI image to see what’s up in there. Did you replace the chip yourself? Do you have a programmer? If not, let’s at least try to dump the BIOS region from the SPI chip. Try fptw -bios -d bios.bin command and then compress & attach the resulting file. I’d like to see if even MEBx is at your BIOS region as it should.

  1. control p does not work
    2) I do have a 68SCF.bin file from 8MB. I don’t know where I got it from, maybe from one of my searches. Dos flash program does not accept this file.
    The chip I put in myself, since it had to be done twice, a few islands were lost, but were repaired properly.
    I don’t have a programmer. sorry.
    Attached the spi dump bios.bin file (executed with fpt -bios -d bios.bin, fptw was not excepted)

    Also Attached the possible bios settings.

@ bicalov:

Generally, others have had this problem as well. For example, here is a Dell example.

CTRL+P does not work since MEBx is not detected. Can you compress & upload this 68SCF.bin 8MB file to see if it’s the same I have? The HP tools won’t work with such image, only FPT (fpt.exe for DOS, fptw.exe for Windows x86/x64 and fptw64.exe for Windows x64). If you wanted to flash such an 8MB image you would need FPT or a programmer. Since FPT works only when the Intel Flash Descriptor is unlocked (your’s is locked, error 26 at fpt -d spi.bin command) the only way is via a Programmer.

However, if the problem is at the BIOS region and not ME, you can replace the 3MB BIOS Region via fpt -bios -f bios.bin command. The BIOS region is not protected by the locked Flash Descriptor (ME and the Flash Descriptor itself are) so in theory you should be able to replace it manually via DOS/Windows using the FPT tool. Fpt -bios -d dumps the BIOS Region whereas Fpt -bios -f flashes a new BIOS Region into the SPI chip. I believe the problem is at the BIOS and not ME region (if MEManuf is to be trusted).

Let’s exhaust the software solutions first. Make sure you do a clear CMOS. This is a laptop so remove the external power, remove the battery and then remove the motherboard battery. The last step is the most important to perform a clear CMOS. Leave it for 5 minutes alone (you can also press the power button on purpose some times to clear any capacitors and stuff). Then reconnect the motherboard battery, laptop battery and external power. Turn the laptop on. It should tell you to reconfigure BIOS settings because a CMOS was performed. Enter BIOS settings and reset to defaults. Does that fix the problem?

If not, enter BIOS setup and under the menu System Configuration check the AMT options. Enable “Firmware Verbosity” in case it reports something useful, enable “AMT Setup Prompt (CTRL+P)”, enable “Unconfigure AMT on next boot” to reset MEBx settings. Now, test if you can enter the MEBx menu after system POST (before Windows starts loading) by pressing CTRL+P multiple times (to not miss it). If you manage to enter MEBx, your goal is to find a “reset settings” option or similar. Just in case something is messed up there. You can find a MEBx User Guide at ME System Tools v7.x found at the start post, section C2. Check if the problem persists.