HP Elitedesk 800 G1 TWR - Unlock hidden menus

Now that I have my programmer and clip operating properly, I would like to unlock the hidden menus and settings in my BIOS.

I have tried setting everything to "USER" in AMIBCP, but that does not seem to help.
I have also used the IFR extractor, but could not find anything that was obviously being suppressed.
AMIBCP shows 2 "Advanced" menus with the same ID, one of which has the enabled menus, and the other has the menus that I cannot access. There are also a number of menus and settings without names.
I also notice in AMIBCP that there is an unnamed subfolder under "Main," which contains a lot of settings that I would like to access.

Here is a dump of my BIOS from ch341a: http:// s000.tinyupload .com/index.php?file_id=11464843465038591551
(I cannot post links so I have added a space after http:// and a space before .com)
Let me know if you need anything else.

Thank you!

Edit: I saw your post about the "Magic String" so I will try that now.

Edit: Within the BIOS setup I see File, Storage, Security, Power, Advanced.
Within AMIBCP I see File, Storage, Security, Power, Advanced, Advanced, Boot, Chipset, Save&Exit, Main, Security.
So I have 5 enabled and 6 disabled.
When running IFR extractor, I get the data from Setup -> Compressed section -> 97E409E6-4CC1-11D9-81F6-000000000000
I extract that file with UEFITool, and search for 00 00 00 00 00 00 01 01 01 01 01, but do not find anything.

Edit: I did find those values within the PE32 Image Section, so perhaps I should change those to 01s and see what happens.

Edit: Well holy crap, it worked! Thought the Intel ICC menu is mostly empty, which I think might be some of those settings that have no names in the IFR file. I would really like to have those overclocking settings available.

Yes, it’s on the PE32 of setup in this BIOS, the settings and IFR are created from the other non-PE32 part of setup. Show me image of ICC contents, if something is missing that you see in IFR it may need further unsuppressed.
Or, you may need to edit ME FW to make changes to ICC profile possibilities (if only profile is standard you need to make adaptive instead, and remove standard and set adaptive as main)
What is chipset here? Some chipset you can only use standard of Adaptive, others you can use Overclock or Overclockext etc.

Chipset is Q87, which I’m guessing does not have impressive options. Though, there are Q87 boards with decent overclocking options.

I think that I am confused about how ICC overclocking works. I will need to do more reading. I want to change BCLK but I am not sure how that works.

One thing that I see in IFR, but not BIOS setup, are the memory settings such as “DIMM profile,” “Memory Frequency Limiter,” etc.
Attaching my IFR file. Do you have any suggestions?

Edit: I guess I can’t attach files… IFR: http:// s000.tinyupload .com/index.php?file_id=00230168801308253314

If Q87 has overclock possibility and you’re sure, then we can set overclock profile or above as only or main in ICC profiles of ME FW

ON Dimm Profile, Frequency Limiter (these are in IFR twice, top area is hidden debug, so ignore), but the ones at middle of IFR you can make visible in BIOS. Can you see Memory Config section already, inside Chipset >> System Agent >> Memory Config?
Dimm Profile looks like it should already be visible to you there, but Memory Freq Limiter may be hidden.

I too know little about ICC overclocking, most people I see with this as only resort use XTU in windows instead.
Send me new dump of your unlocked BIOS, and I will check the ME FW and change it to Overclock for you if it’s not already there (Stock BIOS only has “Standard/User” by default, so probably same as your current one too)
Or, if you unlocked FD before you wrote back in BIOS, you may be able to dump all with FPT and then write back all with FPT

Bclk is not in your BIOS, at all, so any bclk changes would need done in windows with XTU or other software.
Unless adding overclock profile to ICC in ME FW makes something like that appear in ICC area?

I was mistaken. I do have all of the memory options available. I am not used to having so many options in BIOS!

Here is my modded BIOS: http:// s000.tinyupload .com/index.php?file_id=09556082580448619797
Please do take a look at the ME FW.
I can flash ME region with FPT, just not BIOS region due to FLOCKDN.

Thank you for all of your help!

You’re welcome! And, thanks, try this - Program in BIOS with programmer, or flash ME via FPT, up to you but I’d program in due to the unlocked FD

ME, flash via >> FPTw.exe -me -f -MEOC.bin
Followed by >> FPTw.exe -greset

Then if it does not automatically reboot at -greset above, shut down system, remove power cable, press and hold case power on switch for 10-15 seconds, then let sit for one minute without power.
Then boot back to BIOS, load optimal defaults again, save and reboot back to BIOS and see if you can do anything new in ICC Area.

So, you can see Memory Freq Limit setting too, correct?

If this fails to boot, bricks, then let me know, I will make similar edit, but change profile selection back to softstrap instead of BIOS (I changed to BIOS + added Overclock profile and set OC profile to default)

I see ME read/write is NO in your FD, so without jumper I assume you cannot write ME FW with FPT. So, I unlocked FD for you also here, so now after you program this in, or jumper then flash in complete BIOS, you can then write ME with FPT without jumper

I am able to see all of the memory settings, though it appears that they don’t save, or get set back to default automatically. I have not seen any of the memory settings stick after reboot.

I flashed your file with the programmer. The only ICC difference that I see, is that it seems like the menu options under “ICC Overclocking Lib” are gone now: http:// s000.tinyupload .com/index.php?file_id=00271480607765999554

Another thing that I am trying to find a fix for, is the terrible current limits on this board. As noted here: https:// www. techspot .com/article/1841-gpu-cheap-oem-pc/
"In the end we saw a peak package TDP of just 49 watts and again a maximum all core frequency of 3.5 GHz. In contrast to that, the aftermarket Z97 motherboard allowed the Core i5-4690 to hit 3.7 GHz at a package TDP of 58 watts and no limits were imposed, 18% higher than that of the OEM system."
I have disabled all of the power limits in the BIOS CPU settings, but it will throttle it around 55W TDP, though the processor is rated at 84W Max TDP.
I replaced the weak OEM power supply with a Corsair CX550, so the board should get enough power.
Do you know of anywhere else that this limit might be set?

Edit: I flashed back to the original ME, looked at a BIOS manual that has ICC settings, and it seems like this is what I’m missing:

0xC5BA4 		Suppress If: {0A 82}
0xC5BA6 Variable 0x1AB equals 0x0 {12 06 AB 01 00 00}
0xC5BAC Grayout If: {19 82}
0xC5BAE Variable 0x197 equals 0x1 {12 06 97 01 01 00}
0xC5BB4 Numeric: New frequency [10kHz] (28995564767019010-28995564767019010) , Variable: 0x0 {07 A6 E7 09 E8 09 D3 04 18 00 00 00 04 11 00 00 FF FF 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00}
0xC5BDA Default: 16 Bit, Value: 0x0 {5B 0D 00 00 01 00 00 00 00 00 00 00 00}
0xC5BE7 End {29 02}
0xC5BE9 End If {29 02}
0xC5BEB End If {29 02}

Though, it says that maximum supported frequency is 100Mhz, so I don't know if changing that setting would actually do anything.

Unfortunately, I don't see any multiplier settings, so it seems like FSB would be my only option. I have options to overclock the memory, which my RAM would support, but as I said those options don't seem to stick.

Edit: OK, I can get package TDP to go over 55 by changing "iout slope" to 1023. I don't know exactly what that does, but it seems to do the trick. Benchmarks confirm that it helps. Temperature still doesn't get any higher than 56C.

Now I just need to figure out a way to change CPU multiplier and memory speed.

Edit: Oops.. The "DIMM Profile" setting wasn't saving because I was using an odd number of memory sticks. Returning to an even number allowed me to set it to "XMP 1" which doesn't allow frequency changes, but at least it lowers CAS from 11 to 9. I'll take that.

Set Manual instead of XMP, then you should be able to set all manually. Do you want me to make you another BIOS to try leaving profile selection back on softstrap, in case this maybe messed up the library thing you mentioned?
Or it’s possible, since this is Business/Corporate ME FW some things may be less compared to what you’d get with consumer ME
But, I’ll go ahead and make that for you tonight (Maybe now if I can get done in time, watch for edit in a bit) so you can test

@bc732 - * Edit - Here is same as I sent you before, but with ICC profile selection set back to original (Softstrap) - http://s000.tinyupload.com/index.php?fil…472769213624793
I think either way may be same/same, since I set Overclock as main profile anyway, but not 100% sure.

* Edit - If stuff is still missing in ICC that was there previously, it may be Q87 doesn’t support overclock profile and we can try Adaptive instead if you want?
If that also fails, then it may be best to put ME FW back to it’s original state, well I mean fixed ME FW as I’ve sent you, but without the ICC changes (I’ll have to make this for you, you do not already have in any BIOS I’ve sent you)

Hello! I just registered on the forum after reading this topic.

Currently, I am unable to purchase a new computer, so I am trying to optimize what I have (Elitedesk G1 800 SFF - i7 4790).

I wonder if anyone could share a modified bios to work around the "current limit throttling" problem. The processor supports up to 3.6ghz without problems, but when I activate the turbo boost, the clock does not go further due to lack of current.

And also the possibility to change the latency of the ram.

I am currently using the most recent bios obtained from the HP website (L01 v02.79). Can I load the modified bios using the HP software?

Best regards!

I have HP 800 G1 model with Q87 chipset LGA 1150

Was wondering if it is worth it to mod the bios for any gaming performance.

I have some RIPJAWS DDR3 that will run up to 2133 mhz with XMP

Stock HP bios has no options for anything.

I guess my concern is with RAM timing and if the sticks don’t exactly match the board if I should MOD bios to better use the RAM?

Currently the controller is running my 2x4 sticks at 1600 mhz which is stock board speeds.

I’m bad cause I thought if the RAM fits it works :joy::joy:


Hi, I’d like to unlock the bios of my prodesk 600. I think the Bios is identical to that of the elitedesk 800 (file sizes are identical and I downloaded and flashed the latest bios for the ED 800 successfully.
However, if I try to flash bc732’s rom, or the latest one from LOST_N_BIOS (using HP’s Dosflash utility) I get the error: System Rom image is invalid.

Do I need to use another flash-tool, unlock the ME stuff first via FPTw.exe first, or is this because I am trying to install a bios version, that is below the already installed version? Another possibility would be I need to do the magic string bit on my own bios because it does indeed differ from the ET 800?

Maybe if bc732 is still around, he would be willing to send an up to date bios image, if he got it all working in the end?

Edit: I tried flashing via fpt.exe, but I get an error saying my processor is not allowed to write to the ME, if I remember correctly. So I will have to unlock stuff first it seems.

@felowkin - Slow down, and STOP NOW!! You should not write anyone else’s BIOS with FPT!!!
And you need to be very careful with FPT, follow directions exactly and ONLY as outlined.

It may not be possible to use FPT to flash this mod BIOS, bc732 was using flash programmer, so he has no issues.
To test if we can flash mod BIOS with FPT, you need to do the following then wait for my reply

I also suggest you FIRST flash back to your PROPER model BIOS!! If you can?
DO NOT use FPT for any other files, DO NOT Use FPT other than described below for now.
Otherwise you may end up with a bricked system!

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

@KnoX2020 @ enessyia - Flash programmer, such as CH341A + SOIC8 / SOP8 Test clip with cable may be required here, not sure yet, please wait and see outcome from what enessyia do here

yeah the flash did not commence (fortunately). I will give the above method try later today.

Oh, the guide seems to require having windows installed on your system. My HP runs linux at the moment. Thats going to be a lot more complicated, or maybe it would be easier to live-boot some windows version just for the purpose of handling ME stuff.

@felowkin - You can do it all from DOS, just use FPT.exe instead of FPTw.exe (DOS info at bottom of spoiler)

I tried the fpt -d biosreg.bin command and got the following error message: error 26 the host cpu does not have read access to the target flash area. "To enable read access you must modify the descriptor settings."

My ME Version is: 9.031.1487

P.S.: Offtopic, but if I manage to unlock the Intel Flash Descriptor, will I be able to run "ME cleaner" as well and be rid of intels backdoor?

Show me image of this >> FPT.exe -i
I’ve never seen BIOS read access denied
Ahhh! Never mind, I see the issue, please be VERY careful with FPT!! You have wrong command there (missing -bios flag)!!
FPT.exe -bios -d biosreg.bin << Dump
FPT.exe -bios -f biosreg.bin << Flash back

Oh indeed I must have entered a wrong command! I promise to really be more careful from now on :slight_smile:
Now it worked:

Here is the dump: http: //s000.tinyupload. com/index.php?file_id=06464110858435444514

I also ordered a programmer just to be on the safe side…

P.S… But the bios is indeed write protected, I got an error: failed to disable write protection…

My ch341a programmer arrived yesterday. I cannot get the clip attached properly to the bios chip, I think the clip contacts are bend too much, I just might to have to order another clip.

I also found a jumper on the mainboard that enables reading/writing the ME part of the bios chip. Alas, the bios part cannot be written while the jumper is set.
At least I managed to clean the ME (using me-cleaner) and flash it back to the chip (via fpt -me -d meclean.bin).

And the system is still up and running!

I would still like to unlock the bios advanced options to be able to set up fan management and maybe undervolt and overclock the cpu a bit.

Just letting everyone know there’s a Linux program called flashrom, it works very well and can use the ch341.

Hello. I know this is an older thread but did you get your unlocked bios working please? I am having bios issues with a similar pc and can’t get the onboard video working. Thank you very much.