HP Pavilion dv6-6c12ed disable /remove AMD gpu (insyde bios)

Merry Christmas Boys and girls !

Is it possible to remove the amd gpu via a bios mod ? by removing modules or vbios ?

I have a dv 6 witch was oveheated so replace MB or a work a round is needed.
If it is possible I would like to remove the amd gpu so windows does not see it any more, I can work fine on just the intel gpu.
I have tried to load the stock bios in some tools but it does not seems to be recognised.
I do have a programmer so I can read the orginal and complete bios, but really like to know if it is possible or some one has a dump/link for me to try. I guess I am not the only one with a DV65 with black screen when drivers are loaded.

thanks !!

HP bios > BIOS<

@jeroenvtec - Merry Christmas late to you as well, hope you had a good time celebrating! So, you replaced motherboard, that does not have the onboard GPU that was originally there, but it’s the same motherboard/BIOS?
Or, you have new board, but graphics from both AMD (Onboard) and Intel (CPU). Since you have a programmer, please make a backup dump and send me that to look at / edit.
How is there AMD and Intel, I mean which is what? That doesn’t sound right, unless you have some odd random Intel or AMD Graphics card or chipset that has built in GPU too.
Please give more exact and precise details on what is AMD graphics and what is Intel graphics/ What is your CPU and what is your NB/SB chipsets?

Easiest thing to do here is change BIOS settings, can you currently switch graphics/use either, aside form the driver issues? You can see both AMD/Intel on GPU-z drop out menu on the bottom?
If yes, we confirm Switchable Graphics is enabled in the BIOS (And leave for safety reasons), but disable onboard graphics or set PCIE/CPU as default whichever you wanted to use.

Hi yes was fine just one day left and then all should back to normal :). Did you enjoy aswell ?

I try to make it more clear, was already late yesterday.
Ik have a HP dv6 with defective amd gpu, when you load the drivers screen goes on black, is a common issue with this model.
So I can replace the whole mainboard OR let the amd gpu disappear (no drivers = ok) and let the laptop run on the build in intel gpu.

And I was wondering If that can be done by do a mod by the bios. I have a seen the HP stock bios is encrypted so thats why not program reconise it …
When I searched for a bios dump I only found a wrong model of the dv6, but the tools did opened the the bios file but then I am stuck with a lot of GUID id’s
So for sure I need help but I also like to learn from it

In the actual bios you can choose dynamic of fixed GPU mode.
Radeon HD7470M
Intel Core i7-2670QM
Intel Mobile HM65
( more specs > https://uk.hardware.info/product/136548/…/specifications )

I will try to make a dump asap


Yes, had a good quiet time this year Thanks for all the info, now it’s more clear!

Encrypted BIOS might or might not be an issue, since you have a programmer there’s a better chance that doesn’t matter.

In case I still need to know while editing BIOS dump, please run this command from command prompt and tell me the output >> wmic BIOS get SmbiosBiosVersion

ok cool :slight_smile:

I find out that is was possible to decrypt the stock bios with phoenix tool, I will attach it. version BID017FC.F1C
the wmic command will give F.1C

I just can’t reach the bios chip not yet. doubt to trear down or remove a bit of platic …

IF I am right I have found some hits in:

I read somewhere the the vbios should be arond 60-70kb and that seems be be correct.
very curious now :slight_smile:

FC1-decrypted_stock.bin.rar (1.91 MB)

Yes, I already know all about BIOS editing, so no need for you to decrypt or do anything like that

vBIOS module I could tell you instantly what the GUID is, but I am not sure removal is the safer option, but if that is what you want to do let me know and I can tell you it’s GUID.
If you do remove, be sure you have a verified and valid backup (not all 00 or FF, and opens and looks proper in BIOS tools) created with your programmer before you flash or program anything to the board, so you can recover if necessary
Best option I think is disable in BIOS settings as mentioned

Oh ok, i did not have seen encrypted before.
Disable is also just fine
I have a proper backup now

Ps i have tried to remove those 3 guid but then the laptop does not start at al :stuck_out_tongue:
So i Will listen closer to you what to do :slight_smile:

See, I thought removal would not be ideal, neither would leaving in place and filling with all FF’s via hex

For informational purposes, here are the 4 main graphics GUID’s/Info (you was correct )
9FD8F494-6E3F-4A04-A2B0-8DF7E9E01BF6 = BR41116.001-WHISTLER.PCI_EXPRESS.GDDR5 - HP/Flex Grant Whistler XT GDDR5 128Mx16 1GB - ATOMBIOSBK-ATI VER013.

8DFAE5D4-B50E-4C10-96E6-F2C266CACBB7 = BR040957.001-SEYMOUR.PCI_EXPRESS.GDDR5 - HP/Flex Grant Seymour XT GDDR5 128Mx16 1GB - ATOMBIOSBK-ATI VER013.

8DFAE5D4-B50E-4C10-96E6-F2C266CACBB8 = BR041689.001-WHISTLER.PCI_EXPRESS.GDDR5 - HP/Flex Grant Whistler XT GDDR5 128Mx16 1GB - ATOMBIOSBK-ATI VER013.

8DFAE5D4-B50E-4C10-96E6-F2C266CACBB6 = OROM VBT VBIOS SANDYBRIDGE-M Version 2111 - Build Number: 2111 PC 14.34 - 02/23/2011

Please send me a copy of your backup, put in zip or rar etc. I will edit that moving forward, since it contains all your proper board specifics (Serial, UUID, etc)
First I will make two test edits for you, so we can first see if RSA signature is going to be an issue or not. One I will unlock the FD, and second I will make a single change in a BIOS setting. Then we will test to see if either boot, cause auto-recovery, or fail to boot at all

Please download this Intel ME System Tools package - https://mega.nz/#!rQ9WXQYL!LfEvstS2CLK05…R6puRfFe7vqs60U
Inside you will find MEinfo folder, go into that and select the Win32 or Windows folder and hold shift, then press right click and choose open command window here. Then run this command, and show me the end of the output >> Meinfowin.exe
This is to check if Bootguard is enabled on this system or not, if it is then RSA means nothing because bootguard will prevent any BIOS changes before RSA would even have a chance to.
Aside from that, some HP have “Sure Start”, you’d probably recognize this name from a BIOS section or settings name, and if this was on your system your failed rom removal would have auto-recovered due to Sure Start, so I don’t think that is on this system

ok flashed the first readout back to, after a cmos reset she booted again , pffffjuh
did run the meinfo:
BIOS Version: F.1C
MEBx Version:
Gbe Version: Unknown
VendorID: 8086
PCH Version: 5
FW Version:
UNS Version: Not Available
LMS Version: Not Available
MEI Driver Version:
Wireless Hardware Version: 1.5.229
Wireless Driver Version:

FW Capabilities: 17833056

Intel(R) Anti-Theft Technology - PRESENT/ENABLED
Intel(R) Capability Licensing Service - PRESENT/ENABLED
Protect Audio Video Path - PRESENT/ENABLED
Intel(R) Dynamic Application Loader - PRESENT/ENABLED

CPU Upgrade State: Upgrade Capable
Cryptography Support: Disabled
Last ME reset reason: Power up
Local FWUpdate: Enabled
BIOS and GbE Config Lock: Unknown
Host Read Access to ME: Disabled
Host Write Access to ME: Disabled
SPI Flash ID #1: BF254A
SPI Flash ID VSCC #1: 20092009
SPI Flash BIOS VSCC: 20092009
BIOS boot State: Post Boot
OEM Id: 00000000-0000-0000-0000-000000000000
OEM Tag: 0x00000000

Thanks, I just remembered boot guard is not until Haswell CPU, so we’re good there too. Glad you were able to recover! Now we can test disable setting only, after a few quick initial tests.
I should have had you make a single edit before you wrote back that BIOS, so BIOS lock would be disabled and we could FPT flash BIOS region, ohh well we need to make a single edit setting change test anyway

Please read this guide, starting at step #6 is where you need to be, since I will give you variables from the first steps.
[GUIDE] Grub Fix Intel FPT Error 368 - BIOS Lock Asus/Other Mod BIOS Flash

On your USB you need to rename the .efi file to Shellx64.efi if it is not already when you download the files (I forget).
Here is what you will change >> BIOS Lock >> Mull
So at grub screen you will type >> Setup_var Null 0x0

And, since the exit page with “Launch EFI From Shell” is hidden from you, you may need to use this method (But keep file named as mentioned above, I got that name from your BIOS, it’s what it will look for when you boot to USB)
[Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN (2)

If all that is too much for you to follow along, or you can’t get it, we can do another 23 minute write

Once that is done, in the ME Tools package fine Flash Programming Tool folder, go inside it and select Win32 folder then hold shift and press right click, choose open command window here.
And then run the following commands (One backs up BIOS region, second is to test writing back that same backup region to BIOS, to see if the above unlock was done correctly)
FPTw.exe -bios -d biosreg.bin
FPTw.exe -bios -f biosreg.bin

If any errors, stop and take screenshot showing command entered and error.
none of that applies to your BIOS, sorry for my confusion!!

*Edit - @jeroenvtec - Actually, never mind the above! Since you are still playing with programmer, lets do this now and then you can put programmer away and we can use FPTw instead moving forward.

This BIOS has unlocked FD so you can write to any region with FPT, unless we find there is a FPRR lock (only test with FPT as mentioned above will show us this, then if so I will try to remove, if I can’t you’ll have to keep using programmer - sorry )
Program this in with proven working version you used before that write was OK, just to be sure it will be 100% on there correctly, so we know if anything fails it’s due to RSA signature stuff.

@jeroenvtec - OK done editing for now, apologies again for all this confusion, sleeping on the job
Tonight, I will make you BIOS with graphics setup how you wanted (Disabled PCIE (Correct?), enabled and set main IGD from CPU, and leave Switchable graphics enabled for safety reasons(my choice))
Also, I will need to adjust these settings too (Muxed/Muxless - hybrid/dyanmic modes) - current default is Muxeless fixed scheme only (Will change to Muxed Fixed Scheme)

haha yes I will play with in this case slow programmer :stuck_out_tongue:
interesting article I also found about danovan6000 but his blog is closed or only for members, mebay there was there a already a existing solution.
But I have full trust in you ! And I try to understand so I do learn from it.

So as example plutomaniac teached me how to unlock the discripter via a hex editor :slight_smile:

If you see any pages from danovan6000 on this exact system, feel free to link them for informational purposes. Sometimes you have to go to an “Archive/wayback” type site to find his pages.

So you already knew how to unlock FD, that is good, That’s all I did for above BIOS. After you program it test those two FPT commands I gave, if you get error show me.

it is writing at super-sonic speed now hahah then I will test.
if I compare youre file I see some diffrence then I have would done it, is that for crc/byte count ?


BIOS and GbE Config Lock: Unknown
Host Read Access to ME: enabled
Host Write Access to ME: enabled

but fpt give error 28 prevent to flash


No, only changes I made was 6 bytes to FF at line 60 via hex
I didn’t change anything at line 100, and not sure what you’re seeing at 60x0a and 60x0b? Looks like only yellow and lines on your image, I can’t even see what values are there, but I set FF as you see in my image at 0000006a-0000006b


Show me FPT error image, thanks!

maybe a advanced menu from danovan6000 can help us out ? but I can’t find any how to or bios dump
strange you are right ! when I use ultraedit compare the diffrence is gone.

- Reading Flash [0x400000] 2560KB of 2560KB - 100% complete.
Writing flash contents to file “bios.bin”…

Memory Dump Complete
FPT Operation Passed

C:\Users\Klaas\Desktop\Intel ME System Tools v7 r2\Flash Programming Tool\WIN64>fptw64.exe -bios -f bios.bin

Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007-2011, Intel Corporation. All rights reserved.

Platform: Intel(R) HM65 Express Chipset Revision: Unknown
Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
SST25VF032B ID:0xBF254A Size: 4096KB (32768Kb)

PDR Region does not exist.

Error 28: Protected Range Registers are currently set by BIOS, preventing flash access.
Please contact the target system BIOS vendor for an option to disable Protected Range Registers.

Thanks, I can possibly remove FPRR (Flash Protected Range Registers) setting causing that error, but you would need to program that BIOS to the board first before you could then later FPT flash BIOS region without that error 28.
So for now, only way to update a BIOS edit will be with the stock installer, which will probably need edited .dll or .sys files, depending on the error you get with modified BIOS (you’ll have to show me once you attempt). Forgot you have programmer!
We can deal with this later if need be, once all is done, since this might take me a while to dig out and fix (It’s done in assembly/disassembly)

I can modify BIOS no problem with Intel tools (And can make settings visible to you outside of Intel tools), don’t need danovan6000 guidance, but asked in case you had something exactly relating to this specific system.
Before I make settings visible for you in the BIOS, I need a zip of images of all pages of your BIOS, so I can see what you see and don’t double enable something to be visible. Please put those in a zip for me and I will make settings visible for you in next mod BIOS.

The BIOS below has settings adjusted as discussed previously (+ ME Re-Flash enabled & unlocked FD/always)
Here is all settings adjusted
FD Unlocked
ME Reflash (Disabled) >> Enabled
Internal Graphics device (Auto) >> Enabled
Always Enable PEG (Enabled) >> Disabled << Now, PEG/PCIE Graphics is disabled entirely
PowerExpress Setting (Muxeless Fixed Scheme) >> Muxed Fixed Scheme
Normal Boot Menu (Normal) >> Advanced


@jeroenvtec - All those settings can be made visible to you, once I have all images of your BIOS.

thanks I am on it!
for now I am stuck at 99% for the second time, but keep on trying :slight_smile:

I attached pictures

Stuck at 99%, what’s that about? Thanks for the images, will get on that tonight for you. Good luck in the meantime, hope your BIOS programmer stops hassling you. I will try to unlock FPRR for you, then you wont need that anymore!
Missing exit and main images…

small update, version 1.29 does reconise the chip ! and does the flash in 6 min , jiiihaaaa
but with the special rom the laptop did not post, tired couple of times with and without battery etc.
you can or may keep the protection in the rom, fine by me and a bit saver, I will only program via usb. thx

caps lock blinking, i am out of tries so have to wait for your expertise :slight_smile:
new bios images

bios menu.rar (945 KB)

New BIOS from post #16 does not work, are you sure it’s not due to software 1.29? Did you write back working rom with 1.29 too after that failure?
Did you let it sit for 5 minutes or so with cap locks blinking? Just thinking maybe it was auto-recovering, but I’m not sure how RSA edited BIOS fail, I think when it’s bad it just doesn’t boot so this is not good sign for BIOS mod but see below lets test a few things before we assume this is it.

Thanks for images, no need to blur that stuff, it’s all in your backup BIOS anyway

@jeroenvtec - Here is 5x new BIOS to test, this one with only single settings changed for now, made a few different ways so we can see if editing method is an issue or if RSA signature is the issue and no matter how the edit is done it’s going to fail.

Please test each one, even if one works don’t stop there, please test each and let me know outcome of each one.
No changes will be visible to you in BIOS, so no need to look for that, just test each and see if you can boot to BIOS or not, thanks