HP Pavilion g7-2370sg network card restriction

Hello to all of you,
I have changed the network card in my HP Pavilion g7-2370sg from a Ralink RT5390 to an Intel Dualband Wireless-N 7260.
When I boot the laptop normally, windows 10 shows that the wlan is turned off. I have tried many things to activate the wifi in windows. Unfortunately nothing worked.
However, if I remove the power cord and battery before booting the system and then plug it back in and boot up normally, everything works as it should until the next reboot.
My theory is that in the bios of the system it is checked if the correct network card is installed and if not it is deactivated. And that this check is skipped when I perform the procedure described above.
My question now would be if this theory could be correct and if it is possible to modify this bios to allow the new network card to work properly.
Thank you for your help!

System: HP Pavilion g7-2370sg
Operating system: original win8, completely new installed wi10
CPU: Intel Core i5-3230M
Chipsatz: Intel HM76 Express
Bios: F.26
Bios Vendor: Insyde

System Information.jpg

Hello to all of you,
I want to change my Ralink RT5390 to an Intel Dualband Wireless-N 7260.
I would appreciate it if someone could modify the bios, so I can use every Networkcard I want.

System: HP Pavilion g7-2370sg
Chipsatz: Intel HM76 Express
Bios Vendor: Insyde
Bios Version: F.26 (https://drivers.eu/4dfRZF)

I’m not sure if this is necessary but, here are the data I read with BACKUP_Tools19n:

@Neihckls - Please show me an image of what you see on screen when you boot with a blocked card.

And then do the following

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

And now, full halt >> BIOS may be RSA signed, per this warning, file name is 0183AF26.bin once unpacked - https://www.bios-mods.com/forum/Thread-I…A-Signed-BIOSes
I would not flash any mod BIOS here until you have flash programmer in hand, and a backup made and checked by someone confirmed to be valid and OK backup

First of all thank you so much for your help.
I have already described my problem here:
HP Pavilion g7-2370sg network card restriction

I haven’t really found much on this problem and I suspect that the problem is related to a bios whitlist. You think that might be right?

I will try your method in a moment. In the meantime I made a backup with BACKUP_Tools19n (https://www.sendspace.com/file/abrg7k)

I’m not sure if this is necessary but, here is the copy of the BIOS image created with HP System BIOS Update Utility:
And a copy of the recovery USB flash drive created with HP System BIOS Update Utility:

You’re welcome! If your WiFi card is blocked by whitelist allowances, then you would not be able to boot to BIOS or windows until you remove the card, it will pause boot and put a warning on screen and you can’t go past that until the card is removed.
So your card is not being blocked by whitelist, it’s either incompatible for some reason, or may be partially damaged etc (based on what you describe in the other thread). Or some possible Win10 driver issue, not sure, but it’s not a BIOS whitelist issue.

No need to try my method to backup BIOS, you cannot modify this BIOS without programmer in hand and backup made (and even then, if it’s internally RSA Signed as suspected then it will brick no matter what)
See my edit above about this, if you missed it.

@Neihckls - Merging these threads, no need for two request for same system/BIOS etc

I don’t think it’s the drivers. If the system had no power before the card works fine. I have noticed that when I boot the system normally it takes much longer than when the system had no power before. Could it be that the POST might be skipped? Is it possible that in the POST the network card is influenced in any way?
The laptop has a system diagnostics (HP PC Hardware Diagnostics UEFI Version When i select component tests and then wireless module test it shows that no module is installed. So there is something wrong with the card even before I boot up the os.