HP Z620 workstation bootblock update

I have a first generation z620 unit.
I just bought 2 v2 CPUs which will not boot on the old mobo
Bootblock date is somewhere in 2011
I need to update it to the (at least) 2015 version of it for the new CPUs to work

I need some info as to how/where can I find the updated bootblock in the bios image that can be downloaded from HP site.
If there is no such bootblock info in the downloadable BIOS image, where can I get it from ?

If I was to get it from another HP z620 machine, how/what software could I use to make a full copy of the BIOS ?

All help is greatly appreciated


I am also looking for flash option for modded Z210 bios with no success.

Maybe here

The new 2013 bootblock date which allows for Xeon E5 v2 to boot is included in any of the latest bios images from HP e.g. 3.91 or 3.92
The problem is that the HP has locked writing to the boot block from the factory as a safety feature, so that if the bios would get corrupted in theory you could still recover using boot block recovery. The consequence of this is that when updating using the official HP tools or from the bios the bootblock section does not get written / updated and in effect you are stuck with the old 2011 bootblock date.
TO update the bootblock you need an external SPI programmer. Use the .bin image from the HP file and just flash to the chip. You can try using a chip clip - its a SOP16W type chip, or desolder the bios chip for flashing.

Where can I buy a chip clip from ?
Could you please provide a link ?


Something like this: https://www.aliexpress.com/item/SOP16-TO…iceBeautifyAB=0
Keywords: SOIC / SOP16 300mil or SOP16W (Wide)
Just bear in mind that the cheap Chinese ones are not the most reliable ones - Pomona is generally regarded as one of the better brands.
You also need a programmer - cheap CH341A e,g, the black / gold one on ebay will do fine.
Use the ROM / BIN file from inside the SP package for flashing. You may also need to provide external 3.3 V power to the board - programmer has enough to flash the chip but since chip is connected to board it may be the case that the board will be drawing power from the programmer.

I try to flash modded bios on Z620 and Z820.
Would you mind helping me with instructions?

have you updated the bootblock?
I would like to do same thing for Z620.

Finally I did order another BIOS chip from http://www.bios-chip24.com/HP-Z620-708615-001-Workstation/en and I had it swapped.
It worked perfectly only the hardware MAC address for one of the network cards was not the correct one.

I did not give a try to Intel ME so I do not know if it works or not

I still have the original BIOS chip and I am thinking about having it altered and re-soldered back.

By the way, is there a way to insert a NVME module in this BIOS ?

@danny76 - upload a FPT dump of the BIOS or BIOS region and I will NVME mod for you, and yes I checked another dump I already have here and it’s possible. If you have a programmer, dump the entire BIOS
To fix your MAC >> FPTw.exe -gbe -d gbe.bin and send me that, along with your proper MAC you want inserted (It usually goes at beginning of this file, but can also be in there twice, usually second time is at 1000h if it’s in there twice) Flashback via >> FPTw.exe -gbe -f gbe.bin

@pcuser1 - if you need updated microcodes, send me a FPT dump of your BIOS region (Use FPT From ME System Tools V8 package) >> FPTw.exe -bios -d biosreg.bin

Let me know if I did understand it correctly:

- chip BIOS 1 (original one that did not support Xeon E5 v2 cpus) - is now unsoldered from the mobo and is being kept in a bag, and not connected to the PC
- chip BIOS 2 (now soldered to the mobo) - the one bought online from the link that I provided above, does not have the proper MAC address

None of those BIOSes has support for NVMe

1. However, it needs to have the new bootblock in order to accept Xeon E5 v2 cpus
2. as far as I was able ton understand it might also need some new Intel ME - it is totally unclear to me

On the computer now there is running Windows 10 pro

I can obtain the entire info from BIOS 1 (i have a friend who has reader/programmer)
Is there something I should do with the second BIOS chip - the one running the PC ?


@danny76 - so sorry I missed your reply and this thread until now! Someone linked me to it in a PM, so now I see your post above

Please send me FPT Dump of your BIOS region and I will make you NVME Mod BIOS. Or full programmer dump if you want, either way is OK. It may be easier for you to program back mod BIOS with programmer, maybe he can come do that for you once we’re ready.
If you need MAC fixed, I gave you how-to above at post #10. Intel ME, we deal with once we are done, you can update that with Intel ME FW update tool.
If you need the boot block updated for E5 v2 CPU’s, you need to dump BIOS with programmer and write it back with programmer (or do pinmod and short some pins while starting the board, if you want info about that let me know)

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64
Then on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder.
Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error >> FPTw.exe -bios -f biosreg.bin
If you do get error, show me image of the command entered and the error given
^^ This is important step, don’t forget ^^

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required

Some ME FW of Z620 mobos was 7,I just wanna update it to 8.
Unfortunately,we can’t update it by official method.


And I see the location of it was 005000——50FFFF,and could I just replace it with the latest official bios which ME FW is 8.

I had tried but failed.It didn’t seems too easy to transplant the ME.