HP z820 - Adding NVME

I’m trying to add NVME into my BIOS. It’s an HP z820.
I downloaded a copy of the bios I’m currently running form the HP site - J63_0395.bin
Opened this in UEFITool - 0.26.0
Inserted the NVME ffs - NvmExpressDxe_4.ffs
All SEEMS to be added properly.

When I go to Flash ROM on the computer itself I can see the .bin file (I kept it the same name).
the flashing takes approx half a second and immediately says Flash successful.
I reboot and nothing seems to have actually changed/loaded.

I look at the created file in UEFItool and I can see the new entry. But nothing seems to make the PC actually install this new modded BIOS. do I have to change a checksum value somewhere so it will actually think this file is different perhaps?

Also when I open UEFITool and load the BIOS there is immediately a message “parseFile: invalid data checksum 5Ah, should be AAh”

@tstuart - It’s a signed BIOS, you can’t flash with the stock tools in the way you mentioned, that’s why nothing happens.
Although, you may have better luck if you try it with the included DOS tools (DOSFlash.exe), if you do and you get an error on screen, show me the error and maybe I can edit the flasher for you.

That checksum is normal, you can ignore it.

Look over your board in person (not the manual) and see if you can find a 2 or 3 pin header that says FD, FDO, ME, Service, Manage etc. If you have this, then life will be easy, if not, you may need to purchase a flash programmer (CH341A) + SOIC8 test clip with cable.

Please also do the following - Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc) - Stock BIOS contains V8.1 for your info, but this may not be what is in the board right now, so do check to be sure
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error given >> FPTw.exe -bios -f biosreg.bin

FDO is unuseful I think for the flashing process in this mobo.
And I tried it by FPT,and set the "Me FW Image Re-Flash",but it still showed error 28.
After using the "prr"or "prr2",error 28 was still alive.

So SPI programmer is your right choice.

This system has a FDO jumper? If yes, put that on, dump FD and unlock it, program it back, then remove jumper, reboot twice and then dump regions one by one and try to write back one by one, see what’s actually locked or not.

MOBO: HP 800g1dm
I had put the FDO jumper on,but I had some question.
1.How to dump FD?Is the order that “FPT -desc -d fd.bin”?
2.And how to unlock it when I dump the fd.bin?Do I need to mod the fd.bin?And how to mod it if so?
Edit:Is that refer to the chapter B of the link? [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing
3.How to program it back?Is the order that "FPT -desc -f fdmod.bin"


I had done all you said.The fdmod.bin was flashed into the mobo successfully.


But it still prompted error 28 when I flashed the bios region.
Even I had used the prr or prr2.BTW I will show you the pic after using prr2.


@gloobox - this is the issue, you always reply in some thread with an issue/question/problem, and then later say your board/system is different than the one being discussed in the thread. That’s all very confusing, for me, for you I’m sure, and definitely for other users.
I know you will probably always do that, since it’s your style Please, from now on, mention the board/system you are talking about when you jump into a thread someone else started, so we know if you really are talking about their same system or not (like your above question, info, reply, all unrelated to the OP’s system / different model)

1. Yes >> Then edit >> Then FPT -desc -f FDMod.bin
2. See this, the main FD Unlock thread Section B, spoiler two, image one or two (depends on BIOS type, you will recognize which when you look at image vs FD File. So yes, as you edited in
3. See #1

PRR/PRR2 is not used if FD is unlocked. Maybe you did incorrect edit? Or, it’s also possible, some BIOS have a FPRR/PRR lock in a BIOS module itself (PCHInitDXE, or Powermanagement, or Powermanagement2)
Send me your FD edited BIOS, I will check the FD edit was done OK and also check and edit if so the other FPRR/PRR lock in above mentioned modules if I can find it. If I do, I will show you where it is, how to edit etc

Sorry I’ll pay attention next time
OK,I’ll upload the bios of the HP 800g1dm.
It contains the full bios and fd region dumped.

It’s OK, I was laughing when I wrote that, it’s funny to me how you always do that

BTW - this is the kind of edit I mean - https://www.insanelymac.com/forum/topic/…comment=1944166
And I think I find in your BIOS (Stock or other dump I checked while I waited on your reply). So I will use your BIOS now, and make 2-3 BIOS for you to test. Put each one on with programmer, then load optimal, then test FPT flash
I will edit those BIOS into this post, so refresh/watch for edit in about 5-10- minutes

* Edit 1 - Did you just dump this BIOS after you unlocked FD? If yes, that is problem, your FD is not unlocked in this full BIOS (NVME one). But, I checked your FD only dumps, and that looks correct, so probably this NVME Mod BIOS was not dumped after FD unlock edit you did.
I see you have SMI Lock still enabled too, this will give you error 280 once FPRR lock is removed. I’ll fix this for you too. BIOS Lock was also still enabled at AMITSE/Setupdata (what AMIBCP changes, some BIOS use this only, instead of setup)

The full bios was dumped just after I put on the FDO jumper.
Should I dumped the full bios after unlocking the FD and mod & flash it ?

And I found the FD region would recover when I remove the FDO jumper.
I had flashed the FD region,and after I dumped the full bios again(contains the unlocked FD region),and modded it and flashed it,but I still found the error 28 unluckily.

FDO Jumper has nothing to do with BIOS contents. If you want full BIOS with FD unlocked on it, you need to dump it again (Since you flashed in unlocked FD after your previous dump)
That way, dump now, will have your unlocked FD in it as a base FD Unlocked BIOS. I noticed several areas (Aside from NVRAM) with BIOS lock and SMI lock both still enabled (At setup & AMITSE/Setupdata), so I am unlocking all those for you and in NVRAM too.
I will send stock/mod modules, so you can compare and see the edits. I will make this BIOS separate, as a unlocked BIOS, aside from the 3 possible internal FPRR unlock edits I want you to try

So first, program in the unlocked BIOS without FPRR test edits, and then try FPT flash and see if you still get error 28. If you do, then on to next test @ 3 FPRR edit tests.

Still working, NVRAM tedious to make out my edit notes/info before I make the actual edit, will be little longer.

To your edit, yes, FD unlocked is unrelated to error 28 FPRR/PRR lock - this is always either a BIOS setting itself, or can be contained within a BIOS module without having an actual BIOS setting to control it (your BIOS has this)

Hmmmmm… No NVRAM!?? Did you recover/fix this BIOS with stock BIOS ever? If yes, I think you lost all NVRAM, I don’t see any NVRAM volume, except stock internal one. I will check some other dumps, more time to wait, sorry. * Edit - seems only this internal one used on this model, BIOS coming soon now

* Edit - @gloobox - Please first test main BIOS (modNVMEFDBLSMINV.bin) outside of the FPRR folder, program it in, boot to BIOS, load optimized, boot to windows and test FPT flash (Or DOS)
If still error 28 OK, onto BIOS in FPRR-PRR test folder If other error, also onto FPRR-PRR test BIOS, but let me know the error if gives you.

In FPRR folder, test in this order, same as above, program in, load optimized, boot to windows/DOS and see if error 28 gone.
No need for PRR/PRR2 tool here, we are trying to go around that and it’s already failed for you, so don’t waste more time messing with that.
1. 74EB.bin
2. 90E9.bin
3. 74EB90E9.bin


BTW, did you already test if BIOS has S3 sleep bug yet? If not, test now, with any BIOS on there, put system to sleep (S3 not hibernate) and then wait one minute, wake system up then try FPT Flash from windows without reboot.

I tried the 4 bioses,but it still prompted error 28.
Sleep bug was tested for long ago but failed too.
But thanks a lot for your work anyway!!!

@gloobox - So error 28 on all four?? That wasn’t expected, I assumed some new error, or messed up BIOS etc No bricked BIOS on any of the FPRR/PRR test BIOS?
Sorry, I can’t find any other places this is locked, one of those in folder should have got it I hoped, I’ve removed it before in several BIOS but layout of the coded assembly is never the same so hard to tell sometimes.
Maybe @Outsyde can take a look and see if he can find it, he seems far more knowledgeable about this kind of edit than I am.

@Outsyde - can you please download package above at post #10, and use modNVMEFDBLSMINV.bin and see if you can remove FPRR/PRR Lock.
I thought I got it in the FPRR/PRR folder edited BIOS, but seems not (PCHInitDXE was only place I noticed it, but maybe I did the edits wrong for this BIOS?
Thanks hope you have a second to spare, and can get it disabled! * Edit, I just noticed I left off the @ before your name, meant for you to get this tag on the 19th

Any one got solution to make MOD and reflash it to BIOS?
Get NVME module from z840 and insert to latest BIOS z820…

P.S. I also have CH341A Burner Chip USB Programmer

hello, does anyone have a bios with nvme support for z820? V 3.94 or 3.96 ?
please visit this thread about this (i can’t post links, so remove the space)

bios-mods .com/forum/Thread-HP-Z820-NVMe-Support

I have been trying to implement this approach to make it work on Z820.
I used MMTool to insert the latest nvme ffs - NvmExpressDxe_5.ffs into the J63_039(4/6).bin in DosFlash directory of the Bios Version 3.94 and 3.96. They are both successfully flashed with FreeDOS boot USB. Since the system was upgraded to 3.96, the 3.94 mod can be flashed upon unplug the Password Jumper on the board.
Next, the Windows 11 is installed into SM951 NVMe SSD (same as others, i.e., 970 *). The system cannot find system boot device after successful installation. Same results as I used the older version of NVMEpressDXE_*ffs.
So, Please try it out with the bios-mod attached. Please help solve the issue. BTW, all SSD AHCI such as sm951 ahci, as well as PM963 // 950 Pro // work fine!
Download the bios_mod “Z820bios394&6.rar” here : <https://mega.nz/file/uElGzJzI#S_ftLOKhaWTN-HT8KUiCRe_y8ldyaorcjtkVwV4SMow>