I lost my network card after updating MEI

Yesterday I tried to do the MEI firmware update which in my sabertooth x79 was in version 7.1 and I tried in every way update to 8.1 the problem is that I did not understand and looking in google I found a program called fptw64 I did the nonsense to use without read nothing on. Resolved after using this software with the 8.1 firmware I restarted my computer and the same did not call anymore it was turned on and off without letting me do anything. So I did the flshback to the original 4701 BIOS and the computer was reconnected and to my surprise I had upgraded the MEI to 8.1 in the BIOS. But entering Windows my network card lost its name is no longer recognized as intel. I tried reinstalling the driver and until the drive says it can not find intel network card. And now what can I do to recover my network card?

The latest BIOS from ASUS already had ME 8 firmware so why did you mess with it? Make sure you have read/write access to the ME region of the SPI/BIOS chip by following [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing. Then use UEFITool to remove the AMI Capsule Header from the ASUS .cap image and flash the 8MB output via “fptw -f SABERTOOTH-X79-ASUS-4801.bin” followed by “fptw -greset”.

Thanks for replying I’m a little anxious because being without a network is sad. But come on, I did the tests and in the beginning this SPI / BIOS was unlocked. As for the second part you ask to take the AMI capsule, I’m very dumb in that part and I do not know how to do it, I’m sorry for that. I started playing MEI because, for some reason, I was with bios 4701 and my MEI was 7.1, so that’s where I got into that misfortune.

Note: I’m sorry for bad English and mistakes. I’m from Brazil and I do not speak English and I’m using google translator.

Download UEFITool, drag & drop the ASUS .cap image at it and then right click at AMI Aptio Capsule > “Extract body…” and save the .rom file somewhere. Download ME System Tools v8 from Intel Management Engine: Drivers, Firmware & System Tools. Then run Flash Programming Tool with command “fptw -f Capsule_Aptio_signed_AMI_Aptio_capsule_body.rom” followed by “fptw -greset”. After the reboot, the system should be working properly. Verify by running MEInfo and MEManuf as explained at Intel Management Engine: Drivers, Firmware & System Tools.



After reading several times I understood what you said and did the extraction. I will put 2 photos of the process after the flash.

IMG_20180925_142453.jpg

IMG_20180925_142507.jpg



Dude, I did not see you responding and I did and I ended up doing it wrong. The machine will not turn on.

First of all don’t call me “dude”. Secondly, I do not have to respond at all, let alone immediately after your reply. You need to respect the time of those who help you as a hobby and for free. Thirdly, you obviously did not follow the instructions at all and ended up bricking your firmware since you flashed the .cap file directly. If you cannot understand and/or follow basic instructions then you should find someone who can.



Please forgive me. It was not my intention. At no point did I want to blame anyone. It’s my fault and you’re right. I’m sorry if for some reason it seemed to me that you were pressured, it was not my intention, maybe something mistranslated by google translator. I’m so grateful you’re trying to help me.



I was able to solve by replacing the BIOS chip with another sabertooth x79 burned. Good luck the chip is good. At first, everything went back to normal, but when checking the BIOS, the ME version is like N / A. What is the correct way to install MEI?

IMG_20180925_155710.jpg

To repair the firmware now, things are a lot more difficult. Thankfully your motherboard has a socketed/removable SPI/BIOS chip so you only need to buy a cheap SPI/BIOS chip programmer like the CH341A and re-flash it manually. @Lost_N_BIOS knows more about the different CH341A versions and can give you different software for it so I’ll let him help you on this task if he wants. No matter what, it will take time until you order and receive the programmer as well to re-flash the SPI/BIOS chip so you won’t be able to use that system in the meantime.

EDIT: Alright, good. You have a 2nd identical (I hope) board so you can transfer its SPI/BIOS chip over. So the programmer is not needed, a huge time saver. That means that you can try again, but this time make sure you follow the steps very very carefully. Before you flash something with fpt, compress & attach it here to verify that you followed the steps properly and avoid another bricked SPI/BIOS chip firmware.



I understand. How much of the BIOS chip I took has nothing to do? Should I have to re-record this chip with this equipment too?

I don’t understand the question, probably due to google translation messing up vital words. As far as I can tell, you transferred the SPI/BIOS chip from another ASUS X79 Sabertooth. There are two options here:

1) You leave the transferred SPI/BIOS chip at the new motherboard (because the other motherboard is dead for example) and follow the instructions of post #4 again (properly this time!). That way, you will re-flash the stock ASUS BIOS at the chip and have a working system.

2) If you want to transfer the currently used SPI/BIOS chip back to its original X79 Sabertooth once you are done fixing the one you bricked, you can do the “hot-swap” method. Basically, you boot the 2nd motherboard with the 1st motherboards’s SPI/BIOS chip and once it has booted into Windows, replace the SPI/BIOS chip with the other one so that you can re-flash it by following the instructions of post #4 again and un-brick it.

No matter what you choose, before you flash something with fpt, remember to first compress & attach it here for me to verify that you followed the steps properly and avoid another bricked SPI/BIOS chip firmware.



Yes I have 2 sabertooth x79 one in use and another burnt out. I’ll follow everything right this time, after all I can not go wrong because I have no more chips and I would run out of machines. You mean I can remove the chip with my computer on and working? In that case, to fix the bad chip, will not I need to buy a tape recorder? If so, that’s great news.

For your case, you can do #1. Alternatively, you may do #2 only if you want to fix the recently bricked SPI chip and end up with two working SPI chips. In such case, you can restore from future bad flashes as well by hot-swapping them each time. And yes, you can remove the SPI chip while the system is running (after it has booted of course) and replace it with another one in order to re-flash that one. But if this is too difficult for you then just follow #1.



Following in the footsteps all went well, my friend. Now version 8.1 appears on the bios and the network card is working, but has the number 2 next to the name of the board that you know why? Is it with 8.1.52 know the latest firmware for my motherboard? And how to update the firmware without causing problems?

Note: Many thanks for the step by step I was very happy to solve the problem. Without your help I would not be able to solve it.

IMG_20180925_171209.jpg

IMG_20180925_171321.jpg

The #2 next to the name has to do with Windows device naming and it is ok, ignore it. The latest firmware for your system is 8.1.70.1590 1.5MB which can be found at Intel Management Engine: Drivers, Firmware & System Tools. You use FWUpdate tool with the command “FWUpdLcl -f 8.1.70.1590_1.5MB_PRD_RGN.bin”, as explained there. After a restart, the system should have the latest ME firmware and be healthy as verified by MEInfo and MEManuf tools.



Okay, in case I format Windows this # 2 will disappear? In the folder has FWUpdLcl and the FWUpdLcl64 my windows are the 7 64bits which one to use? I know it has nothing to do with what we are talking about but is it worth to modify a BIOS to update efi marvell and the network card?


No you don’t need to format. If you desperately need to remove the #2 then just show the hidden devices in Device Manager and remove its old copy. Seriously, that is useless, ignore it.


Obviously if your OS is 64-bit then you can use FWUpdLcl64 but the 32-bit one will work just as fine.


This is off-topic so you should ask elsewhere. Unless you use LAN PXE or you have something connected to the Marvell controller then no, leave them as they are.

As for # 2 not nothing desperate just doubts. I asked why I downloaded a package that only had FWUpdLcl and it had worked I did not even know I had FWUpdLcl64 so I was in doubt. And I realized that the modified BIOS was unnecessary for me. I use the 6g intel and asmedia but I did not find how to update the firmware asmedia and in bios nothing modified does not appear anything on asmedia.


Obs:I updated the ME firmware to 8.1.70.1590. I’m going to leave a print of the error it gave in MEManuf, I do not know if it’s bad.

1.jpg

2.jpg

@plutomaniac One thing that is noticed is that my MAC address is like 88.88.88.88.87.88. I have the original mac in the box have how to retrieve it? I do not know if it gets recorded in BIOS or network firmware.