iaStorA device not started

Hello Fernando,

If this is not the correct place to post this question please feel free to move to the correct thread.

So the other day I realized that my 100 series chipset driver v14.8.12.1059 had mistakenly been updated to what I think is the newest v15 series driver. After noticing I started looking into it, and saw the DM>Properties>Event log… has recorded that the iaStorA the device has not been started. Being as this is one of the main names for the Intel drivers I saw this to be a cause for concern. If this is normal please forgive me for this post. However, if this is not correct and something has gone wrong, I was wondering if you have any suggestions or information to get it corrected. I have attached an image of the events log that I’m referring to, as well as the properties>driver version. If you need any further information, or anything else, to help better give a solution, obviously I’d be happy to get you whenever you need to get this remedied. I’ve noticed that the computer doesn’t run bad or anything, but doesn’t quite have the same read/write speeds, and this could be my imagination, but slightly slower BIOS start-up . A quick google search did not give me anything of note to go on. I know that if anyone can help this issue, it would be you. Thanks in advance, and hope to hear from you soon.


Hope all is well,
Erik

Capture.PNG


Capture2.PNG

Questions:
1. Who updated the driver? Has it been you or was it automaticly done by Windows Update?
2. What lets you think, that the related system has an Intel 100-Series Chipset? The DeviceIDs of the 100-Series Chipset SATA AHCI Controllers are DEV_A102 or DEV_A103, but not DEV_9D03. I suspect, that your system has an Intel X99 Chipset.

Thanks for getting back to me Fernando.

I honestly thought it had that chipset, because I thought that is what you told me when I’ve listed my device ID’s for both systems(Latitude e7470 & XPS 15 9550)awhile back. I may have made a mistake. I’ll go back and look. I know that XPS says 100/230 chipset series.

I believe windows must have done it automatically with an update. After performing a clean install awhile back ago, I think I forgot to turn off the automatic update . I’ve since then turned off automatic update.

However if I have my latitude chipset incorrect then I must go back to your recommended drivers for the x99. Would you suggest downloading the recommended drivers for that chipset and trying to install them manually? Or do you think I should confirm the chipset and then go from there? Is there something wrong with the driver installed as a whole, being as the iaStorA device is being listed as "Not Started"

I have attached two images of the event log, one with the (iaStorA) highlighted, and the other with (iaahcic.inf) so you can see the notes, and information.

As always I appreciate your time,

Erik

Capture3.PNG

Capture4.PNG

Hey I just looked back on the post when I gave you my 2 devices Hardware ID’s. One thing I noticed immediately was that when I posted those ID’s I had my Latitude in RAID mode. After preforming a clean install to get rid of some unwanted bloatware I switched to ACHI since I saw no reason to run RAID when there is only 1 active storage slot in a e7470. Instead of making another post I figured…(thinking the e7470 was a intel 100 chipset) use the same recommended drivers that you listed for my XPS. It would come to workout though as those drivers v14.8.12.1059 seemed to work great. All as I know is since the update and whatever new driver I have going at this moment is not as smooth, and doesn’t perform as well either.
So whatever you think I should try, I willing to do. If you need me to post the hardware ID’s from the e7470 now that it is running in ACHI and there seems to be some confusion (at least on my end) on the actual chipset in this thing, let me know and Ill get them to you as fast as possible. If you can make a accurate judgement off the images I posted earlier then great.
Thanks for the fast reply…here is the original post of the chipsets, and how I got confused.


Thanks a lot,

Erik

Ok so I just tried updating the XPS to the newest ACHI driver v15.2.10.1044.

Its looking like every time I install a driver after the Original Intel driver I install manually, it reverts back to installing the Devices MS Driver. I’m starting to notice things. Like I knew that something was going to go wrong as soon as I installed v15.2.10.1044. Due to the time it took. Typically when I perform the first manual install of Intel’s driver it takes all of 2 to 3 seconds. Anytime that it take 30 seconds I doesn’t start the iaStorA and puts in the:
'aahcic.inf_amd64_b5208b4b05626800\iaahcic.inf for Device Instance ID PCI\VEN_8086&DEV_A103&SUBSYS_06E41028&REV_31\3&11583659&0&B8 with the following status: 0x0.'

Now I wouldn’t care very much but the performance of the computer suffers, and it is noticeable(not just through benchmarks). I tried rolling back the driver immediately, but same thing…Now the iaStorA will not start. Do you have any idea what may be causing this, and is there a solution to it. I really would like to avoid having to do 2 clean installs if possible. Plus since I just did 2 clean installs, id like to get to the bottom of the problem, so I’m not condemned to 1 new driver install.

Any info you might need I can get you. Its very irritating. I have uploaded images on the other posts of the e7470. Basically the same stuff now on the XPS.

Thanks,

Erik

@sealovererik :
To be able to help you, I need the following informations:
1. Which are the exact names of the Intel SATA Controllers, which are listed within the "IDE ATA/ATAPI Controllers" and "Storage Controllers" sections of the Device Manager?
2. Which HardwareIDs do the listed Intel SATA Controllers have?
3. Which driver version was your Intel SATA Controller running, before you mananually updated it?
4. How did you update the driver?l

Thanks for the reply Fernando.

I’ll get those for you this afternoon. It’s frustrating. Since the 18th I’ve been trying to figure it out on the latitude e7470, then it happened on XPS. I’ve exhausted everything I can think of. I appreciate the help, I will return the favor.

Thanks,
Erik

Hello!

So I got extremely busy yesterday, so I didn’t get a chance to get you those information’s you asked about. Luckily I got off at a decent time today. So here is the following Info you asked for. To save space and make it as easy as possible, ill try to keep them in order that you asked. The following is for the XPS 15 9550. This the latest machine I had the problem on. Before the manual update It was running the ACHI driver v15.2.0.1020 ; Dated 9/13/2016.

1.)a.}Which are the exact names of the Intel SATA Controllers, which are listed within the “IDE ATA/ATAPI” Controllers"?: Answer---->“Intel(R) 100 Series/C230 Chipset Family SATA AHCI Controller”
[driver v15.2.10.1044(current)Dated 1/13/2017]
b.}Which are the exact names of the “Storage Controller”?: Answer----->“Samsung NVMe Controller” [driver v2.1.0.1611 Dated12/8/2016] …>also in expanded set is “Microsoft Storage Spaces Controller"

2.) Which HardwareIDs do the listed Intel SATA Controllers have? Answer below: b.) In case you needed the HardwareIDs fir the “storage Controllers” section ill list them below as well.
IDE ATA/ATAPI Controllers” HERE: PCI\VEN_8086&DEV_A103&SUBSYS_06E41028&REV_31
PCI\VEN_8086&DEV_A103&SUBSYS_06E41028 PCI\VEN_8086&DEV_A103&CC_01060
PCI\VEN_8086&DEV_A103&CC_0106

“Storage Controllers” HERE:
PCI\VEN_144D&DEV_A802&SUBSYS_A801144D&REV_01
PCI\VEN_144D&DEV_A802&SUBSYS_A801144D
PCI\VEN_144D&DEV_A802&CC_010802
PCI\VEN_144D&DEV_A802&CC_0108


3.)Which driver version was your Intel SATA Controller running, before you manually updated it? Answer-----> As stated above the driver before the manual update was Driver {v15.2.10.1020}.
4.)How did you update the driver? Answer-------> In the following exact steps…
a.)Downloaded the pure driver from “The greatest site to exist” Win-RAID.com :slight_smile:
b.)Extracted Download
c.)Went to Device Manager>IDE ATA/ATAPI controllers>Drivers>Update driver>Browse from my computer>Download Location>Update Driver

That is it. I think I’ve answered the questions that you asked. As far as the steps to update those are the only steps I took. I didn’t uninstall the v15.2.10.1020 before going to v15.2.10.1044.
Its very weird. The Intel driver is listed as the driver, however when looking into the events log, it shows there was a problem and has the name of the listed driver that it has to start instead. Which is the MS driver. There is a few more details in the main “Event Viewer” However, it is stuff that I don’t “understand” If you need any of that I can get it for you. I’ve attached the smaller “event log” from the properties of the “IDE ATA/ATAPI” section. Thanks for the help and time you dedicate to the forum P.S. In the section about the device that “hasn’t started” I couldn’t fit in the second picture the very bottom sentence. It says under the “problem code” “problem Status” 0x0. Not sure that is relevant but wanted to add that.

DM_1.PNG

DM_2.PNG

DM_3.PNG

@sealovererik :
Thanks for having answered all my questions.
Tomorrow I will do a deeper look into your reported details.

@sealovererik :
Although having done a look into the details you had posted, I cannot find any severe mistake, which may have caused your problems.
Additional question:
Are it just the "Event Viewer" messages, which are making you nervous, or do you have real problems while running your OS? If it should be the latter, which sort of problems did/do you get?

Well I’m not sure I’d call them REAL problems. I mean, I can boot up fine and I haven’t got any BSOD. However, the problems I do get are the following:
1.) I’ve noticed that sometimes when running video, or my tasks that the computer freezes up, where as before the update it did not, during those same tasks.
2.) I’ve noticed big decrease(1000+) in write speeds, as well as minor decrease in read speeds.

Those are the only 2 things of note that I’ve experienced so far. The troubling thing is when I roll back the driver to the previous version…Again it takes 30 seconds to install and it has the same error message of “iaStorA Not Started” Then It says it installs the same thing that I sent you the:
"Driver Management concluded the process to install driver iaahcic.inf_amd64_05410270c68b19ff\iaahcic.inf for Device Instance ID PCI\VEN_8086&DEV_A103&SUBSYS_06E41028&REV_31\3&11583659&0&B8 with the following status: 0x0."

I suppose that if you weren’t able to notice anything that looks off, I can try to roll back to a version in the v14 or to even the v13 since they worked out to give you the best performance and I believe stability. Just to see if my benchmark performance goes back up. Which isn’t really THAT important to me. I more so just don’t like the freezing up. Obviously id like to have great read/write speeds due to transferring a lot of gb’s. I just think the benchmarks would be the fastest way to tell if maybe it just happens with these newer v15 series, or that its a problem with any driver I try to install now. I really wish I knew what all that stuff in the “event Viewer” means. For all I know it might not even be that, that is causing the issues.
Last question…When installing a new driver the steps I gave you are the correct method right? I don’t have to uninstall anything, or make sure I have something Installed, or running nothing like that correct?

Yes, I recommend to roll back as first step to the OS in-box generic MS AHCI driver.
This is the way to do it:

  1. Open the Device Manager and expand the section “IDE ATA/ATAPI Controllers”.
  2. Right-click onto the listed Intel SATA AHCI Controller and choose the options “Update Driver Software” > “Browse my Computer” > “Let me pick…”. Make sure, that the box “Show compatible Devices” is checked.
  3. Choose the listed “Standard SATA AHCI Controller” and click ointo “Conbtinue”.
  4. After the next reboot your on-board Intel SATA AHCI Controller will use the generic MS AHCI driver named STORAHCI.SYS (Win8/10) resp. MSAHCI.SYS (Win7).
  5. Now you can check, whether your problems (listed within the “Event Viewer”) are gone or not.
  6. As next step you can try to replace the MS AHCI driver by an Intel AHCI driver version of your choice.

Yes, if you just install the "pure" driver by replacing a previously used driver from within the "Device Manager", there is no need to uninstall anything.
Just right-click onto the listed SATA AHCI Controller and choose the options "Update Driver Software" > Browse my Computer…".
After having navigated to the driver of your choice, you will be able to get it installed (provided, that the driver is WHQL certified and newer/more specific than the currently used one.)
If you should get the message, that your system is already using the "best" driver, you may have to force the installation of your desired driver by using the option "Let me pick…" and hitting the "Have Disk" button.

Thanks Fernando.

As always I appreciate the support greatly. Ill get back to you in a couple days and let you know the results. I did have 1 more questions. You don’t believe this has anything to do with the rogue iaStorF that gets stuck in the computers registry do you? I only ask because…after doing some more research on the internet I read something in Intel’s support about a iaStorF that never deletes, then causes problems within your computer with slow downs, loss of performance and freezes. I really didn’t get to grasp the main reason for which that issue can happen to diagnose if that is a possible reason for my issues. So I thought id ask you to see if you know of it and if that is something I should look into trying to fix/workaround, or just clean install win10.

Thanks Friend & Cheers from the USA

Erik

The file named iaStorF.sys is the SCSI filter driver, which accompanies the real Intel AHCI/RAID driver named iaStorA.sys within all Intel RST(e) driver sets from v11.5 up.
But there is nothing to worry about the SCSI Filter driver iaStorF.sys, if you are running Win10. Win10 neither needs nor installs the SCSI Filter driver. So there are no iaStorF.sys residues after having replaced any Intel RST(e) driver by another version.