ICC Overclocking Library

Hello. I have questions about failure to load ICC Overclocking Library in BIOS. Does anyone know how to fix this?
I don’t see any problems with ME. BIOS showes right version of ME.
I can enter this menu after pressing OK, but if I enter to Clock1…Clock8 my laptop freezes.
MB: Clevo W67xSFQ Series (W670SFQ), HM86
Intel i7 4700MQ + Nvidia GT840M





Please link to the BIOS you are using, stock one from manufacturer (They’re link please). Also, did you modify the BIOS you are using now?
This is not normally a BIOS setting visible to user, is why I ask.

Lost_N_BIOS, yes, I modified BIOS and upgraded ME. But with stock BIOS (only with opened options by AMIBCP) and stock ME I had the same problem.
Stock BIOS (1.03.04)
Modded BIOS attached

moddedBIOS.zip (1.93 MB)

@AtomZ - Please clarify, with stock BIOS, in BIOS could you see ICC options, or not? If not, this is what you enabled with AMIBCP correct? I didn’t check yet.
If you did enable view of ICC via AMIBCP, did you also test this change only without ME FW update? How did you update ME FW, manually and reflashed it via BIOS flash or FPT etc, or did you update ME FW with ME FW update tool?

I checked BIOS now… Ohh!! WOW!! That is WAY too many things set to USER, this is not proper way to modify a BIOS Do you still need help making chipset or anything visible? * Never mind, I see you found chipset @ Magic String Edit

The issue here is ME FW has only one “Standard” ICC profile (#0), no “Overclocking” profile. So, this means nothing for you to change in this profile.
You need to modify ME FW and add Overclocking profile, set it up how you want, and then reflash ME FW with that, then you should be able to enter those in BIOS.

Thanks for answer!
With stock BIOS I can`t see ICC options. Yes, opened with AMIBCP. Yeah, I tested this options without ME FW update too, and they did not work too. ME FW was updated by FPT in Windows.

Heh, I set all options to USER :slight_smile: to see all things. I made Chipset visible too, and removed block for flasing SPD.

Hmm, could You help me with ME FW modifying? What I should to do.

@AtomZ - ME FW Update by FPT?? Did you clean and transfer settings in ME FW with Intel FITc tool first, before you flashed it with FPT? If not, then this is one of the issues, aside from what I mentioned above
I need your original ME FW before you updated it, hopefully you still have a copy, if not, then nothing we can do until you find some users dump of exact same model. Unless, in the folder you sent me (Clevo W670SFQ\B0304) << is that 6MB file stock, ME FW untouched by you?

@Lost_N_BIOS , yes, that 6mb file has original ME FW

@AtomZ - thanks, but you did ignore the most important question there
I will make you ME FW to use, please wait. And, I can’t make any promises it will work any better/differently, since I do not have any other ME FW to use as base that already has OC profiles in it.

@Lost_N_BIOS , yes, updated with FPT in Windows, but didn’t clean and transfer settings in ME FW with Intel FITc tool first :frowning:
I also can do a dump from same motherboard, if needed

Second part of your answer was what I asked, I assumed you used FPT since you already said that You can’t just flash stock ME FW, lucky you didn’t brick anything! The ONLY time you don’t have to do that is if you use ME FW update tool (FWUpdLcl)
You have to do the settings transfer from stock ME FW to the updated version using Intel FITc before you flash it in, otherwise you can mess up a bunch of stuff, possibly the stuff you are having issue with now too
At least it didn’t brick on you, that’s the good thing here! No dump needed, the settings are in stock BIOS. Let me make you a properly updated ME FW first before I do any editing of it, then you flash that in and test.

Here, flash via FPT >> FPTw.exe -me -f me.bin
Then, before you reboot run this command (be ready for automatic reboot here) >> FPTw.exe -greset

If the system does not automatically reboot on that -greset command above, shut down, pull the power cable out, remove main battery, press and hold the power on button for 10 seconds, then let sit without any power for 1+ minute
Then enter BIOS, load optimal defaults, save and reboot back to BIOS, then check things out.

If that doesn’t change anything OK, at least now your ME FW is updated correctly.
I can then send you new ME FW with OC profile as default, but if your hardware doesn’t support that then nothing will be possible anyway, and it may brick device (only suggested to test this if you have flash programmer in hand, full backup made, and you’re ready to recover with programmer if necessary)

@Lost_N_BIOS , oh sorry, I made mistake… I updated ME FW with FWUpdLcl64 (not FPT). Very sorry. Is it another way, or I should flash your ME.bin ?

@AtomZ - You’re all set then, since you updated ME FW with FWUpdLcl64 and not with FPT, then all your original ME Settings would be retained (ie no need to use the file I provided, unless you didn’t update to latest version previously)

Here is two ME FW for you to test, flash either with FWUpdLcl64 and then reboot and load optimal BIOS defaults and save, then reboot back to BIOS and check things out.
Softstrap file leaves the profile choice selected by the default BIOS method (via PCH softstrap), the BIOS one I changed that to profile choice selected by BIOS - both have OC Profile set as main and original moved to secondary position.
Neither may work due to your hardware, or due to it needs to be configured differently etc, of which I’m not sure how it should be configured as there is MANY settings in each profile.

Warning If this breaks ME FW, you may not be able to recover/fix ME FW without doing Pinmod See “E.1” to unlock FD and allow ME FW write via FPT, or with hardware flash programmer.

General comment here, normally if you want to change such things as you find in this ICC area, it’s done with other settings in the BIOS, not here, so it’s probably best you hide this and ignore it and use the other BIOS options for same type settings.

@Lost_N_BIOS , I need working ICC for turn off Spread Spectrum of BCLK. Because now I have 99.76Mhz BCLK.

Thank You, I will try it later today

You’re welcome! Spread Spectrum has nothing to do with ICC, nor is that setting in that area (which you can see with AMIBCP that you already know shows BIOS settings there)
The bclk thing you mentioned is due to two things, sometimes microcode can affect/cause that, and other times ME FW itself (version) can affect/cause that. The only way to get near 100 exact anymore is to try different microcodes and see if any affect this, if not then try different ME FW and see which works best for your BIOS.
If you had Bclk setting specifically in BIOS, even then you cannot get 100 exact anymore, due to how modern CPU’s work, it will always be 100.0x or more, or 99.xx, never 100 exact and never stays 100% exactly as set either.
You may be able to adjust bclk some in that area with the settings there, but I doubt you can do much unless this board has an off-chip Bclk controller IC which I doubt.

@Lost_N_BIOS , hmm, but DeathBringer (from overclockers(dot)com) showed, that if set 0% (default is 0.5%) for Spread Spectrum in Clock3 BCLK frequency will be higher.

In Clock Commander Tool I can see, that Spread Spectrum is 0.5%


@AtomZ - Then change it and see what happens. Be ready for recover as mentioned above at post #12 If DeathBringer is helping you, why didn’t he make you BIOS or at least ME FW with this changed already?
If you want, I can make you ME FW like above, but without OC profile changes (So you may still not be able to enter ICC in BIOS), but I can make the change you mentioned above.

*Edit - Here is that ME FW = Stock ME FW, updated w/ settings transferred + Change you mentioned above - http://s000.tinyupload.com/index.php?fil…781956123360050


@Lost_N_BIOS , oh thank You! But now new problem… With FPT I have write/read locked status.
Tried to flash with FWUpdLcl64, but it didn`t affected. ssc_percent left 0.5%.

You shouldn’t be using FPT to update ME FW. As mentioned, you better be ready for recovery in case something goes wrong
You are suppose to update ME FW with ME FW Update tool. If you did that, then it’s flashed in. To confirm you flashed it in, dump ME FW with FPT if you can and send to me (FPTw.exe -me -d mecheck.bin)

@Lost_N_BIOS , no, I can`t. Locked status. Clock Commander Tool shows, that ssc_percent is 0.5% after flashing with FWUpdLcl64.exe.

Also, I have CH341A programmer


OK, good you have programmer so you can recover! Send me programmer dump, I will unlock FD too if you want? If not, I will just check ME FW got updated with the changes you mentioned (and show you, so you see it’s there)
This may be due to BIOS settings say only 0.01 increments, and ME FW says 0.00 OK so I used that.