ICH10R & RST 13.2.4.1000 Single SSD TRIM Support

Hello i got a single SSd and two Hd in Raid 0 running on a ICH10R with RST 13-2-4-1000 Driver. My Problem is that it seems like TRI isn´t workig with the single ssd drive. The Driver that the ssd is using is iastorA.sys. Any suggestions ?

@ Voigoth:
Welcome at Win-RAID Forum!

Questions:

  1. Which Intel RAID ROM version is within your mainboard BIOS?
  2. Which OS are you running?
  3. How did you check the TRIM support?

Regards
Fernando

I am at work right now so i can just name the board i am using. I will look up the Rom Version later.

I got an ASUS P5QD Turbo.
I am running Windows 7 Ultimate 64 bit
I checked Trim Support with this tool -> http://files.thecybershadow.net/trimcheck/
And i am having a Western Digital SiliconEdge Blue SSD 64G

Thanks in advance.

If it should be an Intel RAID ROM of the MSM Series (v8.x.x.xxxx or lower), you cannot expect TRIM support at all.

Even if it is a single SSD ? As far as i have fund out in different Forums it is possible to have a single ssd + raid of any kind on a ICH10R Controller and get trim to work for the single ssd. I don´t neet trim for the raid 0 i have, just for the single ssd drive.

Yes, but an Intel RST RAID ROM is required.
The first Intel RST RAID ROM with TRIM support was v9.6.0.1014.

Ok, in case my Raid Rom is not supporting TRIM is it possible to Flash it to a Version that actaully is supporting Trim ?

Yes!

According to the latest 0301 BIOS (AMI v8):

RAID oROM: v8.7.0.1007
DEV_ID: 2822
Uncompressed Size: 79.5KB

So, if you find a v9 or v10 (v11 is larger around 116KB) oROM you can replace it with MMTool v3.26. For example v10.1.0.1008 is 85KB, maybe it will fit.

Ok, sounds fine. I think i will try and flash the Controller. How big are the chances that my raid0 will be recognized after the flash ?

If you update the Intel RAID ROM to v10.1.0.1008, the chances are very good.
If you should run into any problem with your RAID0 after having flashed the modded BIOS, you can easily repair it by reflashing the original BIOS.
That is why I recommend to prepare additionally an USB Flash drive containing the original BIOS.

I have successfully moded the bios and inserted the v10.1.0.1008 Raid Rom. Sadly TRIM is still not working with my SSD. I also changed the RSt Driver from 13.2.4.1000 to v11.2.0.1006 but still no Change. Something i have recognized is that under Hardware my ssd drive still got the iastorF.sys Driver. Shouldn´t it be changed to iastor.sys ?
Anyways Trim wasn´t working with None of the two Drivers after the bios-mod.
Any suggestions what i can do now ?

Are you sure, that your Western Digital SSD is supporting TRIM at all?
If yes, I recommend to replace the original Intel RAID ROM v10.1.0.1008 module of your BIOS by the “Universally TRIM modified” one with the same version. You can find it within the start post of >this< thread.

No, it is the real RAID driver named iaStorA.sys, which has been changed to iaStor.sys. The earlier used SCSI filter driver named iaStorF.sys is now useless and doesn’t have any function, but may be still running in the background and drop your performance (this is a bug of the Intel drivers uninstall software). You can get rid of the iaStorF and iaStorA residues by following >this< guide.

Good luck!

I found some pages that say that the Siliconedge blue ssd got an internal trim Thing, but i don´t know if this is the same. I changed the bios again and updated it with the universally trim modified Version. trimcheck still says that trim isn´t working. i am going nuts …

That is the "Garbage Collection" feature, but not TRIM.

Did you trigger TRIM before running the TrimCheck Tool (look >here<)?

I have looked up more informations about my SSD. Most pages say that it Supports TRIM, so i guess there is nothing wrong with the SSD itself.

I have installed Anvil Benchmark and have triggered TRIM bu still no change. Trimcheck still states that TRIM isn´t working. i have also rerun the Windows Experience Index (Leistungsindex in german)

Has anone on here ever tried to make TRIM work with ICH10R and the bios update i am using ? Or any other tips ?

You should try the manual TRIM test by using an Hex Editor (look >here<). With the manual TRIM test it is possible to detect low TRIM activities within the single or RAIDed SSDs.


I have ICH10R, and TRIM works in AHCI and RAID modes.
I am using now the modded 13.2.4.1000 drivers (to be able to install on ICH10R). My OptROM is 10.8.0.1303 - latest Dell BIOS.

What I did on my previous mobo that was not TRIM capable - I bought a cheap PCI-E SATA adapter with ASMedia 1061 chip.

Hi, i finally found the time to try out a TRIM check via HEX Editor. What can i say…it is still not working. I will try to get my Hands on a different SSD and try out if it works with that one…if not then i don´t know what to do. Weird is that all other Tools i have tried out say that my SSD is TRIM capable and that it is active. Windows also says TRIM is active. I got my Raid Rom updated to v10.1.0.1008 and my driver to 11.2.0.1006. Now it should work but it doesn´t.

It’s a pity, that none of the available methods is able to detect TRIM activity within your SSD.

This is a good idea. Please report here about the test result.