IDE mode enabled Asus X555LB BIOS

I modded my bios to get the IDE mode, the IDE Name shown in settings after modding but it starts with AHCI instead of IDE. Here is the 603 version of my bios:
NOTE: I’m modding it to install retro OSes.

How did you mod it? And, how are you sure AHCI is used not IDE?

I get 7B bsod on Windows XP installer.

Makes sense there, thanks! How are you editing? What did you do, with what app? And then, how did you flash the mod BIOS? Often AFU may appear to flash, but not really flash anything, especially if using mod BIOS and or some AFU that should not be used on this system/BIOS
But, maybe it is getting flashed, since you did see your change in BIOS after flash, correct?

I flashed with AFUDOS

AFUDOS ES or regular? And please confirm, after your edit did you see the IDE option in BIOS?
What did you edit it with, what version software, or manual etc, and how did you make the change (ie what did you change/set) Asking all this to confirm if you did correctly, thus my edit would be same or not etc

I have seen IDE option but when I Install Windows 7 on it, It recognises as ahci.

Please answer my questions so I can help. Did you see IDE option in BIOS after you modified it? If yes, what did you modify the BIOS with, and how (ie what did you set etc, what version software did you use, or if you did manually how did you edit)
Also, when you flash it, what flags /P /B etc are you using? And, did you load optimal defaults after you flashed? Are you sure you want 603 BIOS, not 605?

When I go to bios, I saw IDE mode. I modified the bios via hex editor. I changed the string that names ahci. Replaced as is with UEFITOOL. I used AFUDOS mod.rom /GAN command downloaded on website. I loaded my optimal defaults. I want 603 BIOS.

Thanks for answers finally So, you edited some random string that had AHCI in it via hex editor? Changing AHCI text to IDE text, in setup module I assume? If yes, that is all wrong, no wonder it does not work.
On your BIOS main page, at the bottom of the section, what do you see as “Access Level”? I will make you proper BIOS edit.

I see administrator.

Thanks. Please test, I removed original AHCI only setting option, and enabled new one with IDE/AHCI/RAID, if you can’t see either SATA control mode setting now, it’s OK, let me know and I will make additional edit (was unsure if needed on this or not, so for now left off)…726681333840250

* Edit - moving thread to proper forum, since this is not an “Already completed special BIOS”

I did this method but it was unsuccessful.
I hex-edited my bios. I changed the name AHCI to IDE but still doesn’t apply. Here is the bios file with hex-editing: (2.39 MB)

You need to give more details in your replies, I cannot read your mind. When you said >> I did this method but it was unsuccessful << What do you mean, you did what, and how was it not successful?

You cannot hex edit BIOS and change text name of AHCI to IDE, that will not help anything, you can change AHCI to "CottonCandy" Or "Banana" and it will say that, but does not change the setting itself that is enabled.

If you tried my mod BIOS and it failed, tell me how it failed, what you see in BIOS (and did you see IDE/AHCI/RAID Option or not), what happens at windows install, and I can try to mod again for you.
If you are trying this on a windows you already have installed, you need to do registry edit before you can switch from IDE/AHCI freely.
If you did not see change in BIOS at SATA mode, then you may need to be sure you use /P flag during your AFUDOS Flash >> AFUDOS /P /GAN
If SATA Mode missing totally in BIOS I sent you, let me know, this means I need to unsuppress the item I enabled.

Enable switch between all IDE/AHCI/RAID modes by changing "Start" Values in following keys to 0 in the registry


I saw IDE/AHCI/RAID option but when I install Windows, it automatically detects as ahci. I flashed with fptw but Windows detects as ahci.
Conclusion: You need to unsuppress this item.

If you can see the option I enabled (with IDE/ACHI/RAID) then it’s already unsuppressed or it wouldn’t be visible.
This may be locked by your NVRAM holding in AHCI as set default option. Please send me FPT BIOS region dump, while using the unlock BIOS I sent you flashed in, then i will change it all to IDE in all NVRAM areas, then you flash again by FPT

Here is the dump of the bios (I unlocked chipset setting): (2.39 MB)

@XPWELL64 - Is that a "DUMP" from your system, then you modified? If yes, please remove from the other thread or tell me to delete that post, no one else can use "Dump" from your system modified, only stock BIOS can be modified in that manner for use with other peoples systems.

Yes it is a dump.

Please flash BIOS I sent you at post #12, then make FPT Dump of BIOS region and send to me. Then I will edit again and make all NVRAM set to IDE only as well.