Intel 965P/ICH8R AHCI/RAID confusion

@Fernando

If I could remind you of this previous correspondence regarding my father’s PC (posts 4 to 7).

This chipset has the old Intel AHCI ROM 1.20E and (after my modding the BIOS) RAID ROM 10.1.0.1008; that is, two distinct option ROMs for each purpose.

As I understand it, I need to reinstall the operating system (Win7SP1x64) with the BIOS in RAID mode to make use of the newly-installed RAID ROM and avoid the ancient AHCI ROM; is this correct? I do know for certain that the system boots without expecting a RAID array to be created (the drives are listed as under the control of the RAID BIOS).

If that is the case, then surely the unmodded RST RAID drivers 11.2.0.1006 could be used? From what I can gather looking at the contained INF files for the RST driver pack, the “Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller” which is DEV_2822 is one more than the “Intel(R) ICH8R/DH/DO SATA AHCI Controller (added by Fernando)” within the AHCI INF file (DEV_2821). I have seen similar numerical differences (that is an addition of 1 or 2 to the DEV number) between other AHCI and RAID device versions (ICH7M/MDH for example).

As the boot drive is an SSD, would TRIM still be active using the 10.1.0.1008 ROM/11.2.0.1006 RST combination in RAID mode (there is a secondary mechanical data drive)?

I would appreciate your thoughts and/or advice on this before I attempt the reinstall (although Dad is in another part of the country so not that soon!), if only to prevent needless frustration and the fact I don’t like uncertainty!

Kind Regards

Yes.

Yes.

Yes, that should work as long as you do not create a RAID array.

Fernando

An excellent example of German efficiency! My sincere thanks.

I’ll post updates as soon as possible after the reinstall (here and in the Modding Results thread).

Regards

Hi Fernando (and any other interested parties!)

A minor initial update to this story.

I have just successfully re-modded the last BIOS for the GigaByte board with Intel RST ROM 11.2.0.1527, replacing my previous 10.1.0.1008 mod, without errors, despite the extra size of the ROM!

This board has Dual-BIOS functionality so I will be able to backup the current working mod (as currently listed in your table) before trying the latest version, thus ensuring a working motherboard in the event of problems.
I am shortly to visit my parents and will be applying this mod and reinstalling the OS, as previously discussed.

I’ll update you on completion; wish me luck!

Regards

That is what I do (fingers crossed )!

Hi Fernando

Well, the project has come to a grinding halt.

The modded BIOSes (first with ROM 11.2.0.1527 then back to 10.1.0.1008) were successfully flashed and seemed to work OK but I could not get CTRL-I in RAID mode to work in order to confirm the ROM version. This worked the first time I tried v10 in April so I can only assume a ‘fluke’.
When I tried to reinstall Windows with either version of the ROM, the installer requested a CD/DVD driver to continue (despite the install being done from DVD) and providing the 11.2 RST driver .inf failed every time.

I then tried to load the MSM 8.9.1.1002 ROM recently provided; that wouldn’t even boot from the DVD.

Only the original RAID ROM (v 6.0.0.xxxx believe it or not) got to the ‘upgrade or clean install’ screen correctly. As I fail to see how a ROM that old would help performance, I gave up, switched back to AHCI, restored the disk image and subsequently moved the SSD onto the (upgraded to ROM 1.07.28) JMicron controller as it boots quicker than the msahci driver on ICH8R (there is no difference in Win7 WEI performance between the two - both rate 5.9, but msahci hangs for some time loading the video driver).

After the success I’ve had with my Z68 board this was a huge disappointment but I suppose with a 7-year-old motherboard I probably shouldn’t be surprised.

Any comments or suggestions are welcome but I feel that this may be a lost cause.

Regards

@ Iken:
Your report disappoints me as well, because I was rather optimistic, that you would succeed.

Have you checked your BIOS settings for the option "Force OROM Messages" (or similar)?

Please read >this< article.
Alternative question: Did you have unplugged all storage devices (except the system drive and the DVD drive, before started with the OS installation?

This is somehow a similarity with the experience of the user oldschoolh, who was not able at all to update the Intel RAID ROM version of his DFI mainboard BIOS.
On the other hand you have to consider, that it is a very big jump from a RAID ROM v6.x.x.xxxx to v10.x.x.xxxxx or even v11.x.x.xxxx.

Edit:
It is very important to completely power off the computer for a while (ca. 1 minute) after having flashed a new BIOS. Otherwise the new BIOS features may not work.


No such option in this BIOS I’m afraid. The original ROM and v8.9 displayed config data and the CTRL-I prompt on boot - the v10 & v11 did not.


Thanks for the Microsoft link - I think it can be discounted in this case as the original ROM did not have issues. As I stated, ROM 8.9 did not even see the DVD drive to boot from.


That’s the point I think - the level of compression required to insert these larger ROMS seems to cause compatibility problems. When I reloaded the BIOS with only the JMicron ROM update, the issues disappeared-other than the fact that a simple Intel AHCI driver update with the boot SSD causes bluescreens-compatibility again I suspect.

Please update the BIOS modding table as you require.

Thanks again for all your assistance.

Regards

@ Iken:

When you had flashed the modded BIOSes containing the Intel RAID ROM modules v11.2.0.1527 and v10.1.0.1008, did you really completely powered off your Computer for ca. 1 minute, before you restarted it, then entered the BIOS, choosed "Optimized Settings", set the SATA Controller to RAID mode, saved the BIOS settings and at least hit CTRL+I while rebooting?

Hi Fernando

I probably didn’t power off for a full minute to be honest (though it was powered off after each flash as there is an option within the internal flash procedure to do exactly that).
Clearing CMOS before and after flash (powered off of course) was also tried.
CTRL+I was tried with each of the newer ROMs with no result - the keystrokes were not registered.

The fact remains that the only RAID ROM that didn’t cause issues of some kind or another was the original. This may explain why there was never an update supplied by Gigabyte (only an AHCI update to 1.20E).

I may try the 10.1 ROM again at some point before I leave. I’ll let you know if I do.

Regards

Hi Again!

I think I shall have to admit defeat on this one…

I used CBROM to extract, release and reinsert each individual BIOS element, including MEMINIT, to ensure a correct element order.
I removed the OEM bios screen image to give extra space.
The JMicron ROM was no problem at all and the BIOS flashes without any problem but the RST ROM (10.1 or 11) will not co-operate.
I followed the recommendations to power off for a full minute (usually MUCH longer actually) before clearing CMOS and resetting BIOS to preferences.
The RST RAID ROM will not recognise ANY drive attached to the Intel controller when reinstalling Windows, nor respond to CTRL-I during boot, unless the original ROM is reinstated.

The current BIOS loaded contains the new JMicron ROM and RST 10.1 ROM but is set to AHCI; it will have to remain this way unfortunately.

I’ll be reinstalling Windows 7 64-bit soon(ish) and will (try to) use the RST 10.1 drivers (via Device Manager) once the OS is installed. I’ll update with progress at that point.

Regards

@ Iken:

Additional questions:
1. Which SATA mode will you choose, before you are going to do a fresh install of Win7 x64?
2. As long as you had set the Intel SATA Controller to "RAID", did the BIOS see your RAID array and showed it as bootable drive?

@ Fernando



I thought I’d already answered those questions (in bold above)? As I previously stated, there is one SSD boot drive and second mechanical Data drive; no RAID array.
I confirm that no disk drive is detected; I get the opportunity to install the RAID drivers but no drive is detected after the (correctly selected by the installer) driver is accepted.
I am forced by this failure to use the AHCI BIOS setting and 10.1 RST AHCI driver (assuming that the reinstall is enough to get them accepted)

I am sorry, I missed/forgot, that you don’t have created a RAID array.
Nevertheless I repeat my last question: Does the BIOS of your mainboard detect your SSD and HDD, when the Intel SATA Controller has been set to “RAID”?
If not, you probably will not be able to use any of the drives in RAID mode.

Do you mean a reinstall in AHCI or RAID mode? If it should be the latter, you can verify the chances to succeed already at the beginning of the OS installation and before your drives will be altered. Either the OS Setup will detect your drives or not. If it should not detect your drives, I recommend to reflash the BIOS with the old Intel RAID ROM.

It is the AHCI ROM that detects all the drives during post (and when the BIOS is set to RAID, additional text states the 2 disks are under the control of the RAID BIOS).


I am unsure why you ask these questions; AHCI setting in BIOS and RST AHCI driver surely means AHCI? I previously stated that when set to RAID, no drives were detected by the Windows installer.

It seems pointless trying to use v10.1/11.2 RAID drivers with a v6.0 RAID ROM.

This indicates, that the Intel RAID Controller is able to detect the drives by using the actual Intel RAID ROM module.

I didn’t realize, that have already given up yor intention to get RAID working.

It may be worth a try, but you probably are right.


Not in this case. It reports the BIOS setting; it specifically shows the AHCI ROM version & trademark text before this information.
The RAID text appears (original v6 ROM only) after both the AHCI and JMicron ROMs have initialised.

I suspect that, possibly with all Gigabyte 965P Express chipset motherboards, the AHCI and RAID are ‘interlinked’ so that updating of RAID alone is impossible.

I’ll post again when Windows is reinstalled via the AHCI ROM.

Regards

Hi Fernando

Well, I re-modified the original BIOS to include only the JMicron ROM and have reinstalled Windows in AHCI mode using the original 1.20E ROM. Both drives (SSD boot and HDD data) are now working correctly (and faster) on the ICH8R controller with the RST 10.1.0.1008 driver.
As before, the E-Sata external drive connected to the JMicron controller (solo drive now, still with the latest 1.07.28 ROM and 1.17.65 driver) is also working fine.

Please modify the BIOS Modding Results as appropriate (basically, JMicron the only mod that worked!)

Regards

Thanks for your feedback.

Done!

hi Fernando can i have a bios modded by you? i have an GA-965p-ds4, and i use it on hwbot for PCMARK2005.
but the raidrom is very old, and my SSD in Raid0 are very very slow…can you help me?

this is the last bios for my mobo

thank you!