Intel, AMD, VIA & Freescale CPU Microcode Repositories Discussion

Intel, AMD, VIA & Freescale
CPU Microcode Repositories
Discussion Topic

This thread is meant as a place to discuss the CPU Microcode Repositories.

You can find all details and download links at the project's Github page.

Any issues or suggestions should be reported at the Github Issues page.

Reports of any microcodes not found at MC Extractor's database should be posted here.


CPUID 206A6 not found

I can see it!

as I know if the version is fixed the bug Meltdown and Specter?

Nice one, thanks!

Also, can I somehow package whole Intel microcodes into one microcode.dat file ? I need it because I use VMWare CPU Microcode Updater driver and it needs to have microcode.dat file so it can detect the correct microcode :confused:

@ p82:

You’re right p82, thank you for your report. Due to an oversight in MC Extractor, a total of 6 Intel PRD microcodes were missing. That was because these were all "superseded" by equivalent "Latest" PRE ones and MCE would not pick anything. The latest MC Extractor v1.12.0 r50 has fixed the issue. So I’ve re-uploaded Intel CPU Microcode Repository Pack r1 with these added:


I’ve also added the following at the start post to make the distinction clear:

@ maur0:

As far as I know, there is no official word from the vendors on which microcode versions try to mitigate Meltdown and Spectre. For Intel, it is a safe bet that everything from November 2017 or newer is what we’re looking for.

@ acid96:

Throughout the years there have actually existed 6 variants of ".dat" microcode update containers. MCE is capable of unpacking all 6 of them but not repack them. I don’t plan to add support for that these days, maybe in the near future. In the meantime, you can probably find some other tool online which does that.

Btw, I was trying to point UBU to these microcode bin-files but it has not reacted to them at all. How we supposed to use these files?

CPU microcode binaries are generic and not specific to any tool. UBU related questions should be asked at the UBU Discussion thread instead.

In the Intel Repository Pack I’ve found a newer microcode.bin for my platform but when I try to upgrade the bios using MMTool 3.26 for nonUEFI, I get an error message "This is not a valid CPU MicroCode Patch file"
Funny think is that other microcodes are working and when I extract the older version of same microcode from my bios and want insert back I get the same error message. with other codes frome the same bios don’t have this error (extract and insert).
This is the updated code for my CPU:


Do you have any ideas or advice?

btw many thanks for this useful thread.

Hey @wasisdn , have a look over here: RE:CPU Microcode BIOS modding questions/problems (9), in Post #133 you’ll find a fixed version of the 206C2 microcode over there. I could successfully integrate it with MMTool and I am using it since then with a modified P6T WS Pro Bios on my P6T Deluxe V2 (cross-flashed).

@ms178 yes it works for me thank you very much. tomorrow I will test and flash the bios at my home pc with good old sabertooth x58/x5690

Edit: Flash already and it’s working thx

New microcode.dat…e-Data-File?v=t

PS Hey, my granddad IB-E 4930 received updated microcode: 428 => 42A!

Only 4 new cpu ucodes according to MCE…


I counted 7 on my end:


Maybe I did something wrong when I extracted them. Anyways, more is better. Although I don’t see a newer Haswell update so far. Let’s hope they will push another update…

MC Extractor v1.13.0 says 8 new


Ah yes, it seems that I had already found cpu806EA_platC0_ver00000080_2018-01-04_PRD_F6263DAE a few hours after releasing 1.13.0 r51 and before the new Intel .dat package. So in total, compared to DB r51, there are 8 new microcodes.


Btw MCE writes error when I run on that new micreocode.dat with option "-cont", but creates folder with bin-files.

What error exactly? I don’t see anything wrong with MCE 1.13.0 on my end.