Intel, AMD, VIA & Freescale CPU Microcode Repositories Discussion

If I run "MCE microcode.dat -cont" it doesn`t create folder with extracted bin-files and outputs:

File (1/2): microcode.dat
File does not contain CPU microcodes
Error: MCE just crashed, please report the following:
Traceback (most recent call last):
File "", line 983, in <module>
ValueError: too many values to unpack (expected 3)

If I run "MCE microcode.dat -cont -skip" it creates folder with extracted bin-files and outputs:
File (1/3): microcode.dat
(long table)
Error: MCE just crashed, please report the following:
Traceback (most recent call last):
File "", line 983, in <module>
ValueError: too many values to unpack (expected 3)

The CPU Microcode Repositories are now found at Github. This thread is meant for Discussion and reports.

@ mbk1969:

There was indeed a bug in MCE caused by the previous 1.13.0 update. Thank you for the report mbk1969.

Why did the microcode filename change?
And where can I download all versions of microcodes? At the GitHub only the latest versions.

Can you pls add in Intel repository laste microcode for cpu1067A_plat11?

@SoniX :

The last filename change was a few months ago. Any such changes are made in order to have a proper database. The checksum is needed because some mc have the same header but different data, the CPUID was shortened to 5 digits (no need to have 000 at the beginning for no reason) and the Release was added for Intel (PRD/PRE). The Date has been following the YYYY-MM-DD format for quite some time now, not just a few months.

At the github repositories there are only Production microcodes to avoid any legal issues with Intel. I also upload the latest only as that’s what 99% of people actually care for. As for the older ones you seek, what’s their CPUIDs for me to look?

@ Horus:

You haven’t read the Repositories ReadMe file, last bullet point.

Thanks cpu1067A_platB1 is the right file.

I wanted to implement utility which would load specified archive file with repository and then would show/extract bin-files inside that repository matched with CPUID of current CPU in the rig. But .Net framework has built-in classes only for zip-archives. I browsed for 3rd party libraries and all of them have flaws.
So I can ask questions:
1. Any interested in such utility?
2. @plutomaniac Why rar format and not zip one?

The repositories are at github without any compression

Oops, no utility then.

What is the reasoning for not including the PRE microcode in the repo?

This microcode are missing from database: CPU106E0, 106E1, 106E3, 106F1.
If anybody need them it can be found here: SOLVED - UPDATE Microcode for Lenovo T410 BIOS - replace PAT file and flash !

MCE report some of them as not latest.
Can somebody post latest 106E0 and 106E3.

thank you


Someone asked me to mod their bios and update the cpu microcode of cpu50654 plat 97 to the latest BUT the latest is platform ‘B7’ ??

I can’t find plat ‘97’ in the repository… Is it the same thing?


use Intel Microcode List to check for what platform it is original microcode.
latest it include this platforms:
"F:\Microcode\Intel CPU Microcode Repository Pack r1\cpu50654_platB7_ver0200003A_2017-11-21_PRD_C088D252.bin"
CPUID=50654 Rev=200003A 2017/11/21 CRC=C088D252 Off=0 Size=6C00 Plat=0,1,2,4,5,7

from 20180808 archive you can find latest version:
File: 06-55-04
| # | CPUID | Platform | Version | Date | Release | Size | Checksum | Offset | Latest |
| 1 | 50654 | B7 [0, 1, 2, 4, 5, 7] | 200003C | 2017-12-08 | PRD | 0x6C00 | A4059069 | 0x0 | Yes

So its ok replacing Platform ‘97’ with ‘B7’ ?

Yes. It is just a bit mask.
Read Intel Intel® 64 and IA-32 Architectures Software Developer’s Manual Volume 3A: System Programming Guide, Part 1, page 9-32/33

Ok Will take a look. Thanks.

@ fs-esprimo:

All these CPUIDs are for Pre-Production microcodes. Read the CPU Microcode Repositories ReadMe.

@ davidm71:

Yes, 0xB7 supersedes 0x97. Read the last bullet point at the CPU Microcode Repositories ReadMe.


Please take a look at my inquiry on [GUIDE] AMI CPU Microcode Update Guide (2). Had some difficulty manually integrating the updated cpu microcodes into that x299 bios. UefiTool refused to save the file!

Anyhow I will definitely read up on those bullet points. Thanks!

in the readme file it states "Only Latest microcodes are included in the repositories" but after recent Intel bulletin it seems like it might be better to have at least two of each CPUID: the latest and the latest "safe one"

Considering NO PRE / only PROD policy I think it is best to stick with only one microcode per CPU = latest recommended.