Intel Apollo Lake N3450 SoC AHCI/RST?

Please have a look into the start post of >this< thread and follow my tips.
By the way: Which one of my various mod+signed Intel AHCI drivers did you install?

Will do for sure!

The one I used is - Universal 64bit Intel RST AHCI+RAID driver v13.44.0.1026 comp+mod+signed by Fernando

Another BIG Thank You from an Ezbook 3 Pro User!! I had Problems after installing a Transcend m.2 SSD. I had read Speed 2 MB/s and write Speed 6 MB/s with Standard Windows driver. After installing your modded Driver i have read Speed 270 MB/s and write Speed 260 MB/s. Transcend’s SSD Tool says the Interface is SATA2 (not 3) so there is probably no way to come anywhere near the SSD’s advertised read Speed of 570 MB/s.

@VTG :
Welcome to the Win-RAID Forum and thanks for your feedback!
Which driver version did you install?
Dieter (alias Fernando)

10.0.16299.192 bzw. 948068.rar

@VTG :
I have never offered mod+signed Intel RST drivers with such version numbers. The first one is the version of your OS.
If you should not remember, which driver you have installed, please run the Device Manager, expand the “IDE ATA/ATAPI Controllers” section and look for the driver version of the listed “Intel SATA AHCI Controller”.

Hi there
Another Ezbook 3pro owner that installed the driver v13.44.0.1026 to improve the performance but after installing this driver the laptop doesn’t turn off. Strange as no one else mention this. Roll back to standard driver and the laptop turns off.
I have unlocked the bios.
Wonder if anyone can help me resolving this problem.

My ezbook still boots from eMMC. Maybe that is why it turns off?

This only happen after installed the new driver. I’m booting from new ssd since i installed it without problems (almost).
Now it’s all ok.
I can turn off the ezbook and it stays off.

@yoonohoo :
Welcome to the Win-RAID Forum!

According to my knowledge there is no direct relationship between an AHCI driver and the shutdown procedure of a PC or laptop.
Nevertheless you may test as an alternative the mod+signed Intel RST(e) drivers v13.2.8.1002, which have just been re-customized by me to make them usable with ApolloLake CPU systems like yours.
Look >here<.

Dieter (alias Fernando)

@Fernando :
It does not allowed me to install directly saying there’s a better version already installed so I have to go through the iaAHCIC.inf file and then I have multiple models and none of them matches the hardware id. Which model should I pick? Thanks

EDIT by Fernando: Unneeded fully quoted post replaced by direct addressing (to save space)

The one, which contains exactly the same DeviceID as your on-board Intel SATA AHCI Controller.
To make it as easy and safe as possible for the users of my mod+signed drivers, I have added the related DeviceID to each listed Controller.

Hi everyone
I have got 2 jumper ezbook 3 pro. One v4 and the second v6.
In the first one my ssd 120gb runs perfectly. But in the v6 version I have de same issue than yoonohoo. I’ve unloooked the BIOS but nothing seems to be wrong. Even I’ve compared the two version’s BIOS and no diferences found.
I’ve installed the driver v13.44.0.1026 and the write performance has improove a lot. But when I try to turn off the laptop it restarts again.

yoonohoo, have you find out a solution?

Thanks Fernando for your work and your help

@eledu :
Welcome to the Win-RAID Forum!

What lets you think, that the problem is Intel RST driver related?
Which AHCI driver did you use before? Have you tried the mod+signed Intel RST(e) driver v13.2.8.1002 as well?

Dieter (alias Fernando)

well, as in the case of yoonohoo, when I reinstall de standard driver, the windows turn off button works perfectly. But when I install the v13.44.0.1026 the laptop does not turn off, it seems to do it, but it alwais restarts again.
I tried installing driver v13.2.8.1002 but I have not found a way to do it.
Thank you for you help Fernando

The same way as you installed the mod+signed Intel AHCI driver v13.44.0.1026. Maybe you have to force the installation by using the “Have Disk” button.
This is the procedure:

  1. Check the HardwareIDs of your on-board Intel SATA AHCI Controller resp. “Standard AHCI Controller” (listed within the “IDE ATA/ATAPI Controllers” section of the Device Manager) and keep in mind the shown DeviceID = DEV_XXXX.
  2. If not already done, import the Win-RAID CA Certificate according to my guide (look >here<).
  3. Right-click onto the listed Intel SATA AHCI Controller resp. “Standard AHCI Controller” and choose the options “Update driver” > “Browse my computer…” > “Browse”, navigate to the folder, which contains the desired driver, and click onto “OK”.
    If you should get the message like “Couldn’t find a better driver than the already installed one”, repeat the driver update procedure, but now choose the optios “Update driver” > “Browse my computer…” > “Let me pick…”, hit the “Have Disk” button, navigate to the desired driver folder and click onto the file named iaAHCIC.inf. If you should get a list of Intel SATA AHCI Controllers with different DeviceIDs (= DEV_XXXX), choose the one, which you detected within step 1. Then click onto “OK”.

That’s all. The rest will be done automaticly.
After the next reboot your on-board Intel SATA AHCI Controller will use the freshly installed driver instead of the previously used one.

Your driver doesn’t work on a Lenovo V320-15IAP Intel Apollo Lake SoC (Intel Celeron J3355 -…r/p/11LV1VDV320) PC with Windows 7 Ultimate x64. I used your step-by-step guide above and every time I install the driver, when the PC reboots, always go into repair mode. The result, is always the repair to uninstall the driver and switching back to the default “Standard AHCI 1.0 Serial ATA Controller” windows 7 driver !!

Hardware Id’s :

@BetaTester :
Welcome to the Win-RAID Forum!

Since I have modified and signed a lot of different Intel AHCI drivers, you should write, which one you have tried to install. What means “your driver”?

Dieter (alias Fernando)

Thank you!

The driver i used is the x64 driver in first page of this tread (New Universal 64bit Intel RST AHCI & RAID driver v13.44.0.1026 mod+signed by Fernando.rar).