Intel Apollo Lake N3450 SoC AHCI/RST?

Are any of the AHCI/RST drivers posted here compatible with this SoC?

Haven't been able to find an Intel driver for my Jumper Ezbook Pro 3.
It only loads the generic Microsoft Standard SATA AHCI Controller driver 10.0.16299.15 dated 2006.


@netRAT :
Welcome to the Win-RAID Forum!

Zitat von netRAT im Beitrag #1
Are any of the AHCI/RST drivers posted here compatible with this SoC?


I doubt, that Intel will ever release any RST AHCI driver, which natively supports that specific Intel SATA AHCI Controller.
For Apollo Lake SoC users, who want to use an Intel AHCI driver instead of the Win10 in-box MS one, I have attached freshly modded and signed "new" Universal 32/64bit Intel RST(e) drivers v13.44.0.1026 dated 02/22/2017, where I have added the related HardwareIDs.
Please test them and report here about your result. Don't forget to import the Win-RAID CA Certificate, before you try to replace the driver of the "Standard SATA AHCI Controller", which is listed within the "IDE ATA/ATAPI Controllers" section of the Win10 Device Manager.

Good luck!
Dieter (alias Fernando)

EDIT: The attached drivers have been removed by me, because there are better/updated ones available >here<.

Many thanks for modding the drivers Fernando!
I just loaded the x64 version and here are my CrystalDiskMark results:

Microsoft driver


Modded Intel driver

Fernando modded.PNG

It appears as through the MS driver overall performs slightly better that Intel v13.44.0.1026, apart from the 4KiB write speed where the Intel takes the lead significantly.
I haven’t tested stability, etc… these are just bench results.
Do you think a different Intel driver version could possibly yield better resuts?
By the way this has been tested on a crucial mx300 275gb m.2 SATA SSD.

Thanks again!


@netRAT :
Thanks for having tested my mod+signed driver and for your report. Your benchmark results verify, that it is possible to get an Intel AHCI driver installed and working with an Apollo Lake SoC system having an Intel SATA AHCI Controller DEV_5AE3.
My advices:
1. If you really want to compare the performance of a system while using different storage drivers, you should better use “Anvil’s Storage Utilities” (requires .NET Framework 3.5). You can find download links >here<.
2. If you want to know how to boost the AHCI performance, please have a look into the start post of >this< thread.

Probably not. According to my recently done benchmark comparison tests (look >here< and >here<) the Intel RST driver v13.44.0.1026 has given my Z170 SkyLake Desktop and my KabyLake Mobile systems the best performance while running a SATA SSD in AHCI mode.

Just a quick thanks Fernando as this has fixed my issue.

I have a Jumper EZBook 3 Pro (version 4) and today received my KingSpec M2 2242 ssd (256gb).
I was only getting 1MB/s write speed, 500+ read. It was so slow it took CrystalDiskMark over 5 minutes to write the initial file to the drive and start the benchmarking procedure!
Now it’s 120MB/s, so orders of magnitude better

@psprog :
Welcome to the Win-RAID Forum and thanks for your feedback, which I obviously missed.

Question: Which driver solved your performance problems and which driver did you use before?

Dieter (alias Fernando)

Hey there,
I have a similar problem… Got an Ezbook 3 Pro (I think Rev.3) and installed an ADATA 120GB SSD (2280) and cloned the eMMC to the SSD.

The write speed was less than 30 MB/s, reading was ok (I think).
Then I searched the web and found your thread here and installed your modded drivers. Unfortunately Win10 dies at booting now (BSOD with 0xc225). Do you have any ideas/hints what is gone wrong? I installed the certificate and let Win choose the driver from the extracted folder automatically…

Im back at the eMMC now and try to fix the bootup of the SSD…

Lots of greetings,

@sturmtiger :
Hello Alex,
welcome to th Win-RAID Forum!

If you really want help, you should give me some information about
a) the chipset and the in-box disk drives of your Ezbook 3 Pro,
b) the used interface (AHCI or NVMe) of your ADATA SSD,
c) the Storage or IDE ATA/ATAPI Controller to which your system drive is connected,
d) which one of the various drivers, which have been modded by me, has been installed by you and
e) which driver you had used before.

Dieter (alias Fernando)


Thanks for your reply and your help! I hope I can answer your questions.

to a)
Chipset: Good question… Dev-Manager just says “Standard SATA AHCI-Controlle” (PCI\VEN_8086&DEV_5AE3&SUBSYS_72708086, PCI\VEN_8086&DEV_5AE3&CC_010601, PCI\VEN_8086&DEV_5AE3&CC_0106)
eMMC: Sandisk DF4064, 64GB
SSD: ADATA SU800NS38, 120 GB

to b)
Unfortunately I received one with a completely locked BIOS, so I can’t see/switch anything. I guess it’s AHCI.

to c & d & e)
Onboard on the MB, driver is/was Windows stock from 2006 (this one I tried to replace with your “New Universal 64bit Intel RST AHCI & RAID driver v13.44.0.1026 mod+signed”).


I hope I understand everything correctly as my English isn’t that good and the last time I worked this “deep” at computers is year’s ago, but I’m out of touch in the meanwhile…

EDIT by Fernando: Unneeded fully quoted post removed (to save space)

@sturmtiger :
Thanks for trying to give me some additional information.
Your on-board Intel SATA AHCI Controller is not supported by any Intel RST/RST(e) driver and not yet even by any of my modded ones. Maybe I will add the HardwareIDs to them in the future.
So you have to stick with the Win10 in-box MS AHCI driver (by the way: It is brandnew and has been compiled in 2017).
Regarding the performance please look into the start post of >this< thread.

EDIT: I have to correct my previous and now crossed out statement, because my latest mod+signed Intel RST(e) drivers v13.44.0.1026, which are attached to >this< post, do support DEV_5AE3 Intel SATA AHCI Controllers.


Thanks alot again for your help!
And bummer that your modded drivers don’t work (great work btw!).

But I don’t understand why the SSD is so slow, even if Windows thinks it must use the old one. At the moment I use the Windows on the eMMC and didn’t fix the boot of the SSD (if I’ll do that I think I’ll give it a new clone instead of repairing it - the thing is still brand new and there is no data yet). But I could access the screenshots I took from the benchmark I did before I tried to change the driver. I attached them to this post FYI.

Maybe you have some other ideas why it’s THAT slow…

Thanks alot and a nice weekend!

Kind regards,

Wirklich sorry für mein schlechtes Englisch… :confused:

as-ssd-bench ADATA SU800NS38 11.01.2018 14-39-19.png

as-ssd-bench SanDisk DF4064 11.01.2018 14-46-20.png

@sturmtiger :
I doubt, that your bad benchmark results are caused by the generic Win10 in-box MS AHCI driver. You should get much better scores, if the SSD itself is 100% healthy and the system configuration has been optimized.
My advices about how to boost the AHCI performance of an SSD are layed down >here<.
Did you follow them?
When you choose the “Optimize” button from within the Explorer (right-click onto the drive > “Properties” > “Tools”), does the OS detect your SSD as SSD?
If not, run the Command Prompt or the Powershell as Administrator, enter the words “winsat diskformal” and hit the Enter key.

I just have realized, that I was wrong, when I wrote, that none of my currently offered mod+signed Intel RST/RST(e) drivers do support the Intel SATA AHCI Controller with the DeviceID DEV_5AE3. Such drivers are attached to the second post of this thread.
So it would rather like to know the reason why you got a BSOD with the 0xc0000225 error message during the reboot after having installed my mod+signed Intel AHCI driver v13.44.0.1026. >Here< you can read more about this specific error message.
1. Is the SSD with the slow speed your system drive?
2. How full is the SSD?
3. Have you recently TRIMed the SSD by running the OS “Optimizer”?
4. Did you check the related driver informations of the Intel SATA AHCI Controller (right-click > “Properties” > “Driver” > “Driver Details”) from within the Device Manager after having installed the driver, but before having induced the reboot?

Hey there and sorry for my late answer…
The ADATA-Tool tell’s me, that the SSD is at 100% health (see the attached screenshot).
I haven’t seen your advices yet, as a google-search brought me directyl to this thread. But in the meanwhile I tried everything what was possible - no change.
Yes, the drive is recognized as a SSD.

That was the driver I installed. Today I loaded the hive of the damaged Windows-Installation into the regedit of the working installation and checked the AHCI entry’s (like if I’ll switch from IDE to AHCI) and changed some keys. That removed the 0xc225 and brought me 0xc185 and some other BSOD. Then I cloned the eMMC again to the SSD and it’s still having troubles booting with BSOD’s. If I hit Enter (“retry”) often enough, it was booting up, but still extremely slow. Opening the Start Menu took like 10-20 seconds and Windows is comletely lagging. Again I did some research and it seems that I’m not the only one with that problem. There’s another Ezbook 3 user with the same experience and I found something similar in an Amazon comment. So I think the ADATA is somehow picky for the mainboard as it’s tested quite fast and I don’t think the SSD is defect. Right now I ordered another SSD (Kingspec as another Ezbook-user in this thread was satisfied with that SSD).

But to answer your open questions:
To 1:
I wanted it as my system drive. I cloned the build-in eMMC 1:1 to the SSD. So I’m able to boot from both drives depending on how I arrange the boot order in the UEFI. But even if I’ll boot to the eMMC and test the speed of the SSD the results are super-slow.
To 2:
Just windows and some downloads (like the eMMC). 40 of 120 GB are in use.
To 3:
Not until I found your tips. No change after the trim.
To 4:
Nope… I installed it and immediately rebooted into the BSOD, sorry.

So as I said: I bought a different SSD and when it’s there I’ll tell you if there is a difference.

Kind regards,

EDIT by Fernando: Unneeded parts of the fully quoted post removed (to save space)


@sturmtiger :
Thanks for your detailed rport.
If you should find the reason for the bad performance of your SSD, please let us know it.
Dieter (alias Fernando)

I have to thank you for your help and support!

Of course I’ll keep you informed, but the new SSD will take some time until it arrive (ordered in China again ^^), like 3-4 weeks maybe.
But in the meanwhile I ordered an external USB3 case for the Adata. I’m curious if it’s speed will change when it’s connected externally.

Kind regards,


As promised here the first update:

Today the external case for M.2-SSD’s arrived (that cheap 13€-thingy from the bay).

The SSD is WAY faster at the USB3-Port of the Ezbook (see the attached Screenshot below).

I’ll keep telling what will happen with the new SSD. When it’s faster there’s really an incompatibility between the Adata and the chipset (I had something similar years ago - a CPU which didn’t wanted to work with a certain motherboard… but back in that time a bios-update fixed the problem. But to update the bios I had to buy different CPU… tricky sh*t).


as-ssd-bench ASMT 2115 SCSI D 16.01.2018 15-47-01.png


As promised…

Today I put in the KingSpec-SSD… It’s (super-)fast… So it seems that there’s really an incompatibility between the Adata and the chipset of the Ezbook. Maybe there will be a firmwareupdate for the SSD, but until then I keep it as an external backup-drive.

Kind regards,

Benchmark KingSpec.png

Hi Fernando, incredible work here, I am so glad that I found your site, thank you!

I have the exact same Jumper EZBook 3 Pro and recently upgraded the SSD to intel m.2 ssd 5400s 180gb.
I did a fresh install, all the possible optimizations, the drive is recognized as SSD by Win 10, but as the other forum members above me, the speeds are much slower then expected, especially the 4K speeds (single digits).
I tried installing your modded drivers, but for the life of me I cant make Windows to update to them, tried all manual options, but is keep refusing and telling me the "best ones are already installed" :frowning:
Maybe its an extreme noob question, but can you please advise how can I force install them, thank you again!

@trentbg :
Welcome to the Win-RAID Forum!

This is what you should do:
1. Import the Win-RAID CA Certificate according to the start post Chapter I of >this< thread.
2. Open the Device Manager, expand the section “IDE ATA/ATAPI Controllers” and search for the listed “Standard SATA AHCI Controller”.
3. To make sure, that it is the Intel SATA AHCI Controller, right click onto it and choose the options “Properties” > “Details” > “Property” > “HardwareIDs”. The VendorID should be VEN_8086 = Intel.
4. Right click onto the Intel SATA AHCI Controller again and choose the options “Update driver” > “Browse my computer for driver software” > “Let me pick from a list…”.
5. Hit the “Have Disk …” button and then the “Browse…” button. Then navigate to the folder, where the wanted mod+signed Intel driver and the associated *.inf and *.cat files are stored.
6. Double-click onto the listed file named iaAHCIC.inf and then hit the “OK” button.
7. New the compatible Intel SATA AHCI Controller should be listed within the “Model” list.
8. Click onto the “Next” button and choose the “Reboot” option.
9. After the reboot your on-bord Intel SATA AHCI Controller will use the just installed mod+signed Intel AHCI driver.

Good luck!
Dieter (alias Fernando)

Huge Thank you Fernando!
The results a lot more consistent - the Read seq speed dropped on half from 500 to 280 but the write jumped from 30 to 270
Also the 4K Write speed is up to 40 now, reed is still low at 9
4k-64Thrd is way up now to 171 read and 105 Write
Access time is also quicker at 0.094 and 0.092 Write.

Overall much better, still not sure why the 4K is that low and why the Read Seq dropped on half, but its fine.
Thank you again.