Intel EFI RAID/VMD BIOS Modules

Yesterday I tried to get GOP output working on my P8Z68-V. I inserted the IntelSaGOPDriver module which I took from BIOS of P8Z77-V and the Sandy Bridge and Ivy Bridge GOP modules linked to in the first post of this thread. I also flashed a GOP capable BIOS on my GeForce GTX 670. The problem now is that the boot process stops with a blank screen when switch from "Legacy mode" to "EFI compatible" in BIOS. I cannot see the POST screen and have to clear the CMOS in order to get the computer booting again. So I think just inserting GOP modules is not enough to get it working.

When I only insert the mentioned GOP modules into the motherboards BIOS without using a GOP capable VGA BIOS on my GeForce the computer boots fine even in "EFI compatible" mode because of the missing GOP module. But that is not a pure EFI boot.

Is there anything I could try to make it working yet?

MorLipf,
I see you have a GTX 670.
I have an eVGA GTX 670 on my P8Z77-V DELUXE mboard.
To be UEFI compliant the eVGA manufacturer (Tech Support) provided me a specific BIOS to be flashed to replace the original one of the graphic card.
Do you have done ?

@ MorLipf:
Welcome at Win-RAID Forum!

100PIER is right. It is not enough to insert the correct GOPDriver into the mainboard BIOS. You have to flash an UEFI compliant VGA BIOS into the chip of your discrete graphics card.

Regards
Fernando

I did, as mentioned in my first post. :wink:

Sorry, I have missed this information.
Provided, that you have done the correct BIOS settings, I only see 2 possible reasons for your reported issue:
a) the mainboard P8Z68-V or its BIOS version doesn’t fully support the UEFI mode or
b) there is another Controller (JMicron?), which cannot be used in UEFI mode.

There is a JMicron ESATA Controller onboard. When I switch to EFI mode without a GOP capable VGA BIOS the Option ROMs seems to be skipped on boot. So I think the JMicron Option ROM should not be the problem.
I think ASUS just do not support pure EFI boot on this mainboard. I hoped that inserting GOP modules into the mainboard BIOS and flashing a VGA BIOS with GOP module will make it possible but it seems that this is not enough to do so.

Nevertheless the inserted EFI SataDriver is working very well in EFI compatible mode when I leave the GOP modules out of the BIOS.

Are booting W7 or W8.1 ?
On the same hardware , for me, w7 x64 SP1 is not 100% UEFI and don’t support “CSM disabled” in BIOS, and with W8.1 “CSM disabled” is supported…

Windows 8.1. But the problem I have with inserted GOP modules is not operation system related. The blank screen problem initially appears right after power on before POST or operation system start.

Hello everyone, it appears I am running into some trouble. I have an ASUS P8Z68 V-PRO/GEN3 board with the 3603 bios, extremely similar to the board ‘ney2x’ is using in his guide. The issue is that I cannot access the new EFI utility. When I press right in advanced it goes through each tab, then the “Exit/Save changes” tab, then cycles back to the main tab, perhaps I’ve done something wrong.

The procedure I to to modifying the bios was using MMTool to manually insert both the Raid OROM and the EFI Module 12.7.0.1936 modified for Z68.

Then I ran that file through “UBU” and updated the rest of the modules with the tool including the microcode, I did not touch the RAID portion of the tool.

I installed the bios via USB using the built in ASUS EZ Update application, and set the options as shown in ney’s guide, however I cannot access the EFI RAID utility, any help would be appreciated. Thank you.

@ Bulls729:
Welcome at Win-RAID Forum!

Questions:
1. How did you update the Intel EFI SataDriver module of your BIOS?
2. Have you cleared CMOS and completely powered off the computer after having flashed the updated BIOS?
By the way:
You will only be able to get access to the EFI mode "Intel(R) Rapid Storage" tab within the "Enhanced Options" of the BIOS, if you have set all BIOS settings within the "BOOT" section to "UEFI mode". Additionally you have to set the Intel SATA Controller to "RAID" mode.

Regards
Fernando

IRST 13.1.0.2030, FFS, Not compressed.
SataDriver90.ffs GUID 90C8D394-4E04-439C-BA55-2D8CFCB414ED
SataDriver91.ffs GUID 91B4D9C1-141C-4824-8D02-3C298E36EB3F

satadriver_13102030_ffs.rar (77.6 KB)

Update of the start post

Changelog:

  • added: Intel RST(e) EFI RAID “SataDriver” FFS module v13.1.0.2030 for GUID 90C8D394
  • added: Intel RST(e) EFI RAID “SataDriver” FFS module v13.1.0.2030 for GUID 91B4D9C1

Thanks to SoniX for offering the source files!



What do you mean for GUID xxxx?. Is that reliable for Z68?

If you want to replace an already inserted SataDriver module, you should extract it (uncompressed) and open it with an Hex Editor.
If the hex code should start (offset 0) with "94 D3 C8 90", the module for the GUID 90C8D394 will be suitable. If the code should start with "C1 D9 B4 91", you will have to take the GUID 91B4D9C1 module.

@SoniX
@Fernando

Here is IntelGopDriver 5.0.1036 :slight_smile:
(GUID 5BBA83E6)

IntelGopDriver1036.zip (25.6 KB)


Did you install win 8 from a GPT formatted usb/dvd? Did you boot said media in UEFI mode when installing? Does your bios have a fast/ultra fast boot mode?

Hi @ all,

New here and absolutely not a tech-expert. I am sorry to bothering you with my questions. But I really need an advice.

1. Need I this when I have a RAID 1 / 0 / 5, hard drives larger then 4TB and want GPT instead of MBR?
2. Need I this when I have a RAID 1 / 0 / 5, only 2TB hard drives and think MBR is fine?

I’m not sure if I should update my UEFI. I still not get it why you provide this, lol. (>.<)
Just to have the RAID interface in the UEFI (BIOS) interface and to use 2TB+ HDDs?

I have three motherboards, all with the latest BIOS version and Intel RAID ROM v13.1.0.2030:

ASUS Maximus V FORMULA Z77 | only 2TB HDDs
ASUS SABERTOOTH Z77 | only 4x4TB HDDs; no RAID now but I want to to a RAID 5 soon
ASUS P8Z77-V PRO Z77 | only 2TB HDDs

@ Cola:
Welcome at Win-RAID Forum!

The answers are: "No, you don’t need to touch the EFI mode Intel RAID BIOS modules named SataDriver." Nevertheless it would be a good idea to update them as well, when you are optimizing your BIOS.

No, the installation of the OS in UEFI gives the RAID user a remarkable reduction of the boot time and the possibility to enhance the data secutity.

Regards
Fernando

Hi Fernando,

Thank you for welcoming me in your forum.


Well then I want to update my UEFI-BIOS of my Sabertooth Z77 for my upcoming RAID 5 first. I have a GIGABYTE GTX 670 and just installed the "Graphics Output Protocol" (GOP) firmware, now I can disable CSM and can boot in the UEFI only modus.
I downloaded AMI_Aptio_EFI_MMTool_v4.50.0.23 from this website and I opened my BIOS .CAP-File. I can’t find SataDriver, but I find IntelSaGropDriver - this is not right, or? So I think I need to insert the Intel UEFI RAID "SataDriver" but I’m not sure.
Is it possible that a SataDriver is already included in the BIOS file but the name of is is not "SataDriver"?


Interesting, another good reason to update. But why is this better for data security? TrueCrypt is not working with GPT and BitLocker also runs with MBR, I’m confused.

Regards,
Cola

EDIT: Sry, but is that normal?



Just downloaded this .CAP (I’m lazy :-D) and It looks like it’s already included?! Is that tool showing me a wrong version or is this really included?

Then you should go to an ophthalmologist.
I found the "SataDriver" module within the Sabertooth Z77 BIOS without any problem:



The advantage is the "Secure Boot" feature. Look >here<.