@ all Intel RAID or Intel VMD users, who are booting or want to boot in UEFI mode:

Intel RST EFI RAID and VMD BIOS Modules

(only for Intel Chipsets from 6-Series up)

(last updated: 07/05/2024)

Note: The Intel EFI LAN and GopDriver modules can be found >here<.

While booting modern Intel RAID systems do not use the "LEGACY" Intel RAID ROM module, which usually is within the CSMCORE file of th
e BIOS. The RAID Configuration Utility is managed by a separate “DXE Driver” BIOS module named “RaidDriver” (formerly and sometimes still named “SataDriver”).
Contrary to the conventional Intel RAID ROM the "RaidDriver" is no PCI ROM module! Users, who want to insert, replace, delete or extract a "SataDriver" BIOS module by using the AMI Aptio MMTool, have to make sure, that the "For Option ROM only" section is completely unchecked.

Remarks regarding the Intel EFI RAID BIOS Modules:

  1. Many Intel RAID users, who are going to install Win7 or Win8 in UEFI mode, have the choice, whether their Intel SATA RAID Controller shall be managed by the LEGACY Intel RAID ROM or by the Intel EFI RAID "SataDriver".
  2. The first "SataDriver" module version, which has been released by Intel, was v11.6.0.1702. That means, that a SataDriver module v11.6.0.1702 or higher is required within the BIOS to get for Intel RAID systems the fast boot option in "UEFI mode".
  3. Advantage of the EFI RAID SataDriver option: The boot time for RAID systems will be very short, because the UEFI RAID Utility named "Intel(R) Rapid Storage" is part of the BIOS and not an extern utility anymore (no Ctrl+I required).
  4. Intel RAID users, who have installed Win7/Win8 in EFI mode or are going to do it, can get access to the Intel EFI RAID Utility named "Intel(R) Rapid Storage" by entering the BIOS, choosing "Advanced Options" and hitting the right (or left) arrow navigation keyboard button until they see the new tab, which is outside the usually shown UEFI tabs.
    Precondition: The BIOS settings within the "Boot" section have to allow the boot off UEFI media and the use of "EFI" instead of the "LEGACY" OROM modules.
  5. It is possible to insert the EFI "RaidDriver" (resp. "SataDriver") file into an UEFI mode capable BIOS, which doesn’t yet contain such module, and this inserted SataDriver will work! The exact procedure was detected by the user ney2x and layed down >here<.
    Consequence: All users with a Z68 RAID system probably are able to install Windows 8 in EFI mode and to get rid of the typical boot delay caused by the detection of the RAID array, whether the original BIOS already contains an EFI RAID module named "SataDriver" or not.
  6. Note: Contrary to the Intel RST RAID ROM modules, which are usable with all DEV_2822/282a RAID Controllers, different Intel RAID systems may need a different sort of the same "SataDriver" module version. According to SoniX (>LINK<) the big majority of the Intel 6-Series and 7-Series Chipset BIOSes need a "SataDriver" module with a GUID starting with 90C8D3394 (the hex code of the uncompressed file begins with 94 D3 C8 90), whereas the Gigabyte BIOSes usually need a "SataDriver" with a GUID starting with 91B4D9C1 (hex code: C1 D9 B4 91).

Download Links:

Since the EFI “RaidDriver”, “SataDiver” or “VmdDriver” module version of the original BIOS is not always up-to-date, I offer here the latest/best ones.
The replacement of the BIOS module can be done either manually by using an appropriate BIOS modding tool like the UEFITool or automaticly by using the UBU tool (look >here<).

General notes:
  • To get the *.rar archives properly unzipped, you have to use an up-to-date packing tool like WinRAR (from v5.xx up) or 7-Zip.
  • The archives contain either
    • an *.FFS file (= complete module with a MB manufacturer specific GUID header) or
    • an *.EFI file (= generic/uniform “body” of the related module without GUID header)
    for the replacement of the complete RAID module respectively just its body.
A. Recommended for Intel 6-Series chipsets: (except X79 running in RSTe mode)
Details: (open/hide by a click)

B. Recommended for Intel 7-/8-/9-Series Chipsets: (except X99 running in RSTe mode)
Details:(open/hide by a click)

  1. Intel RST(e) EFI “RaidDriver” v13.1 Series:

  2. Intel RST(e) EFI “RaidDriver” v13.2 Series:

  3. Intel RST(e) EFI “RaidDriver” v13.5 series:

C. Recommended for Intel 100-/200-Series Chipsets:
Details: (open/hide by a click)

  1. Intel RST(e) EFI “RaidDriver” v14.8 Series:

  2. Intel RST(e) EFI “RaidDriver” v15.2 Series:

  3. Intel RST(e) EFI “RaidDriver” v15.5 Series:

  4. Intel RST(e) EFI “RaidDriver” v15.7 Series:

  5. Intel RST(e) EFI “RaidDriver” v15.8 Series:

  6. Intel RST(e) EFI “RaidDriver” v15.9 Series:

D. Recommended for Intel 300-/400-/500-Series Chipsets:
Details: (open/hide by a click)
  1. Intel RST v16 platform EFI “RaidDriver” Modules:
    (may not work with 100-Series Chipset systems)

  2. Intel RST v17 platform EFI “RaidDriver” Modules:
    (may not work with 100-/200-Series Chipset systems)

  3. Intel RST v18 platform EFI “RaidDriver” Modules:
    (don’t work with Intel 100-/200-Series Chipset systems)

E. Recommended for Intel 600-/700-Series Chipsets:
Details: (open/hide by a click)

  1. Intel RST v19 platform EFI “VmdDriver” Modules:
    (only usable with VMD supporting Intel Chipsets)
  2. Intel RST v20 platform EFI “VmdDriver” Modules:
    (only usable with the latest VMD supporting Intel Chipsets)

F. Recommended for Intel’s Enterprise Edition Chipsets (X79/X99/X299 and up):
Details: (open/hide by a click)


Here are short guides about how to update an already existing "SataDriver/RaidDriver" module and how to insert the desired "SataDriver/RaidDriver" module into a BIOS, where such file is missing:

How to update an Intel EFI "RaidDriver/SataDriver" module:
(requires the presence of such module within the UEFI AMI BIOS)
  1. Open the BIOS with the AMI Aptio UEFI MMTool and search for the FileName "SataDriver" resp. "RaidDriver" having a GUID usually starting with "90C8D394" or "91B4D9C1".
  2. Important: Don't check the "For Option ROM only" option (the SataDriver module is no Option ROM)!.
  3. Highlight the "SataDriver/RaidDriver" line, hit the tab "Replace" and navigate to the already extracted suitable "SataDriver" or RaidDriver" file you want to insert.
  4. Hit the button "Replace".
  5. Save the updated BIOS file.
Verification of the update success:
  1. Extract the freshly replaced/inserted "SataDriver/RaidDriver" module with the AMI Aptio MMTool by using the option "Extract UnCompressed"
  2. Open the extracted file with a hex editor and search for the text fragment "sata".
  3. You will find the version number of the module on the right side very close to the searched word "sata".

How to insert an Intel EFI "RaidDriver/SataDriver" module:
(when such file is missing within the AMI UEFI BIOS)
  1. Open the BIOS with the AMI Aptio UEFI MMTool and verify, that no module named "SataDriver" or "RaidDriver" is listed.
  2. Check the Volume number (leftmost column) of the file "CSMCORE".
  3. Hit the tab "Insert".
  4. Hit the button "Browse" and navigate to the file named SataDriver.ffs resp. RaidDriver.ffs you want to insert.
  5. Enter the Volume number of the file "CSMCORE" (will be 01 or 02) into the field "Vol. Index".
  6. Go to the "Insert FFS Options" section and check the option "Insert Compressed".
  7. Hit the button "Insert".
  8. Save the modified BIOS file.
The inserted "SataDriver" resp. "RaidDriver" should now be listed by the AMI Aptio MMTool at the end of the related Volume Index numbers.
Users, who need a more detailed guide about how to insert an EFI module, can find it >here<. Since both modules (NVME and RaidDriver) are EFI ones, the procedure about how to insert them is exactly the same.

Good luck!

P.S.: If you should see anywhere a newer Intel "RaidDriver" (="SataDriver") version, please let me know it.
1 Like

The MMtools say the Intel RSTe RAID "SataDriver" v3.6.0.1023 is a "invalid ffs file", does anyone have a ffs verions of this file?

@ DummyPLUG:
Welcome at Win-RAID Forum!

The newer "SataDriver" v3.7.0.1049 is an .ffs file. You may try that one.


Thanks, it is working

The newer "SataDriver" v3.7.0.1049 is an .ffs file. You may try that one.


Hi @Fernando !

I’m quite accustomed to flash, and customize BIOS as I was already following the articles you wrote at the time of Win-Lite. Thank for your support!

I’ve bought a Gigabyte GA-Z77X-D3H and already flashed the BIOS with the latest unofficial I found on the web (version 18e).
I’m using this motherboard in full UEFI mode: I dropped the legacy BIOS mode, by selecting EFI driver when asking for PCI support and by specifying UEFI only regarding drives and boot method. All is working fine.

The problem is I’m unable to launch the EFI RAID Utility via an option in the UEFI Setup interface. (No button is present). I checked the BIOS I used, I’ve the SataDriver integrated by default. I even patched it against the latest version you provided, with no result. No additional menu appears in the interface. I even tried the trick you provided (right arrow at boot or in the uefi interface), but it seems it only applies to the Asus motherboards. How can I solve this problem? Go back to legacy BIOS mode, configure my disks as RAID with the BIOS OptionRom and go back again in full UEFI mode?

@ wget:
Welcome at Win-RAID Forum!

The "Intel(R) Rapid Storage" tab should be available within the "Enhanced Mode" section of the BIOS, if you hit the right array key several times (provided that you really have installed Win7 or Win8/Win8.1 in UEFI mode).
What about the "CSM" settings within the BOOT section of the BIOS? Which setting did you choose?
What about the "Option ROM Messages" settings? Which one did you choose?
Have you tried to hit CTRL+I while booting? If yes, what happened?


I’m already in the advanced mode/enhanced mode in my Gigabyte motherload. No button is present. The CSM option only appears when I put "OS type" on "Windows 8" instead of "Other OS".
No OS is installed (new hardware). I’m planning to use ArchLinux on this motherboard too. So I put the option on "Other OS".

I even tried to put the option on "Windows 8" mode with "CSM Support" on "Enabled" and test, but no result: still no button.

Option ROM messages is an option defined as "Other PCI Device ROM Priority" which I set on "UEFI OpROM"

When I’m in FULL UEFI mode, nothing. But in legacy mode, as I said, the Intel Rapid Storage Interface appears, and I can access to it with CTRL-I.

Please see my screenshot hereby joined:

@wget :

Thanks for your reply and the details of your Gigabyte UEFI BIOS, which looks totally else than my ASUS P8Z77-V one.
Aften havng chosen the needed UEFI BIOS settings there should be the "Intel(R) Rapid Storage" tab with the option to set up a RAID array by using the Intel EFI "SataDriver" BIOS module.
Since I cannot help you regarding this point, I recommend to contact the Gigabyte Support. It is their task to solve this problem.


Thanks for your kind support! I’ll contact them.

Btw, I performed the RAID creation according my procedure: back to BIOS mode, using then the legacy OptionRom, and back again to UEFI mode.
My linux kernel recognizes my RAID0 disk array. So I assume the SataDriver is loader implicitly, but there is no option in the UEFI interface.

Hey Fern: When using the ROM switch, and running the RAID array using the RST OROM and not the RST-E OROM, does the SataDriver come into play at all when using UEFI ?

Just wondering if it’s worth replacing when running RAID in UEFI with RST.

I extracted the AHCI, SataDriver, SataDriver 11, in compressed and uncompressed, seems there is no version identity in the code such as we see with the OROM, with the OROM you can easily see what version it is.


The Intel EFI "SataDriver" BIOS module will be the only one, which is managing the Intel SATA RAID Controller of your system, if you have installed the OS in UEFI mode.

You can see the version of the SataDriver module as well, if you extract it in uncompressed form.

Thanks fern: Here is a pic, I checked Uncompressed, SataDriver, I did NOT check ROM.

Is the version in a different Offset ?

SataDriver un com.jpg

mm tool extract SataDriver UNCOM.jpg

I found it.

In my SataDriver The offset 00010260-

I downloaded your driver and found it at offset 0001600-

Yes, it is not at the beginning as with the Intel RAID ROM modules.
You will find the version of the uncompressed SataDriver module, if you search for the text "SATA". Then you will be in the region, where the version is shown on the right hand side.

Thanks, Fern.

My GUID is different then what you have posted, you can see it on the pic of the MM tool, does this mean I should not replace it with the one you have posted ?

Sorry, If I would have read how to replace I would have seen how to find the version.


I confirm. I had the same problem with gigabyte ga-z77x-up5 th. I did exactly what you did. I made the array in non uefi mode(csm=on, legacy rom), and then i changed in full uefi mode and installed windows.
I don’t think there is a way to have option for raid creation in uefi mode in gigabyte motherboards. Except the new series z87 of course.

I also want to thank Fernando for his guide. I installed module, and everything works perfect.

The SataDriver GUID of X79 chipset mainboard BIOSes is different, but you can replace it by the newer SataDriver module nevertheless. AFAIK the GUID will be customized during the insertion.

@ greg.chalk:
Welcome at Win-RAID Forum!

That may be possible. Contrary to you I was able to create the RAID0 array with my ASUS Z77-V from within the UEFI interface, that means by using the SataDriver.

Thanks, I will put your report into the BIOS modding success/failure table.


Thanks Fern, everything seems to be working great, no problems, you have the most helpful an informative site there is.

EDIT by Fernando: Quoted text corrected

Hi Fernando!

Nice forum with the best information available for onboard RAID users here, great job!

I have a question about the SataDriver.

I’m trying to replace my BIOS for ASUS Z9PE-D8 WS 5004 and found out I have:

ScuDriver_3_6_0_1023 (GUID 85FB8D3D-…)
SataDriver_3_6_0_1023 (GUID 43A0A7B3-…)

I tried to replace both of them with Intel_RSTe_EFI-RAID_SataDriver_v3.7.0.1049 but MMTool shows up "Ffs File with same GUID exists in Firmware Volume."

Because I do use the Scu RAID so now I am confused, should I just replace the SataDriver and leave the ScuDriver alone?


Hello muerte,

welcome at Win-RAID Forum!
The Intel SataDriver and ScuDriver seem to be different modules (SataDiver for "normal" RAID, ScuDriver for SAS RAID). Infortunately i cannot yet offer the new Intel ScuDriver v3.7.0.1049, because nobody has seen until now such module Version within an X79 mainboard BIOS.
So you will only be able to update the Intel SataDriver to v3.7.0.1049, which may be without any effect for your SAS RAID Controller.


Thank you, Fernando!

So this is after I replace only the SataDriver part and leave the ScuDriver untouched.

I will flash it and give a try to see how it works.