Intel inf Chipset 10.1.2.74 and IME

Anyone else noticed the new Intel Inf Chipset drivers (10.1.2.74) now takes care of the Intel Management Engine without installing any .sys drivers on the 100 series Chipsets?

Intel INF and Intel ME.png



EDIT by Fernando: Screemshot resized (to save space)

check the registry if no files is loaded …
the box and the services.msc have tab showing infos …like the dependencies one or description . but they read the registry so if driver does not write these info…the mbox can show errors or no dependency to drivers .

If I were you, I would uninstall the Intel Chipset Device INF file and install a “normal” Intel ME driver. You can find it >here<.

I’m not going to install the usual drivers if I don’t need it. I’ve been using IME without the usual .sys file driver for a couple of days now, and doesn’t seem it is actually needed for IME on a consumer motherboard/chipset.

Maybe Intel and OEMs got fed up of seeings bricked consumer Motherboards RMA’ed because people failed their unneeded IME firmware update? That’s what I wanted to point out.


@grml4d I just checked, no .sys files are loaded and the device isn’t linked to any other service in the registry. The driver even states “Needs_NO_DRV” in the inf.

Firmware and Drivers are completely different things.

The Intel Chipset INF files are no drivers and don’t use any drivers (*.sys files).

the firmwares you find here are working but can bug with "old" hardware…
you can give them a try if your mainboard has a dual bios or is able to replace the bios when off by usb [ like the sabertooth x79 i have ]
if you have not it then it s better not to update it .
updating firmware can be very cool and make the pc better . mainboards makers are aware of that but they want money so some buggy bios is not a problem…it is even worse with Android os …with Google making updates that are never distributed by samsung and others …Google is making a Blacklist of these fuckers…my next phone with the new Android 7 will be a Google .samsung being one of the worst brand i ever seen .

i made screencaptures to show places about drivers-services in win 7 …10
with one of amd

AMD Services and Events.jpg


with intel Me

Intel ME details.jpg



both are in the same “very long” registry branch , in GUIs they are not in the same and taskmangr does see the amd but not the intel…both having holes in infos…
like we say in france " ce qui se conçoit bien , s’énonce clairement " : what it is well conceived, is easy to explain …
M$ registry keys are not so well handled by these big brands…so what about us ?

EDIT by Fernando: Screenshots resized (to save space) and the off-topic video removed

These are not drivers, just placeholders for Device Manager to not complain of missing driver. You cannot use anything ME related without proper drivers (.sys). Trying to launch anything driver related like System overlocking utilities, System monitoring utilities that show ME/AMT info, MEInfo, MEManuf will prove that.

Sorry for jacking this thread but I thought it was relevant for me that I had the same question and need more clarification.

I saw this thread while doing research on IMEI. I didn’t know much about it and your site has been very helpful so be patient with this noob.

I just built a new system (see specs in my sig) and always thought it best to install Chipset drivers first, which I did. I was as surprised as Chris34 to see that there were no devices showing as needing a MEI driver. I now understand that the INF “driver” are not really drivers but just a way to fool Windows.

Fernando’s advice was to uninstall the Chipset “driver” (in my case 10.1.2.77) and install the MEI drivers. But there’s no uninstall entry in Windows 7 Programs and Features for uninstalling. All of those multiple entries for Intel(R) Xeon(R) E7 v3/Xeon(R) E5 v3/Core i7… entries show no drivers installed (see both pics). So should I uninstall them one by one or just use the non-INF MEI installer here?

Intel Management Engine: Drivers, Firmware & System Tools
Intel MEI Driver v11.6.0.1023 MEI-Only Installer

And if I use the file above will that correct all the “No driver files loaded” messages?

Device Mgr MEI.PNG

Device Mgr B MEI.PNG

@redwald :
Welcome at Win-RAID Forum!

Your experience is the proof, that it is not a good idea to force the installation of the Intel Chipset Device Software.

The "Add/remove Software" section of the Control Panel is not usable, if you want to uninstall any driver. This has to be done from within the Device Manager.
If you want to uninstall the not wanted Intel Chipset Device "drivers" (that are just INF files), you should do the following:
Run the Device Manager, expand the section "System devices", right click onto the related device, whose name is starting winth "Intel(R)", and choose the option "Properties" > "Driver" > "Uninstall".
After having done it with all listed devices, which are currently using the not wanted Intel Chipset Device INF files, you should reboot, run the Device Manager, expand the section "System devices" again and look for yellow flagged or "unknown" devices.
Now you will be able to get the Intel MEI driver installed by doing a right-click onto the device, which is yellow flagged or named "Intel(R) Management Engine Interface", and choosing the options "Update driver software…" > "Bowse my computer…" and navigating to the desired driver.

Regards
Dieter (alias Fernando)

@Fernando

Thanks for the reply.

After uninstalling I got all the listed devices. See pics. I had to do 2 pics to show them all.

4 questions:
1- How do I know which devices require the MEI driver?
2- If I run the single non-INF MEI installer will it load a driver for all 63 devices?
3- If not, should I run the Chipset driver again for all the leftovers?
4- If I run the Chipset driver after MEI install will it mess up the MEI install?

I made a system restore point so I can always go back.

After Chipset Uninstall A.PNG

After Chipset Uninstall B.PNG

@redwald :
I have never seen such chaotic Device Manager. You should better recover the system, which you had before taking your last restore point.
How did you get all these devices listed within the Device Manager? Did you force the installation of all INF files by choosing the " -overall" command?

By checking the HardwareIDs of the devices (right click onto them > "Properties" > "Details" > "Property" > "HardwareIDs"). For your on-board Intel ME device they will be PCI\VEN_8086&DEV_8D3A.

No.

It may be better to download and unzip my "Latest Intel Chipset Device INF Files v10.1.x.xx WHQL" and to let the Devce Manager itself search for the INF files, which are matching the listed devices.

I don’t think, that the INF file installer will replace an already installed driver by a simple text file, but why do you want to run an Intel Chipset Device Software Instaler at all?


I completely agree with you. I’ve built 5 previous systems going back to 1996 & I’ve never seen so many system devices. Especially all the multiple entries for Intel(R) Xeon(R) E7 v3/Xeon(R) E5 v3/Core i7… I just figured it was common to all x99 hardware and not out of the ordinary.

The first thing I did after installing Win7SP1 was to install the Chipset Driver from the ASUS website as this has always been recommended as the first driver to install. But I noticed after some research that their IMEI driver was out of date. My last system didn’t require a MEI driver so I needed to research it a bit. I discovered your site which seemed to have great info about it (plus other great info about RAID/AHCI, etc). (Their USB3 & Ethernet drivers are also out of date. As a separate issue, I had a terrible time getting USB devices to work right, which is still not completely resolved.)
http://www.asus.com/us/Motherboards/X99A/HelpDesk_Download/


Thanks, after uninstalling all the devices I wasn’t sure how many would use the MEI driver. I now understand that its only one. It was originally called PCI Simple Communication Controller (PCIVEN_8086&DEV_8D3A).


Are you saying I should not install a chipset driver at all and just let the devices show with a yellow bang in Device Manager?

No, this is not what I recommend to do. The Device Manager should look “clean”, that means without any yellow flagged device.
But to avoid the installation of unneeded or unusable INF files I recommend to install only the related INF file for devices, which are still yellow flagged after the OS installation. This can be done manually by using the “Latest Intel Chipset Device INF Files v10.1.x.xx WHQL”, which I am offering within the start post of >this< thread.
Procedure: Right click onto the yellow flagged device > choose the “Update driver software” > “Browse my computer…” >Browse" > navigate to the root of the unzipped INF file package > “OK”.
If the Device Manager finds the matching INF file, it will install it automaticly. If not, it will let you know it.
Then do the same with the other devices.

@Fernando

LOL…I was hoping you would say that.

Perhaps I have the worst luck of anyone in the world, but it appears that the folder for Haswell-E is empty. I’m assuming thats what I need. Download from Mega and check that I’m not crazy.

The package did, however, have drivers to these 2 devices out of the 60.
Intel(R) C610 series/X99 chipset SMBus Controller - 8D22
Intel(R) C610 series/X99 chipset SPSR - 8D7C

No, you are right and I am sorry about that.
Attached is the complete Set inclusive the INF files for the “Haswell-E”.

EDIT: The links within the start post of >this< thread now will give you packages, where the INF files for Haswell-E systems are inserted as well.

Latest Intel Chipset Device INF Files v10.1.x.xx WHQL.rar (394 KB)

@Fernando

Yes! Thank you!

Once again thank you for all your guidance, patience, and understanding concerning my struggles with this new x99 board.

I hope this will help others as well.

Now on to tackling my problems with Intel USB3 driver and UEFI options/combinations to get it to recognize my USB devices that won’t wake from sleep state.

@redwald :
I just have realized, that the Haswell-E folder contains only 1 INF file, but is usable for a big amount of different devices!

Yes, it does. And thats perfect.

I’m of the mind that we shouldn’t just be trusting the motherboard makers for the best drivers especially when theres a chance that they’re out of date or will install bloatware which oftentimes causes other problems.

By the way: The latest Intel Chipset Device Software Sets contain the subfolder named "null-heci", which obviously was responsable for your trouble.