Intel ME on Asus Z97-A not initializing

Hello there,

I’ve got an Asus Z97-A that didn’t start at all. So I got the schematics and (almost) repaired it (I replaced a chip). It worked, I installed Windows etc… but few days later it broke again - sometimes it started, then it went off again, sometimes it didn’t start at all (like in the beginning).
I poked a little bit here and there and finally unsoldered the replaced chip again. The fault was bad soldering. So I took a new chip and soldered it back on. Now it constantly functioned.

Now, the internal graphics do not work anymore. And I have no Intel ME Interface in Windows / at all.
Intel ME was working since I had a device in the device manager that is now faded out (view all devices).

In the BIOS I read Intel ME (typical error for a non-working Intel ME)
I read a lot of stuff in this forum and through Google.
I re-flashed the chip (via programmer and via FTK & tools).
I found out which pins to short to get write access (I experienced Error 26 AFAIR).

I think the ME image is fine. I have the output of DOS\mestate.bat (FTK v9) which is:

CurrentState: 			Init
ManufacturingMode: Disabled
FlashPartition: Valid
OperationalState: Transitioning
InitComplete: Initializing
BUPLoadState: Success
ErrorCode: No Error
ModeOfOperation: Normal
Phase: ROM/Preboot
ICC: No valid OEM data, ICC not programmed
ME File System Corrupted: No
PhaseStatus: UNKNOWN

Any ideas?

Tools I have: CH341A, TL866II Plus, hot-air, soldering irons, USB sticks + SSDs, etc

Use Intel Management Engine: Drivers, Firmware & System Tools > ME System Tools v9.1 for any ME related tools and not other random things from the internet.

The MEInfo report shows that the ME is not working properly but with your knowledge and tools, this repair should be easy. Either re-flash the 8MB (0x800000) SPI chip using the latest BIOS from ASUS after removing the first 0x800 AMI Capsule data or use UEFITool to “Extract as is…” the ME Region and flash it via Flash Programming Tool parameter “-me -f me_rgn.bin” followed by “-greset” (the latter requires an unlocked Flash Descriptor of course).

Hello plutomaniac,

I extracted the ME region and used “fpt.exe -rewrite -me -f me_rgn.bin” (with unlocked FD / I’m using a USB stick with FreeDOS created with Rufus) and “fpt.exe -greset”. I use fpt.exe from ME System Tools v9.1. I tried with and without “-rewrite”. Still the same behavior.

More ideas?

Reflash the entire SPI image via "fpt -f spi.bin" after removing first 0x800 AMI Caspsule data from ASUS .CAP file. Then remove all AC power for 1 minute and try again. If it persists, the problem is at the hardware.

Hello plutomaniac,

I re-flashed the entire image again, didn’t work.
I also used me_cleaner to at least get a different state with “meinfo.exe -FWSTS” but no success (me_cleaner -S -O mod.bin orig.bin —> fpt -f mod.bin).

I’m sure I shorted something with my tweezers, whereas the voltages are all correct around the chip I replaced. Damn…

Don’t use me_cleaner, the goal is to fix the system, not brick it more. Re-flash the entire SPI image to repair the me_cleaner damage, reboot and show outputs of MEInfo -verbose and MEManuf -verbose.

Hello plutomaniac,

okay, I re-flashed a clean image again (fpt.exe -rewrite -f bios.bin), rebooted and the output of "meinfo.exe -verbose" und "memanuf -verbose" is attached as file.



By re-flashing the entire SPI image we can be sure that there is no BIOS/ME firmware problem so that leaves hardware. What chip did you replace (PCH, SPI etc)? Was it exactly the same?

Hello plutomaniac,

I replaced the RT8065ZQW that is located near the PCH. I found that one defective on an ASRock B75 Pro3 also that is working fine again.


Alright, final test to rule out firmware. This is the stock BIOS/SPI image from ASUS but with a cleaned/updated ME firmware as well (shouldn’t be needed in this case) after following [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization. I suggest you flash with the programmer and verify afterwards that the reading result is the same before first power on (to check if the SPI chip is healthy). For good measure, clear CMOS, remove all power (AC + RTC battery) for 1 minute and swap memory modules. If the same problems are shown in MEInfo -verbose after that, you have a hardware problem somewhere and there is nothing more we can do on a firmware level.

Z97-A-ASUS-3503_clean.rar (5 MB)

Hello plutomaniac,

unfortunately no change after doing as advised. I think something in the PCH is toast.

Thanks for your help - I learned new stuff :slight_smile: