Intel RST/RSTe Drivers (latest: v20.1.0.1013/ v8.6.0.2003)

A post was merged into an existing topic: [Guide] Integration of Intels AHCI/RAID drivers into a Windows XP/W2k3/W2k CD

[email protected]_09.16.rar (2.5 MB)
(>[email protected])

2 Likes

Hi guys,

I’ve just recently upgraded my Win7 to a Win10 on an Asus Sabertooth X79 system, and I can’t get my Samsung 970 EVO 1 TB NVMe drive (on a PCIe riser card) to work - it worked just fine on my previous Win7 installation and now I can’t get it recognized properly - it always shows up as a SCSI device, no matter which X79 drivers I try.

  • If I don’t install anything, the controller shows as “Standard SATA AHCI Controller” in Device Manager and the disk as a SCSI disk drive and everything hangs (even explorer doesn’t work)

  • Tried installing RSTe drivers from the v13 platform - nothing

  • Tried RSTe from section C from the v4 and v8 platform - nothing

  • Tried pure >64bit Intel RST AHCI+RAID+NVMe drivers v18.37.4.1007 WHQL<, system says nothing can be installed

  • Currently uninstalled all RST(e) drivers as nothing was working

  • There’s also a Marvell 9128 controller which just shows up as “Standard SATA AHCI Controller” in Device Manager.

What am I missing, someone please help. The NVMe is not empty, there are some important files on it.
I really need to have it working again.

@CatalyticCoder
You have posted your request into a not matching thread, because the Samsung NVMe Controller of your NVMe SSD needs an NVMe driver and not an Intel RST/RSTe SATA one.
The easiest and safest way to get Win10 or Win11 properly installed onto an NVMe SSD is to unplug all other SSDs/HDDs and to do a fresh install of the OS after having let the Setup removed all existing partitions of the NVMe SSD. Since Win10/11 have a generic MS NVMe driver in the box, which supports all existing NVMe Controllers, there is no need to install any NVMe driver.
It was a big mistake, that you haven’t done a backup of the important files.

Hi Fernando,

first of all, thank you for your quick answer, but I believe that you have misunderstood my question, or maybe I haven’t explained it well enough.

  • The OS is not on the NVMe, it’s on a SATA-connected SSD (I gave up trying to have the PCIe riser card mounted NVMe as boot, the installation would always hang at “Getting devices ready”)
  • The NVMe is currently only used as a data disk (for faster transfer rates when editing videos and photos) and I when I still had Win7 on my system SSD, I transferred all the important stuff from the SSD to the NVMe, because I formatted the SSD and put a fresh Win10 install on it
  • I do have the Samsung NVMe driver installed (v3.3), and I actually see the controller in Device Manager when the PCIe card is inserted into the motherboard
  • The problem is that when I plug it in, it shows as “Samsung 970 Evo SCSI drive” and the whole system hangs, I thought installing Intel RST drivers would include proper AHCI drivers for the X79 chipset and the problem would be gone
  • The funniest thing is that, in Windows 7, it actually worked and I was able to use the NVMe as a data disk once I installed Intel RSTe drivers (very old ones, v3.0.0.2003) and Samsung NVMe drivers.

@CatalyticCoder
Is it possible, that you have tried to do an upgrade from Win7 to Win10/11 instead of doing a fresh OS installation? If yes, this was the reason for your problems.
My advice: Do a clean install of Win10/11 onto the NVMe SSD by using the GuiMode Partition Table (GPT) and don’t integrate or load any third party storage driver. You will not need any Intel SATA driver.
Before you start with the OS installation you should
a) do a backup of your important data and store them outside the NVMe SSD and
b) prepare the BIOS settings to be able to boot in UEFI mode.
For further details please look into the start post of >this< thread.

The start post has been updated by me on 10/22/2022.
Thanks to @westlake for the Intel RST drivers v17.11.2.1004 WHQL dated 09/07/2022.
The AHCI driver is working fine with my Intel(R) 6th Generation Core Processor Family Platform SATA AHCI Controller running Win11 x64 Build 25227.
Here is the proof:

Hi Fernando

No, I didn’t do an upgrade, I formatted the my 2,5" SSD (Samsung 830 Pro) and installed a fresh copy of Win10 on it.

But, while I appreciate your advice about how to install the OS onto the NVMe, that’s not what I want to do. I’m just trying to access the data that’s on the NVMe, but Windows doesn’t properly recognize the drive.

@CatalyticCoder
I gave you the advice to install Win10/11 x64 onto the NVMe SSD, because only this way you will fully benefit from its performance and short boot time.
Since I don’t know what you did after having installed the new Windows OS, I cannot tell you the exact reason for your problems. I suspect a bad handling/formatting of the NVMe SSD and propose to check its health by a matching utility.
By the way - the main content of my previous post is valid for a clean Win10/11 installation onto a SATA connected SSD as well. No third party storage drivers are required. Nevertheless it may be a good idea to attach additional SSDs (incl. the NVMe one) later on, when the OS is up and properly running.
Just for your information: Win7 may need an additional SCSI Filter driver to get full TRIM support for the SSDs, whereas all newer Windows Operating Systems neither need nor use such driver.

19.5.1.1040.rar (4.2 MB)
(> 19.5.0.1037.2)

1 Like

@westlake
Thanks for having found the new drivers and for having uploaded them.

@all
The start post has been updated today.

1 Like

2 posts were merged into an existing topic: [Outdated] Recommended AHCI/RAID and NVMe Drivers

7.8.0.1031 (two months newer than 8.0.3300)
iaStorB & iaStorE & iaVROC 7.8.0.1026 (2022.07.07)

1 Like

@westlake
Thanks for having found and published the new Intel RSTe v7 platform drivers and the related Installer Set.
The start post has been updated today by me.

1 Like

A post was merged into an existing topic: [Guide] Integration of Intels AHCI/RAID drivers into a Windows XP/W2k3/W2k CD

Installer:
Intel_Rapid_Storage_Technology_17.11.3.1007.2 (>Intel_Rapid_Storage_Technology_17.11.0.1000.1)

Drivers only:
iaAHCIC [email protected]_10.19 (>iaAHCIC 17.11.2.1004)
iaStorAC [email protected]_10.19 (>iaStorAC 17.11.2.1004)
iaStorHsa_Ext [email protected]_10.19 (>iaStorHsa_Ext 17.11.0.1000)
iaStorHsaComponent [email protected]_10.19 (>iaStorHsaComponent 18.7.4.1007)
iaStorPinningComponent [email protected]_10.19 (>iaStorPinningComponent 18.7.4.1007)

17.11.3.1007.rar (8.3 MB)

And not that I should mark it, but the source is HP’s FTP site (sp143635).

3 Likes

@westlake
Thanks for the new Intel RST drivers v17.11.3.1007 and the related complete Drivers & Software Set.
The start post has been updated by me.

1 Like

Installer:
Intel Virtual RAID on CPU 8.0.0.4035

Drivers only:
iaNullVMD [email protected]_11.10 (>iaNullVMD [email protected])
iaStorB [email protected]_11.15 (>iaStorB [email protected]_07.31)
iaStorE [email protected]_11.15 (>iaStorE [email protected]_07.31)
iaStorT [email protected]_11.15 (>iaStorT [email protected]_same)
iaVROC [email protected]_11.15 (>iaVROC [email protected]_07.31)

Download

Source

1 Like

In Intel’s release notes I read that RSTe compatibility with C600 and C220 is up to version 4.5. Do the versions you provide have any special features or are they officials?

@Cixert

This is not correct. All Intel RSTe drivers of the v4 platform (latest available one is v4.7.0.1098) do support Intel C600 and C220 chipset AHCI and RAID Controllers. The later released Intel RSTe drivers do only support C600+ and C220 chipsets.

All Intel RST/RSTe drivers I am offering here (except the mod+signed ones) have been officially released by Intel, but only a very few of them are/were published on Intel’s Download Center.
Note: The driver support is the obligation of the mainboard manufacturer and not of the chipset manufacturer. All Intel RST or RSTe drivers, which are/were offered within Intel’s Download Center, are/were designed just for Intel mainboards.