[Guide] Integration of Intels AHCI/RAID drivers into a Windows XP/W2k3/W2k CD

@popdog : Welcome to the Win-RAID Forum and thanks for your detailed report.
This thread has been designed for users, who want to install XP or W2k3 onto an Intel chipset PC/Mobile system, whose Intel SATA Controller is running in AHCI or RAID mode. All other problems, which may occur during the XP installation onto a system with a quite modern hardware, are not topic of this thread. Furthermore I am not really able to help you, because I have given up all my tries to get an outdated OS like XP installed onto any of my modern PCs/notebooks.
According to my knowledge these are the main problems to get XP installed onto a modern system with an Intel chipset:
1. Advanced Configuration and Power Interface (ACPI): The problem is, that the XP in-box file named acpi.sys may not be able to detect and handle modern hardware correctly.
2. USB 3.0/3.1 Controllers: Windows XP doesn’t have appropriate in-box drivers, which can detect and handle modern USB 3.0/3.1 Controllers. Unfortunately modern Intel USB 3.0/3.1 drivers do not work with Windows XP.
Since the ACPI and USB related questions are off-topic, please search for the answers and help within other threads of the “Windows XP/W2k/W2k3” Sub-Forum.
Good luck!
Dieter (alias Fernando)

CPU QQLS AND ASRock B365M Phantom Gaming 4. I want to build a 32MB BIOS so that any me can use it. I use Intel (R) Flash Image Tool. Version: the system starts, passes the cpu check and the ram hangs on the boot, it is generally possible to do this and how.

?????? ?????? (2).png

?????? ?????? (3).png

?????? ?????? (4).png

?????? ?????? (5).png

?????? ?????? (6).png

?????? ?????? (7).png

?????? ?????? (8).png

can anyone give me a hint on ami aptio V UMA buffer size unlock option ? the new bios file from asus cannot be easily modified with tools found here or stuff inside bios dont match…
i want to mod an Vivobook 15 OLED (M513, AMD Ryzen 5700u) and change the vega r8 uma buffer to 1/2GB, default is 512MB

Continuing the discussion from [Guide] Integration of Intels AHCI/RAID drivers into a Windows XP/W2k3/W2k CD:

Hello, please need help with Supermicro X11SAE (Intel C236 chipset), Xeon 1220 v6. Motherboard can only do AHCI or RAID (I preffer RAID 1, but AHCI should be also fine). Tried to burn down two CD, and install them (boot from optical drive) but always get 0x0000007B error. Included “Universal 32bit Intel RST AHCI+RAID driver v11.2.0.1006 mod+signed by Fernando”. Tried to install fresh copy in Hyper-V, then Acronis image and clone it to hard drive, this way Windows started booting, but restarts during process with no error displayed. Is there anything else I can do try? Thanks.

Welcome to the Win-RAID Forum!
Since your problem has much more to do with the topic of this already existing thread than with your specific mainboard, I have moved your request here.
It is not enough to integrate a certain Intel AHCI driver into the demanded XP Image, you have to integrate the support of your currently active specific on-board Intel AHCI Controller and nothing else.
This is what I recommend to do:

  1. Check the HardwareIDs of your on-board Intel SATA AHCI Controller (look into the start post of this thread).
  2. Set the Intel SATA ports within the BIOS on “AHCI mode”.
  3. Create a new XP CD by following the start post of this thread.

Good luck!
Dieter (alias Fernando)

Hi Dieter (Fernando), I forgot to mention I have done that. It Is VEN_8086 & DEV_2826. This is the closest I have found in your driver. I did not go further to SUBSYS_089515D9 & REV_31. Is there anything else I could try. Just to mention, when I tried on Hyper-V to load this driver from floppy via F6, I got the same error almost immediately. I was thinking to make image from Hyper-V, and load it to SSD drive, but also with no luck.

DEV_2826 is the DeviceID of an Intel RSTe RAID Controller.
My advice: Try to get XP installed in AHCI mode. In this case you should know the DeviceID of the on-board intel SATA AHCI Controller.

I have the following:

I would like to install a cut-down version of XP 64-bit? Which driver should I look to integrate.

Many thanks

You can find usable Intel AHCI drivers for Windows XP x64 within the start post of this thread.
I have moved your post here, because this thread matches much better your request.
Good luck!

5 posts were merged into an existing topic: [Guide] Integration of drivers into a Win7/8/10 image

I am new to this forum, I hope this is an appropriate place for this question.
I want to install Windows XP 32bit on a desktop computer with Samsung SSD drives, using an installation CD. Here is some information about my desktop (obtained from Linux lspci command):

SATA controller: Intel Corporation Q170/Q150/B150/H170/H110/Z170/CM236 Chipset SATA Controller [AHCI Mode] (rev 31)

I type F7 and F6 and when the installation needs more drivers to be installed, I have a USB floppy drive that it recognizes. I wanted to try some of the modded drivers on this site, but I am confused because Windows XP requires a TXTSETUP.OEM file, and none of the drivers I have downloaded from here have this file. Is it possible to somehow obtain this file?

Welcome to the Win-RAID Forum.
I have moved your request into this already existing thread, because you can find the requested Intel AHCI driver for Windows XP (inclusive TXTSETUP.OEM file) within its start post.
My recommendation is to use the “Universal 32bit Intel RST textmode driver v11.2.0.1006 mod+signed by me on 05/01/2022”.
Good luck!
Dieter (alias Fernando)

Hi Fernando,

I tired to boot Win XP on TB-250 BTC motheboard. But without luck. There is A282 ahci. I tried to boot with nlite and from flopy (with clean ISO) …every time I got 0x7b and 0x7e. I downlaoded clean xp iso sp3 and sp2 x64 but without luck. Any Idea?

Welcome to the Win-RAID Forum!
Please read my previous post and do what I have proposed there.
Additional advices:

  1. Don’t mix 32bit with 64bit drivers and XP Images! XP needs an x86 driver, XP x64 needs an x64 driver.
  2. Don’t try to load or integrate the iaStor.inf, the matching one is named iaAHCI.inf.

Good luck!
Dieter (alias Fernando)

I know this is an odd thing to write here in 2022 but I’m trying to install Windows XP 32-bit on an Intel X79 motherboard with the onboard Intel Matrix Raid / Intel RST in RAID mode with two SSD’s in RAID-0 together. I found your thread here and I’m trying to use your drivers. I tried both slipstreaming it into a modified XP install disc image with N-Lite and also F6 with an actual floppy disk in a USB floppy drive during setup with a CD. Your drivers do let me see the exported RAID volume and select it to install to but then after system reboot I get the “Windows could not start because of a computer disk hardware configuration problem. Could not read from the selected boot disk.” So your drivers work during Textmode but do not appear to work during PNP / Graphical mode. From a lot of searching I can’t seem to find any indication that Intel ever released any official F6 drivers for XP-32 for this platform (even though there are drivers for every other hardware device for this motherboard’s onboard components on their website for XP-32). Do you have any suggestions?

EDIT: I have been reading many posts and threads written by you in the WinRAID forums here and I have found multiple different modified driver packages you posted to the public. Unfortunately it seems none of them have the Device ID for the Intel RAID controller on this X79 system in INF file. I’m kind of tired of looking and about to give up. Is there any way you could point me to the correct download that will have it? It’s DEV_2826.

Welcome to the Win-RAID Forum!
I have moved your post into this much better matching thread. You will find matching Intel RAID drivers for your DEV_2826 Intel SATA RAID Controller within the start post.
Here are my comments to your questions/statements:
Intel X79 chipset systems are natively supported by the Rapid Storage Technology “Enterprise Edition” (RSTe) drivers. Unfortunately none of Intel’s original RSTe drivers do support older Operating Systems than Windows 7.

You obviously didn’t look into the correct *.inf file. Since your onboard Intel SATA Controller is running in RAID mode, the related Windows OS (here: XP) Setup needs the file named iaStor.inf. It cannot use the iaAHCI.inf file at all, because it only supports AHCI Controllers.
The best suitable Intel SATA RAID driver for your X79 chipset is the “Universal 32bit Intel RST RAID driver v11.2.0.1006 mod+signed by me”. You should only point to the iaStor.inf file, when you load or integrate the driver.

Good luck!
Dieter (alias Fernando)


i have a ASRock H87 Pro4 mainboard, chipset should be Intel H87,
the compatible ID is DEV_8C02.
I want to put AHCI DRV in the ISO to install Windows XP Pro x64 from USB flash drive to a SSD.
I am lost, it’s so confused with all this drivers that i don’t know what is the right one. Can someone please point me to the needed driver?

Thank a lot!

Welcome to the Win-RAID Forum!
I have moved your help request into this already existing thread, because you will find everything you will need within the first post of this thread.
My tip: Use the “Universal 64bit Intel RST textmode driver v11.2.0.1006 mod+signed by me on 05/01/2022”.
Good luck!
Dieter (alias Fernando)