Intel UHD 600 on Windows 8.1 Help

Hello to all of you friends. I bought a new computer and Windows 10 board came and I can not use windows 10 I installed it windows 8.1, but I could not install the graphics driver of a kind of computer features: Lenovo Ideapad 330-15 IGM processor: Intel Celeron N4000 graphics card: Intel UHD Graphics 600 what happens if you help me immediately ?

HELP PLSSSS

Download modded by Raistlin from ixbt.com - https://yadi.sk/d/f5gJDnUpjKp26A
Unpack it.
In file igdlh64_8_81.inf replace all occurrences of DEV_5A85 to DEV_3185
Install this driver manually(!) in Test Mode.
If it is installed normally, then turn off Test Mode

@mia7711 :
Welcome to the Win-RAID Forum!
>This< is the only promising link I found by doing a Google search for “Intel Graphics 600 driver Win8.1”, but I don’t know, whether the offered driver will work with your specific system.
Alternatively I recommend to follow DeathBringer’s advice.
Good luck!
Dieter (alias Fernando)

P.S.: I have deleted the other thread, which has been started by you about the same topic.

I think that is fake.

I’ve checked it. It has unmodded sys-file. So it hasn’t support for DEV_3185!

@mia7711

Welcome to the n4000 - uhd 600 club. You can read more here in my thread about it: ACPI mod request for vga Intel UHD Graphics 600 detection

If you want to run w8.1, at the moment I haven’t found a driver to get UHD 600 working. But you can try this to change the resolution to the native monitor resolution:

https://ywjheart.wordpress.com/2014/04/1…ter-resolution/

I recommend you go to early w10 versions like 1511.

There’s only one way to get something like w8.1 running on this laptop with uhd 600.



Tried this on w8.0 6.3.9369, the driver is installed after I disabled driver signature but with yellow exclamation:

This device is currently waiting on another device or set of devices to start. (Code 51)

Intel Display Audio it’s installed correctly too and working. but UHD not, only installed with yellow mark. It maybe has some dependency, I don’t know…

The system (w8.0) works incredible fast and smooth compared to w10 on this hardware.

In w8.1, as I commented before, it’s not detected on Device Manager, but I installed with Add legacy hardware option and after it’s installed I get yellow mark and Code 31

I don’t know if the old UpperFilters / LowerFilters tweak on registry has something to do here ( answers.microsoft.com/en-us/insider/forum/all/device-manager-code-31-with-graphic-driver/382fae4d-9ee0-4f20-8c93-279434be6547 )

Today I tried installing the one linked by Fernando which seems like an original one.

But I get the same as always:

"This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

Object Name not found."

Since this card (UHD 600) it’s not detected on w8.1 for some reason.

The same as it’s predecesor (Intel HD 500):

“Mysterius Intel HD Graphics Compatibility” https://answers.microsoft.com/en-us/wind…50-c00780a05b64

_ttps://drp.su/en/devices/video/intel/in…windows-8.1-x64

I don’t know if it’s something about Lenovo BIOS / Acpi… but it’s impossible to get it detected on w8.1, in w8.0 6.3.9369 beta it’s detected but I get different error. It’s something about the bios config I’m 100% sure.

Edit:

Now I tried to install it on w8.0 6.3.9369 and I ended with the same as previous:

"This device is currently waiting on another device or set of devices to start. (Code 51)"

and Intel Audio driver installed correctly.

qwdqwd

Do you still need it?



@DeathBringer Yes, I need it too. May you provide link with a modded one that works, please?

I have seen you recent message on this thread: Problem installing intel UHD 600 on Win7

"3. Install modded driver as usual.
4. Choose “Install this driver software anyway” when Windows ask.
5. Reboot and get the error with 43 code (or someone else)
6. Open Event Viewer and go to Windows Logs->Application
7. Find last event with a source is Windows Error Reporting and a name is LiveKernelEvent. Show this."


You can take a look at my threads talking about the driver issue and INT3453:

https://msfn.org/board/topic/178262-inte…device-manager/
ACPI mod request for vga Intel UHD Graphics 600 detection (4)

If you know any new solution, please tell me.

Edit:

Maybe it’s possible to port a DLL or driver from the first w10 betas since it is very similar to w8.1 Update 3?

If I enable Devices by connection on Device Manager, I can see Intel UHD Graphics 600 as a children of PCI Express Root Complex connected (driver: pci.sys)

It is possible to port or patch PCI.SYS from w10 beta to w8.1 or some required library from early WDDM 2.0 DX kernel ?

I have seen something about pci.sys for different purposes but related to External GPU compatibility here: https://www.reddit.com/r/eGPU/comments/g…acbook/frx2gq3/

Thanks

@voug
1. Download official driver 22.20.16.4675. E.g. - https://yadi.sk/d/ouRptt9f3UmR6d
2. Open igdlh64.inf and after [IntelGfx.NTamd64.6.3] add:

; GLK
%iGLKGT2E18% = iSKLD_w81, PCI\VEN_8086&DEV_3184
%iGLKGT2E12% = iSKLD_w81, PCI\VEN_8086&DEV_3185

3. Before line ; Do not modify or copy the following line add:

; GLK
iGLKGT2E18 = "Intel(R) UHD Graphics 605"
iGLKGT2E12 = "Intel(R) UHD Graphics 600"

4. After [MSDK_4_0_AddSwSettings32] add:

; GLK
HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iSKL_3184, DeviceID, %REG_DWORD%, 0x3184
HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iSKL_3184, VendorID, %REG_DWORD%, 0x8086
HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iSKL_3184, APIVersion, %REG_DWORD%, 0x108
HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iSKL_3184, Merit,%REG_DWORD%, 0x08000015
HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iSKL_3184, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw32.dll"

HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iSKL_3185, DeviceID, %REG_DWORD%, 0x3185
HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iSKL_3185, VendorID, %REG_DWORD%, 0x8086
HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iSKL_3185, APIVersion, %REG_DWORD%, 0x108
HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iSKL_3185, Merit,%REG_DWORD%, 0x08000015
HKLM, Software\Wow6432Node\Intel\MediaSDK\Dispatch\iSKL_3185, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw32.dll"

5. After [MSDK_4_0_AddSwSettings64] add:

; GLK
HKLM, Software\Intel\MediaSDK\Dispatch\iSKL_3184, DeviceID, %REG_DWORD%, 0x3184
HKLM, Software\Intel\MediaSDK\Dispatch\iSKL_3184, VendorID, %REG_DWORD%, 0x8086
HKLM, Software\Intel\MediaSDK\Dispatch\iSKL_3184, APIVersion, %REG_DWORD%, 0x108
HKLM, Software\Intel\MediaSDK\Dispatch\iSKL_3184, Merit,%REG_DWORD%, 0x08000015
HKLM, Software\Intel\MediaSDK\Dispatch\iSKL_3184, Path, %REG_SZ%, “%16422%\Intel\Media SDK\libmfxhw64.dll”

; GLK
HKLM, Software\Intel\MediaSDK\Dispatch\iSKL_3185, DeviceID, %REG_DWORD%, 0x3185
HKLM, Software\Intel\MediaSDK\Dispatch\iSKL_3185, VendorID, %REG_DWORD%, 0x8086
HKLM, Software\Intel\MediaSDK\Dispatch\iSKL_3185, APIVersion, %REG_DWORD%, 0x108
HKLM, Software\Intel\MediaSDK\Dispatch\iSKL_3185, Merit,%REG_DWORD%, 0x08000015
HKLM, Software\Intel\MediaSDK\Dispatch\iSKL_3185, Path, %REG_SZ%, "%16422%\Intel\Media SDK\libmfxhw64.dll"

6. Boot in with disabled driver signature enforcement or enable test mode.
7. Install driver by Device Manager.
8. Choose “Install this driver software anyway” when Windows ask.
9. Reboot in normal mode.

Thanks!

I will try this, but did you read my posts about GPU detection on w8.1 ?

In 8.1 beta 9369 the GPU it’s detected for example but for some reason it’s not detected on w8.1 may I port a SYS file from w8.1 ?

But the problem I think it’s INT3453, PCI.sys, DSDT tables or some missing Windows DLL

Well, I’m gonna try this driver and give you feedback later…

Just tested this driver on a w10 early version (WDDM 2.0) and works, now I’m gonna try with w8.1 and w8.0 beta

I can see the GPU in devicemanager on w8.1 if I port some files from other build but I can’t get it working since I get this when installed:

Code 51 - This Device Is Currently Waiting on Another Device or Set of Devices to Start

In w beta 9888 (last beta with w8.x theme) I can install the driver! but I get a black screen, I think it is cause I added the ; GLK part on the this section too:

[IntelGfx.NTamd64.10.0]

If I only keep the IntelGfx.NTamd64.6.3 section, then it’s not possible to install it as a WDDM 1.3 driver on w9888

You don’t need other modification to install this driver in Win8.1

The GPU it’s not detected by default in W8.1 (it doesn’t appear on Device Manager). You can read it and see screenshots in my previous threads

I managed to get it detected on build 9888 on Device Manager without yellow marks. But when I install the driver I get black screen flickering and I need to restart to safe mode and uninstall it.

By default 9888 doesn’t detect it but (if some user interested is reading this) you can port a .sys file from a previous build and the GPU appears on Device Manager.

I think it couldn’t be so much difficult to get it working in this build but it needs more testing since in other builds I didn’t get black screen cause and also nothing than a yellow mark, the screen didn’t changed and nothing. So maybe the direction to test the drivers is this build.

Why do you think it gives me black screen flickering?


Look at System devices

Please, read my other thread, I explained here one year ago.

One question: Can UEFI boot affect non-signed drivers if I boot with 7) Disable driver signature enforcement ?

@voug
You walked on your own way without success.
Try something else.