Intel's Flash Programming Tool (FPT) - links and Guide are missing!

Hi there.

I just went to MSI to check their forum, and found some program called "Intel FPT", where FPT (NOT FTP!!) stands for "Flash Programming Tool". I played around a bit, but I think it programs Intel EFI BIOS "on-the-fly", so I don’t want to play too much, before my system dies. I don’t have THIS MUCH knowledge regarding BIOS. :wink:

Here is the link to the site:

The D/L link for the tool is there, too. But I think you only can see the link if you are regged there, so I post the links here:

Win x64:
Win x86:

Run the tool with argument "/?" to get usage examples.

Would it be possible with that tool to insert new ROMs into Intels EFI BIOSes? I like to get an RST OROM into my DX79TO BIOS, but atm. this still is not possible, as far as I know.



Edit by Fernando: Thread title customized


Thank you for the info and the links.
I will check the tool, when I will have the time to do it.

Although I don’t know it for sure, I doubt, that it will work with Intel’s .BIO files.

It is NOT for the BIOS files themself, it is for modding the onboard-present BIOS. I did some SLIC modding (I think you know what I mean) in the past with my board (it is genuine Intel) and I found out, there are indeed no tools to mod the BIO files in any way, but the SLIC tool i had (i know where it is offered to D/L if you are interested) inserted the SLIC directly into my onboard BIOS without any flashing required. I still wonder how that is possible, but i reinstalled windows a few times and code stayed there, so it HAS to be permanent. :slight_smile:

Would you mind an exchange of knowledge? :wink:

Greetings from a place not far away from you. :stuck_out_tongue:


It is NOT for the BIOS files themself, it is for modding the onboard-present BIOS.

Ah, then it is something else than a "normal" BIOS modding tool.

Ok, I am always interested in learning something new.

"Not far away" from me may be the moon, the Netherlands or my neighbour. Where are you living? If you don’t want to post it, please send me a PM.

Fernando… I have an Asus p8h61-m-lx-plus-r2.0 motherboard that won’t take a bios update… it’s on #1203 right now and it’s corrupt… I have tried using EZ FLASH 2 on the old Bios and it says the same #1203 is not an UEFI bios…, which it truly is… How can I flash the GOOD 1203 to fix it…???
Any help will be appreciated…
A newby…, lentmain

@lentmain :
Welcome at Win-RAID Forum!

What lets you think, that it is corrupt?
Did you flash the BIOS yourself? If yes, did you flash an original or a modded BIOS?
Have you already cleared the CMOS?

Dieter (alias Fernando)

The original motherboard was a SATA 2 board and I wanted a SATA 3, for the SSD and other hard drives… I had tried to use a PCIe adapter that created 4 new SATA3 data ports… It was working great…, except after finally loading all of the windows downloads from Microsoft…, it cme up with a black screen…, " There is no boot device… Click N and pick a new boot device"… I tried clicking N It didn’t work with anything… I tried to flash the same #1203, the most current BIOS from Asus, onto the MB with the adapter still attached… Well… , it didn’t work… Now it will only say…, “the item you are flashing is not a UEFI bios…” Which it is… It will not respond to a F2 or Delete click during restart, to open the BIOS programming… I have to use F8 to open up the BOOTABLE comuter components and none of them work to Boot the computer… It’s like the UEFI line to boot iss missing…
A corrupted BOOT…


@lentmain :
Have you already tried to contact the ASUS Technical Support?

Yes sir…, they want me to do an RMA return and fix… I think I might just look for a replacement MB that already has 6gb SATA’s… Oh well…
Thanks for the forum… I just love programming…

A post was merged into an existing topic: Intel (CS) Management Engine: Drivers, Firmware and Tools for (CS)ME 16+

Link seems to be dead:

Unfortunately all your links don’t work anymore. Is it possible to fix this problem?

If not, this very old thread wouldn’t make sense anymore. I would rather like to ask you you or someone among our BIOS modding experts to start a new thread with a complete Guide about where to get and how to use Intel’s Flash Programming Tool (FPT). Once the new guide is up, this outdated thread can be deleted.

Do you agree?

I think I may have found a new link to ms-dos fpt version.

That’s an EFI version.

If it’s not too easy or too close:

Paragraph C2. (CS)ME System Tools

1 Like