Issues flashing bios from unreleased Dell Vostro 7590 i9 gtx 1650

I can’t boot from any legacy device, i wanted to try to flash the bios in dos. I tried through the option in the boot menu to flash the bios but it fails, same within Windows. Even with /forceit it says bios upgrade failed rebooting system

Is it possible to flash the bios from a efi shell?

I can’t get the gpu installed

processors microcode isnt up to date

Edit by Fernando: Thread title shortened and customized

Did you try booting in safe mode? Or command prompt? You did not list any of the utilities you used to try n flash it?OR what the failed flash said?

i used the dell bios utility, through command prompt with /forceit and without it

Its not failing inside of Windows but when it reboots to install, it instantly fails. I don’t believe safe mode would make a difference since its failing outside of the OS.

It said Firmware update failed. Rebooting your system

I also tried through the bios f12 menu

I don’t have the original charger or battery but the /forceit command pushes it through the warning

I can’t get the graphics card drivers to install, tried the dell drivers and the nvidia drivers. I think i can edit the inf for the nvidia drivers but oddly, it says its the wrong version of Windows. Windows 10 Pro is 100% up to date, 1809

The processor says its a ES of a xeon but its 8 core 16 threads, for this model the i9 9980h is listed

@bobcatchris - What do you mean unreleased? BIOS Downloads are here, so I assume it’s been released to the public now -…-laptop/drivers
What BIOS version are you on now?

Dump BIOS with FPT and let me see it, what you need done might not even need a BIOS flash or BIOS update, we may be able to change the required setting via grub using setup_var

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)…creators-update…menu-windows-10…ator-privileges

Bios version is 0.0.5

this model wasn’t released at the time

the official bios and drivers were released on the 15th i believe

I pmed you the bin you requested

Thank you very much

Thanks, I will look into this for you tonight. In the meantime, please test writing back the dumped BIOS region you made >> FPTw.exe -bios -f biosreg.bin
If there is any error, stop and do not try to redo, send me image showing the command you entered and error shown. If the above does not give you error, then we can easily flash in latest BIOS region (I’ll make you a file from your dump so board specific details will be preserved)

Model wasn’t released at what time, what do you mean? You have a test model or something, or at least some beta/test BIOS is flashed into it, is that what you mean?
Show me CPU-z image of motherboard tab, thanks.

Did you already try using the BIOS_IMG.rcv BIOS and recovery method too? That can be attempted with the actual BIOS_IMG.rcv file, or renaming the stock exe to BIOS_IMG.rcv too.
Put file on root of FAT32 USB - Shut down system completely, with ready USB already inserted. Press the Ctrl+Esc keys while holding the power button until the BIOS Recovery Menu dialog box is displayed.

Alternate method - hold down the left Ctrl + Esc keys and connect the charging cable to the computer. The computer will start up automatically.
Continue to hold down Ctrl + Esc until the BIOS Recovery window appears.

Writing back the dumped BIOS was successful

I believe its a development laptop or engineering sample or a test model. No idea, i got it second hand and I work on laptops all the time at work. I had a good idea its possible i could get it running correctly. All i knew it booted into bios and it wasn’t physically broken. I seen the core/thread count, cache and knew from all the hardware releasing at the time it had to be a i9 also with a nvidia gpu. it didn’t come with much, not even a back cover. Also in the bios it shows its a inspiron 7590 but its a vostro 7590 for sure, vostro comes in that color only and the options it has such as the fingerprint reader are on the vostro only. The bios posted on the dell site shows its for a inspiron 7590 7591 and vostro 7590. The dell service tag doesn’t pull up anything.

Here are the pictures requested

I tried every single way posted online to attempt to get into bios recovery including yours but i just tried again. Still no way in i could find. I think they locked that out as well like legacy booting, it detects nothing when i try to boot from external legacy device. I spent hours making usb freedos or ms dos and other things so attempt to flash the bios outside of the ways it allowed me to attempt but also failed.

Thank you very much for the help

@bobcatchris - Great, so BIOS lock is not enabled, and we can flash in any BIOS region we want. Do you care about asset tag or serial #, UUID etc? If you do, please send me copy of this info, so I can locate all it’s locations in BIOS easier (Also send MAC, since it’s often tied to/part of or near other related info)
Do you want updated/moved to retail/public BIOS version, or do you simply want the settings you mentioned changed and BIOS maybe updated for ucodes+roms, but left as it is now?

Please test, is FD unlocked >> FPTw.exe -desc -d fd.bin (send me this file)
Then write it back via >> FPTw.exe -desc -f fd.bin

And, dump ME and send to me too (zip this with FD file) >> FPTw.exe -me -d me.bin
Also, test writing it back (This and FD write back may both fail = expected) >> FPTw.exe -me -f me.bin

Please also run the following, from MEInfo folder in the ME System tools package and show me image or text of the end of this report
Checking for Boot Guard enabled, this is checked by looking at Measured and Verfified Boot shows enabled on left/FPF side at bottom of this info
MEInfoWin.exe -verbose

Checking your dump vs the stock BIOS, they have same FID (Flash ID), I’m surprised standard update method is being stopped only difference is this is BIOS 30 vs latest stock is 38


Enable legacy option roms is disabled in the stock latest BIOS too, but it looks like you’ll be able to see and change this option vs the BIOS you have now where this option isn’t present in same location and probably hidden from you
But, no matter what, I can eventually unlock any hidden setting for you. However, there is no legacy storage rom, we can try inserting one but unsure if that would work (Intel is trying to force legacy everything to disappear)

Here’s rom and ucode info from your dump vs stock


Additionally, there is a few more oroms and vBIOS in the stock vs yours too

Dumped BIOS video roms
Intel GOP SubGUID D8248140-88B5-4C14-9E9F-FD1CFA9D071E = Intel GOP 1082
VBIOS in GUID FD41D244-F0FB-4FD0-8FD6-4276BD4323D0 = Intel(R) CFL Mobile/Desktop PCI Accelerated SVGA BIOS Build Number: 1006 PC 14.34 12/27/2017
VBIOS in GUID 8FA17447-FA3F-456C-A282-DDDFDC84D931 = Nvidia GP107 E2904 SKU 1 VGA BIOS Version

Latest Stock BIOS video roms
Intel GOP SubGUID D8248140-88B5-4C14-9E9F-FD1CFA9D071E = Intel GOP 1085
VBIOS in GUID 76646656-48F0-4814-B988-6B74B3D814A6 = Intel(R) CFL Mobile/Desktop PCI Accelerated SVGA BIOS Build Number: 1006 PC 14.34 12/27/2017 (None of the "dupes" shown here are matching files)
VBIOS in GUID 365C62BA-05EF-4B2E-A7F7-92C1781AF4F9 = Nvidia GP107 E2904 SKU 1 VGA BIOS Version
VBIOS in GUID FD41D244-F0FB-4FD0-8FD6-4276BD4323D0 = Intel(R) CFL Mobile/Desktop PCI Accelerated SVGA BIOS Build Number: 1006 PC 14.34 12/27/2017
VBIOS in GUID 8FA17447-FA3F-456C-A282-DDDFDC84D931 = Nvidia GP107 E2904 SKU 1 VGA BIOS Version
VBIOS in GUID C4BEF7EC-4DBC-4874-ABC8-990135797AD5 = Nvidia GP107 E2904 SKU 1 VGA BIOS Version 86.07.6D.00.3A

I don’t the care about asset tag or serial #, UUID etc

No need to worry about booting from legacy either, its just not booting from legacy at all on external devices at all right now

Latest bios would be great. I really need the cpu id/microcode to be update to date to be correct and vbios for both gpus to be working

the gpu hardware id PCI\VEN_10DE&DEV_1F92&SUBSYS_09221028&REV_A1

here is the ME pic

I sent you a pm with what you requested

Ahh, external booting from legacy and booting from legacy are two very different things.

None of the nvidia vBIOS, in any of the files (your dump or stock) match that device ID 1F92 (GTX 1650) - Stock has 1C8D (GTX 1050) & 1C91 (1050 3GB Max-Q), your dump has only 1C8D so that’s why it’s not working properly.
I could edit this ID, but that does not guarantee it’s going to load the orom/vBIOS and use it. We may need to find vBIOS with that exact ID, on same system with this exact card
Otherwise we wont be able to edit the connectivity and or settings parts of the vBIOS and that always differs from system to system and this is not something we can edit except in Intel vBIOS

ME FW is disabled! So not good for our check on bootguard. - please wait a little bit before I do anything here, so I can get some info from plutomaniac on this,
I can enable and update ME while I build you the new BIOS but I want to ask him to look that and the FD over to see if anything looks like I need to change it vs what’s in the stock ME/FD

plutomaniac - when you have time, can you please check this file package for me (MEInfo report = ME Disabled) and dumped FD/ME + Stock.exe ( I didn’t send extracted HDR files, due to triple the size that way)
Do I need to do anything special to ME or FD, when cleaning/update, or simply enable ME as I normally would? Anything I need to change at FD outside of enabling stuff in FITc?
Thanks! - Sorry for crap hosting site, tinyupload was down -…-15-7590-laptop

it has the gtx 1650 listed on as a option

This system is running Pre-Production CSME firmware so you can only update/work-with PRE, not Production (PRD) that the official setup includes. The CSME firmware is healthy as far as I can tell so the restriction is probably at the FD or BIOS. Do we have a full SPI dump to take a look at FIT?

Thanks to you both!

plutomaniac So, without programmer we can’t upgrade him to PRD ME FW, or is it that we can’t do that without a retail dump to transfer settings from?
I had not looked into BIOS just yet, was waiting to get it all and compile, I guess I should have started with trying to get dump of complete SPI via FPT (requested in PM just now)
We already found no GbE, so I tried to compile FD/ME/BIOS region and still get “image is truncated” when dropped in UEFITool, and fails to decompose in FITc, so apparently some region is still missing, (resolved, EC was missing and Full FPT dump below)

Here is BIOS region, FD+ME dump above (that FD does look a little odd to me?) -…364135189788384
I checked BIOS settings, MEBx hotkey enabled, and I don’t see anything disabling ME there, at least not in general “BIOS Settings” ME State = enabled, looks like only USB Provisioning is disabled.
I do see “Manufacturing Mode Attribute” = 3

* Edit - update, here is Full FPT SPI Dump -!THoCwIiZ!0QtM6bIQAvLLC…JP3n0EC_nDd5gjA

Can you send me latest PRE ME FW you have for this, if it’s not in the repo package, thanks. I didn’t check in the package yet, so asking blind

I planned to copy out NVRAMx2 (In separate test), along with any board specific padding files or SMBIOSData etc, into a stock region rebuild, and then a stock region rebuild without that in case some of the restrictions in NVRAM too.
But waiting to figure it out a bit more first, and find correct vBIOS to use too, which hopefully is in above linked system BIOS.

@bobcatchris - Thanks for Vostro link above, but now I see that is same system correct? If yes, I wonder why this BIOS doesn’t have the vBIOS for that card too.
vBIOS on the card itself usually too, but there’s almost always a copy necessary in BIOS too. I guess we’ll have to wait and see what happens when I get you onto the retail BIOS
I assumed you don’t have a flash programmer, but since you repair and buy/sell systems often maybe you do and only used FPT here for convenience? If you have flash programmer, please dump both BIOS chips and send to me, thanks.

Yes its the same system

I don’t have a flash programmer, this is the first time I’m using FPT with your instructions. This preproduction systems are really cheap at times, i purchased one hoping I can use.

I sent you the SPI

Thanks for dump, I see the EC region was the missing part that was causing me to have a failed build when trying to compile the region dumps you’d provided previously.

PRE/BYP CSME firmware runs only on Pre-Production PCH so the motherboard is not Production. That system works only with PRE firmware and no programmer or similar can change that fact. Now, almost certainly, the BIOS has some option enabled which disables the CSE for servicing or similar. Prime candidate is the “Me FW Re-Flash” option, if it exists at the BIOS IFR. Lost can take a look there and figure out if something needs to be altered. I don’t think there is an FD option for disabling the CSE nowadays, apart from the HAP bit (“Reserved” at FIT), which is not set at the provided dump. I’ve sent a CSE-cleaned/updated SPI dump to both of you, in case you need it. As I said though, the BIOS is probably what’s causing the disablement. Once you find it, you can then just replace the BIOS region with the fixed one at the SPI image I provided so that the CSE is cleaned/updated and the BIOS is configured to enable it.

I see how that would be an issue with PRD FW then, thanks. Funny to see ES Chipset out in the wild, I’ve only ran into ES boards but with retail chipset (I think) and ES CPU’s before. Thanks for the ME Clean/Update!
So, due to this PRE-PCH, do you think replacing the BIOS region with retail one would cause any issues, or we’ll have to find out?

ME FW RE-Flash is disabled at Setup module and at NVRAM/AMITSE-SetupData, so it’s not this, and I checked ME FW settings and didn’t look disabled except for AMT functions.
The only thing in the BIOS settings that caught my eye was Manufacturing Mode Attribute = 3 (reminded me of the ME Disabled 3) stickers someone’s posted here a few times.
I thought you were the one that resolved that, or immediately knew how to fix, and I thought it was at the FD, that’s why I asked about FD maybe being a possibility

We’ll have to find out. It is very likely though that Pre-Production boards might use their own BIOS.

That was Disablement 6 and it was valid for old platforms but the end result was equivalent to the modern HAP bit, which is also at the FD. You’ll have to do tests to see if these IFR options are the culprit as it’s anyone’s guess at this point.

Thanks, I guess we shall see then. I checked and HAP bit is not set, only AMT looked disabled in MW FW, but disabling that aspect doesn’t disable ME totally, correct?
IFR and all BIOS options set at NVRAM/AMITSE too all look OK, nothing disabled that I noticed, however there is a lot of unusual Dell stuff in there, so I may need to look again with AMIBCP

Correct, of course it does not.